16:00:57 <adamw> #startmeeting F38-blocker-review
16:00:57 <zodbot> Meeting started Mon Apr 10 16:00:57 2023 UTC.
16:00:57 <zodbot> This meeting is logged and archived in a public location.
16:00:57 <zodbot> The chair is adamw. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
16:00:57 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:57 <zodbot> The meeting name has been set to 'f38-blocker-review'
16:01:00 <adamw> #meetingname F38-blocker-review
16:01:00 <zodbot> The meeting name has been set to 'f38-blocker-review'
16:01:03 <adamw> #topic Roll Call
16:01:26 * nirik is lurking in the back
16:01:47 <adamw> sit up straight and tuck in your shirt
16:02:27 <nirik> man, why do I always get called on? ;)
16:02:41 <geraldosimiao> .hello geraldosimiao
16:02:42 <zodbot> geraldosimiao: geraldosimiao 'Geraldo S. Simião Kutz' <geraldo.simiao.kutz@gmail.com>
16:03:31 <bcotton> .hello2
16:03:31 <zodbot> bcotton: bcotton 'Ben Cotton' <bcotton@redhat.com>
16:03:47 <coremodule> .hello2
16:03:49 <zodbot> coremodule: coremodule 'Geoffrey Marr' <gmarr@redhat.com>
16:04:05 * coremodule is willing to act as secretary for the meeting.
16:04:46 <jfaracco> .hello2
16:04:47 <zodbot> jfaracco: jfaracco 'Julio Faracco' <jfaracco@redhat.com>
16:05:03 <adamw> thanks coremodule
16:05:46 <Eighth_Doctor> .hello ngompa
16:05:47 <zodbot> Eighth_Doctor: ngompa 'Neal Gompa' <ngompa13@gmail.com>
16:06:04 <adamw> alrighty, let's got going
16:06:12 <adamw> this should be pretty short
16:06:14 <adamw> impending boilerplate alert
16:06:16 <adamw> #topic Introduction
16:06:18 <adamw> Why are we here?
16:06:23 <adamw> #info Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs.
16:06:25 <adamw> #info We'll be following the process outlined at:
16:06:27 <adamw> #link https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting
16:06:29 <adamw> #info The bugs up for review today are available at:
16:06:33 <marcdeop[m]> .hello
16:06:33 <zodbot> marcdeop[m]: (hello <an alias, 1 argument>) -- Alias for "hellomynameis $1".
16:06:33 <adamw> #link http://qa.fedoraproject.org/blockerbugs/current
16:06:36 <adamw> #info The criteria for release blocking bugs can be found at:
16:06:41 <adamw> #link https://fedoraproject.org/wiki/Basic_Release_Criteria
16:06:43 <adamw> #link https://fedoraproject.org/wiki/Fedora_38_Beta_Release_Criteria
16:06:46 <adamw> #link https://fedoraproject.org/wiki/Fedora_38_Final_Release_Criteria
16:06:50 <adamw> #info for Final, we have:
16:06:53 <adamw> #info 0 Proposed Blockers
16:06:56 <adamw> #info 2 Accepted Blockers
16:06:59 <adamw> #info 3 Proposed Freeze Exceptions
16:07:03 <adamw> #info 13 Accepted Freeze Exceptions
16:07:26 <adamw> yess, no proposed blockers. what was everyone doing over the weekend? enjoying their personal lives? UNACCEPTABLE
16:07:40 <adamw> special thanks to geraldosimao for doing a bunch of testing, like everyone else should've been doing
16:07:46 <adamw> i'm looking at you in the back, mr. nirik
16:08:15 <adamw> #info coremodule will secretarialize
16:08:44 <marcdeop[m]> somebody has energy today ;-)
16:08:47 <bcotton> the one time i finally want kamil to find a bunch of last minute blockers so we can cancel the go/no-go meeting...
16:09:27 <adamw> sooo, since we have no blockers, let's start with
16:09:35 <adamw> kparal: hear that? unleash the testing kraken!
16:09:43 <adamw> #topic Proposed Final freeze exceptions
16:10:09 <adamw> #topic (2184223) Joining AD realm with kickstart no longer works in F38
16:10:13 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=2184223
16:10:15 <adamw> #link https://pagure.io/fedora-qa/blocker-review/issue/1139
16:10:17 <adamw> #info Proposed Freeze Exceptions, anaconda, NEW
16:10:20 <adamw> #info Ticket vote: FinalBlocker (+0,0,-4) (-bcotton, -geraldosimiao, -lruzicka, -adamwill)
16:10:22 <adamw> #info Ticket vote: FinalFreezeException (+0,0,-2) (-bcotton, -geraldosimiao)
16:10:35 <adamw> since this isn't really reproducible, i'm -1 finalFE
16:10:57 <adamw> could change my mind if we reproduce it and find a consistent bug that somehow isn't a blocker, but.
16:12:22 <nirik> ditto
16:12:38 <Eighth_Doctor> -1 FinalFE
16:13:17 <adamw> proposed #agreed 2184223 - RejectedFreezeException (Final) - as we don't have a clear reproducer there's kind of no reason to grant an FE at this time. we could revisit this decision in future if appropriate
16:13:27 <geraldosimiao> ack
16:13:36 <nirik> ack
16:13:42 <marcdeop[m]> ack
16:13:55 <bcotton> ack
16:14:30 <adamw> #agreed 2184223 - RejectedFreezeException (Final) - as we don't have a clear reproducer there's kind of no reason to grant an FE at this time. we could revisit this decision in future if appropriate
16:15:03 <adamw> #topic (2185463) Request freeze exception for plasma-discover-5.27.4-2
16:15:06 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=2185463
16:15:08 <adamw> #link https://pagure.io/fedora-qa/blocker-review/issue/1144
16:15:10 <adamw> #info Proposed Freeze Exceptions, plasma-discover, ON_QA
16:15:12 <adamw> #info Ticket vote: FinalFreezeException (+2,0,-0) (+geraldosimiao, +ngompa)
16:15:27 <marcdeop[m]> +1FE
16:15:37 <adamw> yeah, i'm +1 if we need to respin for some reason
16:15:43 <adamw> having these issues fixed for first update ootb makes sense
16:15:44 <nirik> +1 FE
16:16:37 <bcotton> +1 FE
16:16:54 <coremodule> +1 FE
16:17:27 <marcdeop[m]> I wanted to include another patch in that update but i t hasn't been reviewed unfortunately: https://invent.kde.org/plasma/discover/-/merge_requests/530
16:17:51 <Eighth_Doctor> +1 FE
16:18:20 <adamw> proposed #agreed 2185463 - AcceptedFreezeException (Final) - this is accepted as an FE to have these issues fixed for the first update of a freshly-installed KDE system out of the box
16:18:37 <nirik> acl
16:18:39 <nirik> ack even
16:19:02 <Eighth_Doctor> marcdeop: have you tested the fix to see if it resolves that problem?
16:19:02 <bcotton> ack
16:19:02 <Eighth_Doctor> if you have, feel free to ship it as a patch
16:19:02 <Eighth_Doctor> ack
16:19:02 <geraldosimiao> ack
16:19:38 <adamw> #agreed 2185463 - AcceptedFreezeException (Final) - this is accepted as an FE to have these issues fixed for the first update of a freshly-installed KDE system out of the box
16:19:43 <adamw> #topic (2185625) qt-creator drop explicit dependency on clang-libs
16:19:45 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=2185625
16:19:48 <adamw> #link https://pagure.io/fedora-qa/blocker-review/issue/1145
16:19:56 <adamw> #info Proposed Freeze Exceptions, qt-creator, NEW
16:20:23 <marcdeop[m]> Eighth_Doctor: no because I didn't consider it critical enough and I was busy with... how did adamw callit? personal life ;-)
16:20:26 <geraldosimiao> well, I think this must be accepted too, since the LLVM 16.0.0 update needs it
16:20:33 <geraldosimiao> +1 FE
16:20:40 <adamw> yeah, although as things stand, we'll ship with the mesa update but not this
16:20:41 <adamw> oh well
16:20:51 <adamw> qt-creator isn't in anything important, is it?
16:20:59 <Eighth_Doctor> it shouldn't be
16:21:00 <tstellar> This was mentioned on the LLVM update, but we werent' sure if it needed a separate FE, so I just filed one.
16:21:11 <marcdeop[m]> +1 FE
16:21:26 <Eighth_Doctor> is it part of the LLVM update?
16:21:33 <adamw> if you'd just edited it into the mesa update it would've been fine
16:21:41 <Eighth_Doctor> yeah
16:21:46 <tstellar> Eighth_Doctor: Ideally it would have been, but it was built separately.
16:21:48 <adamw> oh well, nbd
16:21:56 <adamw> please don't edit the mesa update *now*, though
16:22:03 <adamw> since it's in RC1 and we have a shot at shipping RC1
16:22:17 <Eighth_Doctor> tstellar: in the future, note that it is possible to tag in more builds even if it was built outside of that tag
16:22:18 <adamw> anyhow, +1 in theory, to fix the FTI in the release repo.
16:22:36 <tstellar> Eighth_Doctor: Even if the build was already added to an update?
16:22:37 <Eighth_Doctor> but yeah, it's not in any artifacts, we can approve and karma it to land
16:22:44 <bcotton> +1 fe
16:22:49 <Eighth_Doctor> tstellar: well, that takes more work, but please don't do it in this case
16:23:26 <tstellar> Eighth_Doctor: Ok, I'll remember that for the future, though.  I didn't realize that was possible.
16:23:29 <Eighth_Doctor> it is possible to merge updates, it's just annoying and bodhi is prickly about it
16:23:44 <Eighth_Doctor> (aside, bodhi seems to have a problem remembering BZs when you edit the update, seems to be new with the latest deploy)
16:24:02 <Eighth_Doctor> for now, we should be okay
16:24:03 <Eighth_Doctor> +1 FE
16:25:15 <nirik> +1 FE
16:25:15 <adamw> proposed #agreed 2176759 - AcceptedFreezeException (Final) - this is accepted to fix the fails-to-install problem in the frozen release repository.
16:25:15 <bcotton> ack
16:25:15 <geraldosimiao> ack
16:25:15 <marcdeop[m]> ack
16:25:41 <adamw> #agreed 2176759 - AcceptedFreezeException (Final) - this is accepted to fix the fails-to-install problem in the frozen release repository.
16:25:44 <adamw> aaand that's all the voting
16:25:46 <adamw> let's do a quick:
16:25:58 <adamw> #topic Accepted Blockers
16:25:59 <adamw> review
16:26:12 <adamw> #topic (2185122) Fedora 38 Final needs a non-prerelease fedora-release package and fedora-repos with updates-testing disabled
16:26:15 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=2185122
16:26:18 <adamw> #link https://pagure.io/fedora-qa/blocker-review/issue/1143
16:26:21 <adamw> #info Accepted Blocker, fedora-release, ON_QA
16:26:31 <adamw> #info this is in RC1 and should be fine
16:27:14 <geraldosimiao> yes it is, I checked that
16:27:20 <adamw> thanks geraldo
16:27:25 <adamw> seriously, thanks for all the testing you did, it's super appreciated
16:27:32 <geraldosimiao> :D
16:27:41 <geraldosimiao> glad I can help
16:27:57 <adamw> #topic (2113005) Live image made with BOOTX64.EFI from latest shim-x64-15.6-2 fails to boot on some boards
16:27:59 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=2113005
16:28:01 <adamw> #link https://pagure.io/fedora-qa/blocker-review/issue/1087
16:28:04 <adamw> #info Accepted Blocker, shim, NEW
16:28:17 <adamw> #info the kernel NX patches still aren't reviewed so we're basically stuck here
16:28:35 <adamw> #info the expectation is this will be waived at the go/no-go meeting when it happens
16:29:31 <adamw> anything else to add here?
16:30:11 <geraldosimiao> so, lets just wait for go/no-go to waive it.
16:30:18 <adamw> yeah
16:30:25 <adamw> that feels like the appropriate approach
16:30:33 <geraldosimiao> and see if it can be fized for f39
16:30:41 <geraldosimiao> *fixed
16:30:57 <adamw> #topic Open floor
16:31:02 <adamw> any other business, folks?
16:31:16 <geraldosimiao> not from me
16:32:29 <marcdeop[m]> hope everybody had a nice  easter
16:33:01 <Eighth_Doctor> ehhh
16:33:46 <adamw> i may have overbrunched
16:35:58 <adamw> alrighty, thanks for coming everyone
16:36:13 <adamw> if folks can help fill out the test matrix for the RC today and tomorrow that'd be great
16:37:33 <adamw> #endmeeting