16:00:18 <adamw> #startmeeting F39-blocker-review
16:00:18 <zodbot> Meeting started Mon Sep 11 16:00:18 2023 UTC.
16:00:18 <zodbot> This meeting is logged and archived in a public location.
16:00:18 <zodbot> The chair is adamw. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
16:00:18 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:18 <zodbot> The meeting name has been set to 'f39-blocker-review'
16:00:19 <adamw> #meetingname F39-blocker-review
16:00:19 <zodbot> The meeting name has been set to 'f39-blocker-review'
16:00:19 <adamw> #topic Roll Call
16:00:26 <adamw> morning morning, who's around for blocker review fun?
16:01:07 <travier> .hello siosm
16:01:08 <zodbot> travier: siosm 'Timothée Ravier' <travier@redhat.com>
16:01:14 <travier> 👋
16:01:23 <geraldosimiao> .hello geraldosimiao
16:01:25 <zodbot> geraldosimiao: geraldosimiao 'Geraldo S. Simião Kutz' <geraldo.simiao.kutz@gmail.com>
16:01:28 <Son_Goku> .hello ngompa
16:01:28 <humaton> .hello
16:01:28 <zodbot> Son_Goku: ngompa 'Neal Gompa' <ngompa13@gmail.com>
16:01:31 <kparal> .hello kparal
16:01:31 <zodbot> humaton: (hello <an alias, 1 argument>) -- Alias for "hellomynameis $1".
16:01:36 <zodbot> kparal: kparal 'Kamil Páral' <kparal@redhat.com>
16:01:37 <coremodule> .hello2
16:01:40 <zodbot> coremodule: coremodule 'Geoffrey Marr' <gmarr@redhat.com>
16:01:40 <humaton> .hello2
16:01:42 <lruzicka> .hello lruzicka
16:01:43 <zodbot> humaton: humaton 'Tomáš Hrčka' <thrcka@redhat.com>
16:01:46 <zodbot> lruzicka: lruzicka 'Lukáš Růžička' <lruzicka@redhat.com>
16:02:10 <kparal> it seems I can talk even though I haven't bothered to provide my password to NickServ. That's nice.
16:02:25 <adamw> what's that? we can't hear you
16:02:25 <kparal> if you don't see my messages, let me know ;-)
16:02:32 <adamw> i saw nothing
16:02:38 <lruzicka> I can see your messages.
16:02:41 <adamw> #chair kparal humaton
16:02:41 <zodbot> Current chairs: adamw humaton kparal
16:02:44 <humaton> what messages?
16:02:50 <adamw> oh no, now I can't see lruzicka's messages either
16:02:54 <adamw> it's spreading
16:03:04 <lruzicka> adamw, no?
16:03:05 <humaton> spreading by tcpip
16:03:08 <kparal> lruzicka: time to pack up and go for a beer
16:03:15 <lruzicka> kparal, looks like this
16:03:25 <humaton> pick me up in TPBC
16:03:29 <humaton> :D
16:03:30 <aoife> Hi!
16:03:39 <adamw> :D
16:03:46 <adamw> hi aoife
16:03:55 <adamw> alright, boilerplate alert
16:04:01 <adamw> #topic Introduction
16:04:01 <adamw> Why are we here?
16:04:01 <adamw> #info Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs.
16:04:01 <adamw> #info We'll be following the process outlined at:
16:04:01 <adamw> #link https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting
16:04:03 <adamw> #info The bugs up for review today are available at:
16:04:05 <adamw> #link http://qa.fedoraproject.org/blockerbugs/current
16:04:07 <adamw> #info The criteria for release blocking bugs can be found at:
16:04:09 <adamw> #link https://fedoraproject.org/wiki/Basic_Release_Criteria
16:04:11 <adamw> #link https://fedoraproject.org/wiki/Fedora_39_Beta_Release_Criteria
16:04:13 <adamw> #link https://fedoraproject.org/wiki/Fedora_39_Final_Release_Criteria
16:04:18 <adamw> #info for Beta, we have:
16:04:19 <adamw> #info 4 Proposed Blockers
16:04:19 <adamw> #info 2 Accepted Blockers
16:04:23 <adamw> #info 3 Proposed Freeze Exceptions
16:04:23 <adamw> #info 22 Accepted Freeze Exceptions
16:04:27 <adamw> #info for Final, we have:
16:04:41 <adamw> #info 5 Proposed Blockers
16:04:53 <adamw> anyone want to secretarialize?
16:05:38 * coremodule will do it.
16:05:52 <frantisekz> .hello2
16:05:53 <zodbot> frantisekz: frantisekz 'František Zatloukal' <fzatlouk@redhat.com>
16:06:01 <sgallagh> .hi
16:06:02 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
16:06:38 <adamw> #info coremodule will secretarialize
16:06:44 <adamw> hi latecomers
16:06:46 <adamw> have a seat at the back :D
16:07:13 <adamw> alright, let's get started with:
16:07:16 <adamw> #topic proposed Beta blockers
16:07:19 * sgallagh slowly drags a chair right up to the front of the classroom, scraping all the way.
16:07:30 <adamw> #topic (2237878) Anaconda webUI can't handle two btrfs volumes with the same name, writes into a different partition than indicated
16:07:30 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=2237878
16:07:31 <adamw> #link https://pagure.io/fedora-qa/blocker-review/issue/1295
16:07:31 <adamw> #info Proposed Blocker, anaconda, NEW
16:07:31 <adamw> #info Ticket vote: BetaBlocker (+5,0,-1) (+kparal, +adamwill, +geraldosimiao, +frantisekz, +lruzicka, -lnie)
16:07:33 <adamw> #info Ticket vote: BetaFreezeException (+1,0,-0) (+lnie)
16:07:37 <adamw> .fire sgallagh
16:07:37 <zodbot> adamw fires sgallagh
16:07:52 <adamw> so this one technically has enough votes to be accepted, but I thought it'd be best to bring it and its buddy up at the meeting as they're quite 'big'
16:07:54 <kparal> I added more scenarios and details today
16:08:48 <adamw> yeah, thanks for that, very useful
16:09:12 <adamw> that just makes me stronger +1 blocker for this one, and -1 to considering it resolved if the other one is fixed
16:09:20 <adamw> anyone have any arguments against making this a blocker?
16:09:26 <sgallagh> So my understanding from that most recent update is that attempting to install F39 into new partitions on a system with F38 on it will overwrite F38?
16:09:36 <adamw> i am a bit worried at how much work it might be to fix, but it definitely seems like a bad thing to release even a beta with
16:09:37 <frantisekz> nope, me been +1 blocker before, now +inf blocker
16:09:47 <frantisekz> did I break you adamw? :D
16:10:01 * adamw has crashed with a buffer overflow
16:10:09 <adamw> backtrace: frantisekz did it
16:10:11 <frantisekz> Platinum Trophy unlocked...
16:10:24 <sgallagh> kparal, do I have that right?
16:10:26 <adamw> sgallagh: I don't think so. you'd need to have *two* previous Fedora installs
16:10:39 <adamw> the triggering condition is two *pre-existing* btrfs volumes with the same label
16:10:42 <kparal> yes, it only confuses two different btrfs partitions with the same label
16:11:01 <kparal> preexisting or new ones, created in blivet-gui
16:11:03 <sgallagh> Ah, well that's... _less_ awful.
16:11:11 <humaton> but still bad
16:11:13 <adamw> i don't expect a lot of people are going to see this, but to me it's bad enough that we shouldn't let *one* person see it
16:11:19 <Son_Goku> yes I agree
16:11:47 <sgallagh> On the one hand: super-rare. On the other hand: catastrophic data loss.
16:11:50 <kparal> I guess if everybody objected, I'd be ok with moving this to Final. But I prefer Beta.
16:11:57 <humaton> I will definitely hit this once back at home running all stable releases on bare metal side by side
16:12:12 <frantisekz> procedural question: do we have a word from anaconda if there is a non-zero possibility of having this fixed by tomorrow?
16:12:23 <kparal> I don't
16:13:30 <sgallagh> I'm really on the fence as to whether this is a Beta blocker or just a really loud warning in the Beta announcement. Unquestionably this has to be fixed for Final.
16:13:39 <kparal> I'm concerned that it will require lots of rewrites in the webui code
16:14:06 <sgallagh> I guess call it a Beta blocker and consider waiving it under the hard-to-fix rule, if needed?
16:14:25 <kparal> I'm also concerned that we haven't found all the use cases and people might hit it easier than we imagine
16:14:28 <adamw> yeah, that's my concern too. though, one thought I have is, even if we can't *fix* it soon we might be able to do a bodge: detect whether we have this scenario and just refuse to do anything
16:14:41 <adamw> let me see if any anaconda folks are arounf
16:16:16 * adamw pings on yet another chat system
16:16:25 <adamw> 2020s chat is going great
16:16:44 <Son_Goku> I would also consider this a candidate for reverting the web UI for F39
16:16:45 <kparal> there's a related problem that the current webui is very obscure when you have two volumes with the same name/label, the mount point screen doesn't really tell you which is which. If you have both partitions of the same size, you're screwed, you can't tell them apart. But even if you can (as I always made sure), it still might write somewhere else
16:16:45 <kparal> then instructed.
16:17:27 <kparal> right, technically, we could revert to GTK UI for Beta. But I'm not sure if all the gnome-initial-setup and other related changes are also easy to revert or not.
16:18:33 <adamw> one thing i saw in the anaconda chat is that vtrefny says this isn't actually new
16:18:42 <adamw> "about this one, it's not a new bug. Anaconda never knew how to work with two labels because we can't recognize them. It's just more visible with Web UI"
16:18:43 <frantisekz> that another chat system logged me out yet again...
16:19:04 <adamw> I don't know what "more visible" *means* exactly there, and whether you can, practically speaking, run into the same result on oldUI
16:19:17 <adamw> (newUI is now oldUI, update your newspeak dictionaries!)
16:20:21 <lruzicka> I guess Blivet-GUI is the same there, right?
16:20:32 <adamw> same as what?
16:20:42 <kparal> that's something I can check, whether it's problematic also in GTK in some cases
16:20:44 <sgallagh> Between WebUI and new/oldUI
16:20:58 <adamw> kparal: thanks
16:21:02 <lruzicka> if the webUI was reverted to GTK, the blivet-gui dealing with partitions is always the same, aint it?
16:21:14 <kparal> the point is, you no longer assign mount points in blivet-gui, you now do it in a new UI in webui
16:21:20 <adamw> lruzicka: you encounter this bug in the webUI mount point assignment screen, not blivet-gui
16:21:52 <kparal> adamw: but I'm not sure if I can do it today, or maybe not even tomorrow, because my daughter got stomach flu or something, it seems
16:21:56 <sgallagh> Right, but is that unique to the new screen, or is the new screen using the same API to do it?
16:22:05 <adamw> kparal: fun! well I can try it too
16:22:45 * kparal tries to look at it now
16:22:47 <adamw> sgallagh: we really don't know yet.
16:23:04 <sgallagh> Sorry, that was me restating the question, not asking a new one
16:23:50 <adamw> so it doesn't seem like we're gonna get the devs' feedback right now. for now I propose we accept this as a blocker, we do have the ability to revote or waive if that seems indicated.
16:24:02 <lruzicka> sounds good
16:24:11 <humaton> ack
16:24:16 <sgallagh> If they're following Cockpit principles, there shouldn't really be much net-new code for the actual actions. The whole philosophy is to separate the logic and UI layers.
16:24:28 <sgallagh> But yes, +1 to block given the available information
16:25:16 <adamw> proposed #agreed 2237878 - AcceptedBlocker (Beta) - this is accepted as a violation of "the installer must be able to: ... Assign mount points to existing storage volumes" on webUI. while the triggering condition is not super common, the potential consequences are catastrophic enough that we believe it should block release
16:25:27 <lruzicka> ack
16:25:29 <sgallagh> ack
16:25:33 <humaton> ack
16:25:34 <geraldosimiao> ack
16:25:43 <kparal> ack
16:25:45 <Son_Goku> ack
16:25:47 <adamw> #agreed 2237878 - AcceptedBlocker (Beta) - this is accepted as a violation of "the installer must be able to: ... Assign mount points to existing storage volumes" on webUI. while the triggering condition is not super common, the potential consequences are catastrophic enough that we believe it should block release
16:26:11 <adamw> sgallagh: it's just inherently a different-enough UI that even if all the 'backend code' is the same (which it is), it is possible this could be encounterable in the webUI but not really encounterable in the oldUI
16:26:38 <adamw> oldUI rolls the 'do partitioning stuff' and 'assign mountpoints' operations into one, webUI handles them separately, so it's just...different
16:27:06 <sgallagh> I'm on board with blocking, so let's move on.
16:27:11 <adamw> #topic (2238292) blivet-gui on Workstation Live doesn't show existing btrfs subvolumes
16:27:12 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=2238292
16:27:12 <adamw> #link https://pagure.io/fedora-qa/blocker-review/issue/1298
16:27:12 <adamw> #info Proposed Blocker, blivet-gui, NEW
16:27:12 <adamw> #info Ticket vote: BetaBlocker (+3,0,-1) (+kparal, +geraldosimiao, +lruzicka, -frantisekz)
16:28:43 <adamw> this does seem like a violation of the custom part criteria to me
16:29:05 * humaton added vote to the ticket
16:29:09 <Son_Goku> yeah
16:29:10 <sgallagh> Yeah
16:29:11 <humaton> this seems like clear blocker
16:29:24 <adamw> as the person who wrote the criterion text debated in the ticket, i'd say kparal is right about how to read it
16:29:35 <adamw> it's not meant to be an exhaustive treatise on how each storage technology works, it's just a list of them
16:29:45 <adamw> displaying btrfs subvols should be read to be in scope
16:30:05 <Son_Goku> I would hope so
16:30:14 <sgallagh> Speaking as a proud pedant, even I agree with that :)
16:31:29 <adamw> proposed #agreed 2238292 - AcceptedBlocker (Beta) - this is accepted as a violation of "the installer must be able to: Correctly interpret, and modify as described below, any disk ... containing ... btrfs volumes"
16:31:39 <frantisekz> yeah, the comparison with LVM makes sense, ack
16:31:39 <lruzicka> ack
16:31:40 <geraldosimiao> ack
16:31:43 <humaton> ack
16:32:02 <adamw> #agreed 2238292 - AcceptedBlocker (Beta) - this is accepted as a violation of "the installer must be able to: Correctly interpret, and modify as described below, any disk ... containing ... btrfs volumes"
16:32:16 <adamw> #topic (2232838) Some NVME controllers fail to initialize with kernel 6.4.11 or later (nvme0: controller is down; will reset: CSTS:0xffffffff, PCI_STATUS=0xffff)
16:32:16 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=2232838
16:32:16 <adamw> #link https://pagure.io/fedora-qa/blocker-review/issue/1291
16:32:16 <adamw> #info Proposed Blocker, kernel, NEW
16:32:29 <humaton> this is ugly :/
16:32:42 <frantisekz> this is already/been proposed for Final, I think it deserves at least Beta discusion too
16:33:14 <kparal> frantisekz: have you looked at the upstream discussion whether there's some movement?
16:33:26 <frantisekz> nope
16:33:39 <adamw> breaking common Dell hardware seems...bad
16:34:18 <Son_Goku> ugh
16:34:20 <kparal> I think it's fine if some laptops can't install Beta, but it would be good to avoid this at Final. But the last time I looked, nobody worked on it.
16:34:31 <Son_Goku> so I guess it's not fixed in 6.5.2 then?
16:34:34 <adamw> well, justin's on the bug, and he's the kernel maintainer
16:34:34 <kparal> and I'm not sure if we want to carry a downstream revert
16:34:42 <humaton> still present in 6.5.2
16:34:46 <adamw> jforbes: are you around?
16:34:49 <adamw> thoughts about this?
16:34:51 <humaton> its mentioned in the tracker somewhere
16:35:00 <kparal> adamw: I meant upstream kernel devs
16:35:18 <Son_Goku> I think carrying a revert is prudent until the problem is solved upstream
16:35:22 <Son_Goku> we've done stuff like that before
16:35:40 <frantisekz> there seems to be a revert-based solution available/used in suse: https://github.com/openSUSE/kernel-source/commit/1b02b1528a26f4e9b577e215c114d8c5e773ee10
16:35:40 <adamw> looks like suse alreadyr reverted it
16:35:42 <sgallagh> Is this impacting other distros?
16:35:47 <sgallagh> You beat me to the question
16:35:51 <humaton> there is a link to suse
16:35:53 <frantisekz> heh, power management, again...
16:35:56 <humaton> https://bugzilla.kernel.org/show_bug.cgi?id=217802#c18
16:36:37 <geraldosimiao> David Klann commented on the ticket: Confirming that this behavior exists in kernel 6.5.2-200 here on Dell XPS 15 9560 (07BE) with the Realtek RTS525A PCI Express Card Reader.
16:36:42 <adamw> ml thread - https://lore.kernel.org/linux-nvme/c766f724-709d-42c1-b0eb-a7a543d28bd6@gmail.com/T/#t
16:37:14 <adamw> where Thorsten is talking about doing an upstream revert
16:37:57 <sgallagh> OK, I don't think this group needs to design the solution, just decide if we can or cannot ship without one. Yes?
16:38:14 <Son_Goku> I do think we cannot ship without a solution
16:38:20 <adamw> yes, but we're considering the practicality of fixing it, which we do sometimes. a revert seems like a viable solution, given the above
16:38:46 <adamw> i'm strong +1 final blocker, +1 beta fe, i guess weak +1 beta blocker...we could probably get away with shipping with a warning but it'd suck
16:38:55 <Son_Goku> +1 Beta Blocker
16:38:59 <frantisekz> +1 Beta Blocker
16:39:00 <sgallagh> I just meant that it seems like we were largely in favor of at least Final blocker
16:39:18 <Son_Goku> final blocker is no question
16:39:25 <Son_Goku> but beta blocker is what we should consider now
16:39:33 <sgallagh> How common is this Dell hardware? Recent XPS machines? All machines since 2002?
16:39:39 <humaton> so
16:39:42 <humaton> also lenovo
16:39:51 <humaton> https://linux-hardware.org/index.php?id=pci:10ec-525a-17aa-222e
16:39:57 <humaton> that is one of the chips affected
16:40:07 <sgallagh> OK, if it's hitting a large swath of at least two manufacturers, I can be in favor of Beta Blocker +1
16:40:28 <Son_Goku> IIRC the chipset is commonly used in 2017+ laptops
16:40:40 <coremodule> +1 Beta Blocker
16:40:42 <adamw> you'd need both the affected controller *and* the affected realtek hardware, AIUI
16:41:15 <Son_Goku> I'm reminded of an old saying about Realtek...
16:42:06 <adamw> the commit that breaks it changes files for several models of realtek card reader. presumably if you have any of those, plus...certain?...NVMe controller(s), you're affected.
16:42:06 <humaton> +1 Beta Blocker
16:42:19 <adamw> anyhow, knowing the several common Dell models are affected seems enough for me.,
16:42:54 <geraldosimiao> +1 Beta Blocker
16:43:12 <lruzicka> +1 Beta Blocker
16:44:29 <adamw> proposed #agreed 2232838 - AcceptedBlocker (Beta) - this is accepted as a violation of "The installer must be able to complete an installation to a single disk" and/or "A system installed with a release-blocking desktop must boot to a log in screen" on affected systems (whichever point it fails at)
16:44:38 <frantisekz> ack
16:44:40 <humaton> ack
16:44:40 <lruzicka> ack
16:44:43 <geraldosimiao> ack
16:45:03 <adamw> #agreed 2232838 - AcceptedBlocker (Beta) - this is accepted as a violation of "The installer must be able to complete an installation to a single disk" and/or "A system installed with a release-blocking desktop must boot to a log in screen" on affected systems (whichever point it fails at)
16:45:27 <adamw> #topic (2237375) blivet-gui creates different volumes with the same name, confusing anaconda webUI
16:45:27 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=2237375
16:45:27 <adamw> #link https://pagure.io/fedora-qa/blocker-review/issue/1260
16:45:27 <adamw> #info Proposed Blocker, python-blivet, ASSIGNED
16:45:27 <adamw> #info Ticket vote: BetaBlocker (+1,0,-2) (+lnie, -kparal, -frantisekz)
16:45:30 <adamw> #info Ticket vote: BetaFreezeException (+4,0,-0) (+kparal, +adamwill, +geraldosimiao, +frantisekz)
16:45:57 <frantisekz> I'll need to run, it's one of the last hot days here, and beer calls...
16:45:58 <adamw> so this one is the companion bug to the first bug - this is about how blivet-gui by default *creates* multiple btrfs volumes with the same label, if you create more than one btrfs volume in a blivet-gui run
16:46:04 <adamw> frantisekz: thanks for being here
16:46:08 <frantisekz> thanks!
16:46:48 <adamw> i think it makes more sense to block on the first one than this one, overall. but making this an FE also makes sense, as even if we make the installer *handle* multiple btrfs volumes with the same label better, *creating* btrfs volumes with the same label as an existing one seems like bad behaviour.
16:46:57 <Son_Goku> yes
16:47:05 <Son_Goku> it's less "game breaking" but it's not great either
16:47:13 <Son_Goku> especially since our default behavior of mounting by label
16:47:36 <Son_Goku> or at least it used to be at some point
16:47:42 <Son_Goku> I just looked and we mount by UUID :)
16:47:47 <Son_Goku> so it's just... not great
16:49:33 <adamw> so, -1 blocker, +1 FE for me
16:49:35 * kparal nods
16:49:45 <Son_Goku> +1 blocker +1 FE
16:49:47 <Son_Goku> err
16:49:48 <humaton> +1FE -1 blocker as well
16:49:53 <Son_Goku> -1 Blocker +1 FE
16:50:00 <lruzicka> -1 blocker +1 fe
16:50:14 <Son_Goku> the main problem with it is that it's just super-confusing
16:50:16 <sgallagh> BetaBlocker -1
16:50:16 <sgallagh> BetaFE +1
16:50:50 <geraldosimiao> I already voted, +1FE -1Blocker
16:52:28 <adamw> proposed #agreed 2237375 - RejectedBlocker (Beta), AcceptedFreezeException (Beta) - we agreed it makes more sense to block on 2237878 than on this (i.e. make the installer handle multiple volumes with the same label). but creating them is still a bad idea and should be fixed if possible, so we grant this an FE
16:52:46 <humaton> ack
16:52:47 <geraldosimiao> ack
16:53:29 <coremodule> ack
16:53:31 <Son_Goku> ack
16:53:48 <adamw> #agreed 2237375 - RejectedBlocker (Beta), AcceptedFreezeException (Beta) - we agreed it makes more sense to block on 2237878 than on this (i.e. make the installer handle multiple volumes with the same label). but creating them is still a bad idea and should be fixed if possible, so we grant this an FE
16:53:51 <adamw> ok, let's move on to:
16:53:56 <adamw> #topic Proposed Beta freeze exceptions
16:54:08 <adamw> #topic (2236156) [webui] "Use Free Space..."  option is not always visible/hidden
16:54:08 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=2236156
16:54:08 <adamw> #link https://pagure.io/fedora-qa/blocker-review/issue/1300
16:54:08 <adamw> #info Proposed Freeze Exceptions, anaconda, MODIFIED
16:54:08 <adamw> #info Ticket vote: BetaFreezeException (+1,0,-0) (+kparal)
16:55:09 <humaton> +1
16:55:32 <sgallagh> I need to run to another meeting. Be well!
16:55:59 <adamw> thanks sgallagh
16:56:07 <humaton> the fix is merged upstream so this should be FE
16:56:20 <geraldosimiao> +1 FE
16:56:22 <lruzicka> +1 fe
16:57:04 <coremodule> +1 FE
16:57:10 <Son_Goku> what are we FE voting for?
16:57:14 <Son_Goku> oh
16:57:15 <Son_Goku> got it
16:57:21 <Son_Goku> IRC formatting facepalm
16:57:23 <Son_Goku> +1 FE
16:58:58 <adamw> proposed #agreed 2236156 - AcceptedFreezeException (Beta) - this is a fairly findable UI issue in the installer that cannot be fixed with an update, since we have a fix for it and the fix is fairly targeted it makes sense to include it
16:59:21 <coremodule> ack
16:59:27 <humaton> ack
16:59:40 <geraldosimiao> ack
16:59:51 <lruzicka> ack
16:59:53 <adamw> #agreed 2236156 - AcceptedFreezeException (Beta) - this is a fairly findable UI issue in the installer that cannot be fixed with an update, since we have a fix for it and the fix is fairly targeted it makes sense to include it
17:00:11 <adamw> oh, next one has -3 already, so i'll handle it outside of meeting
17:00:21 <adamw> #info 2237658 will be skipped as it's already at -3 in ticket voting
17:00:27 <adamw> #topic (2237707) Update Python to 3.12.0rc2
17:00:27 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=2237707
17:00:28 <adamw> #link https://pagure.io/fedora-qa/blocker-review/issue/1287
17:00:28 <adamw> #info Proposed Freeze Exceptions, python3.12, ON_QA
17:00:28 <adamw> #info Ticket vote: BetaFreezeException (+3,0,-3) (+zbyszek, +frantisekz, +geraldosimiao, -adamwill, -kparal, -lruzicka)
17:00:31 <adamw> controversy!
17:00:50 <geraldosimiao> this is fun ;)
17:00:50 <humaton> I think we should ship it
17:00:51 <adamw> i think we got a bit of a green light mentality for FEs lately, but considered strictly, this shouldn't really be one
17:00:54 <humaton> let me read the ticket
17:01:21 <Son_Goku> +1 FE
17:02:05 <humaton> hmm
17:02:26 <humaton> so the problem with hitting hidden bugs is a real one
17:02:49 <adamw> i mean, the thing is, both the benefit and the cost are "hitting hidden bugs"
17:02:59 <adamw> the benefit is "this might help us find bugs in the install process caused by rc2"
17:03:06 <humaton> yeah
17:03:11 <adamw> the cost is..."this might cause us to encounter bugs in the install process caused by rc2"
17:03:17 <humaton> that is my thinking but will people be able to fix such bugs?
17:03:26 <adamw> the 'winning' scenario I guess is that we find one, but it's not bad enough to be a beta blocker
17:03:44 <adamw> the "losing" scenario is rc2 causes a bug which *is* a beta blocker (and for bonus points, a really bad one that takes time to fix and slips the release)
17:04:04 <humaton> that is what  I am thinking about
17:04:23 <adamw> i don't really like the idea of saying "let's take something as an FE so hopefully it breaks stuff!"
17:04:29 <humaton> so -1 FE
17:04:30 <adamw> that feels wrong. :D
17:04:34 <humaton> exactly
17:04:40 <humaton> its nice to have the latst but
17:04:49 <kparal> adamw: OT, I tested the btrfs partitioning issue with F38, my results are here: https://pagure.io/fedora-qa/blocker-review/issue/1295#comment-873591
17:04:52 <humaton> this is the correct sollution just do it as a update
17:05:29 <humaton> the potential of introducing new bugz in the install process is just not worthed
17:06:31 <adamw> any other votes?
17:06:55 <adamw> if this stays with a non-clear result we'll just punt it
17:08:00 <adamw> proposed #agreed 2237707 - punt (delay decision) - we have a split vote here, cannot accept or reject. We will punt this; if a clear consensus emerges in ticket voting it can be accepted or rejected
17:08:13 <kparal> ack
17:08:25 <humaton> ack
17:08:42 <coremodule> ack
17:08:49 <geraldosimiao> ack
17:09:09 <lruzicka> ack
17:09:16 <adamw> #agreed 2237707 - punt (delay decision) - we have a split vote here, cannot accept or reject. We will punt this; if a clear consensus emerges in ticket voting it can be accepted or rejected
17:09:41 <adamw> OK, time for a quick trip through:
17:09:45 <adamw> #topic Proposed Final blockers
17:10:00 <adamw> #info 2237878 was accepted as Beta blocker, so no need to consider it here
17:10:08 <adamw> #topic (2238282) Can't refocus blivet-gui, anaconda crashes on trying to launch it again
17:10:08 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=2238282
17:10:09 <adamw> #link https://pagure.io/fedora-qa/blocker-review/issue/1297
17:10:09 <adamw> #info Proposed Blocker, anaconda, NEW
17:10:09 <adamw> #info Ticket vote: FinalBlocker (+2,0,-0) (+kparal, +lruzicka)
17:10:09 <adamw> #info Ticket vote: BetaFreezeException (+4,0,-0) (+kparal, +frantisekz, +lruzicka, +lnie)
17:10:14 <adamw> note, already accepted as Beta FE
17:11:21 <adamw> hum, fun one
17:11:35 <adamw> seems like a borderline case. it's a conditional blocker, is the condition bad enough
17:11:39 <adamw> i think i'm a weak +1
17:11:56 <kparal> I'm also weak +1 :-)
17:12:31 <humaton> weak +1 here
17:12:32 <adamw> i kinda feel like this might not pass bcotton's Last Blocker Test though
17:12:49 <kparal> it's true that you can reboot and continue making disk changes, and this time try to not click outside the window
17:13:06 <kparal> but it's also lame :)
17:13:15 <adamw> also, you know...i think *most* people are aware of alt-tab...
17:13:41 <kparal> I'm aware of it but it took me at least half a minute to figure it out :D
17:13:57 <lruzicka> adamw, not sure about it ..  alt-tab did not work in oldUI
17:13:59 <kparal> because it doesn't look like a working session, it looks like a single window kiosk-style env
17:13:59 <adamw> well, let's take it for now, we can have second thoughts later. :D
17:14:05 <kparal> so I just didn't think about it
17:14:45 <geraldosimiao> +1
17:14:54 <adamw> proposed #agreed 2238282 - AcceptedBlocker (Final) - this is accepted as a conditional violation of all the disk management criteria, in the case you manage to trigger this by clicking outside of the blivet-gui window
17:14:55 <jforbes> adamw: back now
17:15:05 <geraldosimiao> ack
17:15:08 <humaton> ack
17:15:18 <kparal> now that you started questioning it, I'm less sure about +1 and more like 0 :D
17:15:24 <kparal> anyway, ack
17:15:35 <adamw> jforbes: hi! sorry, we moved on, but we decided to take that NVMe + realtek bug as a blocker, will it be possible to do a revert of the culprit commit? it seems SUSE did this already and Thorsten is talking about reverting it upstream
17:15:57 <kparal> jforbes: https://bugzilla.redhat.com/show_bug.cgi?id=2232838
17:16:10 <adamw> #topic quick 2232838 cameo by jforbes
17:16:16 <adamw> grr
17:16:25 * humaton have to run
17:16:25 <adamw> #topic (2238282) Can't refocus blivet-gui, anaconda crashes on trying to launch it again
17:16:34 <jforbes> adamw: sure was planning to do it with 6.5.3, but that is a massive build. so I will just do a 1 off today
17:16:34 <adamw> #agreed 2238282 - AcceptedBlocker (Final) - this is accepted as a conditional violation of all the disk management criteria, in the case you manage to trigger this by clicking outside of the blivet-gui window
17:16:41 <adamw> #topic quick 2232838 cameo by jforbes
17:17:03 <adamw> jforbes: oh yeah very much a one-off with just that :D thanks
17:17:32 <adamw> #info jforbes says a revert of the offending commit for 2232838 should be possible and he will work on it today
17:17:33 <adamw> thanks!
17:17:59 <adamw> #topic (2236343) When adding a US layout for a non-ASCII-capable layout, put US first in the list, but ensure the KEYMAP setting in vconsole.conf is the native layout
17:17:59 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=2236343
17:17:59 <adamw> #link https://pagure.io/fedora-qa/blocker-review/issue/1240
17:17:59 <adamw> #info Proposed Blocker, gnome-initial-setup, ON_QA
17:18:06 <adamw> i know, i know, adam's being weird about keyboards again
17:18:57 <adamw> so, if i'm right about the behaviour here it's a clear blocker. I should be able to confirm that by testing whether the console layout is correct with the fixed g-i-s, now we have one. i just didn't get around to testing that yet
17:20:25 <kparal> so a punt?
17:20:38 <adamw> either trust adam or punt
17:20:41 <adamw> so, probably punt? :D
17:21:07 <kparal> I trust that you'll do the verification well
17:21:13 <geraldosimiao> Me too
17:21:23 <kparal> and close the bug if already fixed :-D
17:21:36 <adamw> proposed #agreed 2236343 - punt (delay decision) - we need to confirm adam's theory about this affecting the console layout of the installed system before we can confirm whether it's a blocker, adam will test that today
17:21:39 <lruzicka> ack
17:21:41 <adamw> kparal: haaah. well played
17:21:42 <kparal> ack
17:21:47 <geraldosimiao> ack
17:21:58 <adamw> #agreed 2236343 - punt (delay decision) - we need to confirm adam's theory about this affecting the console layout of the installed system before we can confirm whether it's a blocker, adam will test that today
17:22:21 <adamw> #info 2232838 is already accepted as Beta blocker, no need to consider it here
17:22:28 <adamw> #topic (2187858) sddm-wayland-plasma does not respect keyboard layout variant
17:22:28 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=2187858
17:22:28 <adamw> #link https://pagure.io/fedora-qa/blocker-review/issue/1158
17:22:28 <adamw> #info Proposed Blocker, sddm, NEW
17:22:28 <adamw> #info Ticket vote: BetaBlocker (+1,0,-1) (+geraldosimiao, -catanzaro)
17:22:30 <adamw> #info Ticket vote: FinalBlocker (+3,0,-0) (+geraldosimiao, +nielsenb, +catanzaro)
17:22:33 <adamw> this is the one we've punted for more testing twice now
17:22:42 <adamw> i did a quick simple test before the meeting and it seemed to work for me
17:22:50 <adamw> would be good if others can test also and maybe try slightly different setups
17:24:18 * kparal will try
17:24:33 <adamw> i guess we'll punt once more, as i don't think i wanna reject based on just my one test...
17:24:33 * kparal will try to try
17:25:36 <adamw> heh
17:26:04 <adamw> proposed #agreed 2187858 - punt (delay decision) - adam did a simple test here, but it would probably be good for more folks to test more slightly different setups to see if we can identify any remaining issues
17:26:12 <geraldosimiao> ack
17:27:23 <coremodule> ack
17:28:02 <adamw> let's go with Reduced Ack Rules
17:28:06 <adamw> #agreed 2187858 - punt (delay decision) - adam did a simple test here, but it would probably be good for more folks to test more slightly different setups to see if we can identify any remaining issues
17:28:21 <adamw> I just found another proposed blocker, so let's do a quick:
17:28:25 <adamw> #topic Proposed Beta blockers redux
17:29:01 <adamw> #topic (2237986) Fedora 39 fails to boot on qemu VM using OVMF_CODE_4M.secboot.qcow2 firmware
17:29:11 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=2237986
17:29:27 <adamw> #info Proposed Blocker, libvirt, MODIFIED
17:30:02 <adamw> #link https://pagure.io/fedora-qa/blocker-review/issue/1294
17:30:07 <adamw> ticket vote is at -2
17:30:19 <geraldosimiao> this is really strange
17:30:25 <adamw> it's not, we know what's going on
17:30:37 <geraldosimiao> because libvirt isn't installed on the shipped iso
17:30:42 <adamw> it's broken for a specific firmware, and only in 9.6.0
17:30:44 <adamw> oh, that part
17:30:49 <geraldosimiao> yeah
17:30:57 <geraldosimiao> and gnome boxes works
17:31:12 <adamw> gnome-boxes requires a lot of libvirt stuff
17:31:22 <geraldosimiao> but boxes doesn't allow to choose this firmware
17:31:31 <geraldosimiao> it does
17:31:33 <adamw> yeah, which is a -1 argument
17:32:00 <adamw> it's weird, gnome-boxes requires libvirt-daemon-config-network
17:32:12 <geraldosimiao> this is installet
17:32:16 <geraldosimiao> installed
17:32:29 <adamw> anyhow
17:32:36 <adamw> i think i'm definitely -1 blocker on this
17:32:54 <adamw> and probably -1 FE. it can probably just go in as an update and be fine, since as you say, gnome-boxes doesn't let you encounter this, i don't think
17:33:06 <adamw> and anyone using any other tool probably should have updates available before they can do it
17:33:07 <geraldosimiao> ack
17:33:12 <kparal> -1 blocker, ack
17:33:15 <adamw> we need votes before acks :D
17:33:23 <adamw> are you both -1 FE?
17:33:33 <geraldosimiao> this only happen after installing virt-manager and libvirt
17:33:35 <adamw> oh hmm
17:33:48 <geraldosimiao> -1 blocker
17:34:05 <lruzicka> -1 blocker
17:34:08 <adamw> we might want to be +1 FE not to this, but to https://bugzilla.redhat.com/show_bug.cgi?id=2232805 ...
17:34:14 <kparal> no sure about FE, my healthy child is jumping over my head
17:34:21 <adamw> okay, let's just reject as blocker for now I guess
17:34:33 <geraldosimiao> ok for FE
17:34:40 <geraldosimiao> +1 FE
17:34:45 <geraldosimiao> -1 Blocker
17:35:02 <adamw> proposed #agreed 2237986 - RejectedBlocker (Beta) - we don't believe GNOME Boxes offers the affected configuration, and anyone running into it with any other tool should have updates available at the time, so it's fine for this to go as a regular update
17:35:17 <geraldosimiao> ack
17:35:24 <lruzicka> ack
17:35:25 <adamw> i will propose the other bug as an FE for ticket vote
17:35:36 <kparal> ack
17:35:43 <Son_Goku> ack
17:36:15 <kparal> I must go, see you
17:36:16 <adamw> #agreed 2237986 - RejectedBlocker (Beta) - we don't believe GNOME Boxes offers the affected configuration, and anyone running into it with any other tool should have updates available at the time, so it's fine for this to go as a regular update
17:36:18 <adamw> ok
17:36:27 <aoife> need to drop too fyi
17:36:34 <adamw> #info let's skip accepted blocker review as folks are leaving and I also have to, will look at them outside the meeting
17:36:37 <adamw> #topic Open floor
17:36:43 <adamw> any other business?
17:37:09 <adamw> we may need to talk about possibly giving up on webUI for this release at some point, but let's give anaconda folks a day or two at least to look at the current blockers
17:37:38 <geraldosimiao> ok, its fair
17:39:45 <lruzicka> I need to go, too. Take care.
17:40:12 <adamw> alrighty, sounds like nobody has anything else
17:40:16 <adamw> thanks for coming, folks
17:40:18 <adamw> #endmeeting