#fedora-blocker-review: F39-blocker-review

Meeting started by adamw at 16:00:18 UTC (full logs).

Meeting summary

  1. Roll Call (adamw, 16:00:18)
  2. Introduction (adamw, 16:04:21)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (adamw, 16:04:21)
    2. We'll be following the process outlined at: (adamw, 16:04:21)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (adamw, 16:04:21)
    4. The bugs up for review today are available at: (adamw, 16:04:23)
    5. http://qa.fedoraproject.org/blockerbugs/current (adamw, 16:04:27)
    6. The criteria for release blocking bugs can be found at: (adamw, 16:04:29)
    7. https://fedoraproject.org/wiki/Basic_Release_Criteria (adamw, 16:04:31)
    8. https://fedoraproject.org/wiki/Fedora_39_Beta_Release_Criteria (adamw, 16:04:33)
    9. https://fedoraproject.org/wiki/Fedora_39_Final_Release_Criteria (adamw, 16:04:35)
    10. For F39 Final, we have: (adamw, 16:04:37)
    11. 3 Proposed Blockers (adamw, 16:04:39)
    12. 13 Accepted Blockers (adamw, 16:04:41)
    13. 4 Proposed Freeze Exceptions (adamw, 16:04:43)
    14. 12 Accepted Freeze Exceptions (adamw, 16:04:45)
    15. coremodule will secretarialize (adamw, 16:07:26)

  3. Proposed Final blockers (adamw, 16:07:35)
  4. (2242759) dnf system-upgrade fails on some RPi4 due to system boot date that pre-dates gpg key (adamw, 16:07:42)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2242759 (adamw, 16:07:42)
    2. https://pagure.io/fedora-qa/blocker-review/issue/1392 (adamw, 16:07:42)
    3. Proposed Blocker, dnf-plugins-core, NEW (adamw, 16:07:42)
    4. Ticket vote: FinalBlocker (+2,0,-0) (+lruzicka, +saluki) (adamw, 16:07:42)
    5. https://bugzilla.redhat.com/show_bug.cgi?id=2242759#c3 (geraldosimiao, 16:13:32)
    6. AGREED: 2242759 - AcceptedBlocker (Final) - this is accepted as a violation of "For each one of the release-blocking package sets, it must be possible to successfully complete a direct upgrade from a fully updated, clean default installation of each of the last two stable Fedora releases with that package set installed.", on affected rpi 4 systems (we note rpi 4 is a supported arm platform) (adamw, 16:16:27)

  5. (2242874) The image is no longer recognized by 'toolbox list --images', etc. (adamw, 16:16:55)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2242874 (adamw, 16:16:55)
    2. https://pagure.io/fedora-qa/blocker-review/issue/1394 (adamw, 16:16:55)
    3. Proposed Blocker, fedora-toolbox, NEW (adamw, 16:16:55)
    4. AGREED: 2242874 - RejectedBlocker (Final) AcceptedFreezeException (Final) - this does not seem to violate the criteria we put in place and probably won't affect 'typical' usage, but it would be good to have it right on release day for folks who might notice, and unblock CI (adamw, 16:29:50)

  6. (2242287) loadkeys from kbd 2.6.1 triggers all mounts in the cwd (adamw, 16:30:00)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2242287 (adamw, 16:30:00)
    2. https://pagure.io/fedora-qa/blocker-review/issue/1381 (adamw, 16:30:00)
    3. Proposed Blocker, kbd, ON_QA (adamw, 16:30:00)
    4. Ticket vote: FinalBlocker (+0,0,-1) (-saluki) (adamw, 16:30:00)
    5. Ticket vote: FinalFreezeException (+4,0,-0) (+kparal, +lruzicka, +sumantrom, +adamwill) (adamw, 16:30:01)
    6. AGREED: 2242287 - RejectedBlocker (Final) - we agreed that this is a nasty situation if you hit it, but the configuration to hit it seems very uncommon so it's not serious enough to block the release on (adamw, 16:35:25)

  7. proposed Final freeze exception issues (adamw, 16:36:15)
  8. (2240311) cmake-3.27.4-7 breaks configuration - CMake can not determine linker language for target (adamw, 16:36:25)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2240311 (adamw, 16:36:25)
    2. https://pagure.io/fedora-qa/blocker-review/issue/1393 (adamw, 16:36:25)
    3. Proposed Freeze Exceptions, cmake, MODIFIED (adamw, 16:36:25)
    4. Ticket vote: FinalFreezeException (+0,0,-3) (-kparal, -lruzicka, -adamwill) (adamw, 16:36:26)
    5. AGREED: 2240311 - AcceptedFreezeException (Final) - this is accepted in order to unblock building of fortran code with cmake, in case anyone needs to do that while we're in freeze (adamw, 16:47:21)

  9. (2239807) Fedora 39 GNOME (X11/Wayland) experiences regular screen blackouts at increasing intervals after login on amdgpu with kernel 6.5.3-300 and later (adamw, 16:48:08)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2239807 (adamw, 16:48:08)
    2. https://pagure.io/fedora-qa/blocker-review/issue/1359 (adamw, 16:48:08)
    3. Proposed Freeze Exceptions, kernel, NEW (adamw, 16:48:08)
    4. Ticket vote: FinalBlocker (+1,0,-6) (+nixuser, -zbyszek, -kparal, -lruzicka, -geraldosimiao, -nielsenb, -adamwill) (adamw, 16:48:08)
    5. Ticket vote: FinalFreezeException (+1,0,-0) (+asciiwolf) (adamw, 16:48:11)
    6. AGREED: 2239807 - AcceptedFreezeException (Final) - this is accepted as an FE just in case we happen to diagnose this bug and hit on a fix that's clearly safe, so we can include it. (adamw, 16:59:33)

  10. (1858437) /usr/bin/lspci symlink missing, causes Dying Light game not to launch (adamw, 16:59:45)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1858437 (adamw, 16:59:45)
    2. https://pagure.io/fedora-qa/blocker-review/issue/1387 (adamw, 16:59:45)
    3. Proposed Freeze Exceptions, pciutils, ON_QA (adamw, 16:59:45)
    4. Ticket vote: FinalFreezeException (+3,0,-3) (+lruzicka, +frantisekz, +ngompa, -kparal, -sumantrom, -nielsenb) (adamw, 16:59:45)
    5. AGREED: 1858437 - punt (delay decision) - this is punted because we cannot agree on a decision. note the effect of a punt is similar to a rejection, which is intended. active acceptance must be the requirement to break the freeze. (adamw, 17:13:07)

  11. (2241351) Apps depending on python-QtAwesome fail to start due to changes to fontawesome fonts (adamw, 17:13:20)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2241351 (adamw, 17:13:20)
    2. https://pagure.io/fedora-qa/blocker-review/issue/1373 (adamw, 17:13:20)
    3. Proposed Freeze Exceptions, python-QtAwesome, POST (adamw, 17:13:20)
    4. Ticket vote: FinalFreezeException (+2,0,-4) (+zbyszek, +frantisekz, -lruzicka, -kparal, -nielsenb, -geraldosimiao) (adamw, 17:13:20)
    5. AGREED: 2241351 - RejectedFreezeException (Final) - this is rejected as there is no clear rationale for breaking the freeze to fix this. it can just be a 0-day update. (adamw, 17:23:54)

  12. Accepted blocker status review (adamw, 17:24:18)
    1. i'm gonna skip ones which have updates going through the process - in general, please test and karma these (adamw, 17:24:53)

  13. (2241632) Netinstall ISO renders a black screen when using kickstart install (bare metal and VM) (adamw, 17:25:01)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2241632 (adamw, 17:25:01)
    2. https://pagure.io/fedora-qa/blocker-review/issue/1354 (adamw, 17:25:01)
    3. Accepted Blocker, anaconda, ASSIGNED (adamw, 17:25:01)
    4. we are waiting on anaconda team to diagnose and fix this one, the bug is well-described and reproduced. we're expecting an update from anaconda team tomorrow (adamw, 17:25:18)

  14. (2242437) updates-testing should be disabled, fedora-release should have release >= 1 (adamw, 17:27:06)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2242437 (adamw, 17:27:06)
    2. https://pagure.io/fedora-qa/blocker-review/issue/1385 (adamw, 17:27:06)
    3. Accepted Blocker, fedora-release, POST (adamw, 17:27:06)
    4. we just need to merge and build the fixes for this - I or releng will do this after the meeting (adamw, 17:29:23)

  15. (2113005) Live image made with BOOTX64.EFI from latest shim-x64-15.6-2 fails to boot on some boards (adamw, 17:29:34)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2113005 (adamw, 17:29:35)
    2. https://pagure.io/fedora-qa/blocker-review/issue/1154 (adamw, 17:29:35)
    3. Accepted Blocker, shim, NEW (adamw, 17:29:35)
    4. it's kinda looking like we'll have to waive this again, sadly (adamw, 17:29:43)

  16. (2241252) Fedora-Workstation-39_Beta-1.1 boots to a black screen on Raspberry Pi 4 (adamw, 17:32:21)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2241252 (adamw, 17:32:21)
    2. https://pagure.io/fedora-qa/blocker-review/issue/1352 (adamw, 17:32:21)
    3. Accepted Blocker, uboot-tools, ASSIGNED (adamw, 17:32:21)
    4. we are just waiting for developers to diagnose and fix this. not a lot anyone else can do at present (adamw, 17:39:18)

  17. Open floor (adamw, 17:39:27)


Meeting ended at 17:42:35 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. adamw (189)
  2. nielsenb (59)
  3. Son_Goku (59)
  4. kparal (54)
  5. geraldosimiao (46)
  6. rishi (21)
  7. lruzicka (18)
  8. zodbot (14)
  9. coremodule (6)
  10. sumantrom (6)
  11. jednorozec (6)
  12. michel-slm (2)
  13. thebeanogamer (1)
  14. son_goku (0)


Generated by MeetBot 0.4.