19:00:13 <jsmith> #startmeeting Fedora Board Meeting
19:00:13 <zodbot> Meeting started Mon Feb 14 19:00:13 2011 UTC.  The chair is jsmith. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:13 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:00:45 <jsmith> #meetingname Fedora Board Meeting
19:00:45 <zodbot> The meeting name has been set to 'fedora_board_meeting'
19:00:58 <jsmith> #topic Roll Call for Board Members
19:01:13 * jreznik is present
19:01:46 <jsmith> #chair jds2001 mizmo smooge spot jreznik ke4qqq
19:01:46 <zodbot> Current chairs: jds2001 jreznik jsmith ke4qqq mizmo smooge spot
19:01:50 * jsmith is here
19:02:04 <jsmith> #chair abadger1999
19:02:04 <zodbot> Current chairs: abadger1999 jds2001 jreznik jsmith ke4qqq mizmo smooge spot
19:02:15 <abadger1999> hola
19:02:34 <jsmith> #chair kital
19:02:34 <zodbot> Current chairs: abadger1999 jds2001 jreznik jsmith ke4qqq kital mizmo smooge spot
19:02:39 * mizmo is half-here (in another meeting as well)
19:03:04 <smooge> here
19:03:14 <jsmith> I know that spot is travelling today, and that Rex is feeling ill
19:03:18 * kital is in unfocused mode - but is here
19:03:36 * gomix will probably just lurk
19:04:06 <jsmith> OK, let's get started
19:04:10 <jsmith> #topic Updates
19:04:17 <jsmith> Just a quick reminder on a few things
19:04:28 <jsmith> 1) FUDCon was great, now let's carry that momentum forward and get stuff done!
19:05:05 <jsmith> 2) We're at the point in the F15 schedule where we start hitting deadlines for the Alpha
19:05:13 <jsmith> In particular, we had our first Alpha blocker meeting on Friday
19:05:23 <jsmith> and there are a number of blocker bugs outstanding
19:05:52 <jsmith> We're hoping to have an RC done by Thursday or Friday, but that'll depend on clearing the bugs on the Alpha blocker list
19:06:04 <jsmith> #info Alpha blocker list https://bugzilla.redhat.com/showdependencytree.cgi?id=f15alpha&hide_resolved=1
19:07:00 <jsmith> Also, a big hats off to Dennis Gilmore for all the work that went into the mass rebuild and F15 branching
19:07:33 <jsmith> As is typical with that sort of thing, there are some broken packages that need to be cleaned up and sorted out -- but all in all, I think things are looking pretty good
19:08:05 <jsmith> If you have time and energy to help out, I'm sure folks would appreciate a helping hand in getting things squared away there
19:08:24 <jsmith> That's all the announcements and updates I have -- anybody else have anything to add before we dive into the main topic?
19:08:30 * ke4qqq is here - sorry for being late.
19:08:54 <jsmith> ke4qqq: No worries!
19:09:30 <jsmith> #topic The Future of Spins
19:09:32 <jreznik> jsmith: thanks for updates!
19:09:47 <abadger1999> jsmith: Can we do that easy ticket first?
19:09:58 <jsmith> abadger1999: If we have a quorum, sure...
19:10:20 <jsmith> abadger1999: I was going to hold off, as I wasn't sure we had enough Board members present -- but if ke4qqq is here, that may be enough :-)
19:10:24 <abadger1999> I think we have 5 with you.
19:10:36 <abadger1999> 6 with ke4qqq
19:10:40 <jsmith> OK, that works
19:10:57 <jsmith> #topic Board Business (then on to the spins discussion)
19:11:20 <jsmith> The Board has a ticket to decide on how to proceed w/ meetings when the FPL is not available for the meeting
19:11:21 <abadger1999> https://fedorahosted.org/board/ticket/97
19:11:33 <jsmith> (as was the case last Monday when I was returning from FOSDEM)
19:12:02 <abadger1999> <nod>
19:12:14 <jsmith> I personally would love to see the Board attempt to have a meeting anyway -- as long as someone on the Board volunteers to lead it
19:12:24 <jsmith> But let's discuss it for five minutes, and take a vote.
19:12:25 <abadger1999> I don't care -- we just should have a plan in advance that we either will or will not have a meeting.
19:12:26 * jds2001 here
19:12:32 <smooge> in my nearly year here, we have had many cases like this. I would say that we should meet if possible, and if no quorum meet as a "sub-committee"
19:12:59 * mizmo just doesn't like seeing emails the morning of or day before stating there *might* not be a meeting
19:13:03 <mizmo> then getting booked for that hour
19:13:09 <smooge> that way we can discuss any outstanding business without ending up with 2-3 week delays and brain loss
19:13:09 <mizmo> then being told 30 min before it is actually going ot be on
19:13:10 <jsmith> abadger1999: Traditionally, the FPL has emailed the Board letting them know of his inability to make the meeting, and asking for a volunteer
19:13:25 <ke4qqq> +1 smooge - we should default to meet - we like jsmith and all, but don't think we are paralyzed without him
19:13:30 <kital> +1 we should meet if possible, and if no quorum meet as a "sub-committee"
19:13:45 <abadger1999> jsmith: <nod>  That happened this last time... I could have lead the meeting but I wasn't reading email over the weekend so couldn't reply.
19:14:11 <jds2001> abadger1999: youre supposed to read mail 24/7 via osmosis :D
19:14:13 <jsmith> Yeah, I should have let people know earlier that I wasn't going to be around
19:14:18 <jsmith> That's my fault
19:14:33 <abadger1999> jds2001: I'll put my computer nder my pillow from now on :-)
19:14:37 <jsmith> OK, does this warrant further discussion, or shall we vote?
19:14:39 <jreznik> +1 for meeting by default but with announcement - without announcement that someone is going to lead meeting it does not have sense... waiting for what will happend
19:15:23 <jds2001> +1 for meeting by default
19:15:32 <jds2001> maybe have rotating chair duty?
19:15:40 <smooge> no I think we are saying  the default is that there will be a meeting. If the FPL can not put out agenda on Friday, then it is up to designated Fedora Board Speaker to do so
19:15:49 <mizmo> jreznik, im having trouble parsing your sentence
19:15:55 <jsmith> jds2001: Or make the rotating secretary be the chair in the absence of the FPL?
19:15:57 <ke4qqq> smooge: the secretary for that meeting?
19:15:58 <abadger1999> If we do meeting by default, I don't htink an announcement makes so much sense as that's the situation we had this last week.
19:16:07 <jds2001> jsmith: sounds reasonable
19:16:08 <mizmo> can we say something like if nobody volunteered up to so many hours before its off
19:16:12 <abadger1999> (No announcement so will there be a meeting?  We don't knw)
19:16:19 <mizmo> dontwant to show up for a meeting with everyone going huh huh and nobody leading it
19:16:33 <mizmo> wastes first 10-15 minutes of everyones time trying to figure out wht's going on
19:16:34 <jreznik> mizmo: abadger1999 said it
19:17:02 <smooge> Ok could I rephrase
19:17:12 <jsmith> smooge: Of course :-)
19:17:56 <abadger1999> secretary sounds good to me.
19:18:26 <rbergeron> I think everyone agrees that having a meeting go on sans jsmith if he is unable to make it is a good idea; perhaps the details of who does what and when and what the cutoff is can be worked out on the mailing list in the interest of discussing the Future of Spins? :)
19:18:30 <smooge> The Fedora Board will meet weekly. The Fedora Project Leader will announce on the previous Friday the agenda but if not able to attend it falls to the Fedora Board Secretary of that meeting. In the case where the Board does not have quorum (2/3's of members), the board will meet as a sub-committee to go over outstanding business.
19:18:40 <abadger1999> <nod>
19:18:56 <jsmith> +1 from me
19:19:04 <smooge> +1 from me
19:19:09 <abadger1999> +1 to meeting by default.  +1 to figuring everything out this week on list/trac.
19:19:10 <jds2001> +1
19:19:22 <abadger1999> *everything else
19:19:26 <ke4qqq> +1
19:19:29 <kital> +1
19:19:34 <jreznik> what about calls? and access to intercall?
19:19:36 <mizmo> +1 only if it is clear who is leading the meeting, headless chaos is a waste of time, sorry
19:19:56 <jsmith> jreznik: I've send the intercall data to a couple of other people on the Board, so it doesn't block on me
19:20:07 <jsmith> jreznik: We'll work out other details this week
19:20:17 <smooge> It falls to the Fedora Board Secretary is meant to be losely that if the FPL doesn't have it, they do.
19:20:52 <jreznik> jsmith: ok, just a technical detail, +1, with same note as mizmo
19:20:54 <abadger1999> If we can't agree on the secretary, I'll volunteer to lead unless I say I'm not going to be present... I just don't like the inscalability of that.
19:21:08 <abadger1999> But we can figure that all out on the list....
19:21:19 <jsmith> OK, looks like the vote is unanimous in the positive
19:21:26 <jsmith> abadger1999: Mind updating the ticket?
19:21:31 <jsmith> #topic Future of Spins
19:21:32 <abadger1999> jsmith: Will do.
19:21:47 <jsmith> OK, so we had a great discussion at FUDCon, but ran out of time
19:21:56 <jsmith> My purpose in meeting today is to continue the discussion
19:22:02 * kanarip is here
19:22:14 <jsmith> (and hopefully find someone with notes/photos of the whiteboard from FUDCon)
19:22:25 <jsmith> Just to recap:
19:22:34 <jsmith> We started by talking about the reasons for spins
19:22:51 <jsmith> then discussed both technical problems and process problems with their current implementation
19:22:57 <kanarip> #link http://meetbot.fedoraproject.org/fudcon-room-4/2011-01-29/pulp.2011-01-29-22.11.log.html
19:23:16 <jsmith> and then ran out of time just as we were getting into technical solutions
19:23:21 <kanarip> sorry, that's pulp, wrong link
19:23:28 <kital> jsmith: photo of whiteboard http://4.bp.blogspot.com/_gQ4q3hjYrFQ/TUScIiuDZQI/AAAAAAAAAyE/04r7TD_AOPM/s1600/IMG_1087.JPG
19:24:20 <jsmith> Awesome :-)
19:24:20 <cwickert> ?
19:24:26 <jsmith> => cwickert
19:24:29 <jds2001> so, the solution to this is to have a spins FAD, IMO
19:24:45 <jds2001> oops, sorry for lack of protocol :(
19:24:51 <jds2001> eof
19:24:51 <cwickert> I wonder why we are discussiong this here and not let the spins sig and the spins owners come up with something first
19:25:00 <cwickert> bottom up, you know? eof
19:25:09 <jds2001> cwickert: +1
19:25:10 <kanarip> cwickert, +1
19:25:13 <jsmith> cwickert: That's a fair question... I didn't mean to assume that we'd solve the problems in this short meeting
19:25:18 <jsmith> cwickert: Only that we'd continue the conversation
19:25:34 <jsmith> cwickert: But generally, I agree with you :-)
19:25:42 <brunowolff_> !
19:25:47 <jsmith> => brunowolff_
19:25:59 <jreznik> cwickert: good idea but we have to restart spins sig first -> so the topic should be how to restart it
19:26:18 <brunowolff_> I think the reason we aren't doing it bottom up, is that the spins SIG isn't getting participation.
19:26:26 <jsmith> That's certainly part of it
19:26:31 <jds2001> !
19:26:33 <brunowolff_> Getting the spin owners together may work.
19:26:33 <cwickert> !
19:26:34 <brunowolff_> eof
19:26:38 <jsmith> That being said, cwickert has agreed to be the Spins Wrangler
19:26:49 <jsmith> And I agreed to lead the Spins SIG until someone else steps up
19:26:57 <kanarip> hmm
19:27:06 <jsmith> => jds2001
19:27:24 * jds2001 was just going to say what you just did.
19:27:32 <jsmith> => cwickert
19:27:50 <jds2001> But I think that we need to get all interested parties together for a FAD as well. EOF
19:28:02 * jsmith reminds folks that it's faster if they write their questions elsewhere, and then copy/paste when called up :-)
19:28:10 <cwickert> brunowolff_ wants to have a spins leader, but I don't think the spins sig needs a leader but rather a coordinator. I think we are not doing that bad, but surely could do better. If we get asked to work something out, this is a good starting point to restart the sig
19:28:11 <cwickert> eof
19:28:32 <cwickert> jds2001: +1
19:28:35 <brunowolff_> !
19:28:41 <jsmith> => brunowolff_
19:29:09 <brunowolff_> There are common improvements that we might work on and other things that having someone
19:29:16 <ke4qqq> !
19:29:18 <brunowolff_> set direction for is useful.
19:29:33 <brunowolff_> There is more to the SIG (or should be) than just publishing spins.
19:29:34 <brunowolff_> eof
19:29:43 <jsmith> Very good point, brunowolff_
19:29:46 <jsmith> => ke4qqq
19:29:50 <ke4qqq> cwickert: so you are going to take this discussion to the spins sig - when will you report back?
19:29:55 <jreznik> brunowolff_: +1
19:30:00 <smooge> !
19:30:10 <cwickert> ke4qqq: I will try
19:30:32 <jsmith> => smooge
19:30:44 <smooge> sorry un!
19:30:52 <smooge> eog
19:30:54 <smooge> eof
19:31:52 <jsmith> brunowolff_: Just to make it clear, would you mind taking a moment to discuss the things that the Spins SIG should do besides just publishing the spins?
19:32:03 <brunowolff_> Sure.
19:32:36 <brunowolff_> Techincal quality of spins. (I recently noticed that the design suite wasn't following agreed upon best practices).
19:32:56 <mizmo> like having a working network stack, tee hee
19:33:04 <brunowolff_> Deciding what is worth having a spin for, both just as a ks and as a an official iso,
19:33:19 <mizmo> (or package group?)
19:33:22 * jsmith spent some time over the weekend looking at the Design Spin, fwiw
19:33:51 <brunowolff_> Possibilities for future enhancements. (I have been working on ways to get more data on spins during my tenure).
19:34:01 <brunowolff_> Other people might wnat otehr improvements.
19:34:47 <smooge> ?
19:34:52 <jsmith> => smooge
19:34:58 <brunowolff_> Documentation requirements for spins.
19:35:21 <brunowolff_> Documentation of the spins process (which is sort of related to publishing, but is a meta task.)
19:35:23 <kanarip> !
19:35:38 <brunowolff_> I think the rest is more directly related to publishing.
19:35:41 <brunowolff_> eof
19:35:44 <smooge> Does it also cover babysitting spin server? You seemed to do that a lot as it is not very stable (rawhide/alpha/beta system).
19:36:09 <brunowolff_> Was that for me? nirik does that.
19:36:19 <smooge> well you would ping nirik :)
19:36:28 * nirik looks up. Arrives late to the party.
19:36:40 <smooge> I just want to figure out where that stands as it is sometimes unloved.
19:36:45 <jsmith> => kanarip (after nirik has a chance to respond)
19:36:50 <smooge> eof
19:37:14 <brunowolff_> I often am looking for things to get done on the server because I am impatietent to test something.
19:37:27 <nirik> I have been keeping spin01 going for nightly spins. At somepoint hopefully soon, we are going to move to having koji make the nightly spins... so that part will hopefully go away. ;)
19:37:36 <brunowolff_> I wouldn't say I am the one who baby sits the spin server though.
19:37:47 <nirik> eof
19:37:50 <jsmith> => kanarip
19:37:51 <brunowolff_> eof
19:37:51 <kanarip> not to steal bruno's thunder here, but as we discussed during FUDCon the Spins SIG could do a lot with more mandate to, for example, actually attach consequences to spin maintainers not complying with the process(es), or to choose it's compose platform/tools, or (...), etc. EOF
19:37:54 <jds2001> brunowolff_: are you not empowered to effect the change you need?
19:38:32 <brunowolff_> (I am not on the infrastructure team and can't directly check the status of builds.)
19:39:30 <brunowolff_> (kanarip please comment more, as you have a lot more vision about what spins should be than I do.)
19:39:34 <kanarip> i am though, but we're only allowed to build rawhide using a rawhide, which isn't always necessary, but does naturally eat babies
19:39:38 <ke4qqq> kanarip: what's stopping the Spins SIG from doing so.
19:41:05 <kanarip> ke4qqq, various other teams in fedora maintain their own areas even as it relates to spins, and the Spins SIG is barely in a position to control these aspects and coordinate stuff as it "only technically approves kickstarts"
19:41:41 <kanarip> now the latter is paraphrasing, as it does a lot more, such as participate in QA, as well as develop spins as a whole, but i've always felt everything it does requires some or the other party sanctioning it
19:42:11 <kanarip> it is not, ... "autonomous" if you will, not endorsed to make spins happen unless X and Y and Z agree on every single move it makes
19:42:16 <jds2001> rel-eng has to buy into the build infrastructure, yes.
19:42:30 <jds2001> beyond that, im not sure waht "sanctioning" is required
19:42:44 <kanarip> jds2001, participating in rel-eng to actually improve what it is they sanction proves to be extremely difficult though
19:43:05 <jds2001> kanarip: dgilmore is working to improve that.
19:43:34 <kanarip> i've been doing this for quite a while, for example, and so has nirik, but approving a new spin will meet rel-eng's limited capacity to make it all happen during the relatively small window in time the release needs to be composed
19:43:53 <ke4qqq> kanarip: so what can we do to unblock that?
19:44:08 <kanarip> as such, before approving a new spin, we need the board, infrastructure, rel-eng, all of them to agree and only then some or the other spin maintainer gets a response
19:44:14 <kanarip> this process needs to be the inverse of that
19:44:33 <mizmo> you need the board for trademark approval?
19:44:38 <mizmo> you need infrastructure for... storage?
19:44:41 <jds2001> so one thing that came up is to decouple the spins from the release process.
19:44:46 <mizmo> rel-eng for the cpacity to make it happen?
19:44:46 <kanarip> we'll always need the board for trademark approval
19:44:54 <kanarip> even though the trademark is not the board's to approve
19:44:55 <mizmo> kanarip, not sure about that
19:45:21 <mizmo> .... (feel free to fill in on this, people who know more)
19:45:29 <kanarip> jds2001, indeed, to avoid such limitations, as well as the limited time-window for spin maintainers and their target audience to develop the most awesome show-case
19:45:32 <jsmith> kanarip: Red Hat has given the Board power to give trademark approval :-)
19:46:03 <nirik> !
19:46:05 <kanarip> mizmo, with 10 spins, rel-eng needs to compose 20 spins (architecture), each of which takes a significant amount of time
19:46:33 <kanarip> nirik, please chime in you've been doing most of the work in recent times
19:46:33 <jsmith> => nirik (after kanarip is finished)
19:46:59 <mizmo> !
19:47:18 <cwickert> !
19:47:47 <kanarip> nirik, vous aves le donner de la parole
19:47:49 <kanarip> EOF
19:48:05 <nirik> I think the move to using koji for images will help a lot with that. Will be easier to do them in parallel and such... As for process, perhaps if we take kanarip's idea: spin submitted, conditionally approved and starts getting testing, building up stuff, at the same time the board can look at trademark... so it's not blocking...
19:48:24 <nirik> that assumes enough of a spins sig to approve a new spin and make sure it meets our standards.
19:48:24 <kanarip> but, who fixes koji when something is broken, you think?
19:48:39 <jsmith> => mizmo
19:48:44 <mizmo> if theres a case of a limited resource like rel-eng cycles maybe it would behoove the spins sig to limit the # of spins each release
19:48:46 <mizmo> eof
19:48:47 <nirik> also, I think it would be good to explicitly empower the sig to be able to drop spins, etc.
19:48:49 <nirik> eof
19:49:09 <kanarip> !!
19:49:21 <jsmith> => cwickert
19:49:29 <cwickert> basically more rights need to be transferred to the spins sig: make us compose the spins, give us permissions to upload them etc. atm all this is distributed over many different groups and rel-eng is the bottle-neck
19:49:48 <cwickert> I think limiting the # of spins is not an option to fix things that are broken in other areas
19:49:49 <cwickert> eof
19:50:14 <smooge> ?
19:50:33 <jsmith> => kanarip
19:50:43 <kanarip> if there's a case of limited resources in terms of people, just empower someone else to participate and take on this particular task / project... if there's limited resources somewhere else, the question should be how to resolve it, not "whether or not" in terms of limiting anything
19:50:45 <kanarip> EOF
19:50:57 <jsmith> => smooge
19:50:58 <cwickert> +1
19:51:47 <smooge> I am not sure we are moving anywhere but in the circle we were before FUDcon. Could we have an email to the list about what rel-eng is blocking on?
19:52:00 <rbergeron> !
19:52:17 <cwickert> !
19:52:17 <jsmith> => rbergeron
19:52:43 <rbergeron> To add on to what smooge just added - we're approaching the hour. Is there a specific list of actoins people are taking from this meeting so that we don't lose momentum, and when people are going to follow up, and where they are going to follow up to (board or spins sig, etc)?
19:53:16 <jsmith> I think we should start at the Spins SIG as was suggested, and provide a list of items we'd like the Board to decide on
19:53:42 <jsmith> => cwickert
19:53:48 <cwickert> to answer smooge's question: rel-eng only has limited manpower to compose and test spins. another problem is the lack of communication, they hardly comminucated to the spins sig or QA. images were composed, but the maintainers or qa were not notified.. eof
19:54:09 <kanarip> manpower, that's it
19:54:40 <cwickert> suggestion: let the spins sig come up with a propsal rather than running in circles here
19:54:46 <jsmith> cwickert: +1
19:55:27 <jsmith> From my standpoint, I think the Board would be happy to help enable the Spins SIG to do what it needs to do to improve the spins process
19:55:39 <smooge> please make sure you have a list of infrastructure requirements.
19:55:44 <kanarip> #fedora-spins is open, fyi ;-)
19:55:45 <jsmith> But let me add that we should be working together w/ rel-eng, not trying to work around it
19:55:54 <brunowolff_> !
19:55:57 <smooge> releng could be 10x the size and they would not be able to build any faster on what is available
19:56:20 <jsmith> => brunowolff_
19:56:46 <brunowolff_> Just so things don't get taken wrong, while there have definitely been communication issues between
19:57:13 <brunowolff_> spins sig and rel-eng, we (I at least) am not blaming rel-eng.
19:57:24 <kanarip> but I am
19:57:30 <kanarip> (sorry, but i am
19:57:48 <brunowolff_> One of the tasks for the wrangler is to liason between spins sig and rel eng so that information flows both ways.
19:57:51 <brunowolff_> eof
19:57:55 * nirik thinks blame is not productive. Find out how to fix things moving forward instead.
19:58:02 <jds2001> as long as we're playing this blame game, nothing productive will happen
19:58:10 <kanarip> nirik, been there, done that, come on ;-)
19:58:15 <jsmith> OK, we're at the top of the hour
19:58:17 <ke4qqq> +1 nirik - rather than blame - find a solution. :)
19:58:19 <kanarip> nirik, and +1 on blame is not effective
19:58:33 <jsmith> I think we have a plan for moving forward -- the Spins SIG will meet and bring some things back to the Board
19:58:50 <ke4qqq> when should we expect a report back?
19:58:50 <jsmith> Any closing comments before opening things up for general questions and answers?
19:59:27 <jsmith> Couple of weeks at a minimum would be my guess -- others may have different opinions
19:59:48 <smooge> please have something for the 2nd March meeting
20:00:01 <mizmo> you mean 7 march?
20:00:01 <smooge> Beta happens soon after that and we need to haul ass to make things work
20:00:04 <mizmo> board meeting?
20:00:11 <mizmo> its either 28 feb or 7 march
20:00:14 <smooge> yeah 7 march
20:00:24 <abadger1999> Okay -- so to formally express this:
20:00:37 <mizmo> #info 7 march deadline for spins sig report back to board
20:00:42 <abadger1999> #action spins sig to to come up with a list of items they need from the Board to do their job better -- will present it at 7 March Board meeting
20:01:20 <jsmith> That works for me
20:01:36 <brunowolff_> Who is going to initiate the spins sig meetings?
20:01:55 * cwickert voluteers
20:02:16 * jsmith volunteers to help cwickert and any other interested parties
20:03:27 <gholms> ! (for open floor)
20:03:43 * jreznik is going to help too
20:04:00 <jsmith> OK, let's open the floor
20:04:07 <jsmith> #topic Open questions and answers
20:04:09 <jsmith> => gholms
20:04:16 <gholms> Does anyone have a copy of the governance outline from FUDCon's Monday death fest?  I only have my copy from Sunday night.
20:04:30 <jsmith> gholms: I've got it -- I'll forward it to you
20:04:34 <gholms> Thanks
20:04:35 <gholms> eof
20:04:43 <mizmo> should it be on the wiki?
20:05:11 <jsmith> mizmo: It's still pretty rough -- I'm not sure it's ready for wikification
20:05:44 <mizmo> could always put a work-in-progress banner on it
20:05:55 <rrix> "release early release often"
20:05:56 <jsmith> Yeah... that's an idea
20:06:05 <mizmo> point of a wiki is it doesnt have to be fully baked right
20:06:09 <mizmo> just an idea
20:06:35 <mizmo> does anyone else have a question?
20:07:22 <smooge> mizmo, it may be the point, but how many of our conversations have revolved around drafts of drafts that people don't understand. I think it has made publishing anything to the wiki troublesome :/. [a bit grumpy]
20:07:59 <mizmo> smooge, hate to see us as a project lose transparency for fear of trolls
20:08:03 <mizmo> f the trolls
20:08:09 <jds2001> smooge: deep breaths :)
20:08:31 <jds2001> mizmo: +1, we just need to make clear its not set in stone
20:09:31 <jsmith> What I feel is still missing is an explanation of what we're trying to accomplish, and where this draft text fits into the bigger picture
20:09:48 <abadger1999> jsmith: If you put it up, I'll add a disclaimer banner right away  to make clear that it's not even to the "draft of something we will do" stage yet.
20:09:58 <jsmith> abadger1999: Fair enough
20:10:05 <smooge> Sorry I don't mean trolls. Many times these arguments have been ourselves (in some form or another). But in any case, I understand and will try to put something up.
20:10:14 <abadger1999> iirc, it's just taking debian's notes and seeing how they'd wrap to our needs.
20:10:22 <kanarip> actually, please set it in stone why don't you?
20:10:47 <kanarip> it's your responsibility to balance what you come up with and what people will vote - with their feet
20:10:48 <smooge> kanarip, well because all governments are jello
20:11:23 <smooge> that reads wrong.. sorry
20:11:32 <kanarip> you're not running a democratic authoritarian government, you're running a constitutionally liberal community
20:13:04 <kanarip> nevermind transparency as long as all of you remember people vote with their feet... and any such vote is very likely to be permanent
20:13:13 <kanarip> the "how it came to be" isn't at all interesting
20:13:21 <jsmith> abadger1999: Text at https://fedoraproject.org/wiki/Board/Possible_Future_of_Fedora_Governance
20:14:15 <kanarip> the "what it ends up being" even if that includes drafting / discussing / improving it in private is way more important, as is the ability to actually show you understand your constituent votes with their feet
20:14:16 <gholms> jsmith: Looks like it fell victim to line wrapping.
20:14:34 <jsmith> gholms: It's a wiki -- feel free to help fix it :-)
20:15:00 <gholms> Oh, I have editing access?
20:15:13 <abadger1999> gholms: Hold on one moment /me makes himself a section at the top to edit
20:15:41 <mizmo> everyone votes with their feet on everything. constantly threatening foot voting doesn't really help create a positive atmosphere
20:16:23 <abadger1999> gholms: Okay: now as long  as you edit a specific section you and I shouldn't have conflicting commits.
20:16:40 <kanarip> mizmo, it's not a threat in any way, it's a factual difference between community and government for crying out loud
20:17:28 <mizmo> okay thanks for clarifying, been faced with a lot of ultimatums lately to the point of their being meaningless
20:17:54 <jsmith> I think everyone understands that people vote with their feet, and hopefully everyone agrees that we don't want people to walk away from Fedora.
20:18:00 <jsmith> That should be pretty obvious :-)
20:18:10 <jsmith> OK... any other topics for discussion?
20:18:22 <mizmo> well its a difference i guess kanarip is trying to point out between using a gov't based structure vs a community or volunteer org based structure
20:18:40 <cwickert> !
20:18:42 <kanarip> not really...
20:18:44 <jsmith> They're not mutually exclusive -- it's not a zero sum game
20:18:47 <jsmith> => cwickert
20:18:58 <cwickert> what about the governance session on Sunday? there were a lot of interesting points in there
20:19:00 <mizmo> okay whatever
20:19:10 <cwickert> in fact it sounded too good go be true
20:19:21 <cwickert> so I wonder where are the minutes from that session?
20:19:29 <jsmith> cwickert: Yes, that will be addressed as well -- just trying to do one thing at a time
20:19:29 <smooge> where because I got thrown out? :)
20:19:40 <mizmo> the minutes can't be posted to the wiki until they have been perfected in private with the idea that people vote with their feet, right?
20:19:42 <jsmith> cwickert: (I just posted the working outline to the wiki -- see my link above)
20:20:19 <cwickert> jsmith: is that all from that session?
20:20:29 <cwickert> I remember there were more things on the board
20:20:55 <jsmith> cwickert: It wasn't a formal meeting -- it was a hackfest session.  Other may have other notes, but I posted everything I had.  (Then again, I wasn't there for the entire meeting either)
20:21:32 <gholms> Was the real-time editing going on on spot's laptop?
20:21:49 <kanarip> iirc, yes
20:22:01 <gholms> It might be worth emailing him.
20:22:02 <kanarip> but i was only there part of the morning
20:22:04 <cwickert> jsmith: IIRC there were some interesting points on the board, e.g. decision making happens bottom up or the board is only to decide on policies but not on things that we have dedicated bodies for
20:22:22 <jds2001> cwickert: those are in that outline.
20:22:30 * cwickert looks
20:22:33 <jds2001> * Any group may subdelegate responsibility
20:22:34 <jds2001> * Cannot override decisions made by delegates within their respective jurisdictions \
20:22:39 <jsmith> cwickert: If there were other notes on those sorts of things, I don't have them
20:23:03 <smooge> gholms, that was Monday's meeting
20:23:14 <cwickert> jds2001: but this is already top down
20:23:40 <cwickert> to delegate means something has been at the board already
20:23:44 <kanarip> cwickert, yes, meritocracy
20:24:29 <kanarip> cwickert, an individual's means to get things moving on a policy level is to step up and make sure one is elected to a decision making body
20:24:55 <jds2001> kanarip: huh?
20:25:07 <kanarip> or, of course, argue his/her case in front of a decisive body
20:25:08 <jds2001> that's *exactly the opposite* of what I'd like to see
20:25:16 <mizmo> yeh thats not how stuff happens in fedora
20:25:28 <kanarip> jds2001, the opposite is making sure you never have any form of control over anything??
20:25:31 <mizmo> not sure what fedora youare talking about
20:25:43 <jds2001> kanarip: no, more about autonomus control
20:25:46 <kanarip> mizmo, thanks, but that is stating the obvious
20:26:05 <kanarip> jds2001, right, two different things we're talking about here, i think?
20:26:22 <mizmo> sorry, i must have lost your point in the layers i tried to wade through
20:26:41 <kanarip> an individuals autonomous position until slapped by policy, vs. creating / adjusting any such policy?
20:26:52 <jds2001> kanarip: perhaps. But I don't like how Fedora is a culture of "asking permission"
20:27:03 <kanarip> jds2001, agreed
20:27:18 <jds2001> take the trusted computing thread today for example
20:27:29 <jds2001> go forth, make your trusted computing SIG
20:27:48 <jds2001> no need to ask me for blessing :)
20:27:57 <smooge> well on the other hand, the world of Trusted COmputing is all about making sure you have asked permission first. Cultural differences
20:28:00 <jds2001> (or anyone else)
20:28:12 <kanarip> smooge, that's so funny, it's not ;-))
20:28:24 <smooge> I mean it is very common in many cultures not to do anything without asking permission first
20:28:59 <smooge> I spend a lot of time on private emails with contributors who are doing infrastructure stuff but aren't going to do it without it being checked by someone else in private
20:29:28 <mizmo> i dont think fedora is a culture of asking permission
20:29:32 <mizmo> sorry if i'm stating the obvious
20:29:46 <smooge> not everyone has a northern european/viking approach of pillage first, then burn, then ask for forgiveness :)
20:29:58 * jsmith isn't sure we're making progress in this portion on the meeting, and thinks people are just talking past each other
20:30:21 * jds2001 agrees
20:30:24 <mizmo> yes
20:30:32 <mizmo> too much snark too little content
20:30:32 <smooge> yes
20:30:43 <jsmith> Any other topics applicable to this meeting?
20:31:11 <mizmo> when is the next board election, may?
20:31:36 <smooge> around 15 release.
20:32:56 <smooge> and my apologies, I was trying not to be snarky about "cultural differences". It is a common thing that we need to be aware and realize that many cultures are going to ask for permission first and not do anything unless it is approved.
20:33:10 <mizmo> i wasnt saying you were being snarky smooge
20:33:29 <mizmo> has anyone resigned from the board before?
20:33:35 <mizmo> is there a protocol for that?
20:33:51 <mizmo> i only see for fesco
20:35:16 <jds2001> mizmo: it's in the succession plan, i think
20:35:42 * jds2001 knows it has happened on fesco, i was the chair when it happened :(\
20:36:48 <mizmo> ok thanks
20:36:49 <mizmo> eof
20:37:07 <jds2001> i guess its not on the succession planning page
20:37:14 <abadger1999> I don't think there is a specific resignation point in the succession plan but I think the "removal" section can apply to how an empty seat would be filled.
20:37:17 <jds2001> https://fedoraproject.org/wiki/Board/SuccessionPlanning
20:37:29 <jds2001> yeah, i was going to say the same thing.
20:37:59 <mizmo> thanks jds2001 i couldnt find that page in the search
20:38:58 <jds2001> surpirse surpirse.
20:39:08 <jds2001> geez i cant spell :)
20:40:23 <smooge> I think in general resignations should be done as an email to the Fedora Project Leader. Some places require them to be cc'd to the board and public, others do not.
20:40:36 <jds2001> oh well, i think we're done here, no? Our fearless leader has left.
20:40:48 <abadger1999> hehe
20:40:50 <smooge> #endmeeting