15:00:41 <jsmith> #startmeeting Fedora Board Meeting
15:00:41 <zodbot> Meeting started Wed Aug  3 15:00:41 2011 UTC.  The chair is jsmith. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:41 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:50 <jsmith> #meetingname Fedora Board
15:00:50 <zodbot> The meeting name has been set to 'fedora_board'
15:01:01 <jsmith> #topic Roll Call (for Board members)
15:01:05 * jsmith is here
15:01:19 * pbrobinson is here
15:01:22 * ke4qqq is here
15:01:35 * gomix here
15:01:35 <jsmith> #chair pbrobinson ke4qqq
15:01:35 <zodbot> Current chairs: jsmith ke4qqq pbrobinson
15:01:39 <jsmith> #chair gomix
15:01:39 <zodbot> Current chairs: gomix jsmith ke4qqq pbrobinson
15:01:42 * jreznik is here too
15:01:46 <jsmith> #chair jreznik
15:01:46 <zodbot> Current chairs: gomix jreznik jsmith ke4qqq pbrobinson
15:04:00 * jsmith pings a few more Board members
15:04:31 * abadger1999 hereish
15:04:42 <jsmith> #chair abadger1999
15:04:42 <zodbot> Current chairs: abadger1999 gomix jreznik jsmith ke4qqq pbrobinson
15:04:48 <jsmith> OK, let's go ahead and get started
15:04:54 <jsmith> #topic Introduction
15:05:06 <jsmith> Welcome to our public IRC meeting
15:05:23 <jsmith> As a general reminder, we ask people to please use the protocol as explained at http://fedoraproject.org/wiki/Board/IRC#General_Rules
15:05:40 <jsmith> That helps us communicate better, and keep from trying to juggle several different topics at once
15:06:15 <jsmith> Since we have had a public IRC meeting with time for general questions and answers in a while, most of today's meeting will be dedicated to that
15:06:34 <jsmith> But first, I've got a couple of items of Board business
15:06:43 <jsmith> #topic Board Business
15:06:56 <jsmith> First item of business is meeting times for the Board
15:07:20 <jsmith> The Board has spent the last few weeks trying to come up with a meeting time that is agreeable to everyone on the Board
15:07:39 <jsmith> It hasn't been an easy process, especially given the geographical diversity of the current Board
15:07:56 <jsmith> In last week's meeting, we put it to a vote
15:08:03 <jsmith> Actually, that was two weeks ago
15:08:19 <jsmith> Since then, I've heard back from the two members of the Board that weren't in that meeting
15:08:51 <jsmith> The majority of the Board members have voted for Tuesdays at 16:00 UTC (noon EDT, 9:00am PDT)
15:09:33 <jsmith> It's not perfect, and may cause some conflicts for various Board members, but it's the best we can do at the present time.
15:10:03 <jsmith> I'll update the wiki with the new times, and set out a new schedule for secretary duty as well
15:10:16 <jsmith> #action jsmith to update the times on the wiki and set a new secretarial schedule
15:10:35 <jsmith> Any questions, concerns, or comments?
15:11:59 <jsmith> The other item I had by way of updates is a FUDCon status update
15:12:22 <jsmith> FUDCon Milan (Sept 30-Oct2) had its first travel subsidy meeting yesterday
15:12:39 <jsmith> and will be having a follow-up meeting on August 16th at 15:00 UTC in #fudcon-planning
15:13:07 <jsmith> If you're in the EMEA region and require a travel subsidy to be able to attend FUDCon, now is the time to open a subsidy ticket
15:14:01 <jsmith> See https://fedorahosted.org/fudcon-planning/wiki/FundingRequest for more information on the process
15:14:04 <rbergeron> ?
15:14:09 <jsmith> => rbergeron
15:14:53 * rbergeron thinks that it would be a great idea to put some of this information into the agenda mail for this meeting, so people can ask questions if they have them, and you don't have to spend 15 minutes of a not-so-often public meeting with the board for the community.
15:14:58 <rbergeron> :D
15:15:06 <jsmith> Yes, I should have done that
15:15:44 <jsmith> FUDCon Pune (4-6 Nov) is also open for subsidy requests, and we'll be having our first subsidy meeting this Friday, if I recall
15:16:20 <jsmith> FUDCon Blacksburg (13-15 January) will be opening for subsidy requests in the next few weeks.
15:16:34 <jsmith> Any other questions or concerns regarding FUDCons?
15:17:38 <jsmith> If there are no other questions, let's move on.
15:17:55 <jsmith> #topic Open Questions and Answer session
15:18:36 <ke4qqq> jsmith: can I toss a quick proposal out there?
15:18:43 <jsmith> ke4qqq: Absolutely!
15:19:31 <ke4qqq> So, following the mailing list discussion of late, can we ask fedora legal (spot) to get some guidance for us on trademark issues, specifically:
15:20:30 <ke4qqq> 1. the current state of how people external to fedora have been reading the tm guidelines - and they are widely deploying fedora - which is a good thing, but apparently contrary to the drafters intention
15:21:17 <ke4qqq> 2. is there a risk in changing it so that combinations of fedora software does not require any additional blessing, what that is, and what our options are
15:21:59 * ke4qqq would hate to see us in the place of telling the rackspaces, linodes, and slicehosts that they either must stop using the fedora brand or must get blessing from the board to do so.
15:22:20 <jsmith> We can absolutely ask Spot to request some guidance
15:22:21 <spevack> ke4qqq: because they will ignore whoever says that and just do what they want anyway
15:22:37 <spevack> or even worse, they will actually stop
15:22:41 <ke4qqq> spevack: or they will stop
15:23:04 <ke4qqq> and we will have less fedora adoption and look likewe don't want people to use fedora
15:23:07 * abadger1999 notes that the way some of the places are interpreting the trademarks (for instance, justin forbes presentation of what's happening) is what I think we should desire.
15:23:09 <spevack> ke4qqq: jinx, you owe me a coke
15:23:22 <rbergeron> spevack: or think that fedora is a bunch of assholes? and then their customers will have the same impression while they are in limbo? or worse - think that somehow they're being bait and switched to rhel? :)
15:23:24 <spot> ke4qqq: to be clear, are you asking me to propose to RH Legal that combinations containing only fedora software should not require explicit Board permission to use the trademark?
15:24:08 * rbergeron can think of all sorts of PR nightmare.
15:24:30 <ke4qqq> spot: I am asking you to discuss that with RHT legal and see if there is some unacceptable risk from a trademark perspective, and whether they'd view such a change to the guidelines as reasonable.
15:25:21 <spot> !
15:25:24 <spevack> ? (related question, when there is time)
15:25:29 <jsmith> => spot
15:25:29 * ke4qqq realizes that change to the guidelines will have to originate with Fedora/RHT legal, and while I am perfectly happy to ask you to consider changing it on my own, I feel like there may be information i don't have.
15:25:37 <pbrobinson> rbergeron: agreed but does it possibly dissolve the Fedora trademark. If its not enforced I believe it can be made void altogether (although I'm by no means a trademark lawyer)
15:26:04 <spot> If the board is in agreement on that request, I can work with RH Legal to see if it is feasible.
15:26:08 <spot> EOF
15:26:09 <ke4qqq> pbrobinson: it's not being enforced now in such a case.
15:26:17 <rbergeron> well
15:26:24 <rbergeron> it's fine now, according to the existing trademark guidelines
15:26:35 <ke4qqq> not according to what pam said.
15:26:43 <jsmith> rbergeron: I'm not sure that's true
15:26:48 <rbergeron> which apparently, despite having an explicit section around trademarks for this exact situation, weren't written as intended
15:27:06 <rbergeron> obviously, we're not sure that's true, in light of whatever was newly baked yesterday.
15:27:33 <rbergeron> But up until yesterday, yes, i think 99.999% of people who actually bothered to read the trademark guidelines would have said that things were reasonably covered.
15:27:35 <ke4qqq> did we get spevacks question?
15:27:40 <abadger1999> +1 to ke4qqq's request... If Legal thinks that would be acceptable, I'd want to try and change our trademark guidelines to that.  If it's not legal, I'd like to try to get our guidelines as close to that as possible.
15:27:59 <abadger1999> *acceptable to legal
15:29:15 <ke4qqq> spevack: your question?
15:29:22 <jsmith> => spevack
15:30:42 <spevack> so fully admitting my new biases in asking this question -- I've been reading stuff all week, watching different threads, and I don't understand what has to happen -- tools used or not used, people running those tools, level of quality and how it is established, for a Fedora AMI to be considered "official" or "blessed" by the Fedora Project.  And we need to understand that in order to move toward a goal of having said AMI ready on the ...
15:30:48 <spevack> ... release day of every Fedora distro from now on.
15:30:51 <spevack> So my question is:
15:30:54 <spevack> Can someone please make that list and articulate it?
15:31:04 <spevack> Or tell me how to go about constructing it myself?
15:31:17 <jsmith> spevack: Well, I think there are two different issues at hand
15:31:26 * spevack listens
15:31:44 <jsmith> spevack: The first is that traditionally, we've said that for a new spin/image/format to be considered "official", it needs to be built by Rel-Eng
15:32:12 <jsmith> spevack: The second is trademark approval for a new spin/image/format
15:32:38 <pbrobinson> spevack: I thought it was intended (at least prior to your change of position) that rel-eng produced the AMI as part of the rest of the release. At least that's what I thought was happening prior to F-15 where F-14 was close to release on the date of release.
15:33:04 <jsmith> In the case of the Fedora AMI images, (and without blaming any individual), there's been a lot of trouble trying to get the building of AMI images worked into the Rel-Eng process
15:33:14 <ke4qqq> F-14 was done by jforbes iirc
15:33:29 <jsmith> My goal has always been do have AMI images on the day of GA
15:33:47 <spevack> jsmith: there's a lack of rel-eng time issue, yes.
15:33:53 <rbergeron> That's been the cloud sig's goal as well. :)
15:33:56 <jsmith> For F14, that wasn't realistic, but I had hoped that by F15 we would be to that point
15:34:07 <jsmith> We obviously weren't, and still aren't to this day :-(
15:34:25 <spevack> So I have a couple of followups:
15:34:25 <jsmith> So, I personally see two options moving forward
15:34:29 <rbergeron> We could be if we could just use boxgrinder.
15:34:30 * spevack waits
15:34:40 <jsmith> 1) Decide that we don't need it to go through Rel-Eng
15:34:40 <jsmith> or
15:34:48 <jsmith> 2) Try to help Rel-Eng make it happen
15:35:04 * gomix inclined to the first
15:35:12 <jsmith> I don't think it's the job's board to dictate to rel-eng what tools they use
15:35:25 <spevack> can i ask my followups now, because it's the right moment for them in the flow of the conversation
15:35:31 <jsmith> Go right ahead, spevack
15:36:05 <spevack> Regarding your "decide we don't need it to go through rel-eng" option -- is that from the perspective of a one-off, or of a larger policy change acknowledging that a rel-eng time issue won't go away?
15:36:22 <spevack> (2) are you purposefully using spin/image/format interchangeably above (see :31:44)
15:36:51 <jsmith> spevack: It could be either... but personally, I'd rather focus on the larger policy issue
15:37:24 <spevack> (3) So if a spin/image/format is built by rel-eng, what else has to happen in order to get the Boar's trademark approval?  Or is that just "follow the guidelines" which are currently being debated on list due to Pam and Spot's conflicting messages
15:37:28 <spevack> EOF
15:37:38 * ke4qqq things that we are  too processheavy on the entire 'what we call fedora' standpoint. /me also notes that we haven't had anything  successfully complete all of those hurdles yet, despite numerous spin/image composes and actual phyiscal media  creation.
15:37:45 <ke4qqq> s/things/thinks/
15:37:55 <jsmith> Regarding my use of "spin/image/format", I'm using them interchangeably from the standpoint of trademark approval.  They have slightly different processes (Spins SIG approval of spins, for example)
15:38:13 <spevack> so is the Fedora AMI a spin, image, or format?
15:38:24 <spevack> and who decides the answer to that? :)
15:38:44 <spevack> jsmith: see what happens when, in the course of one day, my entire perspective changes on Fedora?  Sorry, dude :)
15:38:46 <jsmith> spevack: The Spins SIG made it quite clear that it's not a spin according to their guidelines
15:38:59 <ke4qqq> spevack: we have a quarter, one side marked spin, the other marked image :)
15:39:34 * ke4qqq seems to recall the spins sig complaining quite a bit that it was a spin and were upset it didn't go through the spins process after f14, has that changed?
15:39:41 <jsmith> From most people I've talked to, a "Spin" is a disc image created from a kickstart file, that follows the Spins SIG guidelines
15:39:58 <jsmith> ke4qqq: They were upset that the AMI kickstart file got checked into the Spins git repository, when it clearly wasn't a spin
15:40:09 <ke4qqq> ahhh ok
15:40:46 <rbergeron> can we make decisions here? or can someone tell me what the board's plans are wrt dealing with the trademark guidelines
15:40:50 <jsmith> I'd use "image" or "format" to refer to something that isn't a traditional spin, but is another combination of Fedora software in a different format (sorry for the recursive definition there)
15:40:58 <jreznik> the question is if spin is just a disc image or product distributed some way (disc image for example)? for me it's product
15:41:02 <rbergeron> because it'd been brought up like 40 times on the mailing list
15:41:11 <rbergeron> we keep hearing commitments to rewrite things
15:41:14 <rbergeron> and none of it happens
15:41:30 <rbergeron> soooo
15:41:50 <ke4qqq> any other board members have a problem with my proposal to have spot go garner some guidance for us?
15:41:54 <rbergeron> if i am just going to be targeting F50 for a fedora ami, that would ve great to know.
15:42:40 <jsmith> rbergeron: I think you're confusing the two issues -- trademark approval isn't what's blocking AMI creation
15:42:45 <jreznik> ke4qqq: I don't have a problem but first we have to know what we actually want from them... not sure reading it here/mail thread...
15:42:50 <jsmith> ke4qqq: I have no problem with that
15:43:12 <gomix> ke4qqq: not me either... can summarize just to be sure im following...
15:43:39 <ke4qqq> jreznik: my question was specifically is there any risk from a trademark perspective to permitting 'no additional blessing needed' be applied to combinations fo official fedora software
15:43:42 <pbrobinson> I personally would see a spin as a process. If the output is a AMI image or something else like a "firmware image" to run on an ARM tablet I don't see why its different. This process and policy will also likely change as we ramp up ARM and other embedded platforms
15:43:50 <rbergeron> sure it is.
15:44:24 <spot> !
15:44:24 <pbrobinson> rbergeron: I would hope your not targeting F-50!
15:44:25 <rbergeron> if i dont need trademark approval / signoff from rel-eng, beccause its not going in koji, then i'd be done.
15:44:41 <jsmith> => spot
15:44:59 <rbergeron> pbrobinson: at this rate, tryingbto "solve" something that could be solved by trusting fedora contributors.....
15:45:07 <spot> It would be a lot easier if the board could explicitly propose how they would like for the approval process to work for images, spins, etc.
15:45:22 <spot> I can then see what RH Legal thinks about it from a Trademark perspective.
15:45:30 <spot> and bring back any concerns.
15:45:32 <spot> EOF
15:46:15 <ke4qqq> spot: what if it's a body external to RHT - like an amazon or rackspace, thathave or are currently building fedora images, and using the marks
15:46:24 <ke4qqq> s/rht/fedora/
15:46:41 <spot> ke4qqq: the only permissions they have are the ones we give them in the TM guidelines
15:47:02 <ke4qqq> my reading (and I am sure their reading) suggestedd that they didn't need permission provided it was only fedora software.
15:47:08 <ke4qqq> and thats the reality of what they have done
15:47:29 <ke4qqq> and i think telling them that they don't have permission to use the fedora marks at this point is going to be fail.
15:47:33 <spot> ke4qqq: if i can be blunt here, i would like the board to tell me how they want it to work.
15:47:39 * jforbes notes that Amazon, and probably everyone else, mark every image with an /etc/fedora-release as Fedora, no matter who created them or what else they contain
15:47:45 <spot> ke4qqq: and i will work with RH Legal to see if it is possible.
15:47:58 <jsmith> ke4qqq: In the case of the Amazon AMIs however, it's my understanding that the need a different kernel, etc...
15:48:01 <jforbes> so there are hundreds of Fedora images out there, but we cannot advertise the Cloud SIG created images as official
15:48:06 <jsmith> ke4qqq: So I think it's slightly more complicated
15:48:20 <jforbes> jsmith: no, it uses absolutely no software that is not in the fedora respositories, and hasnt since F12
15:48:34 <gomix> so AMIs are not 100% Fedora only sw ?
15:48:34 <jforbes> jsmith: the exact list of changes is on the fedora-advisory-board list
15:48:44 <jforbes> gomix: absolutely, only config files are changed
15:48:51 <jsmith> jforbes: OK, then that was a misunderstanding on my part
15:49:02 <ke4qqq> spot: so if *I* had the magic wand, we'd let combinations of fedora software not need trademark blessing.
15:49:12 <ke4qqq> or rather additional trademark blessing
15:49:22 <gomix> i dont see any reasons for asking approvals if its 100% fedora sw based images
15:49:25 <jreznik> spot: "the board could explicitly propose" +1
15:49:54 <jforbes> gomix: and even created with tools that are 100% in Fedora
15:50:04 <spot> ke4qqq: okay, but as a counter point, that would mean anyone could take the packages currently in the f16 branch and release it to the world as "Fedora 16"
15:50:49 <gomix> yup, that's true...
15:50:51 <ke4qqq> spot: yes that would be the risk.
15:50:53 <jreznik> spot: exactly
15:51:30 <pbrobinson> I would be some what concerned how it would impact the enforcement of the trademark in other realms/devices etc.
15:51:33 <ke4qqq> but the problem is that effectively we aren't enforcing our trademark guidelines as they were intended (and I think we really ought not) with regards to people outside of fedora buidling 'fedora' for various platforms.
15:52:02 <gomix> either way.. im still on that position and looking for a solution without asking for approvals for spins from third parties
15:52:03 <jreznik> for me the final fedora trademark is - it's produced by rel-eng and probably the right way, tested, signed (!) that it went through the internal process - and that's the process for me
15:52:11 <spot> okay... if the board really wants there to be no approval process outside of "composed entirely from Fedora packages", please vote on that, and I will take it to RH Legal.
15:52:13 <spot> EOF
15:52:22 <pbrobinson> ke4qqq: spot could answer better but I believe if you don't enforce it the trademark becomes void
15:52:32 <spot> pbrobinson: you are correct
15:52:44 <spot> or at least, you run a high risk of that occurring
15:53:17 <jsmith> spot: Personally I'm not ready to go that far, but I'm willing to put it up to a vote if other Board members want that
15:53:17 <ke4qqq> pbrobinson: right. which i think should be a concern, because we aren't sending nastygrams to rackspace or slicehost or $cloudvendor - at least to my knowledge. I imagine the uproar would have been deafening if it had.
15:53:17 <spot> !
15:53:26 <jsmith> => spot
15:53:34 <spot> I would like to propose an alternate suggestion
15:53:47 <jsmith> OK...
15:54:16 <spot> For "spins", the release must be approved by Rel-Eng.
15:54:23 <pbrobinson> ke4qqq: but then you open it up for someone like linpus to use it as well if they like on a netbook remix (assuming they ship non modified packages except configs)
15:54:34 <spot> For "virtual images" based on approved spins, no additional approval is required.
15:55:04 <spot> EOF
15:55:13 <pbrobinson> spot: what about for "Device Images" for say a tablet?
15:55:32 <jsmith> I'm more likely to go for that proposal (though I would like a tighter definition of "base on")
15:55:33 <jreznik> pbrobinson: should be same
15:55:34 <spevack> spot: so your definition of "spin" is essentially "package set"
15:55:47 <spot> spevack: basically, yes.
15:55:52 <spevack> spot: and a virtual image is in the same category as x86, x86_64, etc.
15:55:56 * pbrobinson realises its not exactly on topic but it saves having the same discussion when we can do it with arm
15:56:02 <ke4qqq> what about for parties external to fedora? do they need a rel-eng blessed offering to offer fedora images to their customers
15:56:06 <jsmith> spevack: A spin is more than a package set -- it's typically a package set + minor config changes, as defined in a kickstart file
15:56:12 <spevack> spot: that is the sort of thinking that makes sense to me as well.
15:56:17 <spevack> jsmith: *nod*
15:56:18 <jreznik> and disc media/virtual images etc. are just a distribution channel
15:56:43 <spevack> jsmith: right -- either way, the way Spot laid that out makes sense to me.  a virtual image is a TARGET for a particular package set + config tweaks.
15:56:58 <spot> spevack: I would agree with that
15:57:12 <jsmith> Now, at some level, this requires a working Spins SIG... which hasn't always happened
15:57:13 <jreznik> spevack: I agree if it does not mean any bigger changes - then it's again spin and you should follow the process
15:57:18 <jsmith> But in general, I like spot's proposal
15:57:27 <spot> jsmith: why? the signoff comes from Rel-Eng.
15:57:38 <abadger1999> May I make a set of proposals?
15:57:50 <jsmith> spot: Well, currently the Spins SIG signs off on spins
15:57:57 <jsmith> spot: Are you suggesting we no longer need a Spins SIG?
15:58:11 <ke4qqq> jsmith: yes but so must QA, RelEng and Design
15:58:24 <jsmith> ke4qqq: Yes.
15:58:25 <ke4qqq> and then the board :)
15:58:28 <spot> jsmith: i would posit that anyone can make a spin and go to rel-eng for approval.
15:58:38 <spot> jsmith: we should encourage organization, but not mandate it.
15:59:05 * abadger1999 intended for spins sig to be more important than those other groups in that policy and had the impression others did as well.
15:59:14 <jsmith> I think that sends the wrong message to the folks who have tried to make the Spins SIG work better
15:59:15 <rbergeron> anf if rel-eng dosnt have bandwidth?
15:59:17 <spot> but that is just me talking from the cheap-seats.
15:59:20 <jreznik> abadger1999: +1
15:59:28 <jsmith> abadger1999: +1
15:59:34 <spot> rbergeron: lets worry about that problem when it happens.
15:59:39 <jsmith> Rel-Eng is already overloaded and hard to join
15:59:51 <spot> jsmith: fixable problems.
15:59:55 <jsmith> The Spins SIG helps alleviate some of that pain
16:00:00 <jforbes> spot: it's happened, which is why there are no F15 AMIs
16:00:02 <rbergeron> well, we're essentially there, spot, with waiting on rel-eng to figure out making ec2 happen.
16:00:03 <ke4qqq> so - lets say I start David's VPS service - and I want to offer my customers a Fedora LAMP stack - are you saying that to use the fedora marks that I must get my 'spin' blessed by spins sig, QA, Rel-Eng, Design, and the Board before I can offer Fedora to my customers?
16:00:27 <spot> jforbes: to be blunt, i'm proposing a policy that does not reflect the way it works today.
16:00:27 <rbergeron> which is why we have just maade amis using boxgrinder.
16:00:38 <rbergeron> spot: thank god :)
16:00:39 <Southern_Gentlem> ?
16:00:50 <jsmith> => Southern_Gentlem
16:01:08 * ke4qqq is interested in abadger1999's proposal.
16:01:49 * jsmith notes that we're at the top of the hour
16:02:15 <Southern_Gentlem> ok i am producing updated livecd isos use only the fedora provided kickstarts, using only the fedora repos  for people who cannot install from the origional release
16:02:23 <Southern_Gentlem> so what do i need to do
16:03:16 <abadger1999> Southern_Gentlem: Undetermined.  That was something that needed clarification when the Board decided on the present policy
16:03:29 <Southern_Gentlem> ty
16:03:32 <Southern_Gentlem> eof
16:03:33 <ke4qqq> Southern_Gentlem: at present: submit that ks to spins sig, get sign off there, go to design, get their approval, go to QA, ask them to test and sign off on it, and then go to rel-eng and ask them to produce the iso for you. OR just don't call it fedora.
16:03:55 <abadger1999> some portion of the board felt trademark approval happened once per spin; others felt it happened once per release cycle; others felt it happened per each package-nvr set.
16:04:24 <Southern_Gentlem> ke4qqq,  its a already blessed ks
16:04:25 <ke4qqq> abadger1999: yes, but updates are different combinations of software
16:04:46 <spot> !
16:04:47 <abadger1999> we never clarified which of those three (or other variants) we wanted.... since elections, I don't even know approximately how many board members favor each approach.
16:05:47 <rbergeron> what are the action items?
16:22:41 <jsmith> I, for example, am much more comfortable with (at least a subsection of) part B than I am with part A
16:23:26 <abadger1999> "Fedora Board would like to know what limitations of how we can revise the Trademark Guidelines.  The following questions are posed to try to determine if any legal roadblocks exist that would shape an eventual change in policy:"
16:23:40 <abadger1999> Change the preamble to that.
16:24:07 <spot> !
16:24:15 <jsmith> => spot
16:24:46 <spot> Hate to sound like a broken record here, but you will get a much better response if you decide what you want to do, and ask RH Legal if you can do it, as opposed to trying to tease out "roadblocks".
16:24:53 <spot> EOF
16:24:53 * abadger1999 agrres with ke4qqq but could also see addressing problems I have with the strictness of the trademark restriction at a differnt level.
16:25:06 <jsmith> spot: +1
16:25:10 <abadger1999> spot: Well, then: I want to do #1.
16:25:20 <ke4qqq> yep - #1  for me as well
16:25:26 <gomix> me too
16:25:53 <abadger1999> If legal says no, I'll try something else until they say yes.
16:26:12 <ke4qqq> abadger1999: exactly!
16:26:30 <ke4qqq> pbrobinson: opinion?
16:26:31 <gomix> cheers to that...
16:26:40 <pbrobinson> ke4qqq abadger1999: is that really the way to protect our trademark?
16:27:09 <abadger1999> I guess putting both questions in this proposal is anticipating that they might say no to (A) and figuring out if they'll say yes to (B)... then I'll either agree to (B) or ask another question that falls between (A) and (B).
16:27:26 <abadger1999> pbrobinson:  only legal can tell us that.
16:27:31 * ke4qqq would like B not to be asked unless they reject A out of hand.
16:27:48 <rbergeron> i think it's a matter of writing it so it can be reasonably protected.
16:27:48 <pbrobinson> I want to see an improvement in the process for sure but I think its a bit short sighted to take the opinion of keeping on trying something else until you work around it.
16:27:57 <jsmith> How about we ask folks to make proposals to the advisory-board list, we decide what we want to do, and then we go to Spot?
16:28:14 <abadger1999> and if they say it's fine, then I'd like it.  If they say it's not fine, then I have a basis for looking for another solution.
16:28:23 <ke4qqq> haven't we already secured a majority for the a proposal jsmith ?
16:28:39 * ke4qqq may not be counting properly
16:28:42 <abadger1999> pbrobinson: Can you tell me that (A) is unacceptable from a legal standpoint?
16:28:45 <jsmith> ke4qqq: For which proposal?
16:28:53 <rbergeron> we cant reasonably enforce a trademark on images used everywhere on earth, unless we hire 500 lawyers.
16:29:12 <rbergeron> loosening the restrictions makes it easier for people to comply,and for us to enforce.
16:29:20 <rbergeron> in my non lawyer opinion
16:29:23 <ke4qqq> A) "if  the image consists solely of software from  Fedora it can use the Fedora marks without  explicit review and approval from the Board"  and the Board would forgo explicit review of  images in those cases.  (images == spins/AMI  images/etc)
16:29:28 <spot> rbergeron: doesn't quite work that way.
16:30:01 <ke4qqq> which was the A proposal from abadger1999 and has received a very slim majority i my counting appropriate.
16:30:08 <jsmith> ke4qqq: That's still too vague IMO -- that doesn't address updates, trademark guidelines for logos, etc.
16:30:13 <pbrobinson> abadger1999: No I can't as IANAL
16:30:20 <abadger1999> pbrobinson: All I need is to know if that's within the realm of legal possibility to change it in that manner.  The problem is that I have no idea if it is or not.  So I have to ask for a legal opinion.
16:31:17 <ke4qqq> jsmith: counter proposals welcome, did that receive a majority, or are you vetoing? we've rewritten it 3 times now.
16:31:34 <jsmith> We've only voted for #1, which did have a majority
16:31:44 <jsmith> (#1 = the AMI issue in the short term)
16:31:48 <pbrobinson> and I haven't +/- anything as jsmith said he was comfortable with a subsection but nothing has been explicitly specified so I don't see there's anything to +/-
16:32:07 <jsmith> As far as I know, there hasn't been a formal vote on anything else
16:32:11 <ke4qqq> gomix, abadger1999 and myself +1ed proposal A a few moments back.
16:32:53 <pbrobinson> I saw some + to something and then was asked for my opinion. I wasn't sure anything had been explicitly set.
16:33:05 <jsmith> Yeah -- I didn't know that we were formally voting
16:33:12 <jsmith> I saw it as a "Oooh, I like that"
16:33:22 <pbrobinson> so did I
16:33:36 <jsmith> I'm not sure three votes is a majority either, to be honest
16:33:50 <ke4qqq> how many are here?
16:33:53 <ke4qqq> 5?
16:34:06 <jsmith> rudi joined us a bit late
16:34:23 <ke4qqq> ahhh sorry,didn't see rudi enter.
16:34:23 <pbrobinson> so, as suggested by jsmith are we going to take it to the f-a-b list and flesh it out there so there's something concrete that can be added to the agenda for the next meeting?
16:34:25 <rudi> Sorry, alarm set wrong I think :)
16:34:46 <jsmith> I think that makes more sense, especially considering the fact that we're just barely a quorum
16:34:53 * gomix believes a weak majority is not good enough, but also believes there's no harm on asking legal with the proper questions
16:35:02 <abadger1999> There's nothing concrete that we can discuss until we here back from legal.
16:35:13 <abadger1999> *hear
16:35:24 <ke4qqq> exactly, we are debating about a question to be asked to legal, not the policy itself.
16:35:33 <jsmith> I still think we should make a decision on what we want first, *then* go to Legal
16:35:39 <ke4qqq> and i am concerned that in an hour and a half we can't come up with a question to ask.
16:35:49 <pbrobinson> abadger1999: spot requested that we come up with a list of explicit questions to ask so that's what there is to discuss. What will be asked
16:36:23 <pbrobinson> jsmith: +1
16:36:27 <jsmith> Otherwise, it looks like we're fishing for Legal boundaries so that we can push things as far as we can
16:36:38 <abadger1999> pbrobinson: We came up with a list of two such questions
16:36:39 <jsmith> Maybe that's not the intention, but that's what it might look like from the outside
16:36:42 * rbergeron proposes that those interested/leading the discussion get together and bring back the proposed q's to the board.
16:37:07 <rbergeron> im specifically looking at ke4qqq and abadger1999, and perhaps spot might be willing to help a bit.
16:37:17 <rbergeron> in the next week.
16:38:06 <abadger1999> rbergeron: +1
16:38:08 <rbergeron> or a proposal in general.
16:38:12 <abadger1999> I'll write email to FAB
16:38:14 <pbrobinson> abadger1999: You came up with a list of two questions and jsmith responded with two reservations and the following note " I, for example, am much more comfortable with (at least a subsection of) part B than I am with part A" so I can't see that as been agreement
16:38:18 <gomix> fine...
16:38:41 * jsmith will make a proposal for a spin/image/format approval process (including trademarks) to the Advisory-board list as well
16:38:45 <abadger1999> pbrobinson: We're not looking for agreement... we're looking for questions to pose to legal.
16:39:13 <rbergeron> jsmith: do we need that prior to talking to legal?
16:39:42 <jsmith> rbergeron: Not necessarily, but as I've stated three times now (and spot did too), I'd much rather we made up our minds one what we want to do, and then go to legal
16:39:43 * ke4qqq notes that we just rewrote that process a few months ago.
16:39:47 <abadger1999> pbrobinson: b/c when we make a proposal, the first quesiton that people ask (you did as well, even :-) is whether the proposal is adequate to defend the trademark.
16:39:54 <abadger1999> And that's something that only legal can answer.
16:40:19 * rbergeron sighs
16:40:24 <rbergeron> F50! hooray
16:41:02 <spot> !
16:41:35 <jsmith> => spot
16:41:49 <pbrobinson> abadger1999: my point about agreement was that jsmith (to me reading at least) had reservations about the wording of the questions to pose to legal. At least that's the way I interpreted his comments. And the reservation appeared to be about the board's intentions (very legal speak I know but its about getting agreement of wording on the questions themselves).
16:41:56 <spot> I just want to be clear: I'll take any proposal or question that the board agrees on to RH Legal.
16:41:58 <spot> EOF
16:44:04 <abadger1999> jsmith: So -- I'll retract proposal B.  If you'd like to resubmit with wording that you like, I'll include that in the summary for next meeting.
16:44:22 <jsmith> OK.
16:44:36 <abadger1999> jsmith: We shoiuld end this as its going to end up on the list and delayed until next meeting.
16:44:51 <jsmith> I agree
16:44:58 <gomix> please
16:45:08 <inode0> ?
16:45:13 <jsmith> => inode0
16:45:34 <inode0> when you say end up on the list is that the secret list or the one we can read?
16:45:46 <abadger1999> inode0: fab
16:45:49 <jsmith> The public advisory-board list
16:45:59 <abadger1999> I'm committing to sending this to fab this afternoon (PST)
16:46:00 <inode0> thanks, we find this discussion interesting and important
16:46:07 <jsmith> (FWIW, there's *very little* traffic on the Board private list)
16:46:17 <jsmith> #topic Any other business?
16:46:31 <jsmith> Next Board meeting will be next Tuesday at 16:00 UTC and will be a phone meeting
16:46:35 <abadger1999> #action abadger1999 to send the trademark guideline request for questions to FAB.
16:46:59 <rbergeron> the next public meeting?
16:47:01 <rbergeron> or next private meeting?
16:47:40 <jsmith> rbergeron: Next public meeting will be 16 August at 16:00 UTC
16:48:00 <rbergeron> I know.
16:48:13 <jsmith> Yes, the phone meeting is private
16:48:14 <rbergeron> I'm referring to abadger1999's omment of retracting propposal B, and you resubmitting with wording that you like.
16:48:20 <rbergeron> jsmith: yes, I'm aware of that.
16:48:43 <rbergeron> I'm just trying to get a grip of the endless timeline for making a decision here.
16:48:50 <pbrobinson> rbergeron: I think he's suppose to submit it to the FAB mailing list
16:49:09 <abadger1999> My view would be that at the phone meeting (private) we'd assemble the list of questions to send to legal.
16:49:45 <abadger1999> At the next meeting (16 aug, irc) we'd have answers from legal and discuss wording of policay we could agree on.
16:50:10 <abadger1999> if legal doesn't answer that would push that discussion back
16:50:37 <abadger1999> if legal says no to all of our ideas of what we could change then we'd repeat the cycle.
16:51:06 <jsmith> Ok, anything else today?
16:51:12 <jsmith> We're almost at the two-hour mark
16:51:31 <abadger1999> list of questions *should* all go to FAB prior to the private meeting but a board member may bring up a question at he board meeting itself.
16:51:47 <abadger1999> EOF
16:51:55 <jsmith> WORKSFORME
16:52:53 <jsmith> Last call...
16:53:26 <jsmith> #endmeeting