15:02:23 <adamw> #startmeeting Fedora 12 Beta blocker bug review meeting #3
15:02:23 <zodbot> Meeting started Fri Sep 25 15:02:23 2009 UTC.  The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:23 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:02:27 <adamw> it is #3, right?
15:03:31 <adamw> so...who's here?
15:04:05 * tk009 is here to listen in
15:04:37 <tk009> and #3 doesn't sound right but I have no proof
15:04:56 <adamw> then you will be roundly ignored! =)
15:05:00 <denise> denise is here
15:05:04 <adamw> hi denise
15:05:06 <denise> hiya
15:05:21 <adamw> well, let's get going
15:05:31 <adamw> #topic https://bugzilla.redhat.com/show_bug.cgi?id=516042
15:05:32 <buggbot> Bug 516042: medium, low, ---, rvykydal, MODIFIED, Unable to add NFS yum repo during installation
15:06:04 <adamw> i was going to try and verify this but i just don't have an appropriate setup (no NFS rawhide repo)
15:06:16 <adamw> kamil tried but was blocked by a different bug
15:07:06 <denise> i think Radek has at least partial fix for bug blocking testing - will ask him to expedite
15:07:18 <adamw> thanks
15:07:38 <adamw> does anyone else around have a setup which would let them confirm or deny 516042?
15:07:42 <adamw> hi mclasen
15:07:53 <mclasen> morning
15:10:09 <adamw> hmm, well, in that case the only action possible is to expedite fixing the bug that's blocking kparal from re-testing...agreed?
15:11:16 <denise> adamw, sounds reasonable - Radek has patches in review for at least part of other one, so wo;; be sure review happens today
15:11:24 <adamw> great
15:11:52 <adamw> #action kparal still needed to review 516042, being blocked by 524599: denise will try to expedite fixing 524599
15:12:17 <adamw> #topic https://bugzilla.redhat.com/show_bug.cgi?id=518226
15:12:18 <buggbot> Bug 518226: medium, low, ---, kernel-maint, NEW, INFO: possible circular locking dependency detected - 2.6.31-0.125.4.2.rc5.git2.fc12.ppc64
15:12:23 <adamw> the famous ppc64 kernel bug
15:12:42 <adamw> happily, we have some developer input now, suggesting it shouldn't have major consequences (commnet #7)
15:12:53 <adamw> in view of that i vote we drop it from being a blocker for either beta or final release
15:13:18 <adamw> is that ok for everyone?
15:14:36 <adamw> guess so!
15:14:53 <adamw> #agreed 518226 drops from being a blocker due to feedback from cebbert
15:15:34 <adamw> #topic https://bugzilla.redhat.com/show_bug.cgi?id=519237
15:15:35 <buggbot> Bug 519237: medium, low, ---, harald, NEW, -bash: cannot set terminal process group (-1): Inappropriate ioctl for device
15:16:22 <adamw> we had some action to try and get clarity on this one last time, looks like that's done its job
15:16:34 <adamw> so now we're clear it's a dracut regression and it's assigned correctly
15:16:53 <denise> harald is looking at this one
15:17:12 <adamw> great
15:17:33 <adamw> i don't see any action needed from us now in that case, just monitor and test when the fix arrives
15:17:44 <denise> he is not sure there is much he can do about it
15:18:49 <denise> he will update bz
15:19:27 <adamw> thanks
15:19:34 <denise> might be able to patch switch_root from util_linux_ng
15:19:56 <adamw> #agreed 519237: no direct action needed at present, in hands of harald: monitor for changes
15:20:18 <adamw> #topic https://bugzilla.redhat.com/show_bug.cgi?id=522675
15:20:20 <buggbot> Bug 522675: high, low, ---, kernel-maint, ASSIGNED, mouse,keyboard don't work when boot from LiveCD
15:21:36 <adamw> we have a request for information from cebbert that hasn't been responded to yet; i've set the bug to needinfo
15:22:00 <adamw> i'll try and test this on my x86-64 machines now we've got live CDs that boot again...
15:22:12 <adamw> anyone else any input on this bug? seen it / not seen it or anything?
15:24:12 <adamw> quiet meeting :)
15:24:27 <denise> just you amd me ;-)
15:24:41 <adamw> tk009: feel free to chime in, no qualifications needed...
15:25:16 <adamw> i've been trying to get these meetings to be more popular, they're not for Chosen People Only (although we may have to figure out a way to lay the smack down if we ever wind up with more than a handful of people)
15:26:03 <adamw> #agreed 522675 set to needinfo, maintainer has requested information. those with x86-64 hardware are encouraged to test and provide feedback in this bug so we can try to more accurately assess its impact
15:26:21 <adamw> #topic https://bugzilla.redhat.com/show_bug.cgi?id=524599
15:26:23 <buggbot> Bug 524599: medium, low, ---, rvykydal, ASSIGNED, Https repository problems
15:26:32 <adamw> ah, the prodigal returns :)
15:26:38 <adamw> so this is the one that was blocking kparal's other bug...
15:26:39 <denise> thats the one he has pacthes out for ;-)
15:26:41 <denise> yes
15:27:01 <adamw> so we already have an action here: proposed patches are available, denise will expedite inclusion for testing
15:27:24 <adamw> #action 52599 denise to expedite inclusion of proposed patches for this bug, kparal to test
15:27:26 <adamw> grr
15:27:35 <adamw> #action 524599 denise to expedite inclusion of proposed patches for this bug, kparal to test
15:27:51 <adamw> #topic https://bugzilla.redhat.com/show_bug.cgi?id=525319
15:27:52 <buggbot> Bug 525319: medium, low, ---, harald, MODIFIED, LiveCD boot gets stuck during dmsetup?
15:28:31 <adamw> this is fixed, as far as i'm concerned
15:28:49 <adamw> 20090924 nightlies booted for multiple testers (who all hit the gdm bug we'll talk about in a minute, but that's unimportant)
15:28:58 <denise> adamw, i'm worried
15:29:08 <denise> backing out lvm change migt affect that one?
15:29:09 <adamw> yup?
15:29:22 <adamw> um - what lvm change is proposed to be backed out?
15:29:28 <denise> i think warren was looking yesterday
15:29:36 <denise> their big drop from 9/21
15:30:06 <adamw> uh. wasn't aware of that. where is the proposal to drop that being discussed?
15:30:27 <denise> talk w/jesse
15:30:54 <adamw> Oxf13: ping - are you too engaged in revelry / recovering from previous revelry to join us? :)
15:31:13 <adamw> (i've pinged warren in -devel also)
15:31:19 <denise> ah - harald says it doesnt affect livecd bz
15:31:37 <adamw> um. are we _sure_? the live CD issue is slightly icky as there were multiple problems...
15:32:00 <adamw> the initial problem that manifested in 20090918 and then a further problem which came to light when that was fixed; i believe 525319 is the latter
15:32:01 <warren> sup?
15:32:25 <adamw> warren: we're on https://bugzilla.redhat.com/show_bug.cgi?id=525319 , which i believe was the second fatal live boot bug, right?
15:32:26 <buggbot> Bug 525319: medium, low, ---, harald, MODIFIED, LiveCD boot gets stuck during dmsetup?
15:33:33 <adamw> warren: I believe this one is fixed at present as 20090924 images were confirmed to boot by multiple testers
15:34:00 <warren> adamw: things changed substantially
15:34:05 <adamw> warren: however, denise says jesse mentioned there's a possibility the big lvm changes from 20090921 may be reverted, and worried whether that might cause a regression with this change
15:34:21 <adamw> so, we just wanted as much input as possible on the overall situation
15:34:22 <denise> adamw, caught harald - he says it will be fine
15:34:26 <adamw> ok
15:34:27 <warren> adamw: I thought it was reverted yesterday
15:34:35 <denise> it was
15:34:41 <warren> adamw: I reverted dracut to pre-before-that-bug-was-fixed
15:34:44 <adamw> it may have been for all I know, still working through the rawhide changelog
15:34:47 <adamw> aha
15:35:03 <warren> assuming both lvm2 and dracut were properly reverted, it should go back to how it was on Sept 21st
15:35:27 <adamw> so could i say for a summary that all major changes that will happen in this area before beta are in 20090925 rawhide, so if we test and confirm that boots, we should be OK and that bug can be closed?
15:35:29 <adamw> hi rjune
15:35:41 <denise> works 4 me
15:35:45 <rjune> adamw, just the guy I was looking for
15:35:45 <warren> I have new nightly images for today, downloading.
15:36:03 <adamw> rjune: we're in the blocker bug review meeting, so if it's something meaty please send in priv msg :)
15:36:12 <adamw> warren: i'll wait until nirik's are up
15:36:14 <adamw> and test those
15:37:07 <adamw> #action 523519 there have been more changes in this area in 20090925 rawhide: lvm is now reverted to 20090921 status and dracut has been reverted to match. warren and adamw will test to confirm 20090925 rawhide live images boot and close the bug if so.
15:38:06 <adamw> last beta blocker on the list:
15:38:07 <adamw> #topic https://bugzilla.redhat.com/show_bug.cgi?id=525567
15:38:08 <buggbot> Bug 525567: medium, low, ---, jmccann, NEW, Sept 24th LiveCD gets stuck at autologin
15:39:19 <adamw> this one manifested once we got live boot working again
15:39:27 * mclasen hasn't looked into that yet
15:40:22 <adamw> warren and I will obviously be able to check if this is still the case in 20090925
15:41:04 <adamw> if so it's obviously a definite beta blocker, if nothing else it'd get an avalanche of reports as it'd happen to _everyone_...it's triaged and appropriately assigned, so no particular action possible beyond monitoring i think
15:41:08 <warren> It happened in 924 but not 923 livecd
15:41:16 <adamw> ah, that's worth adding to the report i gues
15:41:17 <adamw> s
15:41:25 <warren> halfline was looking at that bug yesterday, any progress?
15:43:22 <adamw> guess not...
15:43:50 <adamw> #agreed 525567 is a blocker, waiting on developers; adam and warren to test daily and provide appropriate information
15:45:51 <adamw> ok, that's all the beta blockers
15:46:07 <adamw> i'm just going to do a quick look through the final release blockers for any new ones worth considering for beta since last week
15:48:23 <adamw> https://bugzilla.redhat.com/show_bug.cgi?id=524417 looks icky
15:48:24 <buggbot> Bug 524417: high, high, ---, rvykydal, NEW, Anaconda: /sbin/loader crash on kickstart installation
15:48:30 <adamw> aware of that one, denise?
15:49:19 <denise> I saw it yesterday, will see if Radek has anything else
15:49:34 <denise> but he will deal with Beta blockers first
15:51:13 <adamw> this is close to being a beta blocker, really
15:51:30 <adamw> maybe not _quite_ as kickstart install is rather more important in the context of a final release, but it's still pretty nasty...
15:53:19 <adamw> ok, nothing else in the f12blocker list looks like a promotion candidate
15:53:29 <adamw> anyone have any bugs they want to bring to the table that aren't currently listed as blockers?
15:55:44 <adamw> alrighty then
15:55:47 <adamw> thanks for coming, those who did :)
15:55:51 <adamw> #endmeeting