16:00:02 <poelcat> #startmeeting Fedora 14 Alpha Blocker Meeting #2
16:00:02 <zodbot> Meeting started Fri Jul 23 16:00:02 2010 UTC.  The chair is poelcat. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:02 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:07 <poelcat> #topic roll call
16:00:19 <poelcat> who is around?
16:00:44 <poelcat> jlaska: adamw anyone else?
16:01:10 <adamw> yo
16:01:43 * jlaska lurks
16:02:42 <poelcat> adamw: is just the dangerous duo of us again?
16:02:55 <poelcat> oh, hi jlaska
16:03:30 * brunowolff is here
16:03:35 <jlaska> howdy
16:03:46 * poelcat notes we have 5 bugs to run through, would love to finish in 30 minutes so I'm going to drive fast
16:04:05 <poelcat> if you have to step away lets us know so we aren't left hanging
16:04:23 <poelcat> #topic https://bugzilla.redhat.com/show_bug.cgi?id=597858
16:04:24 <buggbot> Bug 597858: high, high, ---, gecko-bugs-nobody, NEW, "SELinux is preventing firefox from making its memory writable and executable." crashes rawhide firefox start
16:04:54 <jlaska> "It must be possible to run the default web browser and a terminal application from the default desktop environment"
16:05:00 <poelcat> reading the comments it seems like a no-brainer
16:05:05 <jlaska> yeah
16:05:50 <poelcat> anyone know the specific maintainer?
16:06:18 <poelcat> or shall we mark this as an approved blocker and move on
16:06:19 <adamw> so this happens to all i686 firefoxes? yeah, seems straightforward
16:06:40 <poelcat> my observation so far is that we loose a lot of time trying to track down people during the meeting
16:06:44 <adamw> it shouldn't block F14Blocker *and* F14Alpha
16:07:21 <jlaska> I don't know if this is running firefox.i386 on an x86_64 install
16:07:29 <jlaska> or firefox.i386 on an i686 install
16:07:37 <jlaska> one of those scenarios seems more common
16:07:50 <poelcat> proposed action--approved blocker, remove F14Blocker, request feedback from maintainer?
16:07:56 <mcepl> poelcat: it is actually a big problem and it is being worked on upstream
16:08:09 <mcepl> https://bugzilla.mozilla.org/show_bug.cgi?id=506693
16:08:10 <buggbot> Bug 506693: normal, --, ---, nnethercote, ASSIGNED, SELinux is preventing JIT from changing memory segment access
16:08:11 <poelcat> mcepl: any details you can provide, please add to the comments
16:08:20 <mcepl> not now
16:08:24 <jlaska> comment#5 seems to indicate it's failing on the native arch
16:08:50 * poelcat trying to spend no more than 5 minutes on each bug today
16:08:54 <poelcat> this one is about to expire :)
16:09:11 <poelcat> responses to my proposed actions?
16:09:11 <jlaska> no objections, I think it's a valid F14Alpha blocker
16:09:24 <jlaska> +1
16:09:31 <adamw> sure
16:09:48 <poelcat> #action https://bugzilla.redhat.com/show_bug.cgi?id=597858 approved blocker, remove F14Blocker, request feedback from maintainer
16:09:49 <buggbot> Bug 597858: high, high, ---, gecko-bugs-nobody, NEW, "SELinux is preventing firefox from making its memory writable and executable." crashes rawhide firefox start
16:10:04 <poelcat> who wants to take care of the paperwork for each of the bugs today?
16:11:38 <adamw> hum, just reading the upstream bug
16:11:41 <adamw> "> Hey nick, whats the status of this?
16:11:41 <adamw> The code works, someone needs to decide if it's a good idea and should be
16:11:41 <adamw> landed.  Eg. see comment 99."
16:11:53 <adamw> it seems there's already a patch for it. if this were any *other* package, we could fix it now. le sigh.
16:12:25 <poelcat> adamw: does that change our proposed action?
16:13:14 <poelcat> #topic https://bugzilla.redhat.com/show_bug.cgi?id=613695
16:13:15 <buggbot> Bug 613695: medium, medium, ---, mgracik, MODIFIED, ImportError: cannot import name GObject
16:13:15 <adamw> it looks to me like we need someone to go to bat for this upstream if it's going to happen.
16:13:22 <adamw> gee, thanks for waiting!
16:13:47 <poelcat> sorry about that
16:14:01 <adamw> right now we have a big ugly mess and fairly minor firepower on the rh/fedora side trying to sort the thing out
16:14:10 <adamw> which is why it's been sitting there since, apparently, f12 and hasn't been fixed yet...
16:14:53 <jlaska> looks like martin stransky might be in a position to provide guidance ... he's on the upstream bug and redhat
16:15:02 <jlaska> let's stick with our "request feedback from maintainer"
16:15:03 <adamw> i think it would probably be profitable to mail the folks from fedora/rh side who are involved on the upstream bug plus the active firefox maintainers and ask them to do what they need to to get it done upstream, otherwise i rather doubt it's going to happen
16:15:30 <poelcat> how do i go backwards to the previous topic?
16:15:49 <jlaska> poelcat: I think you just do #topic again
16:16:08 <poelcat> #topic https://bugzilla.redhat.com/show_bug.cgi?id=597858
16:16:09 <buggbot> Bug 597858: high, high, ---, gecko-bugs-nobody, NEW, "SELinux is preventing firefox from making its memory writable and executable." crashes rawhide firefox start
16:16:55 <mcepl> the guy to contact is Martin Stránský <stransky@redhat.com>
16:17:16 <poelcat> #action https://bugzilla.redhat.com/show_bug.cgi?id=597858 approved blocker, remove F14Blocker, request feedback from maintainer, contact Martin Stránský <stransky@redhat.com> to get a better idea of the future of this bug
16:17:17 <buggbot> Bug 597858: high, high, ---, gecko-bugs-nobody, NEW, "SELinux is preventing firefox from making its memory writable and executable." crashes rawhide firefox start
16:17:22 <poelcat> okay to move on now>?
16:17:41 <jlaska> yes, not sure we can add anything more to that bug here
16:18:01 <poelcat> #topic https://bugzilla.redhat.com/show_bug.cgi?id=613695
16:18:03 <buggbot> Bug 613695: medium, medium, ---, mgracik, MODIFIED, ImportError: cannot import name GObject
16:18:13 <poelcat> jlaska: any luck testing this one?
16:18:24 <jlaska> should be fixed, waiting on these next acceptance images to confirm
16:18:40 <jlaska> should be back in ASSIGNED, or VERIFIED->CLOSED next week
16:18:45 <jlaska> hopefully the later
16:19:14 <poelcat> #action https://bugzilla.redhat.com/show_bug.cgi?id=613695 should be back in ASSIGNED, or VERIFIED->CLOSED next week
16:19:15 <buggbot> Bug 613695: medium, medium, ---, mgracik, MODIFIED, ImportError: cannot import name GObject
16:19:36 <poelcat> #topic https://bugzilla.redhat.com/show_bug.cgi?id=615443
16:19:37 <buggbot> Bug 615443: high, low, ---, dhuff, NEW, boot from liveusb fails (can't mount root filesystem)
16:19:51 <poelcat> i contacted dhuff and he was going to look at before our meeting
16:19:57 <poelcat> looks like he didn't get a chance
16:20:07 <poelcat> oops wrong bug #
16:20:18 <adamw> i updated the firefox bug.
16:20:31 <brunowolff> I tried looking at why things might mount and got as far as finding the ext3 image wasn't mountable.
16:20:31 <poelcat> check that, it is the right next bug number
16:20:33 <poelcat> adamw: thank you!
16:20:49 <brunowolff> However when I rebuilt locally I didn't see that.
16:21:11 <brunowolff> However testing further was blocked by the blackscreen related bug.
16:21:37 <jlaska> brunowolff: so hard to really confirm/deny this bug due to the other blackscreen issue?
16:21:39 <adamw> it seems like a no-brainer blocker.
16:21:40 <brunowolff> I will try to do some more testing this weekend, but it's very slow to do on my hardware.
16:21:45 <jlaska> adamw: +1
16:22:00 <adamw> unless the issue is in the actual nightly compose process somehow (since that's not 'official fedora')
16:22:15 <nirik> you can get past the image/blackscreen bug
16:22:17 <brunowolff> I am not sure why the ext3 image on my local rawhide build was mountable and the ones from the nicghtly compose site weren't.
16:22:21 <nirik> by holding down shift on boot
16:22:35 <brunowolff> Testing that the problem is fixed was complicated by the other issue.
16:22:37 * nirik has no idea why it's broken either.
16:23:04 <jlaska> nirik: ah, good tip about holding <Shift>
16:23:18 <nirik> that gets you to a boot: prompt at least
16:23:19 <adamw> can you add that to the bug?
16:23:20 <brunowolff> I also didn't test newer composes. I will try the latest nightly compose of some image this weekend to see if that part of the problem is fixed.
16:23:32 <jlaska> brunowolff: were you testing soas, or another nightly live image?
16:23:40 <brunowolff> I tried doing tab and delete.
16:23:48 * nirik sees the same thing on xfce nightly.
16:24:12 <brunowolff> I was testing kde for the ext3 stuff, though built livecd-desktop for my local test.
16:24:13 <jlaska> okay ... so it's not isolated to one spin
16:24:28 <brunowolff> I wanted to test something smaller so I could download it quicker.
16:24:48 <poelcat> #chair adamw jlaska brunowolff nirik
16:24:48 <zodbot> Current chairs: adamw brunowolff jlaska nirik poelcat
16:25:03 <jlaska> w/in18
16:25:08 <brunowolff> The livecd-desktop ks also is doing something bad, but I don't think it is related to the problems we are seeing.
16:25:15 <jlaska> doh!
16:25:28 <adamw> so the summary here is 'live CDs are utterly screwed'
16:25:33 <jlaska> sounds like it
16:25:36 <poelcat> proposed next action(s)?
16:25:43 <adamw> well, accept this bug for a start
16:25:48 <adamw> maybe add jkeating to CC?
16:26:03 <brunowolff> I want to see if I can get the blackscreen stuff fixed as there have been some useful comments there.
16:26:05 <adamw> and perhaps monitor the nightlies for the next week and try to keep track of exactly what's broken in each
16:26:25 <brunowolff> Also I want to test the latest nightly composes to see if the ext3 image issue went away there.
16:26:47 <jlaska> we've certainly confirmed the problem exists and is widespread ... need some love to further isolate+diagnose
16:27:04 <poelcat> #action https://bugzilla.redhat.com/show_bug.cgi?id=615443 approved blocker, add jkeating to CC, monitor the nightlies for the next week and try to keep track of exactly what's broken in each
16:27:06 <buggbot> Bug 615443: high, low, ---, dhuff, NEW, boot from liveusb fails (can't mount root filesystem)
16:27:15 <poelcat> #info we've certainly confirmed the problem exists and is widespread ... need some love to further isolate+diagnose
16:27:25 <poelcat> okay to move on?
16:27:51 <jlaska> sure
16:27:51 <poelcat> btw could someone update the bugs to reflect our agreed on actions for each?
16:28:16 <adamw> i've done the firefox one and now this one
16:28:32 <jlaska> I can take a few, but could use some help ... err thanks adamw!
16:28:32 <adamw> i missed 613695
16:28:35 <poelcat> is anyone else willing to help?
16:28:40 <jlaska> I'll get that one
16:28:43 <poelcat> thanks adamw
16:29:12 <poelcat> #topic https://bugzilla.redhat.com/show_bug.cgi?id=616090
16:29:13 <buggbot> Bug 616090: medium, low, ---, bcl, MODIFIED, Rescue mode fails
16:29:25 <poelcat> it's that jlaska guy again ;-)
16:29:41 <jlaska> same deal, I'll update the bz
16:29:56 <jlaska> I'll retest this with the new rawhide acceptance images when they land
16:30:35 <jlaska> "#  The rescue mode of the installer must start successfully and be able to detect and mount an existing default installation "
16:30:48 <jlaska> any objections?
16:30:52 <poelcat> #action https://bugzilla.redhat.com/show_bug.cgi?id=616090 jlaska will retest this with the new rawhide acceptance images when they land
16:30:53 <buggbot> Bug 616090: medium, low, ---, bcl, MODIFIED, Rescue mode fails
16:31:01 <adamw> jlaska: add the AcceptedBlocker whiteboard field...
16:31:06 <jlaska> adamw: you got it, thx
16:31:28 <poelcat> #topic #topic https://bugzilla.redhat.com/show_bug.cgi?id=617115
16:31:29 <buggbot> Bug 617115: medium, low, ---, dhuff, NEW, rawhide live spins showing black screen instead of syslinux boot menu
16:31:38 <jlaska> this is the other bug brunowolff was referencing
16:31:48 <brunowolff> Yes
16:31:48 <adamw> seems to be the issue discussed in that other bug
16:31:48 <adamw> yeah
16:32:06 <jlaska> nirik: did you have some ideas as to what might be causing this?
16:32:12 <jlaska> I'm not sure if livecd-tools is the right component
16:32:33 <nirik> I think it's a change in anaconda.
16:32:34 <jlaska> or if this is also related to fedora-logos changes
16:32:38 <jlaska> nirik: oh
16:32:40 <nirik> it's putting the image in the wrong place or not at all.
16:32:51 <nirik> or not updating the syslinux files with the new path or something.
16:33:16 <adamw> my strategy in such cases is usually to add the world to CC
16:33:25 <adamw> logos maintainer, livecd-tools maintainer, anaconda maintainer
16:33:32 <adamw> bash enough heads together and eventually you get somewhere =)
16:33:34 <jlaska> sounds awefully similar to a previous F14Alpha blocker about the boot graphic not showing up when booting installer
16:33:51 <jlaska> that got closed by spot as fixed in the current fedora-logos package ... but this bug report uses that package
16:33:57 <jlaska> so still broken, or wrong component
16:34:14 <brunowolff> The other bug had some discussion of this, but spun off a separate bug after we decided there were two issues.
16:34:36 * jlaska thinking about bug#614488
16:34:37 <buggbot> Bug https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=614488 medium, low, ---, tcallawa, CLOSED RAWHIDE, syslinux-vesa-splash.jpg installed to wrong location
16:35:02 <jlaska> they seem related
16:35:27 <jlaska> but like adamw already said ... we need some help from maintainers fedora-logos and/or anaconda?
16:35:50 <jlaska> as for F14Alpha blocker ...
16:35:56 <jlaska> I think this impacts "#  The installer must boot (if appropriate) and run on all primary architectures from default live image, DVD, and boot.iso install media "
16:36:02 <adamw> yeah, it's straightforward enough
16:36:41 <adamw> shall i update the bug and add some CCs?
16:36:42 <jlaska> alright, so ApprovedBlocker and enact adamw bug resolution strategy#48  ?
16:36:46 <adamw> =)
16:36:57 <jlaska> go for it!
16:37:06 <adamw> not #48! NEVER #48! there's a reason it's under double key security, y'know
16:37:18 <jlaska> :P
16:38:13 * jlaska just noticed /topic isn't set ... is zodbot upset?
16:38:28 <jlaska> oh, double #topic perhaps?
16:38:32 <jlaska> #topic https://bugzilla.redhat.com/show_bug.cgi?id=617115
16:38:33 <buggbot> Bug 617115: medium, low, ---, dhuff, NEW, rawhide live spins showing black screen instead of syslinux boot menu
16:38:48 <poelcat> proposed-action https://bugzilla.redhat.com/show_bug.cgi?id=617115 ApprovedBlocker, add "the world" to the CC list so we can get some more help attention and help on this critical issue
16:38:49 <buggbot> Bug 617115: medium, low, ---, dhuff, NEW, rawhide live spins showing black screen instead of syslinux boot menu
16:39:07 <jlaska> poelcat: you got the #action
16:39:12 <nirik> the +t flag is set so it can't set the topic.
16:39:24 <poelcat> #action https://bugzilla.redhat.com/show_bug.cgi?id=617115 ApprovedBlocker, add "the world" to the CC list so we can get some more help attention and help on this critical issue
16:39:25 <buggbot> Bug 617115: medium, low, ---, dhuff, NEW, rawhide live spins showing black screen instead of syslinux boot menu
16:39:33 <jlaska> nirik: aha, you always have the channel foo :)
16:39:40 <poelcat> #topic open discussion
16:39:46 <poelcat> that's all the bugs for today
16:39:47 <brunowolff> nirik, what system is the nightly compose builder running? Could the recent glibc change to support 2.6.32+ have an effect?
16:39:51 * jlaska tips hat to nirik
16:39:59 <poelcat> anything else we should cover?
16:40:08 <nirik> brunowolff: it's a rawhide xen guest.
16:40:15 <jlaska> F14Beta is empty
16:40:24 <nirik> it's running the f13 kernel tho, as the rawhide one was blowing up last I tried it.
16:40:28 <nirik> could it be kernel related?
16:41:05 <brunowolff> F13 kernels should be fine.
16:42:11 <brunowolff> I'll be able to do some testing over the weekend. But I have a lot of Fedora stuff to do, and some of it probably isn't going to get done as soon as I had hopped.
16:42:57 <jlaska> brunowolff: is this something we could ask for general testing feedback on from test@ list?
16:43:27 <jlaska> or do we know the problem well enough that we don't need more test failures
16:44:07 <brunowolff> Right now probably not. By Monday I might have a different opinion.
16:44:19 <jlaska> brunowolff: okay
16:44:25 <jlaska> poelcat: no other topics from me
16:44:35 <jlaska> nirik: adamw: brunowolff: howabout you guys?
16:44:40 <brunowolff> Done
16:44:43 <adamw> nope
16:44:56 <jlaska> alrighty ... let's end with a quick friday joke
16:45:06 * jlaska might regret that request
16:45:17 <jlaska> someone has to have a funny link or story? :)
16:45:31 * nirik has nothing.
16:45:40 * adamw can't think of anything that wouldn't potentially get him fired
16:45:49 <jlaska> haha
16:45:50 <poelcat> thanks for your help jlaska brunowolff adamw nirik
16:45:53 <poelcat> #endmeeting