16:00:29 <bookwar> #startmeeting Fedora CI SIG
16:00:29 <zodbot> Meeting started Wed Jun  5 16:00:29 2019 UTC.
16:00:29 <zodbot> This meeting is logged and archived in a public location.
16:00:29 <zodbot> The chair is bookwar. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:29 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:29 <zodbot> The meeting name has been set to 'fedora_ci_sig'
16:00:46 <clime> Hi
16:00:50 <fbo> o/
16:00:59 <bookwar> #topic Roll call
16:01:10 <bookwar> .hello2
16:01:11 <zodbot> bookwar: bookwar 'Aleksandra Fedorova' <alpha@bookwar.info>
16:01:58 <bookwar> i am a noob in chairing the meeting, so if I'd do smth wrong - let me know
16:02:23 <tstellar> .hello2
16:02:24 <zodbot> tstellar: tstellar 'Tom Stellard' <tstellar@redhat.com>
16:02:28 <bookwar> let's give it 2 more minutes to see if more people come
16:02:38 <fbo> .hello2
16:02:39 <zodbot> fbo: fbo 'Fabien Boucher' <fboucher@redhat.com>
16:03:38 <tflink> .hello2
16:03:39 <zodbot> tflink: tflink 'Tim Flink' <tflink@redhat.com>
16:04:18 <mrc0mmand> .hello2
16:04:19 <zodbot> mrc0mmand: mrc0mmand 'None' <frantisek@sumsal.cz>
16:04:27 <bookwar> fbo: thanks for coming, sorry for not fitting into your preferred times
16:04:46 <bookwar> so, let's get started
16:04:54 <bookwar> #topic Welcome
16:04:56 <fbo> bookwar: That's fine
16:05:41 <bookwar> This is a short one: Welcome everyone to our first dedicated Fedora CI SIG meeting, thanks for coming, and I am glad that we have many people interested in the topic.
16:06:17 <bookwar> As you probably noticed, I've put the goals and topics of CI SIG as generic as possible
16:06:40 <bookwar> The actual choice of things we will work on is up to us
16:07:09 <bookwar> and in the end we are shaping the SIG, so don't feel limited by them
16:07:49 <clime> Cool!
16:08:04 <bookwar> I suggest that we do the introduction round first, then we discuss org related matters and then have open floor for anything else
16:08:15 <bookwar> #topic Introduction
16:08:21 <bookwar> I'll start first :)
16:08:58 <bookwar> So i am Aleksandra Fedorova, I am currently member of FESCo, and I am RedHat employee, with related work on CI in RHEL
16:09:19 <bookwar> so my interests in CI are wide, but for now I want to focus on two topics
16:09:55 <bookwar> first - I'd like to work on the stats for current available Fedora CI pipelines - gather the metrics of how many things we run, how much of them fail and so on
16:10:28 <bookwar> second, I am interested in Standard Test Roles and i'd like to refactor the way we manage inventories there
16:10:44 <bookwar> any questions?
16:11:21 <bookwar> fbo: would you present your project?
16:12:11 <fbo> Sure, I'm Fabien Boucher working at Red Hat on CI related subjects in the OpenStack team especially on Zuul. Working on a project called Software Factory (a Forge and CI platform based on Zuul/Nodepool). Mainly interested in helping Fedora to use Zuul and see if it relevant.
16:13:11 <bookwar> ok, if you have any questions - type in, otherwise we are moving on
16:13:18 <bookwar> clime: your turn?
16:13:18 <fbo> We already have some POCs I'm working with Tristan Decacqueray on those subjects
16:13:23 <fbo> done :)
16:13:26 <bookwar> sorry )
16:13:51 <clime> I am clime, a Fedora contributor, devoted one.
16:14:21 <clime> I'd like to launch a community CI/CD system
16:14:43 <clime> Open for public
16:14:58 <bookwar> Similar to Travis?
16:15:27 <clime> Ye, it should build rpms And launch tests
16:15:47 <clime> I would like to use standard test roles for that probly
16:15:50 <tflink> as a replacement for COPR or working with COPR?
16:16:01 <clime> Replacement
16:16:14 <clime> Or fork rather
16:17:05 <bookwar> interesting, do you have more details described somewhere already?
16:17:17 <fbo> clime: no only related to Fedora (I mean for every opensource project ?)
16:17:37 <clime> Not yet., fbo:yes
16:18:28 <bookwar> ok, let's move on for now, and leave more questions for open floor
16:18:52 <bookwar> tstellar: do you want to introduce yourself?
16:19:29 <tstellar> I'm Tom Stellard, Red Hat employee and  mantainer of llvm, clang, and related packages.  CI has been very helpful for these package so far, so I wanted to get more involved.  Things I'm interested in now are multi-arch testing and integrating mass rebuilds into CI.
16:19:55 <bookwar> oh, that's a hard one :)
16:20:06 <bookwar> cool
16:20:23 <bookwar> tflink: your turn?
16:20:51 <tstellar> bookwar: multi-arch or mass rebuilds? or both?
16:21:20 <tflink> I'm Tim Flink, a Red Hat employee with Fedora QA. I'm working on a setup to run generic checks (rpminspect, rpmdeplint etc.) as a replacement for Taskotron
16:21:23 <bookwar> tstellar: both, multi-arch is just resource wise, mass rebuilds is an interesting workflow case
16:22:11 <bookwar> tflink: do you use centos infra currently?
16:22:29 <tflink> bookwar: the replacement will run in the centos infra, yes
16:22:52 <bookwar> ok, thanks
16:23:17 <bookwar> mrc0mmand: what are your interests?
16:24:22 <mrc0mmand> Hello, I'm Frantisek Sumsal, working at Red Hat as the QE for (mainly) systemd. We (systemd upstream) would like to extend our testing efforts to the Fedora CI (mainly rawhide), as we've introduced several major regressions in the past which could've been easily avoided.
16:24:27 <mrc0mmand> We'
16:24:29 <mrc0mmand> whoops
16:24:54 <mrc0mmand> we're making an extensive use of the CentOS CI, which has an amazing infrastructure, however, it lacks support for alternative architectures
16:25:24 <bookwar> it is great to see the initiative coming from actual dev teams
16:25:45 <mrc0mmand> the "ideal" outcome could be something general, which allows (GitHub) PR testing in Fedora infrastructure
16:26:07 <bookwar> mrc0mmand: have you talked with Packit people about it?
16:26:15 <bookwar> ttomecek: if you are around ^^
16:26:37 <mrc0mmand> bookwar: I talked with ttomecek on the CI mailing list and his team would be interested in this as well
16:26:49 <bookwar> gcool, thanks
16:27:38 <bookwar> anyone else present in the room wants an introduction?
16:28:26 <bookwar> if not, moving on
16:29:04 <bookwar> #topic Organizational
16:29:31 <bookwar> so that's a bit generic, so i have couple of questions to discuss on how would you like this group to interact
16:29:59 <bookwar> what we have now: IRC channel. mailing list, Taiga board and Wiki
16:30:25 <bookwar> so if you are working on the project you probably want to have a task tracker
16:30:45 <bookwar> we have a CI project at https://teams.fedoraproject.org/
16:30:55 <clime> Ad. Taiga board. Can you post a link pls.
16:31:20 <bookwar> #link https://teams.fedoraproject.org/project/ci/
16:31:45 <clime> Idk if i have access there
16:31:59 <bookwar> to login there one needs a FAS account
16:32:07 <bookwar> it gives you basic user access
16:32:23 <clime> Probly yes :), great thanks
16:32:32 <bookwar> then to work on the CI project specifically you need to request membership in the project team
16:32:54 <clime> Okay
16:32:59 <fbo> bookwar: can I be added as member https://teams.fedoraproject.org/project/ci/ ?
16:33:00 <bookwar> i can provide such membership, but i need a e-mail associated with FAS id to do that
16:33:42 <tflink> to clarify, since I made this mistake, you need the email that is in FAS, not <userid>@fedoraproject.org
16:33:54 <bookwar> i guess i'll just add everyone according to that hello data above
16:34:09 <clime> .hello2
16:34:10 <zodbot> clime: clime 'clime' <clime7@gmail.com>
16:34:28 <fbo> bookwar: alright thanks
16:34:35 <bookwar> i'll do it right after the meeting
16:34:37 <mrc0mmand> bookwar: that would be perfect as today I accidentaly an invite from you in the junk folder, but that was for my RH email, not the FAS one
16:34:55 <mrc0mmand> found an invite*
16:35:03 <bookwar> mrc0mmand: ack, will fix that
16:35:16 <mrc0mmand> thank you
16:35:32 <bookwar> #action bookwar invites everyone to taiga project
16:35:58 <tstellar> I need to step away for a while, I'll be read-only from now on.
16:36:34 <bookwar> now I suggest that we use taiga for project work, while for bugs and issues on Fedora CI infrastructure we keep using pagure
16:36:56 <bookwar> #link Fedora CI issues https://pagure.io/fedora-ci/general/issues
16:37:46 <mrc0mmand> that definitely makes sense
16:38:14 <fbo> alright
16:38:43 <clime> +1
16:40:10 <bookwar> #agreed use taiga for projects and pagure for Fedora CI issues
16:40:44 <bookwar> one other thing is separation between ideas vs actual tasks
16:41:46 <fbo> bookwar: should we use taiga tags to flag stories related to projects listed in the wiki ?
16:42:03 <bookwar> fbo: good point
16:42:07 <fbo> we can then filter by tag
16:42:29 <bookwar> i am not that familiar with taiga yet, but this makes sense
16:43:02 <fbo> we are using it in our team ... ;)
16:43:11 <bookwar> so i think that we can collet generic ideas somewhere in the wiki, while in taiga there should already be tasks and actionable things
16:43:27 <bookwar> fbo: cool, you are going to be our local expert :)
16:43:56 <bookwar> anyway, this is probably not smth we need to decide today, let's get everyone access first, and see how it goes
16:43:57 <fbo> bookwar: I prefer to have that hat regarding Zuul :)
16:44:39 <bookwar> any other questions regarding Taiga?
16:45:53 <bookwar> ok, moving on
16:46:08 <bookwar> we have also Category:CI in Fedora Wiki, so feel free to use it for any materials you are writing with regards to Fedora SIG and your projects
16:47:16 <bookwar> next one..
16:47:29 <bookwar> #topic Meeting times and purpose
16:47:55 <bookwar> Choosing the meeting time is hard :)
16:48:31 <bookwar> We can keep this time, or we can try to add an alternative time and alternate between different times if needed. What do you think, is it worth it?
16:49:32 <tflink> I'm usually of the mind that alternating times is an invitation to confusion
16:49:43 <fbo> is this time fine with US and EU TZs ?
16:50:13 <tflink> it's fine for US TZs but how many of us are in those TZs?
16:50:29 <mrc0mmand> agreed, making the meeting time somewhat stable would be great
16:50:55 <fbo> tflink: good point let's see what are our TZ maybe ?
16:51:37 <bookwar> whenisgood had this info
16:51:47 <bookwar> but it is temporarily down it seems
16:52:06 <bookwar> i think we are mostly EU
16:52:15 <clime> Utc+1/+2 here
16:52:44 <fbo> UTC +1/+2 here too
16:53:05 <mrc0mmand> ^
16:53:27 <bookwar> ok, how about we keep the time for now and for those who can't make it - lets start with asynchronous channels and see if there is a need for more?
16:54:18 <tflink> UTC-6 for me
16:54:47 <tflink> bookwar: that works for me
16:55:06 <fbo> +1
16:55:14 <clime> +1
16:55:16 <mrc0mmand> +1
16:55:36 <bookwar> #agreed use this time slot for bi-weekly meetings
16:56:37 <bookwar> the related question is, what is the purpose of the meeting
16:57:10 <bookwar> i think the status update on various projects, if you have things to show or questions you would like to get inputs for, or just check in
16:57:45 <bookwar> thus the project updates are going to be main agenda item
16:58:25 <bookwar> what do you think?
16:59:29 <tflink> I don't have a better idea
16:59:44 <bookwar> so, we will see how it goes :)
16:59:49 <fbo> +1
17:00:09 <fbo> One topic by projects known in the wiki :)
17:00:21 <bookwar> ok
17:00:26 <bookwar> so we are running out of time
17:00:33 <bookwar> #topic Open floor
17:00:47 <bookwar> is there anything you want to talk about?
17:01:37 <fbo> could I freely open a wiki page to share the status of the POC we have regarding Zuul ? Is there any specific rules to follow ?
17:02:09 <bookwar> fbo: no rules, you can create a separate child page, or just right a proper section in the current one, up to you
17:02:23 <fbo> thanks
17:02:42 <bookwar> *write
17:02:53 <bookwar> that's my favorite typo
17:03:07 <bookwar> ok, so thanks everyone for coming, next meeting here in two weeks :)
17:03:33 <bookwar> #endmeeting