16:00:57 <mchua> #startmeeting
16:00:57 <zodbot> Meeting started Tue Sep 14 16:00:57 2010 UTC.  The chair is mchua. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:57 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:57 <mchua> #chair nirik mmaricini
16:00:57 <mchua> #meetingname Basic distributed collaboration tools
16:00:57 <zodbot> Current chairs: mchua mmaricini nirik
16:00:57 <zodbot> The meeting name has been set to 'basic_distributed_collaboration_tools'
16:01:00 <mchua> We have officially begun.
16:01:12 <mchua> zodbot over there is logging for folks who come in late (and for us later when we need to read notes).
16:01:16 <mchua> I'll go over zodbot later in class. :)
16:01:29 <mchua> Hello everyone, and welcome!
16:01:29 * mchua is Mel Chua, Fedora contributor (http://fedoraproject.org/wiki/User:Mchua) and Red Hatter (Community Architecture Team)
16:01:31 * nirik waves hi to everyone.
16:01:32 <mchua> #info An outline of the day can be found here...
16:01:35 <mchua> #link http://blog.melchua.com/2010/09/07/fedora-classroom-tuesday-sep-14-at-1600-utc-working-with-people-who-arent-there-basic-distributed-collaboration-tools/
16:01:46 <mchua> I'm going to go through the agenda in a moment, but wanted to say that we'll be here for an hour
16:01:59 <mchua> with some time for questions at the end, but *please* interrupt me mid-class if there's anything.
16:02:03 <mchua> So, agenda.
16:02:06 <mchua> #topic Agenda
16:02:19 <mchua> #info * Introductions
16:02:28 <mchua> #info * What's Fedora Classroom?
16:02:38 <mchua> #info * Realtime meetings on IRC
16:02:42 <mchua> #info * Zodbot and logging
16:02:51 <mchua> #info * Collaborative text editing (gobby, Etherpad0
16:02:59 <mchua> (though we'll probably focus on Etherpad today, for the sake of simplicity
16:03:02 <mchua> )
16:03:13 <mchua> #info * Sharing what you've done asynchronously afterwards
16:03:33 <mchua> #note I'll be practicing a lot of what I preach while we go through this classroom session, so you'll see it in action and be able to help for reals. :)
16:03:42 <mchua> Feel free to pipe up anytime.
16:03:47 <mchua> So... let's start with introductions.
16:03:50 <zoltanh7211> hi guys - I hope I'm not late
16:03:50 <mchua> #topic introductions
16:04:05 <mchua> #info Can everyone chime in, say their name and where they're from, what they're hoping to learn today?
16:04:32 * nb Nick Bebout (nb) - Fedora Contributor - just observing, and maybe will learn something
16:04:32 <Southern_Gentlem> ben willing to learn
16:04:48 <mpaquin> Mike Paquin, Red Hat, looking for tools to use in-house and expand learning options
16:04:57 <plarsen> Peter - get inspiration and knowledge of the tools to run open source projects.
16:05:22 <nirik> Kevin Fenzi here... hoping to learn new stuff and help with any questions on anything.
16:05:34 <zoltanh7211> zoltan - get inspired, learn new tools
16:06:09 * mchua waits a minute for new introductions
16:06:11 <NiveusLuna> Russell Golden, hoping to learn about collaborative text editing for writing and editing literature
16:06:19 <mchua> vreg, lsr - want to say who you are, what you're hoping to learn today?
16:06:19 <NiveusLuna> can only stay for half an hour, sadly
16:06:23 * mchehab Mauro Chehab - Red Hat - learning more
16:06:46 * slinabery redhat, just lurking to see if there's any info I can leech for my team to use :)
16:06:53 <slinabery> s(teve)linabery
16:07:01 <dcr226> Dave , every day's a school day
16:07:03 <mchua> NiveusLuna: That's okay, we're going to be logging this for people who can't make it, so there'll be everything in notes afterwards.
16:07:06 * jbastian Jeff Bastian, Red Hat, just looking to learn something new today
16:07:29 <lsr> mchua: Just saw the message about the classroom session and thought I'd see what it was all about.
16:08:38 <mchua> Awesome. So, first of all, this class is more about culture/practice than it is tools - we're covering tools, but only as they're needed to explain how we Do Things in Fedora-land.
16:08:42 <mchua> I mean, we have tens of thousands of contributors, volunteers from around the world, how do we manage to stay in touch, keep together, and still get out an operating system every 6 months?
16:08:46 <mchua> And what from those practices/tools can be applied to other places (like, say, Red Hat teams?)
16:08:49 <mchua> That's what this class is about, in my mind.
16:08:52 <mchua> (any other last-min intros before we start?)
16:09:03 <vreg> o/
16:09:25 <mchua> vreg: go!
16:09:46 <vreg> that was my intro :)
16:09:56 <mchua> roygbiv: We're just finishing up introductions, do you want to tell everyone who you are and what you're hoping to learn?
16:10:03 * mchua had budgeted 10m for intros, just to get a sense of who's around
16:10:30 <mchua> Okay, we'll start in on the first topic then.
16:10:34 <roygbiv> i'm just a fly on the wall :-D fedora user
16:10:50 <mchua> #topic Fedora Classroom
16:10:52 <mchua> #info The first thing I want to talk about is how we teach each other things - there's the informal IRC/mailing list stuff, but we also have sessions (like this one) on Fedora Classroom.
16:11:10 <mchua> nirik: (feel like giving a shameless plug? now's the time to jump in ;0
16:11:14 <mchua> er, ;)
16:11:23 <nirik> absolutely.
16:11:33 <mchua> nirik: let 'er rip.
16:11:38 <mchua> #link https://fedoraproject.org/wiki/Classroom
16:11:42 <nirik> We are always looking for folks to give classes on topics that they know and love to others.
16:12:05 <nirik> It's a great way to share what you know on an area and spread that info around.
16:12:19 <mchua> It's like the Fedora equivalent of watercooler talks.
16:12:40 <nirik> It doesn't take all that much to do so, just a ability to use some simple irc tools, an hour and a subject you know.
16:12:58 <nirik> You can see on the wiki page some of the past classes (all are archived)
16:13:44 <nirik> if anyones interested in teaching, feel free to see me outside class or read the process on the classroom page. ;)
16:13:49 <roygbiv> content should be delivered completely through irc?
16:14:16 <mchua> Well, this class is one example - we use IRC as a primary channel, but I'm going to be dropping in wiki pages for reference throughout. :)
16:14:20 <nirik> currently thats the case. We have talked about expanding to voice or other media... but haven't gotten there yet. ;)
16:14:33 <mchua> It's really ad-hoc - whenever someone wants to teach something, they simply announce it, and others show up.
16:14:35 <roygbiv> ok thanks
16:14:36 <mchua> Just as we did here.
16:14:47 <mchua> If you want to learn something, you can ask if anyone can teach a Classroom session.
16:14:51 <mchua> It's like training-on-demand.
16:15:22 * DiscordianUK is always willing to learn
16:16:33 <mchua> Any questions on Classroom? I wanted to point out that this isn't a one-time thing, that it can happen again and on any topic you're interested in.
16:16:40 <plarsen> Maybe we can distribute Open Office Impress slides as PDF to have a bit "show and tell"?
16:16:48 <mchua> Red Hatters - if you want external folks to find out about your work / try it out, teaching a Classroom is a *great* way to do that!
16:16:54 <pliu> Hi, I'm new here. I want to learn sth about packaging in Fedora. Any pointers?
16:17:04 <mchua> plarsen: Some folks have distributed slides before running a classroom session, I don't see why not. :)
16:17:15 <mchua> pliu: Ask on the classroom list and see if you can get someone to run a packaging session.
16:17:18 <DiscordianUK> There have been Fedora Classrooms on packaging
16:17:22 <mchua> We've had those several times before.
16:17:56 <pliu> Great! Should I check the archives on the wiki?
16:18:07 <nirik> pliu: please do. there are several there. ;)
16:18:12 <Boe08_Work> pliu: sdziallas ran a packaging class last winter
16:18:21 <mchua> pliu: If you look at the Classroom link I posted up above, you'll see the archives.
16:19:28 <pliu> Wonderful! Actually I want to step my foot into the Fedora Eclipse Packager project. Any advice for me?
16:20:26 <zoltanh7211> pliu: http://fedoraproject.org/wiki/Packaging/Guidelines
16:21:52 <zoltanh7211> mchua please continue
16:21:59 <pliu> Thanks, mchua, nirik, boe08_work, zoltanh7211.
16:22:23 <mchua> Ok!
16:22:36 * mchua is glad folks are getting in the habit of asking questions on IRC, that's one of the things I wanted to bring out in this class
16:22:49 <mchua> Introducing new topics, new questions - like pliu asking about Eclipse packaging - that's great.
16:23:00 <mchua> It's not an unwelcome interruption, it's easy to go back and follow up on other stuff later. :)
16:23:10 <mchua> So, next I wanted to talk about realtime meetings.
16:23:16 <mchua> #topic Realtime meetings
16:23:19 <mchua> We're in one right now. :)
16:23:35 <zoltanh7211> mchua: o/
16:23:38 <mchua> This is exactly how every Fedora teem carries out its meetings.
16:23:46 <mchua> zoltanh7211: did you have a comment?
16:24:05 <zoltanh7211> Why isn't we using empathy with voice?
16:24:15 <mchua> zoltanh7211: a few reasons.
16:24:31 <mchua> (1) I personally prefer to teach in text, because it's more easily loggable - I'm teaching not just for you folks now, but for everyone who reads the logs afterwards.
16:24:34 <mchua> (2) I'm deaf :D
16:24:48 <zoltanh7211> mchua: :)
16:24:49 <mchua> It's a matter of personal preference; some people do use Fedora Talk (our VOIP solution) and some people do slides... this is just the way I teach.
16:24:55 * plarsen likes the second reason
16:25:00 <zoltanh7211> ok, thx
16:25:03 <DiscordianUK> A lot of old hands at IRC will use dedicated IRC clients like xchat for IRC
16:25:09 <mchua> #link http://talk.fedoraproject.org/
16:25:15 <DiscordianUK> That indeed is what I do
16:25:15 <mchua> #info That's Fedora Talk, btw, for those of you who prefer audio
16:25:31 <mchua> But zoltanh7211 brings up an excellent point; people do use different communication media, it's a matter of what you want.
16:25:43 <mchua> IRC is great for logging (since it's text), it's easier to share notes afterwards.
16:26:02 <mchua> So for instance, since in Fedora Marketing we have a very distributed team - not everyone can make our weekly meeting - it's in IRC so that we can share notes afterwards
16:26:12 <nirik> additionally, some people may be working or doing other things, or on the phone, but they could also be following here as time permits.
16:26:13 <mchua> and the folks who are in Europe, say, know that they can read everything, that they're not missing out.
16:26:17 <mchua> nirik: +1
16:26:30 <mchua> However, the Fedora Board will sometimes have its meetings on the phone (well, ok, Fedora Talk).
16:26:53 <zoltanh7211> mchua: could we ask audio classrooms sometime? and have them in podcast?
16:27:04 <mchua> There are relatively few of them, they know they can schedule something all of them can make, and they take the extra burden of taking notes so others can find out what they talked about.
16:27:18 <mchua> zoltanh7211: Absolutely, if you want to teach via audio and recording a podcast you can do that.
16:28:07 <mchua> So, IRC is slower than voice. :)
16:28:15 <mchua> And it can be chaotic, when we have multithreaded conversations with lots of people jumping in.
16:28:33 <mchua> (jump in more, btw! I love these comments, they bring in stuff I hadn't thought of.)
16:28:43 <mpaquin> so what's the key for holding a successful meeting via IRC?  Advance planning and having text already written out?  Patience?
16:28:46 <mchua> But there are tools you can use to help manage the chaos.
16:28:49 <mchua> mpaquin: Great question. :)
16:28:59 <mchua> mpaquin: And yes to all of the above.
16:29:00 <Heldwin> with people like me who don't use VOIP, it can be a problem, thought, the fedora talk
16:29:11 <zoltanh7211> mchua: so we could record fedora talks by pulsecaster?
16:29:20 <mchua> Heldwin: Yep. As I mentioned before, I'm deaf, so audio stuff is pretty much a no-go for me personally, though I know lots of other people like it. :)
16:29:25 <mchua> zoltanh7211: Sure, or whatever tools you like!
16:29:46 <mchua> I wanted to answer mpaquin's question, since it touches on what I was going to cover in this section.
16:29:58 <mchua> I'm going to use the Marketing Team as an example, because I used to run that team.
16:30:11 <mchua> Marketing has meetings once a week. Tuesdays at 4pm EDT in #fedora-meeting-1.
16:30:20 <plarsen> mchua, to me it's an advantage that IRC can have multiple concurrent threads ongoing. Try that with voice ;)
16:30:28 <DiscordianUK> +1
16:30:29 <mchua> (we have special IRC meeting channels so it's easy for people to lurk on the meetings of multiple teams)
16:30:32 <mchua> plarsen: +1
16:30:42 <mchua> (for those who don't know, "+1" is a shorter way to type "yes, I agree")
16:30:57 <mchua> #link https://fedoraproject.org/wiki/Marketing_meetings
16:31:02 <mchua> I'll give folks a minute to take a look at that.
16:31:11 <mchua> See how we have meeting details (with login info) and an agenda.
16:31:20 <mchua> And meeting logs of old meetings, but we'll get to that in a bit.
16:31:32 <nirik> I think personally that a good meeting/class in irc needs: a) a good agenda/outline so people know what they are going to over, b) someone who knows the subject matter well, so they can answer questions easily off the cuff. ;)
16:31:49 <mchua> We paste the agenda there ahead of time, and also send a weekly autoreminder to the marketing list linking to these instructions + the agenda for the meeting, so we don't have to retype that every time.
16:32:16 <mchua> #link http://lists.fedoraproject.org/pipermail/marketing/2010-August/013318.html
16:32:35 <mchua> #info That's a sample meeting announcement. Notice how it can be identical each time - so we've actually just automated the sending of that email.
16:33:12 <mchua> And everyone knows the agenda is always right there, and it's a wiki page, so people who want to add topics just add to that page.
16:33:33 <mchua> We also log these meetings.
16:33:57 <mchua> There are lots of logs (all of them, actually) linked to on the [[Marketing Meetings]] page so you can peruse them at your leisure
16:34:12 <mchua> (and also so new Marketing Team members can catch up on the last couple meetings to get up to speed real quick)
16:34:23 <mchua> but I'd like everyone to take a look at one, so they see what logs look like.
16:34:33 <mchua> Here's one, randomly chosen.
16:34:37 <mchua> #link http://meetbot.fedoraproject.org/fedora-meeting-1/2010-04-20/fedora-meeting-1.2010-04-20-20.01.html
16:34:47 <mchua> So note that these are meeting *minutes*
16:34:56 <mchua> The full log is linked-to right at the top of the meeting minutes.
16:35:00 <mchua> But logs are long.
16:35:06 <mchua> And we want to take notes on the important stuff.
16:35:18 <mchua> So we generate this nice meeting notes with a logging bot.
16:35:24 <mchua> In this channel (and in fedora) our bot is called zodbot.
16:35:30 <mchua> zodbot: swedish
16:35:30 <zodbot> mchua: kwack kwack
16:35:34 <zodbot> mchua: bork bork bork
16:35:38 <zodbot> mchua: (supybot-fedora version 0.2.8)
16:35:40 <mchua> Zodbot is amusing.
16:35:50 <mchua> #link https://fedoraproject.org/wiki/Zodbot
16:35:54 <mchua> #info That's more documentation on Zodbot.
16:36:00 <mchua> You don't have to read it now, it's just there for reference if you're curious.
16:36:07 <mchua> The important thing to know is that zodbot is what takes those nice meeting notes for us.
16:36:17 <mchua> You can see in the meeting minutes how notes and actions are called out.
16:36:21 <mchua> #note This is how you call out a note.
16:36:36 <mchua> (you can also do that with #info or #idea or #agreed, but they all end up looking the same in the meeting minutes)
16:36:49 <mchua> Anything you preface with #note will show up in the meeting minutes, anything you don't... won't.
16:36:54 <mchua> It's a good way of summarizing what's important.
16:37:01 <pliu> #note
16:37:11 <mchua> #note prefacing something with #note will make it show up in the meeting minutes, it's a good way to call out important stuff.
16:37:21 <mchua> pliu: Yep, exactly. Except you'll want to put more text afterwards. :)
16:37:37 <mchua> You can also see, at the bottom of the meeting notes, http://meetbot.fedoraproject.org/fedora-meeting-1/2010-04-20/fedora-meeting-1.2010-04-20-20.01.html
16:37:41 <mchua> ...there are action items.
16:37:42 <mchua> By person!
16:37:48 <mchua> This is my favorite zodbot feature, personally.
16:37:58 <pliu> #note i like zodbot
16:38:03 <mchua> So if we're chatting along and say "hey, someone should do this!" we can go...
16:38:14 <mchua> #action mchua send out meeting notes and logs after this Classroom session is over
16:38:28 <mchua> ...and since my nick is in that #action, zodbot will automatically see it as belonging to me.
16:38:31 <mchua> And sort it accordingly in the meeting notes.
16:38:42 <Boe08_Work> mchua: a useful feature for #note might be to add the ability to #note the last thing someone else said so you don't have to retype something long if they said something worth noting but didnt
16:39:00 <mchua> This is AWESOME for team leaders because they can just look at the notes to see "hey hey, what did people say they were going to do this week?"
16:39:05 <mchua> Boe08_Work: Care to demo? :)
16:39:18 <plarsen> mchua, is there a way zodbot can refer to the list of action items for the next meeting_
16:39:19 <plarsen> ?
16:39:22 <Boe08_Work> i'm not sure if it supports that functionality
16:39:38 <mchua> Boe08_Work: Give it a shot and we'll see, and if it doesn't we can put in an enhancement request ;)
16:39:46 * mchua tends to resummarize, it's faster
16:40:07 <mchua> plarsen: Well, zodbot does make the list of action items in the meeting notes when it's done logging... is that what you meant?
16:40:12 * mchua isn't sure
16:40:15 * nirik notes the meeting functions are the supybot-meetbot plugin. Upstream developer is very responsive to adding or fixing things for us. ;)
16:40:39 <nirik> plarsen: no way I know of. It doesn't have a concept of a 'last meeting'. Only the one thats happening now.
16:40:44 <plarsen> mchua, not directly. For the next week meeting it's customary to follow up on the actions agreed to on the last meeting. Can zodbot go through the list for us?
16:40:58 <plarsen> nirik, ok.
16:41:16 <mchua> plarsen: Not automatically (yet!) but that would be a great thing to put in as an enhancement request :)
16:41:31 <mchua> plarsen: I usually just copy in the link to last week's meeting notes at the start of the meeting, and ask everyone to look as I go through.
16:41:47 <Boe08_Work> mchua: where would you go to request an enhancement?
16:41:47 <mchua> Zodbot is, btw, totally free software so it's easy to deploy on any box you want :)
16:42:22 <mchua> Boe08_Work: https://fedoraproject.org/wiki/Zodbot#Contact has a link to a trac.
16:42:39 <mchua> My Red Hat team has an instance of the same bot running on our internal server for our team meetings.
16:42:59 <mchua> Part of what Fedora tries to be is a place where these sorts of FOSS best-practices can be tested and taught, so other places can adopt what we do if they find it useful.
16:43:04 <plarsen> mchua, "forbidden" when you follow that link
16:43:30 <mchua> plarsen: Ah, you probably need to log in with a Fedora account... nirik, would you mind hopping in and helping plarsen get started?
16:43:31 <nirik> you can also file a bug on the supybot-meetbot package in bugzilla.redhat.com
16:43:35 * mchua can also do that after this class
16:43:47 * mchua wants to make sure we have enough time for Etherpad discussion and Q&A here though
16:43:55 <plarsen> mchua, I can login ... done ;)
16:43:58 <mchua> plarsen: awesome :)
16:44:02 <nirik> yeah, happy to follow up with folks anytime.
16:44:06 <mchua> yeah, maybe we should, uh, document this stuff better
16:44:15 * mchua will review these class notes afterwards and see what can be done.
16:44:24 <mchua> (everyone else, please feel free to chime in with questions, comments, notes, etc. anytime)
16:44:36 <mchua> (this class gets far more interesting if I'm not monologuing :)
16:44:43 <pliu> mchua, please move on to Etherpad.
16:44:45 <mchua> Any other questions on zodbot, realtime IRC meetings?
16:45:05 <zoltanh7211> o/
16:45:12 <mchua> zoltanh7211: Go for it.
16:45:19 <mchua> (you don't need to ask permission to say things, btw, just say them :)
16:46:07 <zoltanh7211> mchua: if an task is given out, is it possible to receive a mail to reminder? or get the full log by default as mail?
16:46:08 <plarsen> What category on that site would Zodbot belong to?
16:46:12 <Boe08_Work> mchua: it doesn't offer the functionality i was looking for, but ill put a request in shortly
16:46:56 <mchua> Boe08_Work: Okeydokey, thanks!
16:46:58 <mchua> plarsen: "general"
16:47:08 <mchua> zoltanh7211: Not yet, that's a great enhancement request to file too :)
16:47:11 <mchua> I actually wish it would do that.
16:47:18 <mchua> What i do is just email the link to the meeting notes afterwards, to the team list.
16:47:30 <mchua> And I also edit the meeting wiki page to have the new meeting log on it as well.
16:47:43 <mchua> #link https://fedoraproject.org/wiki/Marketing_meetings#IRC_meetings_archives
16:47:48 <mchua> ...as an example.
16:48:01 <mchua> So, I want to move on to Etherpad in our remaining time.
16:48:15 <mchua> We actually have instructions on running a meeting in IRC.
16:48:19 <mchua> #link https://fedoraproject.org/wiki/Marketing_meetings#Procedure_for_Minutes_and_Logging
16:48:33 <mchua> This covers a lot of what we just talked about today, and gives a template for how to use these tools to run your meetings as well.
16:48:46 <mchua> (pro tip: writing down HOWTOs on things helps other people do them instead of you ;)
16:49:02 <mchua> as soon as I wrote these instructions down, I was able to start asking other people to chair Marketing Team meetings, which made it easier for when I had to be other places, etc.
16:49:16 <mchua> last call for IRC meeting questions?
16:49:25 <mchua> Etherpad will take about 6 minutes.
16:49:41 <mchua> And true to form, I'll be covering good followup... in the followup, so that's actually not part of the class time right now. ;)
16:49:44 * mchua is sneaky!
16:50:46 <mchua> All right!
16:50:50 <mchua> #topic Etherpad
16:50:51 <mchua> Okay. I also wanted to cover collaborative text editing, which can be a great way to sprint on stuff together (for instance, we did it to work on Feature Profiles for Fedora Marketing)
16:50:55 <mchua> (Gobby is another - see https://fedoraproject.org/wiki/Gobby and note that you can do everything we're about to do in Etherpad... in Gobby.)
16:50:58 <mchua> #note First, I want to show you Etherpad in action, the sorts of things we do with it.
16:51:01 <mchua> So. Everybody read this...
16:51:03 <mchua> #link http://blog.melchua.com/2010/02/27/self-introduction-mad-libs-because-its-science/
16:52:08 <mchua> I'm trying to find a new video of live etherpad editing, since the old link no longer works in that blog post.
16:52:11 <mchua> One sec.
16:52:17 <mchua> Aha.
16:52:22 <mchua> #link http://openetherpad.org/ep/pad/view/ohio-edu-talk-proposal/latest
16:52:29 <mchua> That's a talk proposal I was writing.
16:52:42 <mchua> You can see other people jumping in to help over time (Sebastian, then Kevin)
16:52:52 * plarsen shoots trac!
16:52:59 <mchua> I was in... Boston, I think, while writing this.
16:53:05 <mchua> Sebastian was in Germany, Kevin was in New York.
16:53:12 <mchua> Neither of them knew ahead of time I would be working on this (neither did I)
16:53:30 <mchua> but I started in etherpad and threw the link out to the IRC channel I was hanging out on (#teachingopensource) so folks would know what I was up to.
16:53:35 <mchua> And they happened to be able to jump in and take a look.
16:53:55 <mchua> It's the digital equivalent of working in an office and saying (out loud) "hey, can someone come and help me look at this?"
16:54:08 <mpaquin> that is really, very cool
16:54:10 <zoltanh7211> jesus - I hope I will see this sometime integrated into transifex to translate mass/huge po files
16:54:20 <zoltanh7211> this etherpad
16:54:40 <mpaquin> what does etherpad require to run?
16:54:43 <mchua> That's most of what I wanted to show you, really - Etherpad itself is easy to grok.
16:54:46 <mchua> #link http://openetherpad.org/fedora-classroom-etherpad-demo-1
16:54:47 <mchua> mpaquin: Ah! I'm glad you asked.
16:54:50 <mchua> #note Go to this link now and try it out yourself. :)
16:54:59 <mchua> Etherpad is currently hard to deploy, but there are some folks in Fedora working on making it easier.
16:55:17 <mchua> #link https://fedoraproject.org/wiki/Etherpad
16:55:23 <mchua> There's a packaging effort going on, so mpaquin - that's the requirements
16:55:35 <mpaquin> excellent
16:55:51 <mchua> For those of you interested in learning the status of that and helping to push it along (for instance, I want this for my team at Red Hat, so I'm helping out)
16:55:59 <mchua> there's a FAD - Fedora Activity Day, a hackathon, on it coming up.
16:56:04 <mchua> #link https://fedoraproject.org/wiki/Etherpad_FAD
16:56:14 <mchua> It's in-person in the Boston area for those of you around there, but there's also remote participation
16:56:18 <mchua> using the same tools and techniques we're using now
16:56:23 <mchua> for folks like me who won't be onsite.
16:56:33 <plarsen> mchua, this looks like a light version of google wave? :D
16:56:46 <mchua> plarsen: Etherpad actually got bought by Google, so it... is exactly that.
16:56:57 <mchua> They open-sourced the code, but it's undocumented and, er, I shall say.... messy.
16:57:01 <mchua> Javascript, java, scala.
16:57:04 <mchua> So. Help is good.
16:57:27 <mpaquin> Google Wave is dead, so any idea of the future for etherpad?
16:57:30 <mchua> That's most of what I wanted to show you, really - how Etherpad can be used. Etherpad itself is easy to grok.
16:57:34 <mchua> #link http://openetherpad.org/fedora-classroom-etherpad-demo-1
16:57:36 <mchua> #note Go to this link now and try it out yourself. :)
16:57:42 <mchua> mpaquin: We're trying to make the future for Etherpad, right now, by having that FAD.
16:57:58 <mchua> There are some people in Fedora (and elsewhere) who are interested in seeing it continue, so we're stepping up to try and collaborate on that work.
16:58:05 <mchua> And we'd love help. Absolutely would love help.
16:58:14 * mchua notes we're running short on time and this is the end of the material she had to show.
16:58:28 <mchua> Again, I will be covering "how to follow up on meetings" in my meeting followup.
16:58:51 <mchua> Which will be sent to the fedora-classroom list, as well as to whatever channels mpaquin and mmarcini advertised this session in for Red Hatters. :)
16:58:57 <DiscordianUK> yum list etherpad isn't showing it up in fedora 13
16:59:03 <mchua> DiscordianUK: Yep, that's because it's not yet packaged.
16:59:08 <DiscordianUK> though I see gobby
16:59:11 <pliu> I want to pass the word aroudn to my students. Where can I find updates on FAD and Etehrpad?
16:59:14 <mchua> DiscordianUK: That's what the FAD is working on.
16:59:28 <DiscordianUK> Ahh okay thank you mchua
16:59:34 <mchua> pliu: https://fedoraproject.org/wiki/Etherpad_FAD
16:59:55 <mchua> DiscordianUK: If you want to lurk during that FAD (remotely or otherwise) and ask about the status, that's a good way to find out when it might be up.
16:59:56 <pliu> Thanks, mchua. I will come back to Fedora Classroom.
17:00:01 <mchua> Their goal is getting it deployed by the end of that FAD.
17:00:09 <mchua> And that's also how we collaborate in Fedora, but that's a topic for another class. :)
17:00:13 <mchua> We're at the end of time.
17:00:22 <mchua> I'll hang out for a bit for questions afterwards, but that's all I had.
17:00:25 <mchua> Thanks everyone for being here!
17:00:30 * mchua had a good time
17:00:34 <plarsen> thanks for having this mchua
17:00:42 <nirik> thanks very much mchua
17:00:42 <mchua> #topic After-class Q&A
17:00:47 <pliu> See you, mchua. Very informative and eye-opening.
17:00:53 <mchua> Thanks everyone!
17:00:53 <mpaquin> mchua, in general, the people who attend meetings via IRC as you've shown us, how do they feel these meetings run as opposed to voice/in-person?  Are these more or less productive?
17:00:58 <zoltanh7211> tahnks mchua
17:01:06 * Heldwin thanks mchua :)
17:01:10 <mpaquin> (thinking adoption)
17:01:12 <mchua> thanks for coming, pliu, plarsen, zoltanh7211, Heldwin.
17:01:14 <DiscordianUK> Thank you mchua
17:01:18 <mchua> thanks DiscordianUK!
17:01:25 <mmarcini> thanks a lot for great talk mchua
17:01:30 <mchua> And thanks for the questions and comments, they totally help make this talk much better.
17:01:43 <mchua> Feedback welcome, I'd love to turn this into reference material for new Fedora / Red Hat folks.
17:01:50 <mchua> Again, this'll all be in the follow-up emails. :)
17:02:00 <mchua> mpaquin: so, re: your question...
17:02:32 <pliu> BTW, one more question. What tools are available on Fedora to do slide shows, audio shows, and video shows?
17:02:33 <mchua> I personally prefer IRC meetings for most of the things I work on - because I like being able to draw on a large distributed team for my work, and I'm lazy and don't like taking meeting minutes. ;)
17:02:46 <zoltanh7211> mchua: I think we'll need the audo parts - because of some of between us are blind - it could be fedora the only distribution who supports blind, or impaired persons
17:03:04 <plarsen> The only thing i miss on IRC is the "drawing pad". Meaning a diagram/picture sometimes tell a 1000 words
17:03:12 <mchua> pliu: I'm actually the worst person to answer that question because I can't hear :) but what I'd do is actually ask that question to the Fedora Classroom list, with a "could someone please teach a Classroom on this topic?" Lemme get you a link.
17:03:18 <mchua> mpaquin: (getting to your question in a moment, not quite done, one sec)
17:03:27 <zoltanh7211> mchua: maybe we need reader programs - text to audio
17:03:41 <mchua> pliu: https://admin.fedoraproject.org/mailman/listinfo/classroom
17:03:47 <mchua> zoltanh7211: That's one idea!
17:04:14 <mchua> mpaquin: That having been said (to return to your question) there are some things that in-person is way better for. I mean, it's just... nice to see people, to have that bandwidth, to *be* there.
17:04:29 <plarsen> I would have a problem with audio. A lot of the stuff we talk about is commands or things where syntax etc. has to be adopted. Doing that from an audio source is rather hard. For instance, the links you presented today would have been difficault to do with audio only.
17:04:36 <mchua> mpaquin: I think the rule of thumb I use for myself is... who do I want to be at the meeting, and for that set of people, what's the best medium?
17:04:55 <mpaquin> agreed.  however I do see the value with IRC & bots for notes
17:04:56 <mchua> plarsen: Yep, that's a good point. Some material is easier to present (and digest) in text.
17:05:17 <mmarcini> plarsen, some tools not only allow you to do audio but also to share window/desktop, so you may show commands in xterm with an output as well
17:05:20 <mchua> mpaquin: One thing I've also seen done is having an IRC backchannel for an IRL meeting, and having notetaking done live there.
17:05:32 <mpaquin> personally I'm very interested in Etherpad.  That seems to have the most immediate and obvious value
17:06:10 <mchua> mpaquin: Yep, that's why we're pushing hard for it to be deployable... we need a lot of help getting upstream in shape, so having Red Hatters pitch in on the FAD in a few weeks would be *incredibly* awesome
17:06:21 <mchua> I mean, we have some real javascript/js/Scala wizards
17:06:32 <mchua> and packagers... tons of packagers, people who know what it takes to get something deployed in production
17:06:34 <mpaquin> you have my support.  let's chat offline about how to get participation
17:06:36 <mchua> +1
17:06:38 <zoltanh7211> mpaquin: I think etherpad is very valueable where it's need to edit mass tests, or docs
17:06:49 <mchua> The tradeoff between Etherpad and Gobby (they're both collaborative text editing)
17:06:56 <mchua> is that you have to install Gobby, whereas Etherpad is a web application
17:07:01 <mchua> so Etherpad works from any computer with a browser
17:07:02 <mpaquin> ahh, got it
17:07:08 <nirik> it's nice when a meeting needs to also produce a final document about something.... ie, everyone agrees on a document at the end.
17:07:19 <mchua> Gobby works in Linux... and I think they have a Windows client, but I haven't used it, not quite sure.
17:07:22 <mchua> nirik: +1
17:07:34 <mchua> However, Gobby can handle more users than Etherpad; Etherpad chokes at... 8 or so
17:07:43 <mchua> But it also gives you the time-slider video afterwards :)
17:07:45 <mchua> which I think is cool.
17:07:48 <mpaquin> if gobby is installed, where does the collaborate text get stored during editing and after?
17:07:53 * mchua personally thinks Etherpad is the more promising technology
17:07:56 <mpaquin> scratch, that, I can figure that out
17:08:08 <mchua> mpaquin: There's a configuration file you can set for Gobby as to where it should store those files.
17:08:09 <mpaquin> yes.  scalability will be key for etherpad though.  8 isn't enough
17:08:14 <mchua> mpaquin: hence the FAD ;)
17:08:17 <mpaquin> :-)
17:08:43 <mchua> yeah, we really should talk about getting participation in that, we've got spot (Tom Callaway) coming down from Westford already but we'd love more Red Hat participation.
17:08:43 <mpaquin> your session lived up to my expectation.  thank you very much, this was great!
17:08:46 <mchua> w00t!
17:08:52 * mchua has to go grab food soon, getting hungry
17:09:00 <mchua> mpaquin: I'll catch you later with followup over email?
17:09:10 <mpaquin> absolutely.
17:09:11 <mchua> I've got some notes to write up after this, will send logs and whatnot, and we can figure out where to go from there.
17:09:14 <mchua> Sweet.
17:09:18 <mchua> Thanks for making this happen, mpaquin and mmarcini!
17:09:24 <zoltanh7211> mchua: c u bon apetite
17:09:26 <mpaquin> cool.  thx again!  wouldn't have happened without you
17:09:28 <mchua> And for keeping the Classroom going, nirik. :)
17:09:30 <zoltanh7211> cu guys
17:09:31 <mmarcini> mchua, pleasure is on my side
17:09:34 <mpaquin> bye
17:09:39 <mmarcini> \
17:09:42 <mmarcini> bye bye
17:09:49 * mchua waves
17:09:51 <mchua> #endmeeting