20:02:27 <jforbes> #startmeeting Cloud SIG
20:02:27 <zodbot> Meeting started Thu Jun  3 20:02:27 2010 UTC.  The chair is jforbes. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:02:27 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
20:02:47 <jforbes> #topic Roll Call
20:03:00 <jforbes> So, who might be here today?
20:03:59 * mdomsch 
20:04:15 <jforbes> huff Oxf13?
20:04:22 <Oxf13> howdy
20:05:01 <jforbes> Okay, I didn't see any replies with other topics, so I will start with EC2 images
20:05:10 <jforbes> #topic EC2 images
20:06:08 <huff> Oxf13: sup
20:06:17 <jforbes> It appears that the kernels we have up will only work on *some* of the EC2 systems, they have a mix of servers, some of which are on much older releases and don't work with the pv_ops kernels
20:06:22 <huff> crap is is 4 already
20:06:52 <jforbes> They recommended a very nasty patch which Ubuntu and SUSE are using, but that wont work for us
20:07:17 <huff> jforbes: there aparently are patches in rhel 5 for this
20:07:24 <jforbes> huff: Yeah, kinda
20:07:30 <huff> and I think they are now working to get these into rhel6 last iheard
20:07:37 <huff> not sure how that helps for fedora
20:07:54 <jforbes> So in RHEL 5 we switched the xen version.  As of this morning they are looking to port that solution to RHEL 6/upstream
20:08:30 <Oxf13> yikes
20:09:39 <jforbes> It doesnt force you to choose a lower version of hypervisor compatibility, it simply implements an older hypercall only if the hypervisor errors on not implemented when the new one fails
20:10:02 <jforbes> I should have updated status on this patch tomorrow, and we can review and see about getting it pushed upstream and to Fedora releases
20:10:38 <jforbes> The RHEL 5 patch is not too bad, but of course that is for the older xen, not pv_ops, so a bit of work had to be done
20:11:53 <Oxf13> what's our standing on having our EC2 images use a updated kernel as opposed to the release kernel?
20:11:54 <jforbes> huff: have you looked at moving the kickstart to F13?
20:12:15 <huff> jforbes: not yet I can do that
20:12:58 <jforbes> Oxf13: Not optimal, but shouldn't be a problem for F13
20:13:04 <huff> jforbes: also have you looked into this pv grub thing they are pushing for it on the rhel side and wanted to know if this should be sothing we should look at form fedora as well
20:13:11 <Oxf13> we'll have to make sure we keep the kernel srpm around somewhere
20:13:27 <jforbes> huff: yeah, we are going to use pvgrub
20:13:36 <huff> jforbes: have you tested that
20:13:41 <huff> im looking at it now
20:13:53 <jforbes> Oxf13: We already have a solution for that, it can be placed in the S3 storage with the images
20:13:59 <huff> it dose'nt like out image fromat
20:14:20 <jforbes> huff: what's the problem there?
20:14:31 <huff> so the pvgrub can point to hd0,0
20:14:53 <Oxf13> jforbes: awesome.
20:15:08 <huff> or hd0 our images that our produced with AC have it on hd0,0 i think we have to modify the grub.conf or somthing
20:15:33 <huff> im playing with itnow
20:15:58 <huff> basicly i cant get pvgrub to load our initrd of the ami image
20:16:12 <huff> i think its just a configuration issue
20:16:26 <jforbes> huff: Yeah, sounds like it...  You are working through it?
20:16:47 <huff> jforbes: yea ill let you guys know what i find
20:17:02 <jforbes> Thanks :)
20:17:11 <jforbes> Any other update on the EC2 image status?
20:18:47 <jforbes> Okay, I will say that pvgrub is the target for a real process, but if we can get the kernel issues worked out in a sane fashion, we can get F-13 images up without pvgrub as well.
20:19:08 <jforbes> Any other topics people wanted to discuss?
20:19:41 <jforbes> #topic Open Floor
20:19:53 <huff> anythig on the mirror in ec2
20:20:03 <huff> fedora mirror
20:20:25 <jforbes> #action huff will look into pvgrub issues with ac created images
20:21:05 <mdomsch> sorry, too many meetings
20:21:09 <jforbes> huff: no update on the mirror.  I never got a handoff on the status, and didn't follow up yet since the kernel issues were more pressing.  I will do some digging and see what I can find
20:21:20 <mdomsch> so, I sent someone my gpg key to get access to the accounts
20:21:44 <huff> jforbes: not a huge issue but once we get these up there would be nice to same users bandwith for updates and such
20:22:16 <jforbes> mdomsch: I did too, and they left before sending them.  I need to get with mspevack to get the handoff
20:22:19 <mdomsch> I haven't heard back from nathan on what image sizes we can get.  I thought we'd need their biggest instances, but we can probalby get by with less horsepower, and just add on more storage
20:23:45 <jforbes> I will follow up with mspevack on both the accounts, and the mirror to see where we are before next week
20:24:32 <jforbes> Any other topics?
20:25:23 <jforbes> Okay, going to end the meeing in 1 min
20:26:36 <jforbes> Thanks for participating.... Next meeting will be same time next week
20:26:40 <jforbes> #endmeeting