19:07:51 <kushal> #startmeeting Fedora Cloud
19:07:51 <zodbot> Meeting started Wed Nov 19 19:07:51 2014 UTC.  The chair is kushal. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:07:51 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:08:06 <kushal> #meetingname Fedora Cloud SIG
19:08:06 <zodbot> The meeting name has been set to 'fedora_cloud_sig'
19:08:17 <kushal> #topic Roll Call
19:08:30 <dustymabe> .hellomynameis dustymabe
19:08:31 <kushal> .hellomynameis kushal
19:08:31 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dusty@dustymabe.com>
19:08:34 <zodbot> kushal: kushal 'Kushal Das' <kushaldas@gmail.com>
19:08:35 <roshi> .hello roshi
19:08:40 <zodbot> roshi: roshi 'Mike Ruckman' <mruckman@redhat.com>
19:09:02 <kushal> #chair roshi dustymabe
19:09:02 <zodbot> Current chairs: dustymabe kushal roshi
19:09:10 <kushal> Anyone else ?
19:09:20 <roshi> jsmith: ^^
19:09:24 <roshi> agrimm: ^^
19:09:28 <roshi> mattdm: ^^
19:09:37 <roshi> oddshocks: ^^
19:09:40 <dustymabe> scollier: I think is here
19:09:43 <kushal> mattdm, is busy in fesco one.
19:09:44 <mattdm> oh hi
19:09:49 <agrimm> are we meeting in this channel today?
19:09:57 <scollier> dustymabe, yup
19:10:02 <agrimm> .hellomynameis arg
19:10:03 <zodbot> agrimm: arg 'Andy Grimm' <agrimm@redhat.com>
19:10:03 <kushal> mattdm, yes, the other one you all are discussing fesco :)
19:10:11 <roshi> yeah, since fesco is still going
19:10:14 <kushal> #chair mattdm agrimm
19:10:14 <zodbot> Current chairs: agrimm dustymabe kushal mattdm roshi
19:10:18 * jsmith is here, but occupied with ${DAYJOB}
19:10:31 <kushal> #chair scollier jsmith
19:10:31 <zodbot> Current chairs: agrimm dustymabe jsmith kushal mattdm roshi scollier
19:10:34 * kilted1 lurks
19:10:35 <jsmith> I'll try to participate as best I can...
19:10:49 <kushal> #chair kilted1
19:10:49 <zodbot> Current chairs: agrimm dustymabe jsmith kilted1 kushal mattdm roshi scollier
19:11:01 <kushal> Sounds good.
19:11:22 <kushal> #topic Previous Meeting follow-up
19:11:38 <kushal> Okay zodbot will change the topic as it seems.
19:12:23 <kushal> I already asked nirik.
19:12:41 <kushal> * roshi to email test@ list regarding the new criteria
19:12:42 <kushal> * roshi to point discussion to the trac instance for both test@ and
19:12:42 <kushal> cloud@
19:12:46 <roshi> I did this
19:12:50 <oddshocks> I'm here :)
19:12:52 <kushal> ^^ these are the action items.
19:12:53 <roshi> didn't get much/any feedback though
19:13:02 <kushal> #chair oddshocks
19:13:02 <zodbot> Current chairs: agrimm dustymabe jsmith kilted1 kushal mattdm oddshocks roshi scollier
19:13:37 <kushal> roshi, Do you know who all actually tests these images than the known suspects from the channel?
19:13:50 <roshi> cloud images?
19:14:06 <roshi> most of the people in the channel do (though they don't all report results)
19:14:14 <roshi> I'm pretty much it from QA doing the testing
19:14:41 <kushal> roshi, Okay, just trying to understand how else we can send in the message and to whom? :)
19:14:43 <roshi> if I had to guess, me, matt, kushal would be the top three for testing our images
19:14:53 <roshi> dustymabe and jzb for atomic
19:15:03 <roshi> I'll bring it up at the next QA meeting monday
19:15:11 <kushal> roshi, Okay, thanks :)
19:15:13 * agrimm admits that he typically only tests images when there's a problem to be solved
19:15:31 <kushal> agrimm, which is nice actually :)
19:15:40 <roshi> #action roshi to bring new criteria to QA meeting Monday (2014-11-24)
19:15:51 <kushal> I think last time roshi did the testing in EC2, correct?
19:15:56 * roshi just always assumes there's a problem to be solved...
19:16:07 <roshi> yeah, haven't gotten to it yet for this TC tough
19:16:12 <roshi> s/tough/though
19:16:23 <roshi> once I finish up my end of the testday prep I'll run through them
19:16:43 <kushal> roshi, btw, you have to tell me if I have to update any page for TC2 tests, I already did that in Openstack
19:17:33 <kushal> Okay, now moving to the current tickets.
19:17:57 <kushal> #topic Plan test days for Atomic image (#74)
19:18:05 <roshi> ok
19:18:12 <kushal> jzb, is not here as we know.
19:18:12 <roshi> this is moving forward
19:18:15 <roshi> testday is tomorrow
19:18:29 <roshi> I updated testCloud so people could do easy local testing if they want to poke at it
19:18:31 <kushal> roshi, Can you please paste the corresponding links here.
19:18:37 <kushal> roshi, Thanks :)
19:18:43 <roshi> I'm writing testcases today from what dustymabe wrote
19:18:49 <dustymabe> kushal: is meetbot loaded?
19:18:52 <kushal> roshi, testCloud rocks!!
19:19:00 <roshi> when I found out that my days were mixed up I worked on testCloud instead of testcases
19:19:07 <roshi> thanks kushal :)
19:19:13 <kushal> dustymabe, yes
19:19:17 <dustymabe> usually when you change the topic doesn't it print some stuff out ?
19:19:19 <roshi> once I have the links, I'll put them in the wiki page
19:19:36 <roshi> it should show up in the minutes
19:19:37 <kushal> dustymabe, someone has to -t the channel or op the bot
19:19:39 <roshi> I think
19:19:52 <kushal> roshi, Okay.
19:20:15 <kushal> roshi, I will the meeting blog post in the morning Indian time, I will add the links to it.
19:20:23 <kushal> I missed the last week's blog post.
19:20:35 <kushal> Or may be I will do the post before I sleep.
19:20:54 <roshi> I think you should get some sleep - you have some insane hours going on there friend
19:21:04 <kushal> roshi, :D
19:21:18 <kushal> Moving to next ticket.
19:21:28 <kushal> #topic Article for Fedora Magazine on "state of cloud SIG/product" for beta release	(#75)
19:21:38 <kushal> jzb, said he will publish it soon.
19:22:24 <kushal> Any other update on this?
19:22:27 <kushal> roshi, ^^
19:23:28 <roshi> not that I know of
19:23:36 <roshi> jzb just has to push the button when he's ready
19:23:42 <roshi> it's written and ready to go iirc
19:24:27 <kushal> roshi, Okay.
19:24:44 <kushal> #info Fedora Magazine story will be pushed by jzb
19:25:05 <kushal> #topic publicize fedora-dockerfiles (#84)
19:25:13 <kushal> I am yet to do the blog post on it :(
19:25:43 <kushal> We will require a magazine post also.
19:26:10 <roshi> anyone slated to write that bit?
19:26:28 <roshi> mattdm could put it in the ftiftw post
19:26:42 * mattdm wakes up
19:26:45 <dustymabe> scollier: is pretty familiar :)
19:26:51 <mattdm> I mean, stumbles in from the other channel :)
19:26:57 * scollier reading
19:27:09 <roshi> don't worry matt, we all know how it goes :p
19:27:10 <kushal> mattdm, btw, can you please op the zodbot in this channel?
19:27:25 <roshi> well, we don't typically run meetings here
19:27:44 <roshi> I would prefer going forward if we collide with fesco that we go to f-m-2 or something
19:27:46 <kushal> roshi, Yes, in future we will move to #fedora-meeting-1
19:27:55 <kushal> roshi, yes.
19:27:58 <scollier> dustymabe, roshi, this article was just posted: http://fedoramagazine.org/fedora-dockerfiles-ready-to-go-recipes-for-easy-app-deployment/
19:28:05 <roshi> so no need to op zodbot now, imo
19:28:05 <scollier> there's another?
19:28:53 <dustymabe> scollier: that looks good to me
19:29:03 <kushal> scollier, ah, missed that.
19:29:03 <roshi> I think that was supposed to be for this ticket
19:29:05 <dustymabe> I RT it out there
19:29:11 <dustymabe> I'll
19:29:12 <roshi> so looks good to me
19:29:22 <scollier> roshi, yea, i'm not sure what happened there.
19:29:31 <roshi> but more blog posts and tweets and likes and favors and shindigs and shenanigans the better
19:29:53 <scollier> roshi, the one thing it leaves out is, the call for help
19:30:18 <roshi> ah
19:30:34 <kushal> scollier, may be the blog posts can push for that.
19:31:08 <scollier> sure, i put a few items in the ticket
19:31:18 <kushal> Any other points for this ticket?
19:31:34 <scollier> kushal, so are you going to write a blog post for it?
19:31:37 * roshi has nothing
19:31:43 <kushal> scollier, I will write one.
19:31:47 * roshi needs to blog more
19:31:53 <scollier> kushal, ok, happy to review and add feedback if you want
19:32:01 <kushal> scollier, Okay, thanks :)
19:32:17 <dustymabe> https://twitter.com/dustymabe/status/535153359603265536
19:32:19 <kushal> scollier, I will show you for review
19:32:20 <roshi> woah woah woah, helping each other?! What has this project come to?
19:32:24 <roshi> :p
19:32:43 <kushal> dustymabe, RT done.
19:33:12 <dustymabe> kushal: that was fast.. speed of light is amazing isn't it :)
19:33:40 <kushal> dustymabe, Talking about speed, sgallagh pointed me to https://what-if.xkcd.com/31/
19:33:59 <kushal> #topic Public Uploaded Images Criteria (#80)
19:34:38 <kushal> roshi, do you think you have enough +1(s) in that ticket?
19:35:17 <roshi> I have to get some feedback from the QA guys before I can add it to the criteria
19:35:24 <roshi> but looks like we all agree on it :)
19:35:32 <roshi> I don't foresee any issue
19:35:40 <kushal> roshi, Okay :)
19:35:47 <roshi> since we handle the uploads and QA just helps us verify they're there
19:36:28 <roshi> "us" being the cloud wg
19:36:29 <dustymabe> kushal: that xkcd is really interesting
19:36:47 <kushal> dustymabe, :)
19:37:40 <kushal> #topic participation in OpenShift Commons (83)
19:37:51 <kushal> mattdm, Any update on that ^^?
19:38:18 <mattdm> kushal: I haven't heard back from diane. Did you get a chance to talk to her more?
19:38:55 <kushal> mattdm, Nope.
19:39:20 <kushal> yeah, double checked it.
19:40:41 <kushal> We can move to Open Floor
19:40:50 <kushal> If no one objects :)
19:40:59 <roshi> fine by me
19:41:10 <kushal> #topic Open Floor
19:41:14 <dustymabe> I have one item
19:41:18 <kushal> I have a few things to ask.
19:41:21 <kushal> dustymabe, Go ahead.
19:41:36 <mattdm> kushal: can you ping her again if you get a chance?
19:41:42 <dustymabe> mine is small. still working with the DO guys (going into their office tomorrow actually)
19:41:43 <kushal> mattdm, I will.
19:42:00 <kushal> dustymabe, Nice, take some photos there :)
19:42:00 <roshi> good to hear
19:42:01 <dustymabe> for some reason (I'm not sure yet) they are converting our image to use GPT
19:42:12 * roshi wants some DO swag :)
19:42:31 <dustymabe> which makes cloud-init barf because it tries to use sgdisk to do growpart
19:42:38 <dustymabe> and sgdisk is not in the image
19:42:56 <kushal> That is bad :(
19:43:01 <roshi> I wonder why, though?
19:43:04 <roshi> has to be a reason
19:43:24 <dustymabe> roshi: yeah me 2.. I figure that is a good question to ask in person so I am waiting until tomorrow
19:43:32 <roshi> good call
19:44:28 <kushal> dustymabe, please update us after you get more details.
19:44:33 <dustymabe> just wondering.. should we consider adding it or would it be better to maintain that separately as part of the "get cloud image ready for DO" thing
19:44:53 <roshi> adding what to where?
19:45:03 <kushal> roshi, base image he means.
19:45:16 <roshi> oh, gpt to the base image?
19:45:23 <dustymabe> no.. sgdisk to the base image
19:45:33 <dustymabe> or rather.. gdisk (the rpm that provides it)
19:45:43 <roshi> maybe for F22? it's a bit late in the cycle for it to happen now
19:45:52 <dustymabe> roshi: ok got it
19:46:04 <roshi> unless we could show them how to spin an updates image and then spin their own version with that
19:46:12 * roshi thinks that how it works anyway
19:46:22 <kushal> roshi, +1 to that.
19:46:23 <roshi> like me spinning custom lives with packages I want
19:46:59 <dustymabe> yeah.. personally I'd like to not 'respin' the image
19:47:12 <dustymabe> so it is as close to what we actually release
19:47:15 <roshi> well, they have to do their own tweaks to it anyway
19:47:16 <dustymabe> as possible
19:47:25 <roshi> for F22 we might have the stuff they need in as a default
19:47:30 <dustymabe> roshi: true
19:47:41 <roshi> when I say 'respin' I just mean, add in that package :)
19:47:44 <dustymabe> ok. I'll come back with a larger list of items next week.
19:47:48 <kushal> roshi, :)
19:47:49 <roshi> sweet
19:47:55 <kushal> dustymabe, Nice.
19:49:33 <kushal> So I was looking at http://fedoraproject.org/wiki/Cloud/Governance , I think we should update this page.
19:49:54 <roshi> I thought all that got updated with the slate change and whatnot
19:50:17 <kushal> roshi, I also thought so, but it did not.
19:50:22 <roshi> so it seems
19:50:44 <roshi> who's our fesco liaison now?
19:51:37 <kushal> roshi, I guess it is still mattdm
19:52:12 <roshi> I thought he kinda slipped out so he could focus on FPL stuff
19:52:18 <jsmith> We should probably vote on someone new :-)
19:52:19 <roshi> from officially being on the wg, that is
19:52:24 <mattdm> roshi +1 to mattdm slipping out :)
19:52:31 <jsmith> +1 from me :-)
19:52:44 <kushal> +1 from me.
19:52:44 * jsmith understands just how busy mattdm is
19:52:47 <roshi> :) glad I understood it right :)
19:52:56 <kushal> I though that someone has to be part of FESCO
19:53:00 <kushal> * thought
19:53:02 <roshi> so yeah, probably need another person
19:53:05 <roshi> same here
19:53:14 <mattdm> kushal: originally that was part of the plan but it was quickly amended
19:53:24 <kushal> mattdm, Okay.
19:53:29 <roshi> but we can do it like QA does it, aiui - adam goes to fesco (or one of us does) when needed
19:53:40 <kushal> mattdm, roshi So, I can step up for it.
19:53:50 <jsmith> +1 to kushal being our representative to FESCo
19:53:53 <mattdm> so currently the liasion does not have to be part of fesco but should at the very least pay attention to the fesco agenda and show up at meetings when needed
19:53:59 <roshi> wfm
19:54:00 <mattdm> ideally attend all meetings
19:54:16 <roshi> that work for you kushal ?
19:54:30 <kushal> roshi, It works for me.
19:54:38 <roshi> +1 to that then :)
19:54:45 * dustymabe gives +1
19:55:13 <roshi> first action as liaison is to update the governance page :P
19:55:16 * roshi ducks
19:55:17 <kilted1> +1
19:55:22 <kilted1> lol
19:55:27 <kushal> haha
19:55:37 <kushal> roshi, I will do that tomorrow morning
19:55:48 <roshi> sounds good to me, thanks for taking care of it :)
19:55:49 <kushal> But where is that current member list?
19:55:55 <roshi> mailing list, I think
19:56:07 <kushal> roshi, Okay, I will search tomorrow
19:56:13 <roshi> kk
19:56:23 <roshi> if you can't find it easy, I probably have it somewhere
19:56:34 <kushal> Okay, if required i will ping you.
19:56:55 <kushal> I am doing more updates to my worknotes, things like http://worknotes.readthedocs.org/en/latest/cloudimages.html#how-to-run-kushal-s-personal-cloud-tests
19:57:59 <kushal> No more points from me.
19:58:11 <kushal> Anyone else want to discuss something?
19:58:25 <dustymabe> are we going to finish on time??
19:58:54 <roshi> I think so - I have nothing at this point
19:58:59 <roshi> gonna go get some lunch though
19:59:02 <roshi> ...
19:59:11 <roshi> thanks for running it kushal :)
19:59:24 <kushal> #endmeeting