17:03:04 <jwf> #startmeeting Fedora CommOps (2018-11-28)
17:03:04 <zodbot> Meeting started Wed Nov 28 17:03:04 2018 UTC.
17:03:04 <zodbot> This meeting is logged and archived in a public location.
17:03:04 <zodbot> The chair is jwf. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:03:04 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:03:04 <zodbot> The meeting name has been set to 'fedora_commops_(2018-11-28)'
17:03:06 <jwf> #meetingname commops
17:03:06 <zodbot> The meeting name has been set to 'commops'
17:03:08 <jwf> #nick commops
17:03:12 <jwf> #topic Agenda
17:03:18 <jwf> #link https://infinote.fedoraproject.org/cgit/infinote/tree/meeting-templates/fedora-commops-meeting-next
17:03:21 <jwf> #info (1) Roll call / Q&A
17:03:23 <jwf> #info (2) Announcements
17:03:24 <jonatoni> .hello2
17:03:26 <zodbot> jonatoni: jonatoni 'Jona Azizaj' <jonaazizaj@gmail.com>
17:03:27 * jonatoni is around
17:03:27 <jwf> #info (3) Action items from last meeting
17:03:29 <jwf> #info (4) Tickets
17:03:31 <jwf> #info (5) Open floor
17:03:33 <jwf> #topic Roll call / Q&A
17:03:35 <jwf> #info Name; Timezone; Sub-projects/Interest Areas
17:03:37 <jwf> #action commops New members, please introduce yourself on the CommOps Discourse [ https://discussion.fedoraproject.org/c/project/commops ]
17:03:40 <jwf> If this is your first time at a CommOps meeting, feel free to introduce yourself to everyone and say hello! If anyone has any questions before we get started with the rest of the agenda, now is also a good time to ask.
17:03:43 * jwf waves to jonatoni
17:03:45 <jwf> Good evening :-)
17:03:49 <jwf> #chair jonatoni
17:03:49 <zodbot> Current chairs: jonatoni jwf
17:04:06 * jonatoni waves to jwf :)
17:04:15 <jonatoni> Good evening :)
17:04:20 <VibroMax> Hi all
17:04:47 <jonatoni> hi VibroMax
17:05:29 * jwf waves to VibroMax
17:05:31 <jwf> Hello!
17:05:34 <VibroMax> Hi jonatoni:
17:05:42 <jwf> We'll wait a couple more minutes for anyone else, and then jump in.
17:05:57 * jwf is also digging for announcements
17:06:02 <VibroMax> Hi jwf
17:08:00 <bt0> #info Alberto Rodriguez S; UTC-6; CommOps, Marketing, Fedora Join, dotnet and more
17:08:18 <jwf> #info Justin W. Flory; UTC-5; CommOps, D&I Team, Fedora Badges
17:08:23 * jwf waves to bt0
17:08:27 <jwf> #chair VibroMax bt0
17:08:27 <zodbot> Current chairs: VibroMax bt0 jonatoni jwf
17:08:37 <jwf> Let's go ahead and get started :-)
17:08:46 * jonatoni waves to bt0
17:08:46 <jwf> #topic Announcements
17:08:54 <jwf> #info === "Report: GSoC Mentor Summit 2018" ===
17:08:54 <jwf> #link https://communityblog.fedoraproject.org/gsoc-mentor-summit-2018/
17:08:54 <jwf> #info A summary of what happened this year at the Google Summer of Code Mentor Summit, attended by Sumantro Mukherjee and Martin Bříza.
17:09:04 <jwf> #info === "Secret plans revealed: what CommOps hopes to accomplish in Fedora 30 release cycle" ===
17:09:04 <jwf> #link https://discussion.fedoraproject.org/t/secret-plans-revealed-what-commops-hopes-to-accomplish-in-fedora-30-release-cycle/716
17:09:04 <jwf> #info Summary of what we discussed last week / planning ahead for the future.
17:09:06 <jwf> <eof>
17:09:16 * jonatoni loves event reports :)
17:09:17 <jwf> It was a quiet week last week, I suspect because of the US holiday week
17:09:28 <jwf> jonatoni: I have this one queued up to read today :-)
17:09:36 <jwf> Anyone else have something to share?
17:10:26 <bt0> #info election nominations post on commblog: https://communityblog.fedoraproject.org/elections-nominations-now-open/
17:10:30 <bt0> #info election nominations post on commblog: https://communityblog.fedoraproject.org/elections-nominations-now-open/
17:11:27 <jwf> bt0++ good one to share :-)
17:11:37 <jwf> Announcements, going once…
17:11:48 <jwf> Going twice…
17:11:52 <jwf> And thrice.
17:11:58 <jwf> #topic Action items from last meeting
17:12:06 <jwf> #link https://meetbot.fedoraproject.org/fedora-commops/2018-10-31/commops.2018-10-31-16.03.html
17:12:06 <jwf> #info How This Works: We look at past #action items from the last meeting for quick follow-up. If a task is completed, we move on to the next one. If it isn't, we get an update and re-action if needed. If no status, we'll try to get a quick update and move forward.
17:12:11 <jwf> bt0 Complete a first draft of new CommOps docs page on suggested Pagure tags (due: post-FAW, revisit later)
17:12:23 <jwf> bt0: Do you want to set a date for this one now that FAW wrapped up?
17:12:50 <bt0> the next monday is fine for me
17:12:55 <jwf> Okay, perfect
17:13:21 <jwf> #action bt0 Complete a first draft of new CommOps docs page on suggested Pagure tags (due: Monday, Dec. 3rd)
17:13:29 <jwf> #info === [COMPLETE] "jwf Archive CommOps mailing list" ===
17:13:29 <jwf> #link https://pagure.io/fedora-commops/issue/178#comment-542414
17:13:29 <jwf> #info CommOps list now has an updated description, rejects new posts to the list, and requires moderation for new subscriptions.
17:13:37 <jwf> #info === [COMPLETE] "jwf Start a new Discourse thread to solicit feedback on F30 planning focus" ===
17:13:37 <jwf> #link https://discussion.fedoraproject.org/t/secret-plans-revealed-what-commops-hopes-to-accomplish-in-fedora-30-release-cycle/716
17:13:37 <jwf> #info Link also shared over to Mindshare mailing list.
17:13:43 <jwf> <eof>
17:14:00 <jwf> Nothing else is pending, so we can look at tickets next.
17:14:08 <jwf> #topic Tickets
17:14:08 <jwf> #link https://pagure.io/fedora-commops/issues?status=Open&priority=20
17:14:36 <jwf> I highlighted the three tickets we selected last week.
17:14:47 <jwf> #topic Ticket #186: "Run worldcloudbot on @fedoracommunity Twitter account"
17:14:47 <jwf> #link https://pagure.io/fedora-commops/issue/186
17:15:10 <jwf> #info Next steps: Need to find a willing volunteer to play with Python and fedmsg. Some coding background is helpful, but it should not be complex. If no volunteers in the meeting, let's find a way to make this task more visible in the Fedora community. Discourse? CommBlog? Reddit…? We can be creative.
17:15:45 <jwf> I figure to ask here first. Is anyone interested in working on this ticket?
17:17:17 <jwf> If not, I was wondering if we try to integrate this into GCI somehow or raise publicity for it across the community
17:17:34 <jonatoni> GCI is almost over now :/
17:17:43 <jonatoni> it is too late for it
17:17:54 <jwf> Oh, I forgot it's earlier in December
17:18:14 * bt0 is reading carefully
17:18:15 <jonatoni> yeah
17:18:38 <jwf> One way we could try to do this to write up a CommBlog article (like a "CommOps winter 2018 easyfix newsletter") and try sharing that more widely on social media or user communities
17:18:50 <jonatoni> +1
17:18:54 <bt0> +1
17:19:00 <VibroMax> +1
17:19:02 <jwf> #idea Write up a CommBlog article (like a "CommOps winter 2018 easyfix newsletter") and try sharing that more widely on social media or user communities
17:19:20 <jwf> Seems like an easy agreement :-)
17:20:03 <jwf> Does anyone want to take lead on a new CommBlog article to link and explain two or three CommOps "easyfix" tasks?
17:20:13 * jwf is also open to other ideas. Using Instagram or other social media…?
17:20:40 <bt0> action me for the monday too
17:20:59 <jwf> bt0: Super, I'll action you for the CommBlog article
17:21:10 <bt0> :)
17:21:32 <jwf> #action bt0 Write a CommBlog draft to link and explain two or three CommOps "easyfix" tasks for Winter 2018 (due: Monday, Dec. 3rd)
17:21:39 <jwf> .thank bt0
17:21:39 <zodbot> jwf thinks bt0 is awesome and is happy they are helping! (Please don't forget to bt0++ also)
17:21:57 <jwf> jonatoni: I wonder if we could use something like Instagram stories to highlight contribution opportunities like this.
17:22:07 <tg-fedcommops> <x3mboy> .hello x3m oy
17:22:10 <jonatoni> jwf: definitely yesss
17:22:14 * jwf waves to @x3mboy
17:22:17 <tg-fedcommops> <x3mboy> .hello x3mboy
17:22:23 <tg-fedcommops> <x3mboy> HI
17:22:24 <jwf> #chair x3mboy
17:22:24 <zodbot> Current chairs: VibroMax bt0 jonatoni jwf x3mboy
17:22:34 <tg-fedcommops> <x3mboy> It's lunch time
17:22:35 * jonatoni waves at x3mboy
17:22:40 <tg-fedcommops> <x3mboy> So, I'm partially here
17:22:52 * bt0 waves at @x3mboy
17:22:56 <jwf> jonatoni: Do you think you could help us do something creative on Instagram once the CommBlog article is published?
17:23:13 <jonatoni> jwf: yes, I would be very happy to do that :)
17:23:18 <jwf> Awesome :D
17:23:35 <jonatoni> I love the idea
17:23:41 <jwf> #idea Using Instagram stories to highlight contribution opportunities once CommBlog article publishes (cc: jonatoni)
17:24:13 <jwf> I was wondering how we could try to reach new audiences with some of these things too :-) Could be a fun experiment to see.
17:24:26 <jwf> Cool! So I think we have a plan for this ticket.
17:24:37 <jwf> Anyone want to mention anything else for #186 or the wordcloudbot?
17:24:57 <jwf> Going once…
17:25:07 <jwf> Going twice…
17:25:17 <jwf> And thrice.
17:25:24 <bt0> :)
17:25:43 <jwf> #topic Ticket #159: "Run a "Write the Docs" event targeting Fedora support groups"
17:25:43 <jwf> #link https://pagure.io/fedora-commops/issue/159
17:25:58 <jwf> #info Next steps: Identify barriers to contributing to docs as of today. Start generating a list of pain points. How can CommOps help smooth some of this points and make it easier for a first-time contributor to land their contribution without too much fuss? Start here as our base.
17:26:34 <jwf> I was thinking we could do some brainstorming around this. I was thinking of a way to make this one more interactive, and I had an idea:
17:27:17 <jwf> If different team members could run through different common tasks required to contribute to the docs, we could basically do a set of usability testing, see what we can get fixed in the project, or otherwise include in notes for contributing docs leading to the event.
17:27:36 <jwf> This way, we can hopefully run an event that leads to more successful contributions and less frustrated potential contributors
17:27:41 <jwf> Or that was my thinking, anyways
17:27:56 <jwf> Wonder what you all think?
17:29:46 <jwf> If it sounds like a good first step, we could come up with some test scenarios (make a pull request, run a development environment, etc.) and have different people do them, and report back in the ticket. What was easy, what was confusing, what could be improved? Like a couple of bullet points
17:30:19 <bt0> sounds great, also we need to point for some intro materials like: https://www.youtube.com/watch?v=LkH2ugg49Ag (docs classroom)
17:30:40 <bpabon> .hello blaise
17:30:41 <zodbot> bpabon: blaise 'Blaise R Pabon' <blaise@gmail.com>
17:30:54 <tg-fedcommops> Shyam (@Shyamjos) has joined the Telegram Group!
17:31:37 <jwf> #link https://www.youtube.com/watch?v=LkH2ugg49Ag
17:31:41 <jwf> asamalik++
17:31:41 <zodbot> jwf: Karma for asamalik changed to 8 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:32:51 <jwf> Uh-oh, Telegram bridge died…
17:33:12 <jwf> bt0: Definitely! Using resources like that as a base is helpful. Maybe another task could be finding links for helpful starter resources, like the video, the docs contribution guide, etc.
17:33:20 * jwf waves to bpabon
17:33:27 <jwf> bpabon: Hi, welcome back o/
17:33:35 <jwf> #chair bpabon
17:33:35 <zodbot> Current chairs: VibroMax bpabon bt0 jonatoni jwf x3mboy
17:35:44 <jwf> #idea Running simple user tests to note difficult points of contributing to docs, adding comments to Pagure ticket with notes
17:36:00 <jwf> #idea Collecting intro materials like videos and contribution guidelines
17:36:22 <jwf> I could take an action to draft up some test cases and create new tickets for them
17:36:39 <jwf> And then we can open them up too. They could fit into the easyfix newsletter even
17:36:43 <bt0> cool
17:37:29 <jwf> #action jwf Draft set of user testing scenarios for contributing to docs, create new tickets for each test scenario. Due: Friday, Nov. 30th.
17:38:39 <jwf> I think this is okay for now
17:38:50 <jwf> We can revisit next week. I think we're still very early on
17:38:52 <bpabon> #idea Sketch out constributor onboarding flows, similar to https://blog.sourcerer.io/designing-a-perfect-onboarding-flow-5285c4c3ca91
17:40:16 <jwf> bpabon++ This would be a super idea to do too. I bet this feedback would be super valuable to the Docs development team but also for our own planning on this ticket
17:40:16 <zodbot> jwf: Karma for blaise changed to 1 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:40:44 <jwf> This makes me think, I should probably reach out to the Design Team and get some feedback on the test scenarios, since this is more up their ally too.
17:41:02 <jwf> #action jwf Share test scenarios with Design Team to get additional feedback
17:41:06 <bpabon> #idea Provide instrumentation to collect feedback and user responses to pages. (eg. "what could improve this page) to increase 2way feedback.
17:41:23 <bt0> +1 sounds great
17:41:27 <jwf> That could be done with filing a new Pagure issue too
17:41:34 <jwf> Just to make that link visible and present
17:42:00 <jwf> #info ^ file new Pagure issue on pagure.io/docs-fp-o
17:42:35 <jwf> Super
17:42:39 <bpabon> In the fedora apps collection is there a diagram rederer we can use to create diagrams from text? (eg Graphviz or diagrams.js ?)
17:43:31 <jwf> bpabon: I'm not sure what was used for that. I know there have been complaints about it being difficult to use though. It might be a good idea to consider another tool to visualize. I don't *think* that was something done in-house (versus a framework) but I'm not sure
17:43:59 <jwf> But our use case could be different
17:44:53 <jwf> [Also, since I don't think @dhanesh95 is here, I think we can skip ticket #108? It will be hard to discuss without him.]
17:46:20 <bpabon> Oh, sorry I didn't mean the tool used to create the Landing page https://apps.fedoraproject.org/ I meant something like https://www.websequencediagrams.com/
17:46:39 <jwf> Ooh, okay
17:47:02 <jwf> #link https://www.websequencediagrams.com/
17:47:35 <bpabon> That uses the ancient Graphviz library, so we could include Graphviz plugins for Antora and Pagure, etc.
17:47:42 <jwf> bpabon: I understand what you are asking now. I'm not sure if there is a tool for that. I think the one even mattdm uses these days is a web app
17:48:14 <jwf> Oh, hmm.
17:48:32 <jwf> bpabon: What is the use case for Graphviz plugins in Antora / Pagure?
17:49:02 <bpabon> https://www.sphinx-doc.org/en/master/usage/extensions/graphviz.html
17:49:18 * jwf clicks
17:50:10 <jwf> Oh, neat, I understand now.
17:50:20 <bpabon> Authors can compose elaborate workflows in text, publish them as diagrams, and updat the text without having to rearrange icons.
17:51:07 <jwf> There's two ways to move forward with this:
17:51:17 * bt0 is amazed with the idea
17:51:33 <jwf> 1. A new Pagure RFE ticket on pagure.io/pagure to request Graphviz rendering support in the web browser
17:52:05 <jwf> 2. Probably asking in #fedora-docs / #freenode_#fedora-docs:matrix.org about where the best place to ask for Graphviz support in our docs is.
17:52:25 <bpabon> OK, I can provide lots of cadidate tools.
17:52:39 <jwf> It would be cool to use a tool like this and actually make them visible in our docs too
17:53:16 <jwf> bpabon: Would you want to investigate this one further and then open new Pagure / docs-fp-o tickets for better ways to visualize diagrams from text?
17:54:12 <jwf> We can help point you to all the right places to go :-)
17:54:36 <bpabon> Yes, jwf I will add the ticket number here also.
17:55:21 <jwf> bpabon: Great! Can I give you this action item to do by our next meeting on Dec. 5th?
17:55:37 <bpabon> Yes, please.
17:57:27 <jwf> #action bpabon Investigate ways to visualize diagrams from text further and then open new Pagure / docs-fp-o tickets for rendering support
17:57:45 <jwf> #link https://pagure.io/pagure/new_issue
17:57:54 <jwf> #link https://pagure.io/fedora-docs/docs-fp-o/new_issue
17:57:59 <jwf> .thank bpabon
17:57:59 <zodbot> jwf thinks bpabon is awesome and is happy they are helping! (Please don't forget to bpabon++ also)
17:58:13 <jwf> Great! And we're almost at time, so we can switch to open floor
17:58:16 <jwf> #topic Open floor
17:58:24 <jwf> I had one thing I wanted to bring up
17:58:38 <jwf> I think the meeting time conflict with Mindshare is difficult for this team
17:58:52 * bt0 knows :(
17:58:57 <jwf> I wanted to suggest if we find a new meeting day/time or if bt0 wants to suggest a new meeting time for Mindshare
17:59:02 * jwf isn't sure what is easier
17:59:28 <bt0> me neither :S
17:59:57 <jwf> I'll open a new thread on Discourse about it.
18:00:00 <bt0> cool
18:00:18 <jwf> #action jwf Start new Discourse thread about the Dilemma of the Conflicting Meetings
18:00:19 <jwf> :P
18:00:32 <jwf> Anyone want to share anything else?
18:01:51 <jwf> Going once…
18:02:01 <jwf> Twice…
18:02:08 <jwf> And thrice.
18:02:18 <jwf> Thanks everyone for coming out today and for the good ideas \o/
18:02:23 <jwf> Enjoy the rest of your week.
18:02:25 <jwf> #endmeeting