19:26:30 <randomuser> #startmeeting Fedora Docs Office Hours
19:26:30 <zodbot> Meeting started Thu Nov 27 19:26:30 2014 UTC.  The chair is randomuser. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:26:30 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:26:41 <randomuser> and we'll do the office hours thing to log it, why not
19:26:48 <randomuser> #chair pbokoc
19:26:48 <zodbot> Current chairs: pbokoc randomuser
19:27:00 <pbokoc> oh hello
19:27:14 <pbokoc> randomuser, did you see the earlier conversation? jreznik needed to package relnotes
19:27:22 <randomuser> #info the Fedora Release Notes RPM is build directly from the fedorahosted git repo
19:27:35 * jreznik is here
19:27:42 <randomuser> pbokoc, yeah, I'm going to do that right now, with narration!
19:27:42 <jreznik> randomuser: is there any documentation?
19:27:52 <pbokoc> cool
19:27:59 <randomuser> jreznik, documentation, or meta-documentation?
19:28:04 <randomuser> the latter, not so much
19:28:10 <pbokoc> randomuser, how was the turkey? :)
19:28:20 <randomuser> #action randomuser to add RNs building to documentation guide
19:28:21 <jreznik> randomuser: documentation of documentation :)
19:28:44 <jreznik> as then our guys can help when needed :)
19:28:50 <randomuser> pbokoc, no turkey yet - I just finished cooking some brussel sprout bacon concoction, we'll begin feasting soon
19:29:10 <randomuser> #info First step is to ensure the RNs build, `publican build `
19:29:39 <randomuser> #info next get package sources, `fedpkg clone fedora-release-notes`
19:30:07 <randomuser> #info `fedpkg switchbranch f21` or similar to get release branch
19:31:21 <randomuser> #info Edit spec file so that %version is higher.  %release is for package revisions, bump for spec file changes only
19:32:37 * randomuser adds a mildly smartass changelog entry
19:32:42 <pbokoc> brussel sprout bacon concoction? I don't know what to think about that
19:33:02 <pbokoc> on the plus side, bacon, on the downside, brussels sprouts
19:33:19 <randomuser> #info move back to doc sources repo, and add a tag that matches the %version in the spec
19:35:08 <randomuser> #info `git tag -s '21.08' -m 'Many revisions to F21 RNs'`
19:35:19 <randomuser> hrm
19:36:05 <randomuser> #info `git push --tags`
19:36:58 <randomuser> #link https://git.fedorahosted.org/cgit/docs/release-notes.git/tag/?id=21.08
19:38:51 <randomuser> #info move back to package repo, test sources with `spectool -g fedora-release-notes.spec` then build with `fedpkg mockbuild`
19:40:07 * randomuser waits for his mock build
19:40:30 <randomuser> pbokoc, the brussel sprouts are roasted with the bacon drippings, too
19:40:59 <pbokoc> well, that sounds like it could help, but it's still green
19:41:17 <randomuser> it's a medium for delivering more of the bacon
19:41:17 * pbokoc refuses to put anything green in his mouth unless it's beer
19:41:28 <pbokoc> I'm basically a five year old, as far as taste is concerned
19:42:00 <jreznik> pbokoc: green beer? I don't think it's something that special :)
19:42:09 <randomuser> yeah, all the five year olds I know drink green beer
19:42:18 <jreznik> :)
19:42:19 <pbokoc> jreznik, yeah, but the point is that it's still beer :))
19:42:45 <jreznik> pbokoc: I like that Easter one - red and green, cut in the half :)
19:43:24 <randomuser> I dunno about this
19:43:33 <jreznik> http://www.pivnidenik.cz/data/s/T/T/phpsTTvYt.jpg
19:43:36 <randomuser> beer should not be tainted for amusement
19:43:37 <pbokoc> jreznik, wait, red? I don't remember that
19:43:46 <pbokoc> hahahaha what the hell
19:44:00 <pbokoc> randomuser, that's not even the worst thing
19:44:03 <pbokoc> this is: http://www.heinekenceskarepublika.cz/media/spravy/Modra_Kometa.jpg
19:44:43 <pbokoc> same thing sans Photoshop: http://img.ct24.cz/cache/616x411/article/35/3445/344426.jpg?1333378205
19:44:51 <randomuser> blue hockey beer?
19:44:54 <jreznik> randomuser, pbokoc: btw. comment https://bugzilla.redhat.com/show_bug.cgi?id=1168568 pls
19:45:06 <randomuser> ack
19:45:16 <jreznik> but maybe for f21 it would be easier just +1 it and build final release notes today
19:45:49 <pbokoc> randomuser, yeah, it was made to support Brno's hockey club or whatever, I'm not sure what the occasion was
19:47:46 * randomuser was up until 4AM drinking with the local brewer
19:48:22 <randomuser> he was one of those people that makes it impossible to extricate yourself from conversation
19:48:47 <randomuser> okay, I have a successful mock build
19:49:10 <randomuser> #info after good mock build, commit to pkg repo and `fedpkg build`
19:50:51 <randomuser> jreznik, while I'm building this, would you mind looking it over - at least the 'products' section? I know it needs more intro, fresh eyes help
19:51:10 <randomuser> http://pkgs.fedoraproject.org/cgit/fedora-release-notes.git/commit/?h=f21&id=16e53e96d1c6ac2afcc913853e74b800b429f09d
19:51:18 <randomuser> #link http://pkgs.fedoraproject.org/cgit/fedora-release-notes.git/commit/?h=f21&id=16e53e96d1c6ac2afcc913853e74b800b429f09d
19:53:40 <randomuser> #info next `fedpkg build`
19:54:12 <randomuser> #info any translations you have committed at the tag will also be included in the RPM
19:55:03 * jreznik is looking
19:55:11 <jreznik> and thans for step by step guide :)
19:55:38 <randomuser> jreznik, https://fedorapeople.org/groups/docs/release-notes/ is current
19:56:19 <randomuser> #undo
19:56:19 <zodbot> Removing item from minutes: INFO by randomuser at 19:54:12 : any translations you have committed at the tag will also be included in the RPM
19:56:22 <randomuser> #undo
19:56:22 <zodbot> Removing item from minutes: INFO by randomuser at 19:53:40 : next `fedpkg build`
19:56:41 <randomuser> #info next `fedpkg build;xcowsay "Moooo!! your build is done."`
19:56:52 <randomuser> #info any translations you have committed at the tag will also be included in the RPM
19:57:13 <randomuser> because it takes a while and you're probably going to go do something else
19:57:44 <randomuser> oops,
19:57:56 <randomuser> #info also upload sources.... `fedpkg new-sources`
19:58:05 <randomuser> #undo
19:58:05 <zodbot> Removing item from minutes: INFO by randomuser at 19:57:56 : also upload sources.... `fedpkg new-sources`
19:58:10 <randomuser> #info also upload sources.... `fedpkg new-sources $file`
20:00:18 <randomuser> I've done something bbad to git
20:01:55 <randomuser> the staged changes don't get into the commit?!?!
20:02:04 <randomuser> http://pkgs.fedoraproject.org/cgit/fedora-release-notes.git/commit/?h=f21
20:06:14 <randomuser> #info after good build, `fedpkg update`. Associate any bugs, and add *another* changelog entry.
20:06:40 * randomuser is going to family event now, will pick up after a bit
20:07:10 <jreznik> randomuser: thanks and enjoy family event!
20:40:10 * randomuser completes update
20:40:31 * randomuser goes back to eating too much
23:43:45 <zoglesby> randomuser: did you finish?
23:44:10 <randomuser> zoglesby, well, I built an RPM
23:44:37 <randomuser> zoglesby, I still think it needs polish, but update often, right?
23:45:52 <zoglesby> randomuser: indeed, that is what the zero day is for
02:09:25 <randomuser> #endmeeting