14:04:16 <bexelbie> #startmeeting Fedora Docs
14:04:16 <zodbot> Meeting started Mon Sep 18 14:04:16 2017 UTC.  The chair is bexelbie. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:04:16 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:04:16 <zodbot> The meeting name has been set to 'fedora_docs'
14:04:24 <bexelbie> #topic roll call
14:04:25 <bexelbie> .hello bex
14:04:26 <zodbot> bexelbie: bex 'Brian (bex) Exelbierd' <bex@pobox.com>
14:04:32 <randomuser> morning
14:04:37 <randomuser> thanks for driving, bexelbie
14:05:38 <bexelbie> #topic Open Floor
14:05:42 <bexelbie> Anyone have topics for today
14:05:44 * bexelbie has one
14:06:03 <bexelbie> I am going to be traveling starting the middle of next week and will have limited access for about 2 weeks
14:06:08 <randomuser> i saw some mail from pajure and was hoping to catch up on it
14:06:11 <bexelbie> I want to make sure someone else can publish
14:06:36 <bexelbie> randomuser, there is a patch on the F25 docs that you have to make the republish call on
14:06:49 * bexelbie has a small randomuser pile we can discuss :P
14:07:01 <randomuser> what doc?
14:07:06 <bexelbie> install-guide, iirc
14:07:09 * cybtachyon has a topic
14:07:21 <bexelbie> cybtachyon, say it, then we'll order them and work them
14:07:30 <bexelbie> please throw out topics so I can build an agenda
14:07:33 <cybtachyon> My application to the docs team
14:07:49 <bexelbie> ok
14:07:55 <bexelbie> any other topics for today?
14:08:05 <randomuser> release notes
14:08:20 <bexelbie> I see 4 topics - I'll order them now
14:08:22 <bexelbie> any others?
14:08:25 <bexelbie> going once
14:08:34 <bexelbie> going twice
14:08:41 <bexelbie> .. oo open PRs :)
14:08:44 <bexelbie> going three times
14:08:46 <bexelbie> ok, ordering
14:08:52 <bexelbie> #info agenda
14:08:59 <bexelbie> #info 1. cybtachyon joining hte docs team
14:09:04 <bexelbie> #info 2. Release notes - randomuser
14:09:09 <bexelbie> #info 3. Publishing - bexelbie
14:09:27 <bexelbie> #info 4. F25 PR to install-guide
14:09:33 <bexelbie> #info 5. other open PRs
14:09:42 <bexelbie> #topic cybtachyon joining the docs team
14:09:51 <bexelbie> Hi cybtachyon you're up - what would you like to do
14:09:53 <cybtachyon> RE: "Self-Introduction: Derek "tachyon" Reese" Sep 11, 2017, 9:55 PM PST
14:10:09 <cybtachyon> TLDR My team has started an internal initiative to get some momentum for a Web Development Fedora Project Labs Spin.
14:10:43 <bexelbie> cool
14:10:51 <randomuser> this is exciting, cybtachyon !
14:10:54 <bexelbie> what kind of documentation are you looking to contribute?
14:11:10 <cybtachyon> We have the internal developers and support to get there with the community's help, with the first step being to get a Wiki page documenting all of our steps, fixes, workarounds etc.
14:11:51 <bexelbie> are these steps to build the lab? tips for developers? docs like an install guide?
14:11:53 <randomuser> what kind of workflow are we talking about documenting?
14:12:29 <cybtachyon> Yes and yes - everything involved to get a web dev workflow 100% using OSS on Fedora 25/26
14:12:55 * randomuser nods
14:13:03 <cybtachyon> once we have that all up, the next step is to make it a spin that can be submitted for approval
14:13:41 <cybtachyon> Right now we just have a bunch of internal docs, a little useless for the OSS community since it's in a private Jive instance 😂
14:13:47 <randomuser> as a non-web-developer my answer would be something like "vim and tmux" - I'm curious how you would tersely define this
14:14:09 * bexelbie wonders if the dev workflow stuff wouldn't be best suited for https://developer.fedoraproject.org/
14:14:34 <bexelbie> an install/user guide for spin on docs.fp.o
14:14:35 <bexelbie> and the build steps in the wiki until the lab is regularly built
14:14:43 <cybtachyon> Sure, we're talking specifically common modern workflows
14:14:44 <randomuser> bexelbie, I think that developer.fedoraproject.org is effectively abandoned and well suited for deprecation
14:14:53 <bexelbie> randomuser, they just published updated
14:14:56 <bexelbie> err updates
14:15:36 <cybtachyon> I don't see an issue with that at all, especially since it would be easy to have a link from the build steps wiki entry to the relevant developer docs
14:16:33 <cybtachyon> We have two goals:
14:16:33 <cybtachyon> 1. Make sure the community can benefit from all our hard work getting modern web dev workflows working on Fedora
14:16:34 <cybtachyon> 2. Make sure the community can actually find that work 😆
14:17:14 <randomuser> I'm sure we can find a home for your content :)
14:17:19 <bexelbie> with regard to #2, I think the wiki is a bad choice for docs you want non-spin developers to read
14:17:36 <bexelbie> we need to get them onto either docs.fp.o or developer.fp.o imho
14:17:55 <cybtachyon> Sounds good to me, which do you recommend?
14:18:11 <randomuser> ultimately we don't want to have user-facing content only on the wiki; it's a good whiteboard space as you're tooling up, but that makes it full of whiteboards and hard to get proofed content from
14:18:58 <randomuser> I would lean towards a new asciibinder repo for docs.fp.o, but am a bit biased
14:19:13 <bexelbie> my personal thought is to put the developer focused workflow, etc. on developer.fp.o (contributions here https://github.com/developer-portal )
14:19:22 <cybtachyon> https://developer.fedoraproject.org/start/sw/web-app/about.html is a top google search result for web dev on fedora
14:19:25 <cybtachyon> but alas it is empty
14:19:27 <bexelbie> the install and usage docs on docs.fp with a new asciibinder as randomuser said
14:19:53 * bexelbie has a secret plan to get developers.fp.o moved over to pagure and published via the new tooling
14:20:01 <bexelbie> I had a conversatoin with those folks months ago about it
14:20:39 <randomuser> I honestly didn't realize that they had done anything with that since initial publishing
14:20:58 <bexelbie> it isn't a hot bed of activity - but I think it gets occasional contributions
14:21:10 <bexelbie> i've opened a PR to put it on the main docs.fp.o page to try and get it more visibility
14:21:31 * randomuser nods
14:21:40 <bexelbie> cybtachyon, anything you write for developers.fp.o should be able to be moved if it turns out that site is less than useful
14:22:13 <bexelbie> cybtachyon, what would help you move forward with the contributions?
14:22:15 <cybtachyon> Cool, so target that for now, and once the initial drafts are up, bring it up at the following docs meeting?
14:22:34 <randomuser> yeah, my concern is about a docs site that isn't maintained by or kept track of by the docs team - if we have a plan to do something different going forward it's less painful
14:23:13 <randomuser> cybtachyon, we'll gladly go over your content and discuss your efforts but noone here can accept your PRs for that repo
14:23:18 <cybtachyon> makes sense to me - although I don't think we're talking about anyone else besides me contributing at the moment
14:23:24 <bexelbie> they actually have a separate mailing list ...
14:23:26 <randomuser> #link https://github.com/developer-portal/content
14:23:34 <cybtachyon> Yeah I have a fork
14:23:35 <bexelbie> and I can physically kick a few of them if needed
14:23:46 <cybtachyon> lol perfect
14:23:46 * bexelbie works next to several of those folks
14:24:24 <bexelbie> your contribution may also allow me to implement my nefarious plan to port the whole site over to the new tooling and give it to randomuser :P
14:24:51 <jsmith> bexelbie: You forgot the evil "mua ha ha ha" laugh :-)
14:25:09 <bexelbie> jsmith, I love how my keyboard makes the noise like that when I type muahahahahahahaha
14:25:24 <Amita> we read that status
14:25:26 <jsmith> Much better :-)
14:25:48 <bexelbie> cybtachyon, does that set you up with a path forward?
14:25:56 <cybtachyon> Yes it does, thanks very much!
14:26:16 <bexelbie> do you also have more docs/guide like content that should be started in the docs.fp.o tooling?  We can get you a repo
14:26:43 <randomuser> might be easier to split content up, if needed, after drafting
14:27:02 <bexelbie> ok
14:27:08 <bexelbie> so we ready to move on to #2?
14:27:11 <bexelbie> #chair randomuser
14:27:11 <zodbot> Current chairs: bexelbie randomuser
14:27:44 * rkratky lurking and liking what he sees
14:27:53 <bexelbie> silence being assent :)
14:28:00 <bexelbie> #topic Release Notes - randomuser
14:28:02 <bexelbie> randomuser, go
14:28:11 <randomuser> #link https://fedorapeople.org/groups/schedule/f-27/f-27-docs-tasks.html
14:28:21 <randomuser> We have some prep work to do for the next release:
14:28:33 <randomuser> #action randomuser to solicit for release notes
14:28:49 <jibec> .hello jibecfed
14:28:50 <zodbot> jibec: jibecfed 'Jean-Baptiste Holcroft' <jean-baptiste@holcroft.fr>
14:28:56 <bexelbie> For F26 I tagged the change owners in the issues that pbokoc created ... should we do that again?
14:28:59 <randomuser> #info guides should be branched and checked for needed updates
14:29:03 * bexelbie is wondering if that worked well
14:29:32 <pbokoc> yeah, I think making issues against the repo in pagure works pretty well
14:29:33 <randomuser> yeah, i was even thinking about changing the Change template to link to those issues
14:29:53 <randomuser> or the content in the template, rather
14:29:58 <bexelbie> randomuser, funny you would say that - I was going to talk to jkurik about basically that same idea before I proposed it publicly
14:30:23 * bexelbie thinks we should get the change owners to create the issue :)
14:30:44 <randomuser> bexelbie, yeah, let's see if we can make it easy for folks to get a pagure issue for free
14:30:57 <randomuser> and perhaps get closer to staging that content directly in the repo
14:31:11 <bexelbie> +1 for direct staging via topic branches/issues
14:32:10 <bexelbie> do we want to go ahead and branch the docs that are being published? /me can do that and document the process
14:32:27 <randomuser> sure, that would be helpful, bexelbie
14:32:32 <randomuser> #action bex to branch some guides
14:32:48 <bexelbie> who is going to create the issues for this release's changes?
14:33:11 <bexelbie> #action bexelbie and randomuser to talk to jkurik about potentially modifying the change process to better reflect the Release Notes workflow
14:33:15 <randomuser> #action randomuser to create issues against relnotes repo for Changes
14:33:45 <bexelbie> any other RN/Release issues?
14:34:10 <randomuser> with that said, I'd like us to consider retooling https://fedoraproject.org/wiki/Category:Documentation_beats to be more of a "things we should check" reference than an assignment board
14:34:33 <randomuser> although, perhaps that would be a better list discussion
14:34:42 <pbokoc> it would be pretty nice if we had a script that scraped the changes page on the wiki and opened an issue for each one
14:34:48 * bexelbie thinks it would be cool to move those kinds of things out of the wiki and to our new platform :P
14:34:49 <pbokoc> doing it by hand is really annoying
14:34:50 * bexelbie ducks
14:34:59 <randomuser> pbokoc, that may well be possible, i'll try
14:35:25 <pbokoc> yeah, it's probably not even that hard, but I couldn't program my way out of a wet paper bag
14:35:56 <bexelbie> :( it looks like `pag` doesn't have an issue function - but you might be able to just create new entries in the issue repo for the right repository
14:36:51 <randomuser> https://pagure.io/api/0/#issues
14:37:33 <bexelbie> nice!
14:38:16 <bexelbie> #action randomuser to start a discussion about retooling fp.o/wiki/Category:Documentation_beats on the list
14:38:30 <randomuser> yes, ty, that'll do
14:38:41 <bexelbie> ok, then moving on?
14:38:47 <randomuser> good here
14:38:50 <bexelbie> #topic Publishing - bexelbie
14:39:04 <bexelbie> I am going to be traveling with limited internet for about 2 weeks starting middle of next week
14:39:10 <bexelbie> I'd like confirmation someone else can publish
14:39:15 <bexelbie> I've updated the README at https://pagure.io/fedora-docs/docs-fp-o
14:39:24 <bexelbie> can someone volunteer to test this?
14:39:36 <randomuser> i will confirm my capabilities but others should too
14:39:51 <bexelbie> #action randomuser to test hte new publishing directions at https://pagure.io/fedora-docs/docs-fp-o
14:39:53 <bexelbie> anyone else?
14:40:01 <bexelbie> I can hand out #actions all day :)
14:40:21 <bexelbie> #action Oprah to give everyone a #action
14:40:36 <randomuser> oh, that does remind me, I'll be unavailable for the beginning of next week, will probably not make the meeting
14:40:37 <bexelbie> #undo
14:40:37 <zodbot> Removing item from minutes: ACTION by bexelbie at 14:40:21 : Oprah to give everyone a #action
14:40:39 <randomuser> #undo
14:40:39 <zodbot> Removing item from minutes: ACTION by bexelbie at 14:39:51 : randomuser to test hte new publishing directions at https://pagure.io/fedora-docs/docs-fp-o
14:40:45 <randomuser> heh
14:40:49 <bexelbie> #action randomuser to test hte new publishing directions at https://pagure.io/fedora-docs/docs-fp-o
14:40:57 <bexelbie> and stay put!
14:40:58 <bexelbie> :P
14:41:12 <bexelbie> I'll be here at the beginning of the week, I am gone starting on Wednesday, iirc
14:41:44 <bexelbie> I'll have limited internet through October 15 and will be traveling with limited access, but hopefully full internet until about October 26
14:42:06 <bexelbie> next topic?
14:42:30 <bexelbie> #topic F25 PRs and the old guides bexelbie  / randomuser
14:42:40 <randomuser> #info bexelbie will be mostly afk 15 Oct - 26 Oct
14:42:56 <randomuser> yeah, I don't know why we keep creating new repos
14:43:00 <bexelbie> randomuser, can you take a look at republishing the stuff on docs-old.fp.o to not include f26 and to include the "see the new hotness" suggested by others
14:43:11 <bexelbie> creating new repos around?
14:43:31 <randomuser> it just makes work for us, I have to keep moving issues and such
14:44:06 <randomuser> sorry, this was not what you were intending to discuss
14:44:15 <bexelbie> no, but I'll tack that on the end
14:44:17 <bexelbie> ok?
14:44:18 <randomuser> where's this hotness?
14:44:22 <bexelbie> docs.fp.o
14:44:40 <bexelbie> also, can you decide whether to merge https://pagure.io/install-guide/pull-request/10 and republish the F25 install guide?
14:44:46 * bexelbie cannot figure out how to reopen that PR :(
14:44:47 <randomuser> and what suggestions do we have regarding the hotness?
14:45:36 <bexelbie> Someone suggested we put a notice at the top of hte pages from docbook on docs-old that says - these are really old and you should consider just going to docs.fp.o
14:46:26 <randomuser> mm.. can look into it, sure
14:46:37 <randomuser> there's not really a "top of the pages" feature to that site
14:46:40 <pbokoc> yeah, preferably a huge red banner that covers the entire screen and plays an airhorn sound
14:46:42 <bexelbie> I think there are issues opened on this in docs-fp-o ... I'll have to look
14:47:14 <pbokoc> it would hopefully prevent the issues we had in the past with people coming to ancient docs from google and not noticing the /18/ or whatever in the URL
14:47:30 <randomuser> we should do a robots.txt for that
14:47:33 <bexelbie> there isn't
14:47:39 <bexelbie> an issue I mean
14:47:44 <bexelbie> and yes, +1 to robots.txt
14:48:32 <randomuser> which *could* be a separate action item!
14:48:34 <randomuser> any takers?
14:49:12 <bexelbie> Why don't we do this ... can you (hah!) open an issue and let's tag it easy fix - then describe what we want
14:49:17 <bexelbie> and we can get it listed on the easy-fix page
14:49:47 <bexelbie> ?
14:49:53 <randomuser> #action randomuser to prep robots.txt issue
14:50:40 <bexelbie> #action bexelbie or randomuser to make sure our repos can post to the easyfix page
14:50:59 <bexelbie> next ?
14:51:12 <bexelbie> #topic Open PRs
14:51:28 <bexelbie> there are several open PRs to various books and to docs-fp-o - it'd be nice to have some people chime in
14:51:36 <bexelbie> I am not sure any of them need to be dealt with in the meting
14:51:38 <bexelbie> meeting
14:52:02 <bexelbie> anyone have a burning desire? otherwise I'd like to move the last few minutes to a repos conversation based on randomuser's comment
14:52:24 <randomuser> #info check for and participate in PRs
14:52:43 <bexelbie> #topic should we relocate our old/unused repos and should we create new repos
14:52:51 <bexelbie> I think that sums up your questions randomuser ?
14:52:55 <bexelbie> and adds one of mine :)
14:53:40 <bexelbie> I am all for retaining the existing repos if we port over an old guide ... except for two things
14:53:52 <bexelbie> 1. Some of our repos are stupidly big and take a stupidly large amount of time to clone
14:54:03 <bexelbie> 2. We want to lift and shift some content away from guides
14:54:19 <randomuser> yeah, i get the logistical benefits
14:54:21 <bexelbie> I would like to see us put the docs repos all in one name space though ...
14:54:31 <bexelbie> moving the issues is apparently very easy, if you know the trick
14:54:40 <bexelbie> issues are stored in a ... a separate repo
14:54:48 <randomuser> if I'm browsing pagure for sysadmin guide repos, though, it doesn't help *me* that *you* know that one of the two available repos is smaller
14:54:50 <bexelbie> you can literally clone it and push it over to the new repo's ticket repo
14:55:02 <randomuser> oh, that's cool
14:55:21 <bexelbie> I would like to move the old sysadmin-guide repo to something like pagure.io/fedora-docs-deprecated
14:55:27 <bexelbie> and fix its README
14:55:40 <bexelbie> kjandova built a list that looks fairly complete of repos on pagure that look like docs
14:55:41 <randomuser> yeah, that would work
14:55:51 <bexelbie> we just need to decide we want to do this
14:56:05 <bexelbie> I suspect she'd be willing to help with the heavy lifting if we ask her
14:57:03 <bexelbie> Should I send hte list to the mailing list?
14:57:16 <randomuser> i'm not sure what heavy lifting needs to be done, am just pointing out that figuring out what needs to be done is more complicated this way
14:57:38 <jibec> I would love to have a clean overview of docs repositories ;) this probably is outdated https://fedoraproject.org/wiki/Docs_Project_guides_table
14:58:16 <bexelbie> pagure.io/fedora-docs/ is clean
14:58:20 <randomuser> it definitely is!
14:58:49 <jibec> :D
14:58:50 <randomuser> #action someone to replace https://fedoraproject.org/wiki/Docs_Project_guides_table content with pagure.io/fedora-docs content
14:59:14 <bexelbie> why don't we just delete that wiki page and send people to pagure.io/fedora-docs?
14:59:44 <randomuser> the table is embedded in a lot of places so the content would be best maintained at least with a link
14:59:58 <jibec> we also have this I think: https://fedoraproject.org/wiki/L10N_Translation_State_of_Guides_on_Zanata
15:00:58 * bexelbie hates the wiki so I am biased
15:01:01 <bexelbie> I still vote delete :P
15:01:02 <randomuser> is it important for you that we maintain that, jibec ?
15:01:13 <jibec> I can do it
15:01:22 <randomuser> I abhor having "just do this one more thing" tasks pile onto workflows
15:01:37 <jibec> but we should not delete it, only archive as as with a link to new pagure repo
15:02:15 <bexelbie> ok
15:02:19 <jibec> haha, and this : https://fedoraproject.org/wiki/Docs_Project_old_guides
15:03:07 <bexelbie> #jibec to do magical wiki things to get pagure.io/fedora-docs to be the canonical list of docs repos
15:03:08 <bexelbie> ??
15:03:32 <bexelbie> #action jibec to do magical wiki things to get pagure.io/fedora-docs to be the canonical list of docs repos
15:03:34 <jibec> yep, it's only a few pages to edit
15:03:37 <bexelbie> now it's official :)
15:04:03 <randomuser> jibec++
15:04:10 <zodbot> randomuser: Karma for jibecfed changed to 1 (for the f26 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:04:22 <bexelbie> Anyone else have anything else?
15:04:58 <jibec> !
15:05:18 <bexelbie> go for it
15:05:28 <bexelbie> as long as it isn't translations :P j/k
15:05:39 <jibec> I'm waiting for a few explaination about how to run the internationalization website from https://pagure.io/fedora-docs/docs-fp-o
15:06:04 <jibec> from this, I can write a blog post and submit it to you for review and then publishing
15:06:14 <bexelbie> I put all that code into https://pagure.io/fork/bex/fedora-docs/docs-fp-o/branch/multi-language-support
15:06:28 <bexelbie> however it still doesn't handle the _topic_map.yml
15:06:46 <jibec> ok, this is working for git newbies? ;)
15:06:48 <bexelbie> If I can possibly get to it between now and Tuesday, I'll write you a guide
15:07:34 <bexelbie> as a stop gap, I am wondering if we should push legit copies of the books we are publishing to Zanata so that g11n can get started
15:08:02 <randomuser> i18n?
15:08:10 <bexelbie> that way we are least getting content ready to go
15:08:10 <jibec> l10n :D
15:08:13 <bexelbie> t10n
15:08:17 <randomuser> hehe
15:08:19 <bexelbie> x42z ? :P
15:08:33 <jibec> haha, acronyms
15:08:36 <randomuser> there must be some regex for this
15:08:51 <bexelbie> <letter><number><number><letter> is how many people assume we always talk :P
15:09:24 <jibec> Bexel, we said: first we make it work for French as alpha tester, then es/cz as beta tester, then we open it
15:09:26 <randomuser> anyway, you're suggesting a manual pass and upload with po4a?
15:09:53 <bexelbie> yeah - I think I have a script to automate parts of it that JB helped with at Flock
15:10:26 <jibec> I can upload content to zanata by myself for tests
15:10:29 <bexelbie> jibec, can you get us the Zanata locations to push to and then randomuser and I can work through getting hte pushes up (so we both see it) ?
15:10:40 <bexelbie> jibec, is that easier so we just give you PO files?
15:10:43 <bexelbie> POT files
15:10:47 <bexelbie> x42z files?
15:11:30 <jibec> nope, the easier is to create a zanata.xml file and push content to the translation platform (so I can use the translation memory, and save my time)
15:11:41 <bexelbie> then let's plan to do that ... randomuser  you game?
15:11:56 <jibec> I know how to do this, I only need to understand "how to run the internationalization website from https://pagure.io/fedora-docs/docs-fp-o"
15:12:08 <randomuser> probably?  would happen sooner if someone else took the task
15:12:19 <bexelbie> jibec, yes, but you create those ugly po4a.cfg files :P
15:12:23 <jibec> I don't get the mechanism yet
15:12:33 <jibec> bexelbie: yep, and it works!
15:12:47 <bexelbie> #bexelbie and jibec to work on getting po files pushed for all of the current guides to start French beta testing
15:12:49 <bexelbie> sound good?
15:13:03 <jibec> alpha testing, but yep
15:13:14 <bexelbie> #action bexelbie and jibec to work on getting po files pushed for all of the current guides to start French alpha testing
15:13:31 <bexelbie> #action bexelbie to get jibec some information on how to actually publish a multi-language site from https://pagure.io/fork/bex/fedora-docs/docs-fp-o/branch/multi-language-support
15:13:36 <jibec> you can also add an action for me to build a project is proposal for documentation repo in Zanata
15:13:58 <bexelbie> #action jibec to provide the proper Zanata project information for translations
15:14:12 <jibec> nice rewording <3
15:14:50 <randomuser> okay, i need to start getting ready for the next meeting
15:15:11 <jibec> EOF
15:15:23 <bexelbie> alright, I am already double meeting
15:15:27 <bexelbie> so I am going to close
15:15:33 <bexelbie> thank you everyone!
15:15:41 <bexelbie> #endmeeting