22:34:55 <sdziallas> #startmeeting
22:34:56 <zodbot> Meeting started Sat Dec 26 22:34:55 2009 UTC.  The chair is sdziallas. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:34:56 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
22:35:24 <sdziallas> #topic Fedora Education SIG - Brainstorming
22:36:12 <sdziallas> okay, so. it has been quite calm lately - evidently.
22:36:35 <sdziallas> the question is whether this is because of something we're doing or something we're /not/ doing.
22:36:52 * mchua curious and listening for the beginning
22:36:52 <sdziallas> which leads directly to the point of goals and target groups.
22:37:09 <sdziallas> #link https://fedoraproject.org/wiki/SIGs/Education
22:37:29 <sdziallas> this has seen quite some restructuring over the summer (thanks mchua!)
22:38:06 <sdziallas> I believe a crucial statement on this page is this: "Our first step is to build ourselves and others the tools we'll need to reach our goals. What makes it difficult for educators to use - and contribute to - the Fedora package ecosystem as a way to directly help them teach and learn more effectively?"
22:38:33 <sdziallas> and then this: "We do this by building, maintaining, and evangelizing a strong ecosystem of educational packages within Fedora and by supporting learners in using these packages as tools to reach their curricular goals."
22:38:50 <sdziallas> (sorry for the long copy & paste)
22:39:18 <sdziallas> now this idea is obviously overlapping with what TeachingOpenSource is doing
22:39:34 <mchua> #link http://teachingopensource
22:39:36 <mchua> argh
22:39:38 <mchua> #link http://teachingopensource.org
22:39:47 <sdziallas> mchua: I think we need to make you a chair :)
22:39:51 <sdziallas> #chair sdziallas mchua
22:39:51 <zodbot> Current chairs: mchua sdziallas
22:40:02 <sdziallas> mchua: go for it again, please
22:40:05 <mchua> #link http://teachingopensource.org
22:40:10 <sdziallas> thanks!
22:40:36 <sdziallas> keeping the initial idea of looking at our goals and actions in mind:
22:41:13 <sdziallas> #idea what role does the Education SIG play related to projects such as TOS, especially /in/ Fedora?
22:41:30 <sdziallas> (well, not really an idea, but something I think we should mention specifically)
22:41:41 <sdziallas> the Education SIG can act, for example:
22:42:08 <sdziallas> * as a packaging SIG, where we few folks try to get the coolest educational software (which might be used by this or that teacher) into Fedora
22:42:15 <sdziallas> #link https://fedoraproject.org/wiki/K12_Open_Minds
22:42:40 <mchua> in case it's a useful question: "how is the Fedora education SIG related to other education-and-open-source efforts out there, like GCompris and the KDE Education Project, etc?"
22:42:59 <mchua> and "what makes a package 'educational'?"
22:43:03 <sdziallas> (reference: this was a session, mchua transcribed the teachers' favorite tools)
22:43:28 <mchua> ...but they're only really useful questions if they help us figure out what projects to work on, afaict.
22:43:38 * mchua drops quiet and listens again now, sorry
22:43:39 <sdziallas> mchua: the latter question is interesting.
22:43:49 <sdziallas> mchua: naw, speak up as much as possible!
22:44:03 <mchua> I should let you finish what you have to say first :)
22:44:07 <sdziallas> okey dokey!
22:44:13 * mchua goes to fill a glass of water while sdziallas does that
22:44:19 <sdziallas> let's look at "educational packages" then.
22:44:57 <sdziallas> when we try to follow and - probably a better word - cater what TOS is doing, then "educational packages" are *all* packages that are used or of use for teachers, professors and their students.
22:45:20 <sdziallas> basically, everything, that enables them to contribute to open source projects as part of their studies.
22:45:42 <sdziallas> but for that, we need /feedback/.
22:46:19 <sdziallas> to help, we need to know what's needed. otherwise, we're just shooting into the dark, which we did for about three releases.
22:46:33 <sdziallas> #link http://spins.fedoraproject.org/
22:46:48 <sdziallas> the education spin isn't really popular, it seems.
22:47:30 <sdziallas> why is that? because we don't have a clear target? because the average user on spins.fp.o doesn't know what to do with it?
22:48:34 <sdziallas> anyway. what I'm saying is this: I wonder whether it would make sense to shift a bit more to cater TOS & POSSE.
22:49:16 <sdziallas> and that might exclude an official Education Spin.
22:49:51 <sdziallas> on a totally other side, Sugar comes to mind.
22:50:11 <sdziallas> this is something entirely different which could very well use a "spin".
22:50:52 <sdziallas> but it feels more and more hard to suit peoples' needs, especially with the education spin, because needs differ so widely.
22:51:23 <sdziallas> #idea show people how create their own remixes
22:51:36 <sdziallas> #action test dorrie
22:51:39 <sdziallas> #link http://fedorahosted.org/dorrie
22:52:01 <sdziallas> half-ish EOF.
22:52:09 <sdziallas> mchua: yo.
22:52:12 <mchua> How does the Education SIG differ from Classroom?
22:52:17 <mchua> sdziallas: ah, only half-ish? :)
22:52:30 <sdziallas> mchua: I dunno yet... ;)
22:52:36 <sdziallas> mchua: you mean Fedora Classroom?
22:53:10 <mchua> sdziallas: yeah.
22:53:11 <sdziallas> mchua: Fedora Classroom is outlined in a much broader way... they cover all kinds of topics.
22:53:21 <sdziallas> mchua: actually... that's what we possibly need.
22:53:58 <mchua> One way I tend to look at things is "ok, what problem are we trying to solve for who right now?"
22:54:19 <mchua> You alluded to this earlier when you mentioned needing feedback, and a target.
22:54:28 <sdziallas> mchua: heh, that's a good question. originally, we tried to give Fedora an "educational solution".
22:54:35 <sdziallas> but a solution without users is nonsense.
22:55:17 <mchua> Who's got a problem you'd like to solve, then?
22:55:40 <mchua> Related in some way to education - regardless of whether the Edu SIG is the umbrella for that to be done under or not.
22:56:00 * mchua says this, btw, knowing that sdziallas and myself and many others in this channel are already working on a lot of education-related projects.
22:56:19 <sdziallas> mchua: the schools who are not using open source software and the professors who aren't aware of the advantages of open source.
22:56:38 <sdziallas> mchua: the former one is covered through the lurking K12LTSP and the latter one through POSSE.
22:57:37 <mchua> K12LTSP has also been very low-activity.
22:57:53 * sdziallas nods
22:58:40 <sdziallas> however, I think it doesn't make sense to try to create the "we fit everyones needs by throwing everything together" solution.
22:58:56 <sdziallas> mchua: schools *will* ultimately want to be able to chose what software they use.
22:59:15 <mchua> Why do we exist, then?
22:59:28 <sdziallas> mchua: and when this is open source software (probably even Fedora), we need to tell them how to do this easily.
22:59:46 <sdziallas> mchua: that's question I tend to ask myself.
23:00:15 <mchua> Should we just spend a little time brainstorming out problems we've seen in the education space (whether or not they have a solution)?
23:00:43 <sdziallas> mchua: the limit of what makes sense is creating a show-case. or a solution for a very limited circle. but not the "we solve all the educational problems at once" solution.
23:00:49 * mchua nods.
23:00:52 <sdziallas> (because it doesn't exist, I guess, heh)
23:02:07 <sdziallas> mchua: oh, yes, would make sense, I guess.
23:02:59 <mchua> Okay, I'll braindump for a bit here too, and encourage everyone to interrupt me. :)
23:03:38 <mchua> Actually, let's see.
23:03:58 <mchua> What if I took the devil's advocate position and tried to argue that the Edu SIG should disband because there's nothing left for it to do? ;)
23:04:22 <mchua> sdziallas: would that be a helpful way to try to counter-argue it?
23:04:42 <sdziallas> mchua: nope, because I might agree soon. ;)
23:04:53 <mchua> Okay. So.
23:04:59 * mchua puts on hat with little horns
23:04:59 <sdziallas> mchua: I'm trying to see *whether* there's anything left.
23:05:08 * sdziallas grins
23:05:12 <mchua> The Edu SIG no longer needs to exist!
23:05:23 <mchua> Every problem that it could possibly solve is already being taken on in some other area.
23:05:51 <mchua> Let's divide the territory up a little bit. In terms of education, let's look at K12 education, and then university level, and then beyond university.
23:05:54 <mchua> So first, K12.
23:05:57 <sdziallas> Sugar.
23:06:16 <mchua> Sugar Labs, GCompris, etc. and other groups doing software development work in this area already.
23:06:50 <mchua> They're doing development - but how about deployment, QA, distribution, and support?
23:07:12 <mchua> Deployment: best done locally, usually has to be done by a school's IT staff.
23:07:23 * sdziallas needs to swap hats from time to time.
23:07:25 <mchua> Should the Edu SIG be a support group for those people? I don't know.
23:07:39 <sdziallas> it's probably why I'm pushing for SoaS + Fedora.
23:07:50 <sdziallas> but this is something the OLPC SIG belongs to.
23:07:50 <mchua> QA is usually really under-done for open source projects in general.
23:08:03 <mchua> OLPC SIG == Deployment?
23:08:11 <mchua> Deployment and Support, I'd put in the same category.
23:08:22 <sdziallas> nope. well, used to be, but not anymore.
23:08:36 <mchua> Because those who roll it out usually are the ones supporting it afterwards (and if they're not, they should be, otherwise you end up with the "and this got dumped on my lap and wtf?" situation.)
23:08:39 <sdziallas> OLPC SIG = the place where Sugar stuff would happen, especially distribution.
23:08:48 <mchua> How active is the OLPC SIG nowadays?
23:08:51 <mchua> Also, OLPC != SL.
23:08:55 <sdziallas> right.
23:09:18 <sdziallas> OLPC SIG is mostly... well, the XO-1 and XO-1.5 builds.
23:09:22 <mchua> OLPC itself does hardware - so I'd think of an OLPC sig about being more XO-specific, making sure it worked on that platform, yeah.
23:09:29 <sdziallas> used to be much more active.
23:09:31 <sdziallas> right.
23:09:48 <mchua> SL does software, I'd think of a Sugar SIG as focused on the deployment of the software, but SoaS is doing a lot of that already.
23:09:51 <mchua> (If not all of it.)
23:09:52 <sdziallas> I won't let the cat out of the bag here with regard to Sugar & packaging, though.
23:09:58 * mchua nods.
23:10:16 <sdziallas> the point is: I don't think we need *more* SIGs involved in education with the same people around.
23:10:19 <mchua> So, QA and distribution (which I see as closely tied together, because you can't get testing done if nobody can get the software to use it.)
23:10:20 <sdziallas> we need less.
23:10:22 * mchua nods.
23:10:26 * mchua nods again.
23:10:45 <mchua> Do K12 teachers - or students - using this software need a place to go?
23:10:54 <mchua> Arguably, that's not the highest point of leverage right now.
23:10:59 * sdziallas nods
23:11:12 <mchua> Students have other students in their classrooms and their schools, and they can also become part of global online communities.
23:11:20 <mchua> Teachers have already networks of fellow teachers.
23:11:36 <mchua> So looking at university-level real quick...
23:11:41 <sdziallas> the latter one doesn't imply they share their results, but let's leave this aside for now, yes.
23:11:53 <sdziallas> +1 to moving to university-level
23:12:04 <mchua> Deployment is pretty much handled by university IT departments.
23:12:27 <mchua> Which - I'm guessing - would mostly use RHEL rather than Fedora.
23:12:39 <mchua> Which is I think what I've seen happening.
23:12:45 <sdziallas> Presumably, yes.
23:12:49 <mchua> Fedora *is* used by research labs.
23:12:53 <mchua> I don't know how many labs.
23:13:03 <mchua> But a nonzero amount - it's used as a research platform.
23:13:06 <sdziallas> well, those would probably opt for FEL, no?
23:13:21 <mchua> If they're electronics-related, and have heard of FEL, maybe.
23:13:30 <mchua> One problem I do know about from at least one lab is that they use Fedora on their machines
23:13:36 <mchua> but it's *totally* out of date
23:13:41 <mchua> They're running... Fedora 7 or something
23:13:41 <sdziallas> heh.
23:13:47 <sdziallas> cool, that was a great release :)
23:13:51 <mchua> With some kludges to the kernel
23:14:03 <mchua> Basically, they're carrying their own diffs and it's not working very well.
23:14:21 <mchua> So how do those labs get discovered and encouraged to bring their stuff back into upstream?
23:14:52 <mchua> (For that matter, last week I talked with a university sysadmin who's done some neat projects/hacks for his college, but never shared them upstream.)
23:15:01 <sdziallas> by having some place with people to talk to?
23:15:14 <mchua> Is that purpose served by TOS?
23:15:31 * mchua ignores the post-college segment for now - lots of opportunity there, but not something I think we have a lot of leverage to tap
23:15:38 <sdziallas> like a group of people going: "oh, w00t, this is interesting what you're doing, lets see whether we can help you to get this there"
23:15:52 <sdziallas> mhm. I think TOS is more the prof-wise approach, no?
23:16:01 <mchua> Find people in the education sector who are already doing cool things, get them to bring their changes to upstream?
23:16:21 <mchua> Yeah, TOS is more about "these students in our classrooms, how do we teach our courses so they can contribute to open source?"
23:16:30 * sdziallas nods
23:17:06 <mchua> but TOS isn't the place for a "hey people, Bring Your Stuff Upstream" effort
23:17:13 * sdziallas nods again
23:17:31 <mchua> which could be packaging.
23:17:46 <mchua> And using that as a way to introduce people to the culture of open source contribution.
23:17:49 <sdziallas> yeah...
23:18:02 <mchua> Now. Who *else* can solve that problem? :P
23:18:20 <sdziallas> I dunno.
23:18:51 <mchua> Is there a specific group of people already doing cool stuff but not taking it upstream that we could target to work with for the beginning?
23:19:03 * sdziallas grins, yes, there is.
23:19:17 <mchua> (How does this weigh against the other things we could do with our time? Is this something that would be nice to do, but should be put aside in favor of working on other projects?)
23:19:21 <mchua> sdziallas: who?
23:19:32 <sdziallas> they've a certain acronym with four letters - and have already a SIG around them.
23:19:48 * mchua coughs.
23:19:55 <mchua> Ok, what are they doing that's not going upstream?
23:20:17 <sdziallas> mchua: there's a number of still-forked packages.
23:20:29 <sdziallas> mchua: and there's a number of hardcoded things in various packages.
23:20:39 * sdziallas notices that this is not university-level.
23:20:54 <mchua> It's not, but that's fine. :)
23:21:04 <mchua> Ok. Who's working on un-forking it?
23:21:13 <mchua> Is that something that should be done by the OLPC SIG, or by people at OLPC, etc?
23:21:26 <sdziallas> mchua: people at OLPC used to be busy with readying a release.
23:21:33 <sdziallas> mchua: and the OLPC SIG is pretty calm.
23:21:49 <sdziallas> mchua: I still don't think it's time to let the cat out of the bag here, heh.
23:22:10 <mchua> How much membership overlap is there between the OLPC SIG, the Edu SIG, and a hypothetical Sugar SIG, and other education-related SIGs?
23:22:27 <sdziallas> mchua: well, the point is that the Edu SIG is pretty dead.
23:23:09 <mchua> Devil's Advocate: "So let's kill it."
23:23:34 * sdziallas tempted.
23:23:40 <sdziallas> wait, somebody said devil?
23:23:42 <sdziallas> heh. ;)
23:23:45 <mchua> Let's put a message out on the mailing list saying "hey, we've been dormant and not doing anything, the problems we began to solve are being solved by groups A, B, and C if you'd like to join us there."
23:24:01 <mchua> "We'll close the Education SIG down in a month if there are no objections."
23:24:36 * sdziallas will want to think about that for a night. putting it under my pillow.
23:24:50 <mchua> sdziallas: ...so, initial reaction - how does that make you feel right now?
23:25:15 <mchua> Sleeping on it for a while is a good idea, but I'm curious if you have any thoughts right now.
23:25:23 <mchua> For me, I'm a little sad.
23:25:32 <sdziallas> sad. seeing something die. but knowing that it'll have good children...
23:25:46 <mchua> I'm not sure where I'd bring hypothetical future education projects into, for Fedora; they'd have to fit into one of the more specialized umbrellas.
23:26:02 <mchua> But that's also a hypothetical scenario where one could restart the SIG when it's needed.
23:26:14 <mchua> And there'll be clear "this once existed, now it's dormant, and you are unblocked on opening it up again" markers
23:26:22 <sdziallas> mchua: you'd probably want to read this: http://sdziallas.blogspot.com/2008/07/fedora-edu-so-what.html
23:26:30 <mchua> instead of "it looks like nobody's home, but... are we stepping on toes by doing this?"
23:26:33 * mchua reads
23:26:57 <sdziallas> mchua: it used to have a basically dead page saying "this is dead, please replace it when the time has come". I did.
23:27:29 <sdziallas> I'm not happy by going there again.
23:27:35 <sdziallas> But it might be needed.
23:27:47 <mchua> Well, also think about it this way
23:27:54 <mchua> Having that opportunity open is what got you started.
23:28:04 <mchua> You're off and running now.
23:28:13 <mchua> Maybe it's time to leave that spot open for somebody else.
23:28:20 <mchua> Who will the next sdziallas be?
23:29:03 <mchua> A good, clean shutdown/transfer also takes a lot of time and effort - a lot of teaching and documenting and tying up loose ends goes into it - so I don't think it'd really wind down for at least a few months, too.
23:29:43 <mchua> And maybe the energy generated by doing a clean wind-down will be enough to spark something else to start-up. I don't know, but it's happened.
23:29:52 <mchua> But one shouldn't plan for that sort of thing.
23:30:38 * sdziallas nods.
23:34:01 <mchua> sdziallas: lots to think about here.
23:34:11 <mchua> close up for now, come back to this later after some pondering?
23:34:13 <sdziallas> mchua: right. let's close this one here for now.
23:34:17 <sdziallas> mchua: +1.
23:34:23 <sdziallas> #action think.
23:34:30 <sdziallas> #endmeeting