16:00:23 <jcajka> #startmeeting Go SIG meeting
16:00:23 <zodbot> Meeting started Tue Jul  9 16:00:23 2019 UTC.
16:00:23 <zodbot> This meeting is logged and archived in a public location.
16:00:23 <zodbot> The chair is jcajka. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:23 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:23 <zodbot> The meeting name has been set to 'go_sig_meeting'
16:00:36 <jcajka> #topic Roll Call
16:00:39 * decathorpe is here as well
16:00:52 <jcajka> #chair decathorpe
16:00:52 <zodbot> Current chairs: decathorpe jcajka
16:00:57 * jcajka waves
16:03:02 * jcajka is on the move so please excuse if I drop out
16:04:01 <nim> .hello2
16:04:02 <zodbot> nim: nim 'None' <nicolas.mailhot@laposte.net>
16:04:11 <jcajka> #chair nim
16:04:11 <zodbot> Current chairs: decathorpe jcajka nim
16:06:02 <QuLogic> .hello qulogic
16:06:03 <zodbot> QuLogic: qulogic 'Elliott Sales de Andrade' <quantum.analyst@gmail.com>
16:06:09 <jcajka> #chair QuLogic
16:06:09 <zodbot> Current chairs: QuLogic decathorpe jcajka nim
16:11:38 * jcajka_ is back
16:12:32 <jcajka_> let me fire one question how is it looking with the status of rawhide? are we currently waiting on compose?
16:14:09 * jcajka_ is still seeing broken deps locally/on mirrors
16:14:45 <QuLogic> I just fired off the builds to add Obsoletes on the last set of renames eclipseo did
16:15:02 <QuLogic> so at the very least, upgrades won't be working just yet
16:15:35 <decathorpe> some of my packages were probably renamed but haven't been retired (yet?)
16:16:04 <QuLogic> I would wait for eclipseo for exact details though
16:16:33 <jcajka_> thanks looks better ;), this will require successful compose too, not sure what status of them is, but at least buildroot in koji should be better now
16:16:56 <jcajka_> right away
16:19:08 <decathorpe> QuLogic: I just checked, there's still obsoletes missing for some of my renamed packages
16:19:29 <QuLogic> decathorpe: such as?
16:19:52 <decathorpe> for example, golang-github-AudriusButkevicius-go-nat-pmp got renamed to https://src.fedoraproject.org/rpms/golang-github-audriusbutkevicius-nat-pmp
16:19:53 <QuLogic> I don't have a list; I'm just going by commit notifications
16:21:35 <QuLogic> hmm, I recognize a bit of that name, but I don't have it here
16:22:00 <decathorpe> the other three are:
16:22:05 <jcajka_> decathorpe, QuLogic: IMHO it would be good to track those that look like "missed" in the BZ either in https://bugzilla.redhat.com/show_bug.cgi?id=1715534 or separate bugs so they don't get lost
16:22:24 <decathorpe> ah, alright. I'll comment there as well
16:22:59 <decathorpe> golang-github-oschwald-geoip2(-golang), golang-github-oschwald-maxminddb(-golang), https://src.fedoraproject.org/rpms/golang-github-sasha-s-(go-)deadlock are the other three
16:23:44 <QuLogic> I don't seem to have an commit notification on those
16:24:49 <QuLogic> once or twice, fedmsg gave up on fully sending notifications, so I may have not correctly cross-referenced the commits
16:25:00 <decathorpe> yeah, fedmsg is not 100% reliable
16:25:02 <decathorpe> https://bugzilla.redhat.com/show_bug.cgi?id=1715534#c10
16:27:03 <nim> QuLogic, what do you use to detect what needs an obsolete?
16:27:47 <nim> QuLogic, the code I posted last month during the meeting does a dnf repoquery --whatprovides 'golang(*)' --qf "#%{name}|%{source_name}|%{evr}|%{provides}"
16:28:16 <nim> QuLogic, and then you just need to check all the golang() provides on the new repo
16:28:28 <nim> QuLogic, are owned by the same package in the old repo
16:28:39 <nim> QuLogic, otherwise it needs an obsolete
16:28:48 <QuLogic> yea, I could do that, but I need a compose for that
16:28:56 <nim> QuLogic, that should not depend on fedmsg
16:28:56 <QuLogic> or downloading all the packages from the side tag
16:29:24 <nim> QuLogic, you don't need a compose, you can query directly the repo in koji
16:29:43 <nim> QuLogic, all you need to download is the koji repo metadata
16:30:23 <QuLogic> sure, I can run it now to make sure nothing was missed
16:30:42 <nim> (of course that will only tell you what needs an obsolete, not if the obsolete has already been filled)
16:31:04 <jcajka> QuLogic: that would be awesome
16:31:13 <nim> the advantage is you have all the time between the package build and the compose to fix things
16:32:08 <nim> QuLogic, as a bonus dnf works on multiple repos, so you can querry as many old repos as you want to build the from list
16:32:48 <QuLogic> decathorpe: ohh, you mean eclipseo hasn't pushed a retire at all; yea that's why I didn't add Obsoletes
16:33:30 <decathorpe> exactly, these 4 packages were renamed but not retired
16:33:49 <nim> QuLogic, this kind of repoquery is also handy to detect when multiple packages try to provide the same golang(foo)
16:33:49 <jcajka> this should be done now
16:38:23 <jcajka> QuLogic: are you fine if I taf you with action item to clean up the rawhide after the side tag mere?
16:38:28 <jcajka> taf-tag
16:38:50 <QuLogic> decathorpe: done
16:39:34 <QuLogic> jcajka: yea ok
16:39:40 <jcajka> #action QuLogic will clean up missing obsoletes and retires after the side tag has been merged
16:39:42 <jcajka> thanks
16:41:09 <decathorpe> QuLogic: great, thanks
16:41:16 <decathorpe> should I retire the old packages?
16:41:56 <jcajka> ideally after the obsoletes are in place so there is update path
16:42:03 <QuLogic> I'll do it when the builds pass
16:42:14 <decathorpe> QuLogic: thanks 👍️
16:43:14 <nim> wonderful
16:43:32 <nim> (of course obsoletes won't fix upstream API breaks)
16:46:29 <jcajka> eclipseo, QuLogic, nim: I have one thing that I would like to ask you, could you please remove most of the mentions of Go SIG in the https://fedoraproject.org/wiki/Changes/Adopt_new_Go_Packaging_Guidelines as this change is not endorsed/lead by Go-SIG, but just you three
16:46:42 <eclipseo> .hello 2
16:46:43 <zodbot> eclipseo: Sorry, but you don't exist
16:46:49 <eclipseo> .hello2
16:46:50 <zodbot> eclipseo: eclipseo 'Robert-André Mauchin' <zebob.m@gmail.com>
16:46:53 <jcajka> #chair eclipseo
16:46:53 <zodbot> Current chairs: QuLogic decathorpe eclipseo jcajka nim
16:47:36 <eclipseo> QuLogic:you are still seeieng errors??
16:48:01 <QuLogic> eclipseo: hmm, on what?
16:49:13 <eclipseo> no nothing I misread
16:49:35 <nim> jcajka, you're not being constructive, and if we acted the same way WRT your activity, the SIG would soon cease to exist
16:50:05 <jcajka> nim: I would kindly ask you to not be aggressive and personal
16:50:57 <nim> jcajka, I didn't spend months working within the SIG, in meetings, day and night, for you to spam all Fedora channels to disown this work
16:51:16 <jcajka> we all have agreed on some rule set  and you have transgressed that
16:51:38 <nim> jcajka,  you're not being constructiv
16:52:06 <nim> jcajka, if you insist in looking at things only your way, two can play the game
16:53:07 <nim> jcajka, do you realise that you're creating single-handledly a FUD campain against the work others are doing in the SIG?
16:53:42 <nim> jcajka, do you think I don't have other things to do that pointing several times in the week to actual state in koji and other Fedora infra
16:53:55 <jcajka> nim: I would kindly ask you to be constructive and not personal
16:53:58 <nim> jcajka, every time you claim false things in Fedora channels?
16:55:11 <nim> jcajka, that's what I'm asking you to do
16:56:02 <nim> jcajka, and I'm not the one posting negative things on other SIG members work every time I have an occasion to
16:56:13 <jcajka> eclipseo, QuLogic: would you be so kind to do that?
16:58:06 <jcajka> I'm sorry to bring this, this late but at time the change hit FESCO I have been offline on PTO and haven't paid as much attention that I should have
16:58:44 <jcajka> nim: IMO deception shouldn't be something that is normal and acceptable in Fedora
16:59:17 <QuLogic> you should ask eclipseo; I'm only on there because of fixing golist
16:59:41 <QuLogic> but IMO we're discussing it during Go SIG meetings, so the distinction seems moot
16:59:50 <eclipseo> I don't aggree with this, the change is the SIG's work and wouldn't have happened without it. I don't understand why you are making difficulties about this.
17:00:08 <nim> jcajka, like when you claimed we broke something that was not even shipped in Fedora? I had to post the pointer to koji state for FC30
17:00:13 <eclipseo> The work is done anyway so this is a moot point
17:00:14 <jcajka> nim: I don't wan in any extend down play the magnitude of work that you have done, but we haven't got consensus on the change
17:00:26 <QuLogic> eclipseo: seems like new k8s broke prometheus :(
17:00:32 <jcajka> want
17:00:46 <nim> jcajka, or when you claimed we were blocking you ? I had to point you were admin of the git containing the files you "could not" change
17:01:10 <jcajka> nim: I have not in the context that you are describing
17:01:15 <nim> jcajka, it is getting quite tiring
17:01:23 <nim> jcajka, and you've been exalating lately
17:01:48 <jcajka> eclipseo: I disagree if this should be norm that I can propose anything by your name
17:02:59 <eclipseo> We didn't porpose anything by your name and I don't understand why making a fuss of such a trivial point
17:03:30 <jcajka> eclipseo: sorry, but you did, original proposal has had my name on it
17:03:46 <eclipseo> QuLogic: have a link? I have yet to rebuild the final piece of k8s because random error during build
17:04:08 <QuLogic> eclipseo: https://koji.fedoraproject.org/koji/taskinfo?taskID=36152701
17:04:44 <QuLogic> _build/src/github.com/prometheus/prometheus/discovery/kubernetes/client_metrics.go:239:23: cannot use f (type *clientGoWorkqueueMetricsProvider) as type workqueue.MetricsProvider in argument to workqueue.SetProvider: *clientGoWorkqueueMetricsProvider does not implement workqueue.MetricsProvider (missing NewDeprecatedAddsMetric method)
17:05:07 <eclipseo> jcajka: because I thought you were on board with us, now it's removed. I don't understand your persistence of not wanting to be associated with anything we do
17:05:23 <QuLogic> (I assume this is k8s anyway since it's the main upgrade)
17:05:50 <jcajka> eclipseo, QuLogic: could you please leave the k8 technical discussion after the meeting
17:06:09 <QuLogic> anyway, back on topic, eclipseo how much is left to build? just apps?
17:07:51 <jcajka> eclipseo: nothing personal, just technical, in my opinion the change has rather under valued its extend and scope
17:09:00 <jcajka> and it has been rather ignore when I have been pointing it out
17:09:16 <eclipseo> QuLogic: left to build K8s compose on k8s, Unboostrapped containerd, all binary apps packages
17:10:35 <eclipseo> some packages are still bootrstrapped too because Unbundling them completly would have taken too much effort, so k8s for example would need some work at a later time to be fully unbootstrapped
17:10:53 <jcajka> eclipseo, QuLogic: can I please get from you answer, will you remove it or not?
17:16:28 <QuLogic> like I said, it's not my writeup
17:18:59 <jcajka> anyway we are well on top of the hour
17:19:34 <jcajka> QuLogic, eclipseo: really don't get me wrong, I very much appreciate all the hard work that you have done on the execution of the change
17:19:39 <eclipseo> jcajka: I'll remove
17:20:02 <QuLogic> eclipseo: you need any help with the rest?
17:20:11 <eclipseo> QuLogic: updating to 2.11 should fix the compatibility with k8s
17:20:22 <jcajka> eclipseo: I very much appreciate that
17:20:54 <eclipseo> yes I don't have time to do the rest, cause new work so I'll appreciate if you could look into it
17:21:12 <QuLogic> do you have a list of remaining items?
17:21:18 <eclipseo> I need to mass assign the new package to the SIG too and add them to Koschei
17:21:22 <jcajka> FYI there has been new point release of Go, I have just landed go1.12.7  in rawhide
17:21:48 <jcajka> any more topic or stuff that should go on record?
17:21:55 <jcajka> topics
17:22:16 <eclipseo> I'll also need to double check if I haven't missed any library as I worked from a Grokmirror clone which is a bit unreliable
17:23:13 <jcajka> eclipseo, QuLogic  are you fine with ending meeting now?
17:23:18 <eclipseo> QuLogic: any stuff that don't start withh golang- on that list https://fedoraproject.org/wiki/Changes/golang1.13#Dependencies
17:23:26 <eclipseo> jcajka: ok
17:23:43 <QuLogic> jcajka: yep
17:24:17 <jcajka> #endmeeting