16:30:58 <threebean> #startmeeting fedora-hubs
16:30:58 <zodbot> Meeting started Wed Mar 16 16:30:58 2016 UTC. The chair is threebean. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:30:58 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:30:58 <zodbot> The meeting name has been set to 'fedora-hubs'
16:31:06 <threebean> #chair jflory7 bee2502_ threebean devyani7
16:31:06 <zodbot> Current chairs: bee2502_ devyani7 jflory7 threebean
16:31:11 <threebean> #topic rollcall
16:31:16 <jflory7> .hello jflory7
16:31:17 <zodbot> jflory7: jflory7 'Justin W. Flory' <me@justinwflory.com>
16:31:19 <threebean> if you're here for the hubs meeting, say hi!
16:31:26 <bee2502_> .hello bee2502
16:31:27 <devyani7> hi
16:31:27 <zodbot> bee2502_: bee2502 'Bhagyashree Padalkar' <bhagyashree.iitg@gmail.com>
16:31:35 <devyani7> .hello devyani7
16:31:36 <zodbot> devyani7: devyani7 'Devyani Kota' <devyanikota@gmail.com>
16:31:37 <threebean> .hello ralph
16:31:39 <zodbot> threebean: ralph 'Ralph Bean' <rbean@redhat.com>
16:32:19 <threebean> #topic Open Floor
16:32:32 <threebean> #undo
16:32:32 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x3eb32350>
16:32:37 <threebean> #topic Meeting Structure
16:32:56 <threebean> I'll start with just saying that this is the first hubs checkin meeting. hopefully we can do them every week at about the same time.
16:33:00 <dhritishikhar> hi
16:33:11 <threebean> but.. for a project like this, does anyone have any input on how we should structure the meeting?
16:33:14 <dhritishikhar> .hello dhritishikhar
16:33:14 <zodbot> dhritishikhar: Sorry, but you don't exist
16:33:19 <threebean> what would be helpful?
16:33:22 <dhritishikhar> .hello dhrish20
16:33:23 <zodbot> dhritishikhar: dhrish20 'Dhriti Shikhar' <dhrish20@gmail.com>
16:33:26 <threebean> dhritishikhar: welcome :)
16:33:39 <bee2502_> perhaps important issues we are looking forward to fixing this week
16:33:53 <bee2502_> or widgets we want to work on immediately
16:33:57 * threebean nods
16:34:00 <devyani7> or priority bugs^^^
16:34:15 <bee2502_> devyani7++
16:34:29 <threebean> cool. I bet in the future mleonova and mizmo would maybe like to have input on the work we've done in the previous week.
16:34:30 <jflory7> threebean: Cool, we should get these on a Fedocal somewhere. Maybe CommOps?
16:34:40 <threebean> jflory7: +1 can you take that on?
16:34:44 <jflory7> I can.
16:34:47 <threebean> thank you!
16:35:13 <jflory7> #action jflory7 Add a Fedocal entry for Hubs meeting to CommOps calendar (Wednesdays, 16:30 UTC)
16:35:39 <threebean> hm, so priority bugs and upcoming work being one item.
16:35:42 <jflory7> As for meeting structure... should it be ticket-based, i.e. what's sitting in PAgure?
16:36:11 * jflory7 likes ticket-based structures but knows that isn't the best for every project
16:36:20 <threebean> it certainly could be. I imagine if we went through every ticket in the system, it might be a little overwhelming.
16:36:20 <jflory7> Not sure what your thoughts are on that.
16:36:29 <mizmo> a bunch of the tickets are actually ui specs
16:36:31 <mizmo> not really tickets
16:36:33 <mizmo> o_O
16:36:47 <threebean> true true. mizmo we've starting adding a few more task-based ticket at the bottom of the queue.
16:36:58 <mizmo> i can tag the ux ones as ux if it helps
16:37:01 <threebean> for the past few days I've been working on the feed widget.. but there's a lot more to be done.
16:37:50 <threebean> can we aim to try a ticket-based meeting the next time around? I'm not quite prepared today to have them already triaged and ready to paste into the meeting.
16:38:09 <jflory7> Yeah, might be kind of hard to wrangle up some tickets on the spot.
16:38:21 <jflory7> Now is a good time to hammer out things like structure and going forward, etx.
16:38:23 <jflory7> * etc.
16:38:40 <jflory7> I liked the sounds of bee2502_ and devyani7's thoughts
16:38:44 <mizmo> #action mizmo to tag ux / ui spec tickets
16:38:56 <threebean> cool. ok. I'll make a point to go through and tag all the issues before next week's meeting, so we can have a subset ready then.
16:39:01 * threebean and mizmo.
16:39:22 <mizmo> is there a test or staging instance somewhere that mleonova and i could look at to see how it's going or should we be building on our own?
16:39:26 * mizmo hasn't built in forever
16:39:56 <jflory7> A staging instance would be cool to set up too... especially so some people coming in soon (like GSoC applicants) could get a quick visual or idea of it.
16:39:59 <threebean> currently, building your own is the only option we have available. I stepped mleonova through it last week so she has a working copy.
16:40:19 <threebean> if that would help, I can look at setting up a cloud instance of it.
16:40:44 <thunderoy> .hello thunderoy
16:40:45 <zodbot> thunderoy: thunderoy 'Abhishek Kumar Roy' <thunderoy013@gmail.com>
16:40:47 <threebean> #action threebean will set up a cloud instance of the current code so people can login and look at it.
16:41:12 <threebean> thunderoy: welcome :)
16:41:15 <jflory7> For anyone who just joined earlier, feel free to introduce yourself by typing .hello <fas username> like thunderoy just did!
16:41:19 <jflory7> thunderoy: Welcome!
16:41:38 <leasunhy> .hello leasunhy
16:41:38 <thunderoy> threebean, jflory7 thanks :)
16:41:41 <zodbot> leasunhy: Sorry, but you don't exist
16:41:49 <jflory7> threebean: A cloud instance would be cool, just for a quick and dirty look at how things are going. +1
16:41:51 <thunderoy> sorry for being late
16:41:51 <threebean> leasunhy: ah, use your FAS username there if you have one. :)
16:42:08 <bee2502_> +1 on the cloud instance
16:42:09 <threebean> leasunhy: that would be your account username in this system: https://admin.fedoraproject.org/accounts
16:42:09 <mizmo> threebean: a cloud instance is good to show other folks who dont necessarily have things built for second opinions / driveby usability testing / etc
16:42:20 <leasunhy> threebean: ahh, I see :-)
16:42:25 <mizmo> i should get it built locally too though, i'm assuming the readme is still relevant?
16:42:40 <threebean> it is, mizmo. people were just stepping through it a few days ago and got a working copy.
16:42:47 * linuxmodder late
16:42:47 <mizmo> +1
16:42:55 <linuxmodder> .fasinfo corey84
16:42:56 <zodbot> linuxmodder: User: corey84, Name: Corey Sheldon, email: sheldon.corey@gmail.com, Creation: 2014-11-28, IRC Nick: linuxmodder, Timezone: US/Eastern, Locale: en, GPG key ID: 02AABD91 FF32E0EE 2584CBE4, Status: active
16:42:59 <zodbot> linuxmodder: Unapproved Groups: summer-coding security-team fedmsg-announce
16:43:01 <zodbot> linuxmodder: Approved Groups: marketing magazine fedorabugs qa fedora-join commops campusambassadors scitech fi-apprentice ambassadors cla_fpca cla_done
16:43:06 <threebean> #topic Upcoming work and things to do
16:43:07 <narekb_> .hello narekb_
16:43:08 <zodbot> narekb_: Sorry, but you don't exist
16:43:13 <narekb_> oh that's just harsh
16:43:41 <linuxmodder> .hello narekb
16:43:43 <zodbot> linuxmodder: Sorry, but you don't exist
16:43:45 <threebean> narekb_: heh, as mentioned above - use your FAS username there with the .hello command if you have one. that's your username in this system: https://admin.fedoraproject.org/accounts
16:43:51 <Nitrogen> .hello Nitrogen
16:43:55 <zodbot> Nitrogen: Sorry, but you don't exist
16:43:58 <Nitrogen> hmm?
16:44:05 <jflory7> Nitrogen: Caps-sensitive, I think. :)
16:44:08 <jflory7> Try all lowercase
16:44:22 <nitrogen> .hello nitrogen
16:44:23 <zodbot> nitrogen: nitrogen 'Narek Babadjanyan' <babaj96@gmail.com>
16:44:31 <nitrogen> oh, great, thanks jflory7
16:44:45 <bee2502_> threebean : so, what are we looking forward to in this week for Hubs ?
16:45:11 <threebean> well, I plan to keep working on the feed widget. I have a couple sub-items in there for that..
16:45:40 <leasunhy> .hello leasunhy
16:45:41 <zodbot> leasunhy: leasunhy 'Siyuan Liu' <leasunhy@gmail.com>
16:45:47 <devyani7> threebean: i was planning to work on the hyperkitty mailing list widget.
16:46:01 <threebean> the feed is intended to display an aggregate of all the kinds of events that a user may be interested in. for some of those events, we "collapse" the spammy ones into one notification in the feed. I've got some code that allows you to expand that and show the constituent events. but there's more to do..
16:46:03 <linuxmodder> threebean, leasunhy is a gsoc prospect fyi
16:46:23 <threebean> .. we want to be able to show some more long-form content in the feed like details about new badges and content from blog posts. content from mailing lists too.
16:46:59 <threebean> devyani7: the hyperkitty mailing list widget should be cool. :) did you have any luck tracking down the hyperkitty API? I think you were looking at the GNU mailman API last we talked about it.
16:47:18 <mizmo> threebean: have you thought about any kind of template system or something where the handling of different classifications of types of messages is determined?
16:47:22 <devyani7> yes, am going through the hyperkitty docs
16:47:23 <linuxmodder> threebean, like tflink was wanting to do for the install guide a few weeks back ? re: the collapse
16:47:58 <threebean> devyani7: awesome :)
16:48:23 <threebean> mizmo: somewhat. I think almost all of what we want to do there can be handled by expanding the fedmsg.meta lib.
16:48:36 <threebean> that's this module: https://github.com/fedora-infra/fedmsg_meta_fedora_infrastructure
16:49:20 <threebean> mizmo: at least, that's how I'm going to try to do it. it already produces different renderings based on what 'kind' of message is being handled.. so we may just need to add a few more to flesh it out.
16:49:53 <threebean> for instance - the full content of an email from a mailing list isn't handled yet - and the summary of a blog post too.. but there's space and an API already for those to be added.
16:50:22 <mizmo> threebean: oh okay cool
16:50:31 <abompard> the hyperkitty API is very very basic at the moment, I expect it's going to need many improvements for the widget
16:51:14 <bee2502_> threebean : some issues are solved and yet marked open on pagure like this : https://pagure.io/fedora-hubs/issue/97
16:51:18 <threebean> abompard: the thing we primarily need is being able to query for a list of mails to a list. also being able to get the content and metadata about a mail or thread would be nice.
16:51:31 <devyani7> abompard: um, will try and work on it. :)
16:51:36 <threebean> abompard: being able to send mail or POST other things to the API would be secondary, I think.
16:51:42 <threebean> (but still nice)
16:52:03 * devyani7 notes that down
16:52:06 <abompard> devyani7: the good thing is that the REST framework that is in place is very good
16:52:11 <threebean> bee2502_: oh, nice. If you see ones like that, can you comment on them that they can be closed, please?
16:52:19 <bee2502_> we prolly need a close button for the issues for every user on Hubs
16:52:38 <devyani7> abompard: cool, will check it out.
16:52:54 <mizmo> (are you guys on video chat now too?)
16:53:03 * devyani7 also found a few open issues, comments there :P
16:53:15 <fedmsg-hubs> pagure.project.user.added -- ralph added "bee2502" to project fedora-hubs https://pagure.io/fedora-hubs
16:53:26 <threebean> mizmo: not today ;)
16:53:31 <mizmo> kk
16:53:33 <fedmsg-hubs> pagure.issue.comment.added -- bee2502 commented on ticket fedora-hubs#97: "CommOps Default Hub" https://pagure.io/fedora-hubs/issue/97#comment-1972
16:54:38 <fedmsg-hubs> pagure.project.user.added -- ralph added "devyani7" to project fedora-hubs https://pagure.io/fedora-hubs
16:54:49 <fedmsg-hubs> pagure.project.user.added -- ralph added "dhrish20" to project fedora-hubs https://pagure.io/fedora-hubs
16:55:01 <fedmsg-hubs> pagure.project.user.added -- ralph added "jflory7" to project fedora-hubs https://pagure.io/fedora-hubs
16:55:09 <fedmsg-hubs> pagure.project.user.added -- ralph added "pingou" to project fedora-hubs https://pagure.io/fedora-hubs
16:55:40 <fedmsg-hubs> pagure.issue.tag.added -- duffy tagged ticket fedora-hubs#1: ui spec https://pagure.io/fedora-hubs/issue/1
16:55:40 <jflory7> threebean++ Thanks.
16:55:47 <threebean> one other thing I'd like to work on this week is moving all of the 'templates' out of the .py files for the widgets and into their own .html files.
16:55:54 * jflory7 is about to start a class so will not be reading chat as much.
16:55:57 <fedmsg-hubs> pagure.issue.tag.added -- duffy tagged ticket fedora-hubs#2: ui spec https://pagure.io/fedora-hubs/issue/2
16:55:57 <bee2502_> apparently, we cannot close #97 till #98 is closed - though it should be the other way round
16:55:58 <devyani7> awesome :) threebean++
16:55:59 <zodbot> devyani7: Karma for ralph changed to 27 (for the f23 release cycle): https://badges.fedoraproject.org/tags/cookie/any
16:55:59 <threebean> it should make things a little less messy and easier to hack on.
16:56:03 <jflory7> I'll catch up on the logs or chime in time to time. Thanks all!
16:56:07 <bee2502_> threebean++
16:56:15 <threebean> jflory7: thanks, seeya!
16:56:25 <bee2502_> jflory7 : bye :)
16:56:38 <fedmsg-hubs> pagure.issue.tag.removed -- duffy removed the hubs tags from ticket fedora-hubs#1 https://pagure.io/fedora-hubs/issue/1
16:56:38 <devyani7> jflory7: bye :)
16:56:47 <threebean> devyani7: so you're looking into the mailing list widget. bee2502_, do you have an idea of what you want to work on?
16:56:57 <fedmsg-hubs> pagure.issue.tag.removed -- duffy removed the hubs tags from ticket fedora-hubs#2 https://pagure.io/fedora-hubs/issue/2
16:57:12 <devyani7> threebean: yes. :) on it !
16:57:12 <fedmsg-hubs> pagure.issue.tag.added -- duffy tagged ticket fedora-hubs#4: ui spec https://pagure.io/fedora-hubs/issue/4
16:57:13 <fedmsg-hubs> pagure.issue.tag.removed -- duffy removed the hubs tags from ticket fedora-hubs#4 https://pagure.io/fedora-hubs/issue/4
16:57:23 <bee2502_> threebean : I have a few issues in mind . Not sure which I should tackle difficulty level wise
16:57:30 <bee2502_> I am interested in : https://pagure.io/fedora-hubs/issue/98
16:57:38 <fedmsg-hubs> pagure.issue.tag.added -- duffy tagged ticket fedora-hubs#7: ui spec https://pagure.io/fedora-hubs/issue/7
16:57:39 <fedmsg-hubs> pagure.issue.tag.removed -- duffy removed the hubs tags from ticket fedora-hubs#7 https://pagure.io/fedora-hubs/issue/7
16:57:48 <mizmo> oh boy that's making a lot of noise - will wait till after meeting
16:58:14 <bee2502_> threebean : https://pagure.io/fedora-hubs/issue/89 and https://pagure.io/fedora-hubs/issue/62
16:58:19 <fedmsg-hubs> pagure.issue.comment.added -- ralph commented on ticket fedora-hubs#98: "#halp/help widget: Default in the CommOps Hub" https://pagure.io/fedora-hubs/issue/98#comment-1973
16:58:25 <bee2502_> what should I tackle first ?
16:58:29 <threebean> mizmo: (ty!)
16:58:57 <fedmsg-hubs> pagure.issue.comment.added -- ralph commented on ticket fedora-hubs#62: "Gource Gif Widget" https://pagure.io/fedora-hubs/issue/62#comment-1974
16:59:34 <threebean> bee2502_: I'd vote for #98 first. I think its going to be the most straightforward and I think you already have experience with those meetbot fedmsg messages.
16:59:37 <threebean> so it seems like a natural fit :)
17:00:16 <bee2502_> threebean : also, we cannot close #97 till #98 is closed - though it should be the other way round
17:00:21 <threebean> the gource-gif one is more of a pipe-dream ticket. I don't think its technically feasible without some major major architecture to support it. it would be neat, but may be out of scope.
17:00:32 <bee2502_> can we remove the dependancy ?
17:00:39 * threebean checks
17:01:01 <fedmsg-hubs> pagure.issue.dependency.removed -- ralph removed ticket fedora-hubs#98 as a dependency of ticket fedora-hubs#[97] https://pagure.io/fedora-hubs/issue/98
17:01:02 <bee2502_> I see re: gource-gif . #98 it is then :)
17:01:23 <fedmsg-hubs> pagure.issue.edit -- bee2502 set the status of ticket fedora-hubs#97 to: Fixed https://pagure.io/fedora-hubs/issue/97
17:01:37 <threebean> bee2502_: dep removed. :)
17:01:56 <fedmsg-hubs> pagure.issue.new -- skamath opened a new ticket fedora-hubs#114: "PEP8 Compatible Code" https://pagure.io/fedora-hubs/issue/114
17:01:57 <mizmo> what is a #help / #halp request? is that some meetbot keyword?
17:02:02 <bee2502_> and closed threebean :) so I will start working on #98
17:02:30 <mizmo> is there a design for the #98 widget?
17:02:32 <threebean> mizmo: yeah - people can call for help in an irc meeting with it. commops has the idea that if they can aggregate those requests, they can use it as a source of work to follow up on. (to connect the dots between teams)
17:02:41 <threebean> mizmo: and no - no design yet that I know of.
17:02:44 <fedmsg-hubs> pagure.issue.comment.added -- skamath commented on ticket fedora-hubs#114: "PEP8 Compatible Code" https://pagure.io/fedora-hubs/issue/114#comment-1975
17:03:02 <mizmo> are there other commops hub tickets in here? i'm happy to do a hub mockup with the widgets they want
17:03:14 <mizmo> i think it makes sense to know what it's supposed to look like
17:03:40 <fedmsg-hubs> pagure.issue.edit -- devyani7 set the status of ticket fedora-hubs#49 to: Fixed https://pagure.io/fedora-hubs/issue/49
17:04:05 <bee2502_> mizmo : only one other issue is tagged but its not a widget : https://pagure.io/fedora-hubs/issues?tags=commops
17:04:05 <mizmo> decause: around?
17:04:10 <fedmsg-hubs> pagure.issue.comment.added -- ralph commented on ticket fedora-hubs#114: "PEP8 Compatible Code" https://pagure.io/fedora-hubs/issue/114#comment-1976
17:04:54 <threebean> mizmo: a mockup for their hub (and others) would be awesome. maybe you guys can connect after the meeting?
17:05:04 <mizmo> works for me threebean
17:05:28 <threebean> oo - I should share this too:
17:05:44 <threebean> mizmo: garrett sent this my way. a different mockup of how hubs could look.
17:05:46 <threebean> https://people.redhat.com/~glesage/project/fedora-hubs/mockup-20160224-groups-teaser-explanations.png
17:06:04 <devyani7> mizmo-mockups++ :)
17:06:05 <threebean> it was different enough from our current design that I wasn't quite sure what to do with it until we could sync up.
17:06:32 <fedmsg-hubs> pagure.issue.comment.added -- duffy commented on ticket fedora-hubs#98: "#halp/help widget: Default in the CommOps Hub" https://pagure.io/fedora-hubs/issue/98#comment-1977
17:07:01 <bee2502_> threebean : could you suggest another widget/issue till we have a mock-up for help/halp widget ?
17:07:16 <mizmo> threebean: ah i like this direction - will need some mods - i want the hubs look & feel to match ryanlerch's awesome new fedora infra skins
17:07:23 <threebean> +1
17:07:38 <threebean> yeah, we should convert over to using his bootstrap resources asap as at least a starting point for that.
17:07:41 * threebean files a ticket for it.
17:07:41 <mizmo> #action mizmo to sync up with garrett re: mockup, work on sync'ing to ryanlerch's fedora infra skin
17:07:48 <garrett> +1
17:08:25 <fedmsg-hubs> pagure.issue.new -- ralph opened a new ticket fedora-hubs#115: "Replace our bootstrap resources with the new fedora themed ones by ryanlerch." https://pagure.io/fedora-hubs/issue/115
17:09:04 <threebean> bee2502_: could you work on that? track down the bootstrap resources used by pagure.io and slip them in place in fedora-hubs.
17:10:28 <bee2502_> threebean : I cannot really understand the issue - but if you can elaborate a bit, I am willing to work on it :)
17:10:40 <threebean> yeah, I can explain more and try to point you in the right direction. :)
17:11:10 <bee2502_> great !
17:11:36 <threebean> ok. :) anyone else have anything for the meeting? I think we've got lots to do.. ;)
17:11:56 <threebean> any other questions? anyone else need help getting set up?
17:13:20 <thunderoy> threebean, have you did something about that fmn issue
17:13:34 <threebean> which issue is that?
17:15:38 <bee2502_> threebean : do we need any more improvements for pagure_pr widget and github_pr widget ?
17:15:46 <bee2502_> Can I close the issue ?
17:16:12 <threebean> bee2502_: not for the moment I think. those can be closed. I have a couple ideas for them, but I'll file those as separate tickets.
17:16:28 <fedmsg-hubs> pagure.issue.edit -- bee2502 set the status of ticket fedora-hubs#36 to: Fixed https://pagure.io/fedora-hubs/issue/36
17:16:40 <threebean> ok. I'm going to close out the meeting, but let's carry on in the ticket tracker and here in #fedora-hubs (and everywhere!)
17:16:41 <threebean> #endmeeting