15:05:02 <mizmo> #startmeeting fedora-hubs
15:05:02 <zodbot> Meeting started Wed Apr 20 15:05:02 2016 UTC. The chair is mizmo. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:05:02 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:05:02 <zodbot> The meeting name has been set to 'fedora-hubs'
15:05:12 <mizmo> #topic roll call
15:05:16 <mizmo> .hello duffy
15:05:17 <zodbot> mizmo: duffy 'Máirín Duffy' <fedora@linuxgrrl.com>
15:05:19 <pingou> thanks, I'll read the logs when I get back and catch up w/ you on anything I see :)
15:05:35 <sayan> .fas sayanchowdhury
15:05:35 <zodbot> sayan: sayanchowdhury 'Sayan Chowdhury' <sayan.chowdhury2012@gmail.com>
15:05:38 <devyani7> .hello devyani7
15:05:39 <zodbot> devyani7: devyani7 'Devyani Kota' <devyanikota@gmail.com>
15:05:44 <pingou> .bye pingou
15:06:01 <mleonova> .hello mleonova
15:06:02 <zodbot> mleonova: mleonova 'Maria Leonova' <mleonova@redhat.com>
15:06:20 <justharshal> .hello justharshal
15:06:22 <zodbot> justharshal: justharshal 'Harshal Bhatia' <harshalbhatia244@gmail.com>
15:07:05 <Dimuthu> hi guys :)
15:07:09 <mizmo> cool
15:07:16 <mizmo> #topic open floor
15:07:38 <mizmo> so what do we want to talk about today? we could run through what we've been working on. the past week or so i've been looking at the design for the tickets widget
15:07:50 <mizmo> https://pagure.io/fedora-hubs/issue/1
15:07:56 <mizmo> anybody else have progress to talk about?
15:09:32 <devyani7> mizmo: me still hacking around tahrir api for the badges issue, had university tests to deal with :/
15:09:56 <Dimuthu> mizmo: is anybody working on that ticket?
15:10:05 <Dimuthu> i meant issue 1
15:10:07 <mizmo> Dimuthu: yeh pingou has been working on it
15:10:19 <mizmo> Dimuthu: he's working on widget configuration in general
15:10:28 <Dimuthu> i can help with it :)
15:10:29 <mizmo> got a pull request in this morning on it for deleting widgets
15:10:39 <mizmo> well let's gather topics to discuss right now
15:10:50 <mizmo> anybody else have something to bring up? (even if it's that you're looking for something to work on)
15:11:16 <pingou> the feed widget needs fixing
15:12:33 <sayan> ircb update: implemented a logging into ircb last week and a lot of code cleaning happened
15:13:02 <sayan> also implemented an ident server
15:13:13 <mizmo> okay cool, let's start going thru the items them
15:13:19 <sayan> soon we will start working on waartaa :)
15:13:22 <mizmo> i want to hit feed widget first since pingou is still here?
15:13:29 <mizmo> #topic feed widget needs fixing
15:13:41 <mizmo> this morning ryanlerch noticed the feed widget wasn't working at all
15:13:54 <devyani7> :O
15:13:57 <mizmo> pingou started looking at it, got it to load but it's very slow - can you give any other details?
15:15:15 <mizmo> well, that's an issue we have to address going forward
15:15:25 <mizmo> #topic tickets widget design
15:15:33 <mizmo> #link https://pagure.io/fedora-hubs/issue/1
15:15:53 <mizmo> so i had some back and forth with ralph on the ticket about what kinds of ticket views would be interesting / helpful for this widget
15:16:12 <mizmo> there's two versions of the widget - one for people, one for projects/teams
15:16:21 <mizmo> the people version shows tickets related to a person, across all proejcts/teams
15:16:30 <mizmo> the project/team version shows all tickets related to a project/team, across all people
15:16:51 <mizmo> the people version so far has two templates or views - tickets i filed, and tickets waiting on me (open and assigned to me)
15:17:34 <mizmo> the project/team has a few, to help wtih triage and such - open tickets that are inactive, new tickets that haven't been triaged, unassigned tickets, open tickets, high activity tickets (lots of comments)
15:17:54 <mizmo> when pingou started working on the widget config stuff i put together some mockups for how adding/editing the widget might work
15:17:58 <mizmo> so thats where the design is on that
15:18:12 <mizmo> example of some of the ticket views: https://pagure.io/fedora-hubs/issue/raw/files/3e4215111e33e4d8770665f3a04b7c746531ffde426be797847e66dce8e36f2d-more-team-tickets.png
15:18:30 <mizmo> example of ticket widget config: https://pagure.io/fedora-hubs/issue/raw/files/2731a01112251c6f9ab86c9ab492ce8936c9b7ee22cecd69cf7724be1393bb9a-bugs-project.png
15:18:49 <mizmo> #topic irc functionality
15:19:01 <mizmo> sayan: do you want to walk us thru your work on ircb, ident, and what you're planning with waartaa?
15:20:16 <sayan> so right now we are working on ircb which is bouncer that will power waartaa
15:20:57 <mizmo> sayan: is ircb part of waartaa or something that helps connect it with hubs?
15:21:18 <sayan> ircb is part of waartaa
15:21:50 <sayan> ircb acts like a bouncer and waartaa connects to it
15:22:08 <sayan> and we will be integrating hubs with waartaa
15:22:49 <mizmo> cool
15:23:01 <sayan> so for ircb we are right now preparing for 0.2 release which will have the Flux architecture implementation
15:23:23 <sayan> IDENT server so that more number of connections are allowed
15:23:48 <sayan> minimalistic API for controlling the bouncer
15:24:22 <sayan> and also good amount of logging
15:24:42 <sayan> so we completed all of the things last week and right now preparing for 0.2 release
15:25:02 <dhriti> .hello dhrish20
15:25:03 <zodbot> dhriti: dhrish20 'Dhriti Shikhar' <dhrish20@gmail.com>
15:25:24 <sayan> after which we will start working on waartaa will be either on React or Angular :) <eom>
15:26:21 <mizmo> awesome
15:26:26 <mizmo> sayan: any thoughts about react vs angular yet?
15:27:28 <sayan> mizmo: rtnpro is the person to answer this :)
15:27:32 <mizmo> okay cool
15:27:41 <mizmo> anything else to report sayan?
15:27:54 <sayan> nope, that all from my side :)
15:29:22 <mizmo> cool
15:29:41 <mizmo> #topic tahrir hacking
15:29:49 <mizmo> devyani7: want to talk about the work you did on tahrir?
15:30:59 * decause returns from another over-time famsco meeting
15:31:02 <decause> .hello decuase
15:31:03 <zodbot> decause: Sorry, but you don't exist
15:31:06 <decause> .hello decause
15:31:07 <zodbot> decause: decause 'Remy DeCausemaker' <decause@redhat.com>
15:31:10 <devyani7> mizmo: i got it set on my machine, still writing the api, not much progress since last week :/
15:31:21 <mizmo> okay cool
15:31:34 <devyani7> :)
15:31:50 <mizmo> #topic open floor
15:31:57 <mizmo> okay so we're open floor again, we ran through everything i think
15:32:07 <mizmo> any general ideas, questions, concerns about hubs as of late?
15:32:21 <mizmo> anybody have something they want mockups / UX help with?
15:33:24 <mizmo> oh
15:33:26 <mizmo> #topic meeting time change
15:33:37 <mizmo> pingou and i were talking about moving the meeting to one hour before we started today on tuesday
15:34:46 <decause> mizmo: welcome back :P
15:34:47 <sayan> +1
15:35:04 <mizmo> ughhh
15:35:08 <mizmo> i have a kernel bug where i type too fast and my system locks up
15:35:10 <decause> +1 to moving the meeting time (hopefully things will calm down a bit with FAMSco after budget season is done)
15:35:10 <mizmo> sorry
15:35:12 <mizmo> so ....
15:35:14 <mizmo> pingou and i were talking about moving the meeting to one hour before we started today on tuesday
15:35:18 <mizmo> it's 1 pm UTC tuesdays
15:35:20 <mizmo> does that work for folks?
15:35:53 <devyani7> +1, no worries :)
15:35:56 <sayan> is it 1pm or 2pm?
15:35:58 <decause> mizmo: 1pm or 2pm?
15:36:09 <Dimuthu> +1
15:36:13 <decause> 9am or 10am EST?
15:36:14 <mizmo> well one hour before we started today
15:36:19 <mizmo> i think it would be 10 am EST
15:36:26 <decause> yeah, so 2pm UTC
15:36:30 <decause> on Tuesdays
15:36:47 <mizmo> ah ok
15:37:04 <sayan> +1 2pm UTC works for me
15:37:10 <mizmo> decause: you are right
15:37:18 <mizmo> #info new meeting time 2pm UTC Tuesdays
15:37:23 <decause> +1 14:00UTC
15:37:27 <decause> kk, great
15:37:34 <mizmo> i think jflory7 owns the fedocal entry so ill have him update it
15:37:36 <jkurik> mizmo: please put the meeting into fedo-cal so we can subscribe to it
15:37:38 <decause> I can too
15:37:46 <jkurik> ah, ok
15:37:50 <mizmo> decause: if if you can update it that would be awesome
15:38:00 <decause> #action jflory7 / decause update Fedocal with new 14:00UTC meeting time for Hubs
15:38:03 <decause> #undo
15:38:11 <decause> mizmo: chair plz :P
15:38:14 * jflory7 will do so shortly
15:38:32 <decause> jflory7++
15:39:09 <mizmo> \o/
15:39:11 <mizmo> cool
15:39:15 <mizmo> #chair decause
15:39:15 <zodbot> Current chairs: decause mizmo
15:39:21 <mizmo> anything else to talk about?
15:40:16 <decause> mizmo: I got one
15:40:22 <mizmo> hit us up!
15:40:34 <decause> #info GSoC Final Slot Selection due by 15:00EST today
15:40:47 <decause> #info GSoC Student Announcements to go out on 4/22
15:41:38 * jflory7 notices there are two Hubs calendar events on CommOps Fedocal
15:41:45 <jflory7> Is one already accurate or are both wrong?
15:42:14 * mizmo unsure
15:42:27 <sayan> I just saw one last week
15:42:40 <justharshal> jflory7: that Confused me last week. I showed up and there was no meeting.
15:42:47 <justharshal> sayan: same here
15:43:03 <jflory7> One is at 15:00 UTC, the other 16:30 UTC it seems
15:43:12 * justharshal uses calendars :P
15:43:19 <sayan> jflory7: 15:00 UTC one is correct
15:45:04 <jflory7> Okay, will delete second one and adjust first to the new time, 14:00 UTC
15:45:31 <jflory7> Oh, decause is the creator for one too
15:45:34 <jflory7> I will just delete mine
15:46:13 <jflory7> #link https://apps.fedoraproject.org/calendar/commops/2016/4/18/#m3863
15:47:29 <mizmo> okay guys anything else or we close out?
15:47:33 <mizmo> decause: did you have something to bring up?
15:48:10 <decause> mizmo: just that GSoC Decisions are imminent :)
15:48:27 <decause> jflory7: I'll delete mine also
15:49:02 <mizmo> okay
15:49:07 <decause> mizmo: there'll be much onboarding effort to align *all* the interns this summer
15:49:13 <decause> RHT, GSoC, and Outreachy
15:49:17 <mizmo> i am not sure who is handling GSoc decisions for hubs
15:49:22 <mizmo> do you know?
15:49:31 <decause> mizmo: :) me/pingou/lmacken
15:49:36 <mizmo> oh okay great
15:50:24 <mizmo> all right i think we're good then
15:50:28 <mizmo> closing in 5...
15:50:30 <mizmo> 4...
15:50:32 <mizmo> 3...
15:50:33 <decause> mizmo++
15:50:34 <mizmo> 2....
15:50:35 <decause> thanks for chairing!
15:50:38 <mizmo> speak now or forever hodl your piece
15:50:41 <mizmo> ...1
15:50:43 <mizmo> #endmeeting