15:01:13 <sayan> #startmeeting fedora_hubs
15:01:13 <zodbot> Meeting started Tue Nov  8 15:01:13 2016 UTC.  The chair is sayan. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:13 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:01:13 <zodbot> The meeting name has been set to 'fedora_hubs'
15:01:43 <sayan> a2batic: abompard: devyani7 jcline mizmo pingou saptaks: meeting time
15:01:54 <sayan> stickster: ^^
15:01:57 <pingou> o/
15:02:00 <mizmo> o/ long time lol
15:02:08 <jcline> It's been so long
15:02:10 <vivek_> \0
15:02:29 <abompard> back for more!
15:02:30 * devyani7 here
15:02:30 <sayan> #topic Roll Call
15:02:37 <vivek_> .hello vivekanand1101
15:02:37 <sayan> .hello sayanchowdhury
15:02:38 <zodbot> sayan: sayanchowdhury 'Sayan Chowdhury' <sayan.chowdhury2012@gmail.com>
15:02:41 <zodbot> vivek_: vivekanand1101 'Vivek Anand' <vivekanand1101@gmail.com>
15:02:41 <jcline> .hello
15:02:48 <zodbot> jcline: (hello <an alias, 1 argument>) -- Alias for "hellomynameis $1".
15:02:48 <jcline> .hello jcline
15:02:48 <abompard> .hello abompard
15:02:51 <zodbot> jcline: jcline 'Jeremy Cline' <jeremy@jcline.org>
15:02:51 <devyani7> .hello devyani7
15:02:53 <zodbot> abompard: abompard 'Aurelien Bompard' <aurelien@bompard.org>
15:02:56 <zodbot> devyani7: devyani7 'Devyani Kota' <devyanikota@gmail.com>
15:03:17 <saptaks> .hello saptaks
15:03:17 <zodbot> saptaks: saptaks 'Saptak Sengupta' <saptak013@gmail.com>
15:03:37 <a2batic> .hello a2batic
15:03:38 <zodbot> a2batic: a2batic 'Kanika Murarka' <murarkakanika@gmail.com>
15:03:48 <stickster> .hello pfrields
15:03:49 <zodbot> stickster: pfrields 'Paul W. Frields' <stickster@gmail.com>
15:04:08 <sayan> #chair vivek_ jcline abompard devyani7 saptaks stickster mizmo pingou
15:04:08 <zodbot> Current chairs: abompard devyani7 jcline mizmo pingou saptaks sayan stickster vivek_
15:04:21 <sayan> #topic Action items from last week
15:04:38 <sayan> * stickster speak to sayan about making the Trello board cards
15:04:41 <sayan> (including USes and backlog tasks) more specific so people can tell
15:04:43 <sayan> what's happening
15:04:45 <sayan> * stickster email devyani7 & cc the hubs-devel list to get an update on
15:04:47 <sayan> this ticket
15:04:49 <sayan> * mizmo update #17 ticket with request for data so she can work on that
15:04:51 <sayan> ticket as she has with #85
15:04:53 <sayan> * vivek_ to update ticket with progress/results of discussion with
15:04:55 <sayan> threebean
15:04:57 <sayan> * mizmo to file RFEs for meetbot - meeting name suggestion list, and
15:04:59 <sayan> reconcile different meeting names / aliases
15:05:01 <sayan> * mizmo to file RFE idea for meetbot / agenda link metadata
15:05:32 * vivek_ has updated the Issue #63.
15:06:09 <stickster> #info FUDCon Phnom Penh travel + conference was most of last week so nothing to report on Trello, but I can talk to sayan now (after meeting) about Trello issues
15:06:43 <mizmo> i think i sent a summary of the issues i opened to hubs-devel
15:06:45 <stickster> I guess we can get a regular update from devyani7 now about issue #11
15:06:54 <stickster> er, not *now* now, but in the agenda now :-)
15:07:00 <sayan> yes, nothing to report from last week.
15:07:28 <devyani7> 1src
15:07:35 <devyani7> Sec*
15:07:41 <mizmo> Oh yep, here's the list of RFEs I opened. I have some stuff to discuss with everybody about meetbot too. https://lists.fedoraproject.org/archives/list/hubs-devel@lists.fedoraproject.org/message/OXOYWVDDMHOWYDQ26UN5XZRFU32DFGJ5/
15:07:54 <fm-hubs> pagure.issue.comment.added -- sayanchowdhury commented on ticket fedora-hubs#17: "Badges Widget for Project/Teams (with Path Support)" https://pagure.io/fedora-hubs/issue/17#comment-39816
15:08:14 <mizmo> I also updated ticket #17 and finished the user badges widget html/css styling sayan (but i think you already knew that)
15:08:44 * devyani7 is facing issues testing her changes since the site loads very slow.
15:08:48 <mizmo> okay cool on #17 sayan - when you've got the data ready to go ping me and i'll do the html/css the same way i did #85
15:08:58 <devyani7> Thus can't populate the bookmarks to overflow
15:09:22 <devyani7> mizmo: sorry, thought you finished. :/
15:09:54 <mizmo> devyani7: no worries. so you can't populate bookmarks to make an overflow bc the site is loading too slowly? do you know what it's churning on?
15:10:39 <devyani7> Am not quite sure. Though I run the server once, but every time it opens a new window with just the current hub bookmark.
15:11:17 <sayan> devyani7: can you look into your browser network tab (Chrome references) and see what clogging?
15:11:25 <devyani7> sayan: ^^
15:11:44 <devyani7> No sayan, I cleared the cache too
15:12:00 <devyani7> :/
15:12:23 <mizmo> devyani7: do you get any errors in the terminal?
15:12:29 <devyani7> Are you suggesting something else?
15:12:38 <sayan> devyani7: I am suggesting this https://developers.google.com/web/tools/chrome-devtools/network-performance/resource-loading
15:12:41 <devyani7> mizmo: nope, no errors
15:13:15 <devyani7> sayan: ah, okay.
15:13:41 <sayan> devyani7: have a look at it and report
15:13:58 * devyani7 nods
15:14:08 <sayan> #topic #halp/help widget: Default in the CommOps Hub https://pagure.io/fedora-hubs/issue/98
15:14:15 <sayan> abompard: update on this?
15:14:43 <abompard> Not much, I worked a bit on mailman and on fedmsg
15:15:14 <abompard> plus I need the result of the discussion about the link between hubs and IRC channels
15:15:36 <stickster> #link https://pagure.io/fedora-hubs/issue/98#comment-34540
15:15:39 <abompard> So I'll follow mizmo's tickets closely
15:15:43 <sayan> #action sayan to test the halp_widget branch
15:16:11 <abompard> currently, it just assumes that the hub name and the irc channel name are the same
15:16:11 <stickster> #info abompard needs discussion about link btween hubs/IRC to be resolved (see above link)
15:16:49 <stickster> yeah, that gets hairy with e.g. #fedora-meeting{-1,-2,...}
15:17:10 <abompard> yeah, we can deal with the meeting channels after
15:17:21 <mizmo> abompard: technically, what do you think is the best way to solve it right? should we have a table somewhere that maps irc channels <=> hubs (where hub == team)
15:17:34 <abompard> mizmo: I would think so
15:17:37 <abompard> in the hubs configuration
15:17:42 <mizmo> abompard: my thought with the IRC widget on each hub page is the hub admin would configure an IRC channel to be affiliated with that hub
15:18:02 <mizmo> that doesn't solve the meeting channel problem, but i think the meeting channel problem could be solved by taking the team name from the meeting topic
15:18:06 <abompard> I'm not sure a widget can access another widget's configuration
15:18:26 <mizmo> would we make it a hub api call, eg getTeamIRCChannel() ?
15:18:28 <abompard> so the meeting topic == hub name ?
15:18:47 <mizmo> abompard: yeh i think so
15:18:56 <sayan> abompard: not always
15:19:03 <mizmo> abompard: although note some teams mess this up, it's an open RFE in m0te at least to map them together
15:19:11 <abompard> hmm it didn't seem obvious with the sample data I used
15:19:26 <mizmo> ^^ https://github.com/fedora-infra/mote/issues/79
15:19:41 <sayan> #link https://github.com/fedora-infra/mote/issues/79
15:19:41 <stickster> #link https://github.com/fedora-infra/mote/issues/107
15:19:47 <abompard> yeah I'll follow that
15:19:55 <abompard> Who works on mote?
15:20:14 <mizmo> abompard: cydrobolt
15:20:19 <stickster> abompard: cydrobolt, and I think jflory7 has recently started contributing
15:20:35 <abompard> mizmo: yeah, just after asking I replied to myself "Use the git log, dummy"
15:20:36 <mizmo> abompard: is m0te where you are getting the data from?
15:20:51 <abompard> mizmo: no I'm just getting the fedmsg
15:20:57 <abompard> from datagrepper
15:21:20 <mizmo> abompard: ah so that might be problematic right? if m0te has stuff that reconciles a team name alias => a real team name, that probably wouldn't go out in the fedmsg?
15:21:33 <abompard> mizmo: probably not indeed
15:22:05 <mizmo> abompard: so i guess if meetbot did it itself - but then that becomes complicated too
15:22:11 <abompard> hmm. Not sure where is the right place to fix this
15:22:20 <sayan> mizmo: we need to add that to meetbot
15:22:25 <mizmo> abompard: meetbot upstream is dead... i talked to nirik about it last week
15:23:02 <mizmo> i think we use the upstream meetbot from debian but nirik is looking at potentially 'upgrading' to the more recently dead openstack fork upstream of meetbot
15:23:22 <abompard> mizmo: oh boy
15:23:46 <jcline> poor meetbot
15:23:52 <abompard> mizmo: we want to upgrade to a less decomposed meetbot
15:24:16 <mizmo> i was looking into seeing if i could add the agenda item RFE to meetbot last week and ran into problems trying to figure out which version to even do it with
15:25:09 <mizmo> abompard: lol less decomposed!!!
15:26:00 <mizmo> relevant ticket: https://pagure.io/fedora-infrastructure/issue/5552
15:26:09 <abompard> OK I'll follow those tickets and try to chime in, even if I don't really know meetbot.
15:26:18 <abompard> That's all I can say about the halp widget
15:26:23 <abompard> don't want to block you here
15:26:29 <mizmo> abompard: iwas looking at the python for meetbot and it looked relatively straightforward
15:26:47 <stickster> mizmo: I thought supybot was more maintained than that
15:26:56 <mizmo> not that i was able to do anything with it - there was some other component i needed to get it to work and it wasn't working -
15:26:59 <mizmo> stickster: oh thats the component
15:27:15 <stickster> oh, you mean supybot-meetbot is the part that's not maintained?
15:27:16 <mizmo> stickster: so we dont use supybot in fedora, we have a newer one, i think supybot is dead too. (meetbot is on top of supybot, two diff projects)
15:27:17 <sayan> stickster: meetbot is the plugin to supybot
15:27:27 <mizmo> what is the name of the new supybot we use... augh, it was a weird name
15:27:37 <mizmo> limnoria
15:27:50 <mizmo> we use limnoria instead of supybot
15:27:56 <sayan> mizmo: Limnoria
15:27:59 <mizmo> it's a newer drop in replacement. yes. bc i was trying to get meetbot running locally and there is no pypi pacage for supybot.
15:28:06 <mizmo> but there is a pypi package for limnoria
15:28:14 <mizmo> abompard: you getting all of this? lol
15:28:15 <stickster> ah gotcha
15:28:21 <stickster> sorry! rathole?
15:28:31 <mizmo> im not sure. tatically what is the right thing to do here
15:28:47 <mizmo> we dont even have a ticket for fixing meetbot to reconcile meeting names
15:28:52 <mizmo> and team names
15:28:57 <mizmo> and would meetbot store that itself?
15:29:16 <mizmo> i think doing the team name reconciliation feature in meetbot is potentially the best way, because then the fedmsgs will have the right team name
15:29:17 <sayan> can't say, need to look into the code of meetbot
15:29:17 * abompard is trying to picture that
15:29:45 <mizmo> having clean meetbot data is going to help hubs all around
15:30:03 <abompard> mizmo: +1
15:30:06 <mizmo> it seems like a rats nest but then again i think part of the side-effect of hubs is to clean some of these things up in our infra, no?
15:30:24 <stickster> mizmo: it seems so
15:30:32 <sayan> mizmo: yes
15:31:44 <mizmo> so less decomposed == 2.5 yrs or so dead https://git.openstack.org/cgit/openstack-infra/meetbot
15:32:00 <pingou> the flies aren't dead yet
15:32:06 <jcline> ooof
15:32:09 * pingou calls Bones
15:32:27 <stickster> ha
15:32:28 <mizmo> or https://github.com/openstack-infra/meetbot
15:32:36 <abompard> It only works on Halloween
15:32:36 <stickster> that doesn't look much newer
15:32:39 <mizmo> eeehhhh i cant watch that show with my eyes open lol
15:32:48 <mizmo> its like game of thrones
15:32:52 <stickster> Oh I thought he was talking about Star Trek
15:32:52 <mizmo> stickster: the debian one is dead since 2009
15:32:55 <stickster> "He's dead Jim"
15:33:02 <abompard> maybe call its name 3 times ?
15:33:04 <stickster> mizmo: ah, def less dead then
15:33:43 <sayan> well they fixed a typo fix in the last commit https://git.openstack.org/cgit/openstack-infra/meetbot/commit/?id=f56a92a74a41833edff5d1e9cbae4675f9800be8
15:34:01 <sayan> s/fix//
15:34:16 <mizmo> well at least one of the committers is very active on github, hopefully would be responsive.
15:34:22 <mizmo> maybe we can find a colleague who works on openstack who could help us get a PR in?
15:35:36 <mizmo> abompard: are you up for this meetbot adventure?
15:37:03 <sayan> mizmo: maybe ping him https://github.com/emonty
15:37:19 <sayan> anyways moving ahead
15:37:43 <sayan> #topic Badges Widget for User Profiles https://pagure.io/fedora-hubs/issue/85
15:38:25 <sayan> No updates on this for last week
15:38:43 * mizmo would like to see an action item for meetbot mess
15:39:59 <abompard> Well it feels like the first thing to do would be to see if the openstack folks are interesting in forming a new upstream with us, right?
15:40:00 <sayan> abompard: can you follow up with nirik and see if we need to collaborate with the openstack folks?
15:40:12 <abompard> yup, will do
15:41:08 <sayan> #action abompard to talk with nirik to check if we need to form new upstream with openstack folks for meetbot
15:41:31 <sayan> #topic Current status in release cycle widget https://pagure.io/fedora-hubs/issue/63
15:41:51 <vivek_> i have updated the issue as i had talked with ralph
15:41:51 <sayan> saptaks: afaik you were having troubles with the setup which is now resolved
15:42:42 <vivek_> and, i don't have any more updates than that because i had to go home for a festival
15:43:11 <vivek_> (i came back today.. and the festivals are over now)
15:43:18 <saptaks> sayan: yes it is now resolved
15:43:37 <devyani7> saptaks++
15:43:37 <zodbot> devyani7: Karma for saptaks changed to 2 (for the f24 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:43:44 <sayan> vivek_: can you start working on the backend? I think we can use this https://fedorapeople.org/groups/schedule/f-25/f-25-all-milestones.ics
15:43:53 <mizmo> thanks :)
15:43:56 <saptaks> I have done the HTML/CSS design of the Release Widget. I will implement it as a widget and send a PR
15:44:05 <sayan> saptaks: in that case you push a PR with screenshot?
15:44:19 <sayan> saptaks: also remember to update the link of the PR in the ticket
15:44:39 <vivek_> sayan: sure. I know i haven't been working ... because of some reason or the other from last one month
15:45:29 <sayan> seems like there was an issue with their college network ^^
15:45:31 <sayan> :)
15:45:33 <sayan> vivek_: sure
15:45:54 <sayan> #action saptaks to send a PR for the frontend of the Release Widget
15:45:57 <vivek_> i hate this. i missed a msg i guess
15:46:09 <sayan> vivek_: no, you did not :)
15:46:13 <vivek_> cool
15:46:40 <saptaks> vivek_: did the internet just disconnect for you too? happened with me
15:46:55 <saptaks> sayan: will send the PR in a day or 2
15:47:08 <sayan> #topic IRC Mention Notifications https://pagure.io/fedora-hubs/issue/32
15:47:14 <sayan> No updates on this from my side
15:47:33 <sayan> #topic IRC Private Messages https://pagure.io/fedora-hubs/issue/27
15:47:44 <sayan> No updates on this too
15:48:12 <mizmo> vivek_, saptaks - this is implementing the wrong mockup btw  - http://saptaks.me/prototypes/fedora_hubs/widget.html  (ticket #63)
15:48:13 <stickster> #info no updates on IRC side due to FUDCon Phnom Penh last week
15:48:47 <vivek_> mizmo: wrong? which one is correct them?
15:48:49 <vivek_> *then?
15:49:03 <mizmo> vivek_: https://pagure.io/fedora-hubs/issue/63#comment-6228
15:49:20 <mizmo> oh unless that's just the innards of it?
15:49:26 <mizmo> there's another one too though below it
15:49:39 <saptaks> mizmo: yes that's just the innards
15:49:42 <mizmo> the status across releases one
15:49:51 <saptaks> Should I implement the other one too?
15:49:54 <mizmo> saptaks: ahh ok. i need to get you better icon art for that
15:49:57 <mizmo> saptaks: yeh if you dont mind!
15:50:17 <mizmo> saptaks: i wonder if it would make sense to make it one widget and tab between the views?
15:50:23 <saptaks> mizmo: that would be great. I just cropped them from the mockup. or I should say I tried.
15:50:27 <sayan> mizmo: yeah, he just cropped them out of the mockup :)
15:50:43 <mizmo> #action mizmo to get saptaks better icon artwork for ticket #63
15:50:57 <saptaks> mizmo: yeah. tab implementation would be good I think. I will work that out.
15:51:51 <mizmo> saptaks: cool!
15:52:09 <mizmo> #action saptaks to look at implementing release status widget designs from #63 as one widget that tabs between the views
15:52:26 <sayan> #info no updates on the Badges side too due to FUDCon Phnom Penh last week
15:53:05 <sayan> #topic Manage Bookmarks Widget (Modal) https://pagure.io/fedora-hubs/issue/11
15:53:16 <sayan> devyani7: did you get to see what's the issue?
15:53:43 <devyani7> sayan: nope, page isn't loading completely
15:54:04 <devyani7> Will check it out tomorrow morning with office network
15:54:19 <devyani7> And ping you back
15:54:26 <sayan> devyani7: no, did you see which request is taking time?
15:54:49 <devyani7> Didn't get you?
15:55:16 <devyani7> Localhost:5000/ralph
15:55:23 <devyani7> Is the page am trying to load
15:56:12 <sayan> devyani7: I mean did you see via the network tab (ref the link I gave) which request is taking time?
15:57:13 <devyani7> sayan: page isn't loading, I blame my network here
15:57:21 <sayan> devyani7: ok :)
15:57:56 <sayan> we are almost at time
15:57:58 <devyani7> Will get back to you tomorrow !
15:58:03 <sayan> Going to open floor
15:58:17 <sayan> #topic Open Floor
15:58:18 * devyani7 raises hand
15:58:24 <sayan> devyani7: yes
15:58:36 <devyani7> sayan: the links in the readme !
15:58:46 <devyani7> Did you get a chance to look into it.
15:59:03 <devyani7> A couple of new contributors pinged me for the same
15:59:06 <sayan> devyani7: yeah
15:59:35 <sayan> devyani7: I could not do much last week
16:00:10 <sayan> devyani7: let me see now itself
16:00:15 <devyani7> Ok
16:00:28 <devyani7> I gave them my old readme file
16:00:51 <jcline> Ah yeah, the docs need to be built and pushed to pagure
16:01:16 <sayan> jcline: you mean here https://pagure.io/docs/fedora-hubs/
16:01:20 <devyani7> jcline: I see.
16:01:49 <jcline> Yeah, there's a git repo that backs that. I found the Pagure docs on how to do that, let me go dig them up
16:02:16 <jcline> sayan, https://docs.pagure.org/pagure/usage/using_doc.html
16:02:29 <sayan> https://docs.pagure.org/pagure/usage/using_doc.html
16:02:40 <sayan> jcline: thanks
16:03:10 <sayan> #action sayan to fix the fedora hubs docs
16:03:21 <sayan> Going over and ending the meeting
16:03:28 <sayan> #endmeeting