#fedora-meeting-1 Meeting

Meeting started by quaid at 19:30:22 UTC (full logs).

Meeting summary

  1. http://fedoraproject.org/wiki/Better_GSoC_umbrella_org (quaid, 19:30:51)
    1. https://fedoraproject.org/wiki/Summer_Coding_SIG (quaid, 19:39:42)
    2. http://gsoc-wiki.osuosl.org/index.php/Saturday_Sessions_2009/Umbrella_Organizations (loupgaroublond, 19:41:54)

  2. Rough schedule for present to March 2010 (quaid, 19:45:58)
    1. http://blog.chris.tylers.info/index.php?/archives/217-StudentProject-keyword-in-Fedora-Bugzilla.html (quaid, 19:59:40)

  3. workflow and improving processes (quaid, 20:01:39)
    1. http://gregdek.livejournal.com/55670.html (quaid, 20:02:58)
    2. AGREED: special online location for students to interact that logs (e.g. MUD) (quaid, 20:14:48)
    3. AGREED: student sourced proposals have the highest chance of success. (quaid, 20:37:38)
    4. AGREED: mentors provide a defined problem statement, a proposed objective/deliverable. Task chunking and problem solving is up to the student. (quaid, 20:38:10)
    5. quaid: Summer Coding SIG focus includes overseeing GSoC while growing the mentoring practice of all involved organizations; this is good strategy and innovation growth. (quaid, 20:59:47)
    6. We need to start working on process of how we are going to attract and handle student proposals now, in advance of the Google schedule announcement; this work is useful regardless of ongoing GSoC participation. (quaid, 21:01:09)
    7. Attracting students from within the existing projects and upstream communities is a good method for successful projects with a bigger impact. (quaid, 21:02:06)
    8. AGREED: Require sub-project/mentor commitment early. Enable the pool of upstreams that can be accessed through jboss.org/fedoraproject.org rather viewing each as "From {Fedora,JBoss}" (quaid, 21:04:27)
    9. IDEA: put proposals in to a spreadsheet in Melange and invite all upstreams to participate in the proposal process more fairly. (quaid, 21:06:00)
    10. IDEA: admins can be empowered to rank proposals, evaluate mentors, and potentially apply non-transparent decision processes for the betterment of the overall umbrella effort. (quaid, 21:06:55)
    11. IDEA: continue focusing on lowered barriers between projects post evaluation (e.g. shared blog planets, etc.) (quaid, 21:07:38)
    12. ACTION: quaid to produce a schedule from past experience & this meeting log (quaid, 21:08:08)
    13. ACTION: send summary of this discussion to mentors list (quaid, 21:08:18)
    14. ACTION: quaid to suggest jira.jboss.org admins add a checkbox for student_project (quaid, 21:08:47)
    15. AGREED: on-list discussion of how we evaluate projects at a granular level -- process discussion amongst mentors (quaid, 21:09:47)
    16. AGREED: transparency and strong admins will prevent the potential "more @foo mentors can up-vote their favorites" concerns of previous years. (quaid, 21:18:58)
    17. AGREED: student integration needs to be upstream (in the actual coding project), mentors need to integrate downstream (Summer Coding SIG) (quaid, 21:19:50)


Meeting ended at 23:04:05 UTC (full logs).

Action items

  1. quaid to produce a schedule from past experience & this meeting log
  2. send summary of this discussion to mentors list
  3. quaid to suggest jira.jboss.org admins add a checkbox for student_project


Action items, by person

  1. quaid
    1. quaid to produce a schedule from past experience & this meeting log
    2. quaid to suggest jira.jboss.org admins add a checkbox for student_project


People present (lines said)

  1. quaid (147)
  2. loupgaroublond (86)
  3. pilhuhn (44)
  4. sankarshan (32)
  5. abadger1999 (30)
  6. spevack (2)
  7. zodbot (2)


Generated by MeetBot 0.1.4.