16:59:46 <spot> #startmeeting Fedora Packaging Committee
16:59:46 <zodbot> Meeting started Wed Dec 14 16:59:46 2011 UTC.  The chair is spot. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:59:46 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:59:48 <spot> #meetingname fpc
16:59:48 <zodbot> The meeting name has been set to 'fpc'
16:59:52 <tibbs|h> Howdy.
16:59:57 <spot> #topic Roll Call
17:00:10 * limburgher here
17:01:04 <spot> ping: abadger1999, geppetto, rdieter
17:01:15 * abadger1999 here -- has to get door though
17:01:17 <abadger1999> brb
17:01:29 <spot> abadger1999: don't let that door get away!
17:01:42 <limburgher> I use blowdarts, typcially.
17:01:56 <limburgher> Can drop a double garage door at 15 meters.
17:02:14 * abadger1999 back
17:03:38 * spot notes that we currently have four people, which is not quorum
17:03:56 <spot> but i'll wait.
17:07:50 * spot has spent the last several days legal auditing texlive2011
17:07:59 <spot> so i'm a bit loopy, be forewarned
17:08:02 <limburgher> Oh you poor thing.
17:08:03 <tibbs|h> Really?
17:08:20 <tibbs|h> I was going to try and be involved with some of that.
17:08:32 <spot> tibbs|h: you still can be.
17:08:52 <tibbs|h> I'll have to read up on the current status.
17:09:04 <spot> i'm just waiting for jindrich's feedback then i'll make a new wiki page and send out emails about it
17:09:09 <tibbs|h> People around here are asking why our tex install is so old.
17:12:35 * geppetto is here
17:13:57 <spot> hey!
17:13:59 <spot> thats five.
17:14:18 <spot> #topic Updated Eclipse Guidelines - https://fedorahosted.org/fpc/ticket/122
17:14:49 <spot> So, the original reporter added the broken out macros, but wants to keep the "super macro". I don't think that is a good idea.
17:16:25 <tibbs|h> I mostly agree.
17:16:50 <tibbs|h> I mean, I guess there is simplification to be had if we were to allow this kind of thing all over the distro.
17:17:12 <spot> i just think it is a recipe for confusion and error
17:17:19 <spot> "but I don't have a %posttrans!"
17:17:46 <geppetto> Yeh, I mean it's like 1 simple (very maigc) line vs. 6 simple lines
17:18:03 <spot> geppetto: indeed.
17:18:55 <spot> so, lets kick it back to them to amend their draft to drop the magic macro entirely and we'll revisit this next week
17:19:19 <tibbs|h> +1.
17:19:32 <limburgher> Agreed.
17:20:16 <spot> okay. next!
17:20:33 <spot> #topic Update Emacs Guidelines - https://fedorahosted.org/fpc/ticket/124 - https://fedoraproject.org/w/index.php?title=PackagingDrafts%2FEmacs-Dec2011&action=historysubmit&diff=262887&oldid=262760
17:21:06 <spot> Honestly, like emacs, these guidelines were a bit confusing before, and are still a bit confusing, just in a different way.
17:21:10 <tibbs|h> Crap, I didn't read up on this.
17:21:26 <limburgher> tibbs|h: Might not have helped. :)
17:21:31 <spot> That said, I generally assume that jgu knows what he's talking about
17:21:40 <spot> and it seems to be reasonably sane enough
17:21:48 <spot> so i'm inclined to give him the benefit of the doubt.
17:22:15 <limburgher> That would certainly be simpler.
17:22:33 <limburgher> I don't see anything that jumps out at me as Bad.
17:22:36 <spot> and it does drop the major oddity of the current text, which is the -el subpackage
17:22:55 <spot> so, I'm +1
17:23:42 <limburgher> +1
17:23:58 <abadger1999> +1
17:24:16 <geppetto> yeh, I kind of prefer to not ship the .el files … given no sane person can read them … but we don't require that for python, so it seems selfish
17:24:18 <geppetto> +1
17:25:12 <geppetto> And, to be fair, anyone installing emacs is probably not caring about a minimal install much
17:25:45 <tibbs|h> Still trying to read.
17:26:05 <tibbs|h> Most of it appears to be minor cleanups and eliminating the -el package (and stuffing the source files into the main package).
17:26:09 <limburgher> geppetto: heh.
17:26:16 <tibbs|h> Which sounds great to me.
17:26:42 <spot> tibbs|h: yeah, thats a good summary of the changes.
17:26:59 <tibbs|h> Not like the el files take much space.  (And maybe I am insane; I did a good bit of elisp work about half a lifetime ago.)
17:27:15 <limburgher> tibbs|h: RMS can probably sing them.
17:27:23 <spot> tibbs|h: no one here is presuming you retain any sanity. ;)
17:28:14 <tibbs|h> I also want to make sure he's not sneaking in any requirement that if there's an el file anywhere in a package, you have to go through the whole emacs packaging mess.
17:28:27 <tibbs|h> There was an argument over this last time.
17:28:29 <geppetto> tibbs|h: Some of them are pretty big: repoquery --qf '%{ui_nevra} %{size}' \*-el
17:29:28 <spot> tibbs|h: i don't think he did
17:29:46 <spot> if he did, it snuck past two readings of it for me
17:31:28 <tibbs|h> So according to that repoquery, some packages get bloated quite a bit.  (11MB in one case).
17:31:34 <limburgher> And a cursory Ctrl-Fing.
17:31:38 <tibbs|h> Is that something we care about?
17:33:08 <tibbs|h> repoquery --qf '%{ui_nevra} %{size}' \*-el|sort -n -k 2
17:33:54 * spot points to geppetto's comment
17:34:01 <tibbs|h> Although that list includes some unrelated pacakges for whatever language 'el' is.
17:34:35 <spot> el is greek
17:34:40 <tibbs|h> I can sacrifice 14MB to have emacs, I guess.
17:34:55 <geppetto> ^another
17:35:00 <limburgher> tibbs|h: A pittance, really, for such a fine OS.
17:35:38 <spot> limburgher: i hear it boots the hurd
17:35:43 <tibbs|h> Anyway, I guess if nobody here cares then I'm not really going to do so.
17:35:48 <tibbs|h> So +1.
17:35:51 <spot> #action Draft update to emacs guidelines approved (+1:5, 0:0, -1:0)
17:36:25 <spot> and with that, the agenda is done for this week
17:36:25 <tibbs|h> And for the record, I use both emacs and vi.  Right next to each other.
17:36:28 <spot> #topic Open Floor
17:36:58 <limburgher> spot: :)
17:38:05 <tibbs|h> Nothing from me.
17:38:13 <abadger1999> spot: any update from lennart on that systemd ticket?
17:38:21 <spot> abadger1999: none whatsoever.
17:38:32 <abadger1999> Okay.
17:38:32 <tibbs|h> Are we done with the usrmove thing?
17:38:45 <spot> tibbs|h: it is still blocked on panu accepting that patch
17:38:52 <spot> is that bug closed->rawhide?
17:39:15 <tibbs|h> I thought panu said it was OK with him.
17:39:39 <tibbs|h> Of course, it still needs to actually get in a package at some point, but do we need to wait for that?
17:39:48 <spot> tibbs|h: i guess we don't have to.
17:40:12 <spot> i think i will be spending this afternoon doing writeups (there is quite a backlog)
17:40:16 <spot> so i'll just do it then
17:48:28 <abadger1999> welp, nothing more from me.
17:48:36 <limburgher> nor me.
17:48:56 <spot> okay. closing it out then
17:48:59 <spot> thanks everyone
17:49:00 <spot> #endmeeting