17:06:58 <abadger1999> #startmeeting
17:06:58 <zodbot> Meeting started Wed Jan  4 17:06:58 2012 UTC.  The chair is abadger1999. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:06:58 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:07:04 <abadger1999> #meetingname fpc
17:07:04 <zodbot> The meeting name has been set to 'fpc'
17:08:16 <abadger1999> #topic Eclipse Guidelines https://fedorahosted.org/fpc/ticket/122
17:08:47 <tibbs|h> Oh, hmm, looks like he asked a question there.  I don't know the answer.
17:09:37 <limburgher> 50-50 shot.
17:09:51 <limburgher> Not that that helps.
17:10:06 <tibbs|h> We could tackle that guideline first, I guess, but I'm hesitant to delay this further.
17:11:05 <tibbs|h> Otherwise I think the draft is pretty good.
17:11:49 <tibbs|h> I do have to admit that I really don't get the plugin1/plugin2 thing, though.
17:11:57 <limburgher> And it would be good to have this in the wild sooner rather than closer to freezes, branches, etc.
17:12:44 <tibbs|h> And I really don't understand why plugin1 and plugin2 appear nowhere outside of the glossary at the top.
17:14:56 <tibbs|h> But then again, that was in the original guideline, so things haven't gotten worse.
17:15:54 <abadger1999> yeah
17:16:00 * spot is here now, sorry
17:17:20 <abadger1999> I'm ready to vote on this I think.
17:17:22 <abadger1999> +1 from me
17:17:26 <spot> +1
17:17:41 <tibbs|h> I agree, but we do need to answer his open question before he can implement things.
17:18:06 <abadger1999> The rpm-state directory.... I think the guideline should own it.
17:18:30 <tibbs|h> Not sure what you mean by that.
17:18:34 <limburgher> +1
17:18:39 <abadger1999> I'll make sure we add a notice that it no longer needs to be owned in F17 if we approve that and get it into the rpm package
17:18:56 <abadger1999> tibbs|h: Was the rpm-state directoy the open question?
17:19:09 <tibbs|h> Yes; I just didn't know what you meant by "the guideline should own it".
17:20:03 <abadger1999> ah, sorry  --- the eclipse guideline should say for packages to own the dir
17:20:15 <abadger1999> err
17:20:25 <abadger1999> Have the eclipse package own the dir
17:20:47 <abadger1999> Sorry again :-)  I misremembered that each package would own it vs the main eclipse package.
17:20:47 <spot> I think the eclipse package should own that dir
17:21:03 <tibbs|h> At least for now, that makes sense.
17:21:10 <spot> that dir = %{_localstatedir}/lib/rpm-state/eclipse
17:21:17 <tibbs|h> I was misremembering as well.
17:22:07 * spot sees +3 on this draft
17:22:17 <tibbs|h> OK, I'm +1 on the proposed changes, though I do think we might want to ask him if he wants to mess with the glossary at the top.
17:22:25 <rdieter> +1
17:22:31 <rdieter> and what about the parent %{_localstatedir}/lib/rpm-state/ ?
17:22:49 <rdieter> own that one too?
17:22:54 <limburgher> Shouldn't that be rpm?
17:22:57 <abadger1999> rdieter: eclipse to own that as well until we get it into rpm.
17:22:59 <limburgher> That owns it?
17:23:01 <spot> [spot@wolverine master]$ rpm -qf /var/lib/rpm-state
17:23:01 <spot> GConf2-3.2.3-1.fc17.x86_64
17:23:06 <geppetto> lol
17:23:09 <rdieter> abadger1999: ok
17:23:12 <limburgher> <headdesk>
17:23:14 <abadger1999> rdieter: which would be current rawhide.
17:23:43 <abadger1999> limburgher: currently, GConf is the only package which makes use of a state directory during an rpm transaction.
17:23:44 <tibbs|h> Multiple ownership isn't exactly a problem.
17:23:51 <spot> tibbs|h: agreed. it was just humorous.
17:23:51 <geppetto> +1 … although I think eclipse shouldn't joint own the rpm dir. too … just get rpm changed "quick".
17:23:58 <tibbs|h> It would just be nice conceptually to clean this up.
17:24:19 <limburgher> abadger1999:  So that's fine, as long as that's true.
17:24:20 <spot> so, i see +6 here
17:24:24 <abadger1999> #chair tibbs|h spot limburgher rdieter geppetto
17:24:24 <zodbot> Current chairs: abadger1999 geppetto limburgher rdieter spot tibbs|h
17:24:51 <spot> #action Draft approved, minor cleanups may be requested in the ticket and directory ownership notes amended (+1:6, 0:0, -1:0)
17:25:17 <spot> tibbs|h: please add notes to the ticket about the summary cleanup request
17:25:34 <tibbs|h> Doing that now.
17:25:37 <spot> and it would be awesome if someone could file a bug on the ownership in rpm thing
17:26:11 * abadger1999 will do so once we pass ticket 125
17:27:11 <spot> abadger1999: you may need to update that draft to use /var/lib/rpm-state
17:27:14 <spot> instead of /var/lib/rpm
17:27:30 * abadger1999 does so
17:27:52 <spot> #topic Writing Scriptlets - https://fedorahosted.org/fpc/ticket/125 - https://fedoraproject.org/wiki/User:Toshio/Writing_scriptlets
17:28:36 <spot> abadger1999: i like your draft, the only other thing I would add is that it isn't just crossing boundaries that is a concern
17:28:51 <spot> we don't want scriplets that have %pre embedded in them, for example
17:29:15 <spot> or, to be clear, the boundary isn't "no %pre and %post, but rather, no %pre or %post"
17:29:41 <spot> the macro should only contain the meat that would otherwise be expanded and placed below the scriptlet identifier
17:29:41 <abadger1999> ah right.  Make it obvious that adding the start of section is what we want to prevent.
17:29:57 <rdieter> fine by me, +1
17:29:59 <abadger1999> directory name updated.
17:30:13 <spot> with that clarification made, i'm +1
17:30:48 <geppetto> Yeh … maybe it's easier to explain it as "needing the ability to combine one or more of these macros"
17:31:03 <geppetto> But, yeh, +1
17:31:18 <tibbs|h> +1 here.
17:31:20 <limburgher> +1
17:31:39 <spot> i see +5 on the floor, i assume abadger1999 is +1 on his own draft
17:31:54 <abadger1999> Draft updated.
17:31:55 <abadger1999> +1
17:31:56 <tibbs|h> But this does beg the question of what other scriptlets we could make run once in %posttrans.
17:32:41 <tibbs|h> If it were possible to do ldconfig that way we'd see some nice speedups.
17:32:55 <spot> tibbs|h: yes, it would be interesting to review existing scriptlets to see where optimizations could occur
17:33:21 <spot> #action draft approved (+1:6, 0:0, -1:0)
17:33:27 <abadger1999> ldconfig -- probably not generally as something later in the transaction may depend on the library being found by the dynamic loader.
17:33:40 <spot> abadger1999: yeah, i think you're right.
17:33:46 <abadger1999> But there are other things that would benefit.
17:34:00 <limburgher> icon-cache, desktop files.
17:34:26 <limburgher> scratch desktop.  Coffer_FAIL
17:34:29 <limburgher> Coffee.
17:34:32 <limburgher> jeebus.
17:34:51 <tibbs|h> I've never been sure if ldconfig merely optimized things or if the linker only consults the cache if it exists.
17:34:57 <rdieter> abadger1999: I thought ldconfig thing was just a cache, it would still *work* without it, just be slower?
17:35:10 <abadger1999> rdieter: if it still works, then that would be fine.
17:35:15 <spot> i think 126 is the only other ticket on the agenda
17:35:26 <abadger1999> I haven't looked at what it does since before Linux switched from a.out to elf format.
17:35:38 <tibbs|h> 126 just showed up.
17:35:48 <spot> yeah
17:36:01 <tibbs|h> Anyone checked to see if our standard questions are answered?
17:36:08 <spot> and i'm not sure there is enough there to explain why Wx-Scintilla can't be unbundled
17:36:09 <tibbs|h> I seem to remember spending time on scintilla in the past.
17:37:18 <limburgher> Yeah, it looks like they're willing to try upstream's version.
17:37:19 <spot> oh wait, there it is at the bottom, heavily modified
17:38:48 <limburgher> But I get the impression they modified it in part because it was old.  I wonder how many of those mods are relevant WRT current upstream.
17:39:18 <abadger1999> yeah
17:39:18 <spot> yeah. i think if they are able to use the system copy of a modern Scintilla, it would resolve the need for a bundling exception entirely
17:39:52 <spot> i think we should just ask marcela to try to do that, and only if that is not possible or practical will we consider the bundling exception
17:40:02 <limburgher> So I think I'd like to see the results of that attempt, and if it fails, the needed mods to justify the bundling documented.
17:40:11 <limburgher> spot: agreed.
17:40:59 <abadger1999> rdieter: Do you know about the qtscintilla exception mmaslano mentions?
17:42:17 <rdieter> abadger1999: where does mmaslano say that?
17:42:42 <abadger1999> rdieter: https://bugzilla.redhat.com/show_bug.cgi?id=757657#c2
17:42:49 <rdieter> ok
17:44:24 <rdieter> honestly, qscintilla's is very legacy, been around a long time, haven't ever looked that the bundling too closerly
17:44:27 <rdieter> closely even
17:44:55 <tibbs|h> Yes, it is probably bundled in three or four other places in the distro.
17:45:41 <limburgher> Oh, yay.
17:45:44 <tibbs|h> I think eric bundles it, for example.
17:45:53 <tibbs|h> There was a time when we didn't particularly care.
17:46:16 <tibbs|h> /usr/lib/python2.7/site-packages/eric4/QScintilla
17:46:16 <rdieter> tibbs|h: eric doesn't bundle, it uses qscintilla (that's the bundling)
17:47:15 <tibbs|h> Oh, eric bundles a pile of other things too.
17:47:28 <limburgher> tibbs|h:  I know, and there's lots of grandfathered things all over the place for lots of guidelines.  *cough*mergereviews*cough*
17:47:31 <tibbs|h> Pygments, SimpleJSON,
17:47:41 <tibbs|h> Why did I have to look?
17:47:48 * rdieter whaps tibbs|h
17:47:57 <spot> anyways
17:48:00 <spot> #topic Open Floor
17:48:10 * spot is a bit cranky and hungry
17:48:33 <rdieter> If there's spare time, would like opinions on a prob I found with icon scriplets
17:48:33 <tibbs|h> Yeah, I'm done.Did 122 get updated with the vote results?
17:48:51 <rdieter> .bug 771487
17:48:53 <zodbot> rdieter: Bug 771487 icon theme cache not removed on uninstall - https://bugzilla.redhat.com/show_bug.cgi?id=771487
17:49:16 <spot> tibbs|h: i was waiting for you to commit your comment
17:49:42 <tibbs|h> Ah, I was waiting for the vote results.
17:49:49 <tibbs|h> ABBA deadlock
17:50:12 <limburgher> There was something in the air last night. . .
17:50:12 <tibbs|h> I do not know what trac will do if two people comment at the same time.
17:50:27 <geppetto> last one gets screwed
17:50:30 <rdieter> seems largish stale icon-theme.cache files get left behind when one uninstalls icon themes
17:50:51 <tibbs|h> rdieter: That is indeed a problem.
17:51:06 <spot> yeah, i think gtk-update-icon-cache needs some love
17:51:10 <rdieter> I'm hoping gtk-update-icon-cache maintainer(s) can simply make it deal with that case
17:51:18 <spot> who is the maintainer?
17:51:23 <rdieter> it's in gtk2
17:51:35 <spot> okay, so it is mclasen
17:51:43 <tibbs|h> Fixing g-u-i-c would seem to involve the least work.
17:51:47 <rdieter> not that this happens all that often
17:52:27 <rdieter> tibbs|h: yeah, else we could change the scriptets to handle that in umpteen pkgs. :(
17:52:35 <tibbs|h> Right.
17:52:42 <rdieter> k, let's wait-n-see then
17:54:02 <spot> tibbs|h: please let me know when you have commented
17:54:07 <spot> so i don't make trac angry
17:54:24 <tibbs|h> Doneded.
17:55:18 <spot> okay, if there is nothing else, i need to eat before i fall over
17:55:23 <spot> thanks everyone, happy new year
17:55:25 <spot> #endmeeting