17:04:46 <spot> #startmeeting Fedora Packaging Committee
17:04:46 <zodbot> Meeting started Wed Jan 11 17:04:46 2012 UTC.  The chair is spot. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:04:46 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:04:50 <spot> #meetingname fpc
17:04:50 <zodbot> The meeting name has been set to 'fpc'
17:04:53 <spot> #topic Roll Call
17:05:04 * limburgher here
17:05:20 * abadger1999 here
17:05:24 * racor here
17:06:41 <spot> i saw geppetto
17:06:52 * geppetto is here
17:06:58 <spot> so, yes, with me thats 5
17:09:07 <spot> #topic https://fedorahosted.org/fpc/ticket/109
17:09:08 <Rathann> ah
17:09:11 <Rathann> hi
17:09:15 <Rathann> sorry :)
17:09:19 <spot> Rathann: we just started, no worries
17:09:47 <spot> so, on the csmith exception
17:10:20 <spot> they are asking to include bundled copies of glibc headers
17:10:29 <spot> which i do not think we want to permit
17:10:37 <limburgher> Goodness no.
17:11:02 <spot> does anyone disagree?
17:11:26 <geppetto> which headers?
17:11:40 <Rathann> don't we have glibc-devel for that?
17:11:46 <spot> looks like stdint.h and limits.h
17:12:01 <racor> what are we voting on #109, csmith?
17:12:30 <geppetto> 127 is the headers thingy
17:12:38 <spot> oh, sorry. my bad.
17:12:42 <spot> too many things open. :/
17:12:59 <racor> thanks, #127
17:13:00 <spot> #topic https://fedorahosted.org/fpc/ticket/127
17:13:03 <spot> 109 is done
17:13:55 <geppetto> Ok … so yeh, in this case I'd be -1 … and tell upstream to redo his crack in such a way that he can do #ifdef BLAH #include <stdint.h> #else #include "my-custom-stdiunt.h" #endif
17:14:14 <geppetto> And then check at build time that BLAH is fine to be true for Fedora.
17:14:29 <abadger1999> -1 to the exception, at least without other justification than presently given.
17:14:40 <spot> -1 as well
17:14:47 <limburgher> -1 with gusto.
17:15:02 <Rathann> -1 from me, too
17:15:04 <racor> Needs careful analysis, but for now my gut feeling is: This package is broken, their approach is broken => -1
17:15:33 <spot> #action Request for bundling denied (+1:0, 0:0, -1:6)
17:15:47 <spot> abadger1999: would you be willing to comment there to explain why?
17:16:00 <abadger1999> spot: Yep, I'll do so.
17:16:36 <spot> lets do the rubber stamp items
17:16:44 * rdieter is around now, sorry to be tardy
17:16:57 <spot> #topic https://fedorahosted.org/fpc/ticket/130 - yet another md5
17:17:06 <geppetto> +1
17:17:10 <spot> +1
17:17:25 <limburgher> +1
17:17:40 <abadger1999> +1
17:18:16 <racor> -1, is not useful to track individual files
17:18:54 <Rathann> looks fine, +1
17:19:08 <Rathann> racor: we're already tracking copylib md5 implementations
17:20:32 <racor> Pardon, but I am now expecting you to add a bundled(xx) for each and every symbol some library might have copied form somewhere, comprising all hacked up copies of BSD snippets
17:20:34 <limburgher> If we track all of them, maybe someday, in the bright, gleaming future, we could eliminate them. :)
17:21:02 <racor> all you are doing is to pollute rpms's DB
17:21:03 <spot> #action Bundling of new md5 type approved (+1:5, 0:0, -1:1)
17:22:20 <Rathann> racor: obviously, the solution is to provide a system-wide library and patch all users to use it, but someone has to do it
17:22:37 <Rathann> until then, a sensible solution is to at least track them
17:22:42 <spot> #topic Open Floor
17:23:00 <racor> rathann: In case of md5 yes, but not in case of the strpcpy etc. you missed
17:23:18 <rdieter> sorry, got pulled away, consider me +1 for ticket 130
17:23:28 <rdieter> (if it matters)
17:23:47 <geppetto> racor: I think it's fair to say that md5 is slightly more complex than strpcpy
17:24:04 <geppetto> racor: I'd also say that anything using strpcpy is probably beyond hope anyway.
17:27:22 <spot> okay, i hear nothing
17:27:28 <spot> and i am stupidly busy today
17:27:31 <spot> so thanks everyone
17:27:34 <spot> #endmeeting