17:08:25 <spot> #startmeeting Fedora Packaging Committee
17:08:25 <zodbot> Meeting started Wed Feb  8 17:08:25 2012 UTC.  The chair is spot. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:08:25 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:08:29 <spot> #meetingname fpc
17:08:29 <zodbot> The meeting name has been set to 'fpc'
17:08:45 <spot> #topic Roll Call
17:09:04 * limburgher here
17:09:10 * racor here
17:09:11 * spot is here
17:09:17 * geppetto is here
17:09:43 * abadger1999 here
17:10:08 <tibbs|h> Howdy.
17:10:17 <spot> rdieter_work, SmootherFrOgZ: fpc ping
17:10:59 <spot> okay then. that's 6.
17:11:33 <spot> #topic Bundled exception for psi-plus - https://fedorahosted.org/fpc/ticket/137
17:12:36 <spot> i was somewhat hoping we'd have rdieter here for this one
17:13:25 <tibbs|h> Yeah, he's more familiar with the issue and I'd personally defer to him on this.
17:14:09 <geppetto> It's not the end of the world if we just table it until next week, is it?
17:14:15 <spot> nope.
17:14:48 <spot> #action tabling this item for next week, hoping for input from rdieter.
17:15:08 <spot> #topic New guidelines for Ruby - https://fedorahosted.org/fpc/ticket/134
17:15:10 <tibbs|h> Maybe Rex will show up.
17:15:39 <tibbs|h> That came out wrong; maybe he'll drop in later in this meeting.
17:15:47 <spot> So, it seems that upstream wants to use /usr/share/gems after all
17:15:57 <spot> well, by upstream i mean "the ruby packagers"
17:16:28 <geppetto> Yeh, /usr/share/gems seems fine on it's own … it's just that /usr/share/gems/gems that seems retarded.
17:16:38 * geppetto shrugs
17:16:52 <spot> yep. but that last dir is part of the gem standard layout
17:16:55 <tibbs|h> This whole thing appears to be fail.
17:16:58 <geppetto> yeh
17:16:59 <spot> so we can't really expect that to change
17:17:03 <limburgher> <sigh>
17:17:26 <tibbs|h> I got sort of a "how dare you question our draft" vibe from the comments.
17:17:29 <racor> do we meanwhile have example packages?
17:17:56 <spot> rubygem-metaclass for pure Ruby gem
17:17:57 <spot> rubygem-json for Ruby gem with c extension
17:17:57 <spot> rubygem-gettext for Ruby gem with normal library
17:18:00 <geppetto> spot: Yeh, but I don't understand what's wrong with /usr/share/ruby
17:18:15 <tibbs|h> As far as I know, the ruby folks are busily converting packages and approving new ones that follow their draft before it's been approved.
17:18:19 <spot> geppetto: it wasn't suggested to them.
17:18:31 <geppetto> spot: I thought you suggested it, or something very similar.
17:18:47 <spot> i suggested /usr/share/rubygems/
17:18:55 <geppetto> yeh, same thing.
17:19:16 <spot> they pointed out that the directory is already used by the "rubygems" library
17:20:40 <limburgher> should that not be in /usr/lib*?
17:20:56 <spot> limburgher: no, because it is a ruby library
17:21:00 <abadger1999> Ugh.
17:21:09 * abadger1999 doesn't like aspects of the draft as written
17:21:27 <spot> there are no arch-specific bits in "rubygems" the package
17:21:32 <limburgher> Ah, I see.
17:21:53 <spot> limburgher: "rubygems" also lays out the filesystem layout for ruby gems to use, including /usr/share/gems/gems
17:22:21 <spot> i'm not sure i care enough about the naming at this point to mandate that as a change.
17:22:54 <spot> so, the only remaining big area of concern is how to patch packages with C-extension libs
17:23:06 <limburgher> Just so long as we don't end up with /usr/share/gems/gems/gems/eggs/sausage/gems/
17:23:30 <limburgher> spot: and that i'm still foggy on.
17:23:34 <tibbs|h> Well, they say that you do the usual gem install, then you patch, then "you recompile" but I don't know how the latter works.
17:23:34 <spot> limburgher: no, i think the hierarchy below /usr/share/gems/ is only one level deep
17:23:39 <spot> tibbs|h: exactly
17:24:01 <limburgher> spot: good.
17:24:17 <spot> well, two levels, but still
17:24:31 <spot> its /usr/share/gems/$type/$package/
17:24:42 <spot> where $type is either cache, doc, gems, or specification
17:24:47 <limburgher> epicycles of turtles. . .
17:25:45 <spot> so, i think i'd need to see them add an example of how to patch & recompile a C lib before i could even think about approving this
17:26:15 <limburgher> I sort of hoped we'd have that by now.
17:26:15 <spot> the logic makes sense, but because i'm not a ruby person, i don't have any idea how that is done
17:26:29 <tibbs|h> I still dislike the user of something not obviously ruby-related directly in /usr/share, but I'm also bothered that /usr/share/rubygems doesn't contain ruby gems.
17:27:14 <limburgher> what about /usr/share/ruby/gems instead of /usr/share/gems/gems?
17:27:26 <spot> limburgher: we can always propose that.
17:27:26 <tibbs|h> I guess none of the proponents of this draft are online at this time?
17:27:27 <rdieter> hola, sorry got tied-up.
17:27:56 <spot> but i suspect if they are rebuilding packages aggressively to the old dir structure, they're not going to like that
17:28:16 <spot> and yes, i know, they shouldn't be doing that
17:28:17 <tibbs|h> It's 100% mistake to do anything based on an unapproved draft.
17:28:51 <tibbs|h> As I see it, though, there's no way around the whole "compile and install the whole thing in %prep" because ruby is simply broken.
17:29:00 <spot> tibbs|h: yes, i agree.
17:29:04 <tibbs|h> Which is no change from the last draft.
17:29:08 <spot> yes.
17:29:28 <spot> the only real blocker for me is the need for the "how to patch and recompile" part.
17:29:31 <tibbs|h> Yes.
17:29:56 <spot> for non-arch specific code, the how to patch is obvious, just do it after geminstall to the working tempdir target
17:30:07 <spot> the same is true for the arch specific code
17:30:17 <tibbs|h> How opposed are we to the /usr/share/gems thing?  And the /usr/share/gems/gems thing?  Is either of those a blocker for anyone?
17:30:21 <spot> but i don't know how you recompile, sanely.
17:30:42 <spot> it annoys me, but it isn't user visible, so i don't care as much.
17:30:47 <geppetto> tibbs|h: I'm with spot, I hate it but I'm not going to block on it
17:31:01 * abadger1999 wonders how this plays with GPL's "prefered form for modifications"
17:31:26 <limburgher> spot: plus, i means compiling twice.
17:31:29 <spot> abadger1999: it's probably fine. the C source is there.
17:31:31 <limburgher> it
17:31:41 <spot> limburgher: yep. that can be chalked up to "ruby is retarded"
17:31:44 <tibbs|h> I think it's a stretch to involve GPL compliance here.
17:31:48 <abadger1999> <nod>  but you can't just submit the patch upstream
17:31:55 <spot> abadger1999: sure you could.
17:32:01 <abadger1999> Well you could but...
17:32:04 <spot> it's applying to the C source
17:32:10 <spot> might need to change the -p level
17:32:11 <tibbs|h> The thing is, they don't see it as being retarded because they see no benefit to separate unpack, patch, compile, install steps.
17:32:27 <abadger1999> you can't rebuild the gem from the gem and the patch.
17:32:32 <spot> tibbs|h: and arguably, for most ruby packages, there isn't
17:32:35 <tibbs|h> Even though the need to patch things and "recompile somehow" is an obvious counterexample.
17:32:37 <abadger1999> you can only install the exploded form of the gem
17:32:47 <spot> abadger1999: the gem is not the preferred format for the modifications though
17:32:54 <spot> the source files themselves are
17:33:05 <spot> no more than the jar file would be or the rpm file would be
17:33:26 <tibbs|h> Did we get an answer about the deprecation of the gem-as-nongem thing?
17:33:30 <spot> tibbs|h: yes.
17:33:33 <abadger1999> spot: but the gem is what we ship
17:33:38 <abadger1999> tibbs|h: not i nthe ticket
17:33:47 <spot> "Moreover, Ruby core programmers want to gemify standard library [1], so the Gems are pretty much a standard in Ruby world and no one uses Ruby without Rubygems. "
17:33:48 <abadger1999> tibbs|h: I don't think they understood the question.
17:34:14 <abadger1999> tibbs|h: I've been looking through forum and mailing list posts and I think I understand why they don't understand, though.
17:34:30 <limburgher> abadger1999: ?
17:34:36 <tibbs|h> To be honest I never understood that whole thing either.
17:34:38 <abadger1999> When we originally approved ruby guidelines, you needed to do gem_require('foo") to use a ruby gem
17:34:47 <abadger1999> and require('foo') to use a standard library
17:34:49 <spot> abadger1999: because the gem is the encapsulation provided by upstream. no better or worse than a tar.gz for GPL compliance
17:34:58 <tibbs|h> It was something mtasaka pushed for, if I recall correctly.
17:35:27 <abadger1999> I haven't tested this, but it looks like nowadays you can use require('rubygem') ; require('foo')
17:35:44 <spot> ah.
17:35:45 <abadger1999> and when rubygem loads, it sets up the library path so that the require('foo') works.
17:36:16 <spot> i would imagine that most code simply does require('rubygem') to be safe
17:36:45 <spot> especially if the upstream is working on gemifying the stdlib as commented
17:37:02 <abadger1999> spot: That looks like a misinterpretation, though.
17:37:55 <spot> abadger1999: not sure, that page they linked to is confusing
17:37:56 <abadger1999> It looks like upstream is considering changing some of the stdlib to have gem metadata so that it works with gem_require() [and thus can be controlled for separate versions]
17:38:03 <spot> but it does say "Install stdlibs as 'default gems'"
17:38:20 <abadger1999> some of the stdlib might not carry gem metadata.
17:38:27 <spot> mostly so they can be overridden by the gem tooling with newer versions
17:38:40 <abadger1999> and the stdlib would continue to be on the ruby path even if require('rubygem') was not used.
17:38:47 <spot> abadger1999: yeah
17:39:07 <abadger1999> So really, that portion of the argument isn't real.
17:39:16 <abadger1999> s/real/applicable/
17:40:27 <spot> okay, so we can require that all ruby packages come in a gem and non-gem package
17:40:44 <spot> but i imagine their argument will be "why? everyone uses the gem."
17:41:09 <tibbs|h> To be honest, I think this is up to the ruby people.
17:41:13 <abadger1999> We could also document how people can patch the ruby code to do the right hting with modern rubygem.
17:41:38 <spot> abadger1999: that sounds like a noteworthy addition
17:42:18 <abadger1999> Something like If gems are not being found... patch code to require('rubygem') as early in the program as possible; definitely before the part of the program that is giving problems.
17:42:53 <spot> "Since all ruby packages in Fedora are now packaged as installed gems, you may need to use 'require('rubygem')' as early in the program as possible to ensure that these ruby components are properly found."
17:43:05 <abadger1999> it should probably go into the {{admon/warning||}} box instead of/in addition to the deprecation of non-gem installs thing
17:43:48 <spot> abadger1999: yeah, i'd say in addition to
17:44:07 * spot is going to ninja edit it in
17:44:57 * abadger1999 will edit it after spot since this part is wrong too "as Ruby requires RubyGems by default"; it's really because require('rubygems') now adds the gems to the path
17:45:30 <spot> abadger1999: okay, my edit is away
17:46:15 <spot> so, i think we should ask them to add a section with an example of patching and recompiling the C code
17:46:40 <spot> and then once that is done, we should be able to vote on this and hopefully approve it and not have to think about ruby for another two years
17:47:04 <geppetto> sounds good
17:49:42 <spot> okay.
17:49:45 <spot> #topic Writeups
17:50:05 <spot> As you may have noticed, I spent the greater part of a day on Monday writing up the changes to the guidelines and announcing them
17:50:22 <spot> If you see something where I made a mistake like a typo or a grammar issue, please just fix it.
17:50:30 <spot> If it is more substantial than that, open a new ticket.
17:51:01 <abadger1999> (On ruby -- they have added such a section already) -- I'd still like to look at some of their rpms/srpms though, so no objection from me to waiting to vote until next week.
17:51:06 <spot> However, it is worthwhile to note that I am not the only one here who is capable of committing changes, so please help me out with writing up tickets and announce text going forward.
17:51:36 <spot> abadger1999: how did i miss that? :P
17:51:55 <limburgher> Noted, and thank you.  Do we want to coordinate a single announcement, or do them as they're added?
17:52:16 <spot> limburgher: we've traditionally coordinated just to keep the traffic low
17:52:29 <limburgher> spot: Reasonable.
17:52:55 <spot> abadger1999: we'll wait on ruby until next week to give you a chance to research it, thanks.
17:53:01 <abadger1999> Thanks
17:53:06 <spot> #topic Open Floor
17:53:26 <tibbs|h> Thanks for doing all those writeups; I had no idea there were so many pending.
17:54:08 <spot> tibbs|h: i wish i could say i was unaware, but it was more of a "i kept meaning to do it, then got pulled in a different direction" situation
17:54:22 <spot> i had the time on monday, i was idling in a hotel room, i got it done. :)
17:55:02 <spot> If there are no other open issues, i'll close out this meeting in, oh, 2 minutes.
17:55:30 <limburgher> nada
17:55:34 <tibbs|h> If Rex is still here, we can talk about the bundling exception.
17:56:56 <rdieter> tibbs|h: defering on iris is my recommendation, I'm trying to contact the developers working on the development/fork
17:57:44 <tibbs|h> Well good lick.
17:57:46 <tibbs|h> luck.
17:57:55 <rdieter> it's going to be quite painful, I suspect.  as both their language (russian) and workflow (doing everything on jabber chat) is a bit foreign to me.
17:58:28 <tibbs|h> What is this "russian fedora remix" thing, anyway?
17:58:46 <tibbs|h> I thought according to the trademark guidelines, remixes couldn't add non-Fedora packages.
18:00:31 <rdieter> this? http://russianfedora.ru/
18:00:48 <tibbs|h> I guess so; it doesn't exactly mean much to me.
18:01:00 <spot> tibbs|h: can you email me about that? i will put it in my todo pile
18:01:14 <spot> okay, thanks everyone, its lunch time
18:01:17 <spot> #endmeeting