#fedora-meeting-1: Fedora Packaging Committee

Meeting started by spot at 16:07:55 UTC (full logs).

Meeting summary

  1. Roll Call (spot, 16:08:06)
  2. Requesting a new exception for a /nix directory in the root hierarchy - https://fedorahosted.org/fpc/ticket/180 (spot, 16:11:02)
    1. ACTION: FHS violation rejected, please ask Nix upstream to reconsider their choice of toplevel home to something FHS compliant (e.g. /usr/share/nix). (spot, 16:30:37)

  3. Recommend using %make_install - https://fedorahosted.org/fpc/ticket/183 (spot, 16:32:45)
    1. ACTION: abadger1999's suggestion to amend the language to "Instead, Fedora packages should use: %make_install (Note the "_"!), make DESTDIR=%{buildroot} install or make DESTDIR=$RPM_BUILD_ROOT install. Those all do the same thing." is approved (+1:6, 0:0, -1:1) (spot, 16:44:34)

  4. Various scriptlets on ScriptletSnippets assume /bin/sh is bash - https://fedorahosted.org/fpc/ticket/184 (spot, 16:45:30)
    1. ACTION: State the obvious, /bin/sh is bash in Fedora. (+1:6, 0:0, -1:0) (spot, 16:48:20)

  5. Open Floor (spot, 16:48:26)


Meeting ended at 16:53:41 UTC (full logs).

Action items

  1. FHS violation rejected, please ask Nix upstream to reconsider their choice of toplevel home to something FHS compliant (e.g. /usr/share/nix).
  2. abadger1999's suggestion to amend the language to "Instead, Fedora packages should use: %make_install (Note the "_"!), make DESTDIR=%{buildroot} install or make DESTDIR=$RPM_BUILD_ROOT install. Those all do the same thing." is approved (+1:6, 0:0, -1:1)
  3. State the obvious, /bin/sh is bash in Fedora. (+1:6, 0:0, -1:0)


Action items, by person

  1. abadger1999
    1. abadger1999's suggestion to amend the language to "Instead, Fedora packages should use: %make_install (Note the "_"!), make DESTDIR=%{buildroot} install or make DESTDIR=$RPM_BUILD_ROOT install. Those all do the same thing." is approved (+1:6, 0:0, -1:1)
  2. UNASSIGNED
    1. FHS violation rejected, please ask Nix upstream to reconsider their choice of toplevel home to something FHS compliant (e.g. /usr/share/nix).
    2. State the obvious, /bin/sh is bash in Fedora. (+1:6, 0:0, -1:0)


People present (lines said)

  1. spot (82)
  2. hircus1 (37)
  3. limburgher (30)
  4. abadger1999 (26)
  5. Rathann (23)
  6. rdieter (10)
  7. geppetto (10)
  8. zodbot (3)


Generated by MeetBot 0.1.4.