16:22:07 <abadger1999> #startmeeting Fedora Packaging Meeting
16:22:07 <zodbot> Meeting started Wed Jun 13 16:22:07 2012 UTC.  The chair is abadger1999. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:22:07 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:22:15 <abadger1999> #meetingname fpc
16:22:15 <zodbot> The meeting name has been set to 'fpc'
16:22:25 <abadger1999> #topic Roll Call
16:22:29 <abadger1999> Who's here?
16:22:30 * limburgher here
16:22:40 <abadger1999> #chair limburgher rdieter tibbs
16:22:40 <zodbot> Current chairs: abadger1999 limburgher rdieter tibbs
16:23:06 <abadger1999> #chair geppetto spot SmootherFrOgZ
16:23:06 <zodbot> Current chairs: SmootherFrOgZ abadger1999 geppetto limburgher rdieter spot tibbs
16:24:05 <abadger1999> Five of us spoke up in pre-meeting chat so that would be enough to give us quorum.
16:24:37 <tibbs> I'm still around.
16:25:24 <abadger1999> geppetto, rdieter: I'm going to assume you're still here as well.  If you aren't this'll be a short meeting ;-)
16:25:26 <rdieter> yo
16:25:53 * rdieter reload-ed coffee
16:25:54 <abadger1999> #topic add debuginfo package hint  https://fedorahosted.org/fpc/ticket/186
16:26:37 <tibbs> Seems reasonable to me, though to be honest I'd prefer that this kind of "hints for packagers" stuff be moved out of the guidelines.
16:26:42 <limburgher> Maybe just state that you need that, though IIRC you get it with fedora-packager?
16:26:44 <abadger1999> This one actually looks done to me: "The discussion on this page assumes that the redhat-rpm-config package is installed."
16:27:01 <tibbs> Durr..
16:27:11 <limburgher> <facepalm>
16:27:13 <tibbs> OK, next, I guess.
16:27:21 <limburgher> Talk about your EASYFIX.
16:27:25 <rdieter> win
16:27:30 <abadger1999> I'll turn that into an info box so it's easier to see.
16:27:32 <tibbs> Maybe we can add "things won't work right if you don't have it".
16:27:37 <abadger1999> <nod>
16:27:42 <abadger1999> I'll add that too.
16:27:45 <limburgher> abadger1999:  Good idea.  Maybe with a <blink> tag.
16:27:53 <abadger1999> Ooohh.. <blink>  :-)
16:27:54 <geppetto> Do we even need to vote on that :)
16:28:01 <rdieter> just do it
16:28:12 <abadger1999> I'm moving it to clarification and will just fix it after the meeting.
16:28:17 <geppetto> yeh, but without blink :p
16:28:22 * geppetto nods
16:28:41 <abadger1999> #topic PHP Library must not requires Apache https://fedorahosted.org/fpc/ticket/185
16:28:54 <tibbs> Outside of grammar concerns, I agree with this.
16:28:56 <limburgher> geppetto: Oh, you're no fun anymore. :)
16:29:09 <limburgher> So do I.
16:29:41 <tibbs> But absolute prohibitions like that always run afoul of the odd cases when the thing being prohibited is actually important.
16:30:02 <rdieter> agreed, s/must/should/ then
16:30:14 <limburgher> "Must not unless specifically required for operation?"
16:30:21 <abadger1999> Also I think saying that php-common is what should be Require'd instead should be in there.
16:30:25 <tibbs> Well, maybe.  I mean, there's always the implicit exception.
16:30:30 <limburgher> though "should" is probably enough.
16:30:48 <tibbs> And, yes, if php-common is the thing, then great.
16:31:04 <tibbs> He just didn't tell us in his draft what something like php-Smarty is actually supposed to depend on.
16:31:44 <abadger1999> <nod> I gathered that from his replies on the mailing list.
16:31:46 <limburgher> Yeah, he gave me a good set of things to Require for it, but php-common really should Work, and at least on EL-5, it doesn't.
16:32:11 <tibbs> Anything EL-5 needs can go off to the EPEL guidelines, though.
16:32:51 <limburgher> Right, if that's a special case.
16:33:01 <tibbs> I think I'd like for him to actually flesh out a draft that at minimum addresses the concerns brought up on the list.
16:33:22 <tibbs> He just sort of threw this over the wall at us.
16:33:33 * rdieter is ok with the draft as-is, it's certainly better than the status-quo (could be better of course)
16:34:11 <limburgher> rdieter: modulo grammar
16:34:22 <limburgher> tibbs:  Agreed.
16:34:28 <rdieter> grammar/typos are always easily fixable
16:34:37 <limburgher> Like, if something in php needs to be fixed, there should be a plan.
16:35:07 <abadger1999> Okay, so things to change * Something like "unless specifically required for operation" ie: something that gives php access to the apache API.
16:35:30 <abadger1999> * What requires to use in place of requires on php (php-common)
16:36:07 <abadger1999> * If php-common doesn't work on some releases of Fedora or EPEL so we can add a note to the relevant places
16:36:18 <rdieter> abadger1999: ok that goes a little further than "Only a PHP web application, which provide httpd configuration, should requires php and httpd."
16:37:04 <abadger1999> rdieter: Hmm... is that where we want to draw the line?  I'm unsure.
16:37:43 <rdieter> just adding "or is specifically required for operation..." is enough for me
16:38:13 <geppetto> it seems logical to me to say that something which requires apache is better categorized as a "web app" than a "php app".
16:38:15 <rdieter> ie, 'Only a PHP web application, which provide httpd configuration or specifically needs it for operation, should require php and httpd.'
16:38:28 * rdieter used needs instead requires to avoid overloading it
16:40:29 <rdieter> I'm not picky, I'm ok with either version or wording, still consider that an improvement
16:42:47 <abadger1999> Okay, I'm adding this feedback to the ticket.  We can revisit and vote next week.
16:42:53 <limburgher> Excellent.
16:43:58 <abadger1999> #topic What to do with "~" in versions https://fedorahosted.org/fpc/ticket/178
16:44:11 <tibbs> spot asked me to draft something, so I did.
16:44:40 <tibbs> Which is just to say that you can't use '~' in Version: in Fedora.
16:45:16 <geppetto> That seems fine for now, although I guess we might want to start using it for "it's intended purpose" in a release or two?
16:45:38 <tibbs> I personally wouldn't.
16:45:48 <tibbs> We already have a proper and relatively sane way for dealing with this.
16:46:31 * geppetto nods … fair enough. ".0." is probably easier to understand for most people anyway, if maybe a little uglier.
16:46:35 <abadger1999> I don't think I want to revist just to revisit but I'd be fine to revisit if people start clamoring to be able to use it.
16:46:43 * geppetto nods
16:46:53 <geppetto> +1
16:46:57 <abadger1999> +1 to draft w/ rationale
16:47:07 <limburgher> +1
16:47:52 <tibbs> I would prefer it without rationale, honestly, but I provided two rationales there.
16:48:00 <abadger1999> <nod>
16:48:02 <tibbs> trac just ate the formatting.
16:48:24 <limburgher> Tonight on FOX:  When webapps attack.
16:48:42 <tibbs> Anyway, +1 to my own draft.  If others think rationale is necessary, I won't object.
16:49:12 <abadger1999> rdieter: You're the deciding vote today :-)
16:49:25 <abadger1999> https://fedorahosted.org/fpc/ticket/178#comment:1
16:49:52 <rdieter> sorry, got pulled away for a bit
16:50:09 <rdieter> +1
16:51:23 <abadger1999> #action Decided not to permit use of Debian-style "~" in versions for now. (+1:5, 0:0, -1:0)
16:51:44 <abadger1999> #topic Open floor
16:51:56 <abadger1999> Anyone have something to bring up or a ticket that I've missed?
16:52:09 <limburgher> Not that I can think of.
16:52:19 <tibbs> We're sort of sitting on a bunch of tickets.
16:52:43 <tibbs> I guess we dealt with 172 but it's still open.
16:53:28 <tibbs> I guess 161 is waiting on the submitter.
16:53:53 <tibbs> 126 as well.
16:54:16 <tibbs> Maybe I'll go through and ping on these and if any are ready for us to actually look at them I'll note that.
16:55:34 <limburgher> Thank you.
16:56:46 <abadger1999> tibbs: Thanks.  Looks like just needs  some responses
16:57:04 <abadger1999> Okay, if that's all I'll close the meeting
16:57:14 <tibbs> Just in time.
16:57:42 <abadger1999> #endmeeting