15:59:32 <spot> #startmeeting Fedora Packaging Committee
15:59:32 <zodbot> Meeting started Wed Aug  1 15:59:32 2012 UTC.  The chair is spot. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:59:32 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:59:35 <spot> #meetingname fpc
15:59:35 <zodbot> The meeting name has been set to 'fpc'
15:59:38 <spot> #topic Roll Call
15:59:45 <spot> Happy August everyone.
16:00:54 * limburgher w00t
16:02:53 * abadger1999 here
16:03:46 * Smoother1rOgZ here
16:03:55 <spot> okay, thats four of us.
16:04:08 <spot> geppetto, tibbs_: ping?
16:04:19 <limburgher> That's enough for a decent apocalypse.
16:04:21 * geppetto is here
16:04:32 <limburgher> Whew.  End of Days averted.
16:05:04 <spot> well, okay, thats quorum
16:05:12 <spot> lets go ahead and go into the agenda
16:05:28 <spot> #topic Clarification on the Group tag - https://fedorahosted.org/fpc/ticket/199
16:05:40 <spot> Basically, the Group tag is finally and completely dead in Fedora.
16:05:43 <spot> D E A D
16:05:57 <spot> you can still use it if you want to, but it is entirely optional
16:06:14 <spot> (and there was much rejoicing)
16:06:33 <geppetto> +666
16:06:37 <spot> Proposal: Add a new section to the guidelines called == Group ==
16:06:44 <limburgher> That plus md5 changes plus no buildroot tag makes new EL-5 branches a PITA, but worth it.
16:08:11 <spot> "All current versions of Fedora (and their respective RPM versions) treat the Group tag as optional. Packages may include a Group: field for compatibility with EPEL, but are not required to do so."
16:08:27 <limburgher> +1
16:08:32 <spot> +1
16:08:46 <Smoother1rOgZ> +1
16:09:51 <abadger1999> +1
16:09:57 * spot notes that we are just at quorum, so we need votes from everyone. :)
16:10:32 <spot> geppetto: ?
16:10:41 <geppetto> +1
16:11:14 <geppetto> Thought my +666 was good :)
16:11:15 <spot> #action draft proposal Approved (+1:5, 0:0, -1:0)
16:11:44 <spot> #topic Minor change to "with_python3" conditions in python specfiles - https://fedorahosted.org/fpc/ticket/200
16:12:10 <spot> this one seems like an easyfix, the old example included rhel conditionalization which isn't looking to be valid in the new RHEL model, says the RHEL maintainer
16:12:21 <spot> anyone think this isn't EASYFIX, speak now. :)
16:13:06 <abadger1999> I'm +1 to the change.
16:13:14 <Smoother1rOgZ> +1
16:13:15 <abadger1999> Not sure it's quite an easyfix.
16:13:19 <spot> +1
16:13:25 <geppetto> yeh, what dmalcolm wants he gets … +1 :)
16:13:28 * spot is just as happy to let people vote on it
16:13:32 <abadger1999> dmalcolm would also like to go through and change all existing spec files.
16:13:58 <spot> abadger1999: i wish him all the best with that. :)
16:14:12 <abadger1999> and the link to what rhel is considering seems to involve software collections.
16:14:21 <spot> limburgher: want to vote on here?
16:14:32 <limburgher> +1.  Sorry.
16:14:39 <spot> abadger1999: yeah. it does. but RHEL can dance around naked in the moonlight in a tiny hat if it wants.
16:14:47 <abadger1999> but yeah, I'm still +1 with all that information since it's not our business to dictate what RHEL does, just to make our guidelines work with it where needed.
16:15:25 <spot> #action Approved change (+1:5, 0:0, -1:0)
16:15:48 <spot> #topic Documentation= fields in systemd unit files - https://fedorahosted.org/fpc/ticket/192
16:16:07 <spot> Lennart added some comments after we approved my draft on this
16:16:15 <spot> specifically, he says: "I'd like to see explicitly mentioned that the documentation should: a) answer the question "what is this?", b) answer the question "how do i configure this?" and c) list auxiliary docs if any and relevant. "
16:16:38 <spot> i think we have "a" covered in our draft, tbh
16:16:45 <spot> and probably "b"
16:18:35 <spot> the systemd.unit man page is even more sparse than what we have
16:18:44 <spot> and we already link to the uri documentation in the draft
16:18:50 <spot> so i think we're covering "c" as well.
16:19:22 <spot> The only change we might be able to add is what lennart put in his second comment
16:19:34 <spot> which is a sort of "formal" schema for ordering of items in the field
16:19:42 <spot> e.g. "The first linked man page generally describes what the service is for. The second page is about the service's configuration file, and the third URL refers to some general documentation explaining where logind fits into the big picture. "
16:19:57 <spot> imho, down that path lies madness
16:20:40 <geppetto> Is there anything to vote on here?
16:21:08 <spot> I could however, see us adding something like "Packagers are strongly encouraged to include a broad range of documentation sources in this field, and to be as complete as possible."
16:21:49 <spot> So, I suppose I'll propose that addition for a vote.
16:22:04 <abadger1999> How about "system administrators will be looking at this field to find out "what the service is", "how to configure it", "and where to find additional information about it".
16:22:36 * abadger1999 doesn't quite see  where to shoehorn that in, though.
16:23:34 <spot> "System administrators will be looking at the Documentation= field to determine what the service is, how to configure it, and where to locate additional documentation relating to the service. Accordingly, packagers are strongly encouraged to include any available sources in the Documentation= field which provide this information."
16:23:47 <abadger1999> +1
16:24:20 <spot> +1
16:24:40 <geppetto> +1
16:25:32 <Smoother1rOgZ> +1
16:25:43 <limburgher> +1
16:26:04 <spot> #action Toshio & Spot's additional wording approved (+1:5, 0:0, -1:0)
16:26:30 <spot> okay, i saved the most fun ticket for last
16:26:50 <spot> #topic Please recommend setting Restart=always in normal services - https://fedorahosted.org/fpc/ticket/191
16:27:16 <spot> Lennart says: "I am pretty sure that restarting should be opt-in, not opt-out. And FPC should just recommend to use it, but leave it to the packagers to actually make use of it. "
16:28:07 <spot> I do not agree with his logic. I think the upstream defaults should reflect the common case and we should document corner cases.
16:28:28 <spot> If we put it in the guidelines, it would not be a true "opt-in".
16:29:11 <spot> My thoughts are at this point that this might be a FESCo issue now.
16:29:48 * geppetto shrug … as I've said in the ticket, I'm -1 to requiring a config. change for this.
16:30:04 <geppetto> Either it "just works" and should be on by default, or it doesn't and everyone should stay away.
16:30:05 <spot> I'd like to propose that we ask FESCo to consider having a system wide default Restart= value for unit files within the Fedora systemd package.
16:30:25 <spot> If they come back and say "no, we want it mandated in a packaging guideline, we will revisit"
16:31:07 <geppetto> AIUI a system wide config. change is the worst option, because you need a bunch of conditionals for when to turn it on.
16:31:18 <geppetto> And system's ini parser can't do that.
16:31:25 <spot> geppetto: well, no, not if it is a default value that can be easily overridden on a per unit basis
16:31:31 <Rathann> hi, sorry - got tied up with work
16:31:32 <geppetto> So either the code needs to live in systemd, or every packager.
16:31:59 <geppetto> spot: Yeh, but that then means all the services that it's bad for (which systemd can easily see) will need to opt. out.
16:32:14 <spot> It seems odd for us to say "this is a safe default for the average package", some other packages need special handling
16:32:43 <spot> especially if the safe default is not harmful for the other cases, just suboptimal
16:33:12 <spot> of course, i'm not sure there is a "safe default" here
16:33:58 <geppetto> My understanding is that it should be safe for everything but oneshot.
16:34:07 <abadger1999> although I don't agree with lennart's reasoning that htis should be a default in guidelines but can't be a default in upstream... when rpm upstream was ... in flux, the  did write guidelines to work around what we felt were broken upstream behaviours.
16:34:20 <spot> yeah, i know we did
16:34:23 <spot> and we could do it again
16:34:51 <spot> we could ask lennart to propose an actual draft here.
16:34:58 <abadger1999> otoh, lennart's the one pushing for this change so it kinda feels like... well then, make that change upstream.
16:35:11 <geppetto> yeh
16:35:25 <geppetto> I'm also worried about his last comment.
16:35:37 <limburgher> spot: +1
16:35:57 <spot> lennart seems to be the only one who understands the intricacies of the different choices here
16:36:12 <abadger1999> geppetto: "Also, changing systemd to default to auto restart would be a major change in behaviour and would break an immense number of systems"?  yeah.
16:36:21 <spot> so lets just ask him to write an actual draft elaborating on when each choice is recommended
16:36:28 <geppetto> abadger1999: No, I don't buy that.
16:36:48 <geppetto> abadger1999: Certainly not for "Restart=on-abort"
16:37:04 <abadger1999> maybe he thinks of the guidelines as applying to a subset of the "units" that systemd services?
16:37:52 <abadger1999> so default of on-abrt is fine for the services that we handle but if he made the change upstream it would also apply to .target and whatever the other classifications of units are?
16:38:15 <abadger1999> In any case, he's not  being clear enough for me to know.
16:39:16 <geppetto> The thing is … it's _much_ easier to have different defaults depending on the values of other options … _if_ the default is in the code.
16:39:43 <spot> okay, i've asked lennart for the draft
16:39:46 <spot> we'll see what we get
16:39:46 <geppetto> If instead we have a giant pile of text that every packager of a service has to understand … major fail whale, IMO.
16:40:05 * geppetto nods
16:40:07 <spot> #topic Open Floor
16:40:13 <spot> I'm working on writeups today
16:40:20 <spot> so you'll see that go out shortly
16:40:45 <misc> I have a last minute topic addition for FPC, can I ?
16:41:04 <abadger1999> Yep.  Go ahead
16:41:24 <misc> https://bugzilla.redhat.com/show_bug.cgi?id=844748 while doing the review, I disagree with submitter if there is code bundled or not
16:41:43 <misc> that's for a firmware, so there is clearly need for a exception
16:42:10 <misc> but I forgot to fill a ticket in time and I prefer to not wait 1 week if that's not needed
16:42:41 <misc> ( basically, the bios ship some functipon comming from gcc, glibc, kernel but nothing big )
16:42:43 <limburgher> Assuming #10, are those functions not available in a related -devel pacakge?
16:42:44 <mjg59> misc: It's BIOS code. It can't easily just link against system copies.
16:43:17 <misc> mjg59: sure, but the issue of needing to update if there is problem still apply
16:43:57 <abadger1999> We've specifically made exceptions for code that goes into the kernel.
16:44:12 <abadger1999> So I don't think we'd have a problem granting the exception.
16:44:30 * abadger1999 still debating the question of whether it needs an exception in his own mind.
16:46:31 <abadger1999> misc: Well, if it's the bottom line that really matters -- perhaps we should just vote on an exception?
16:47:33 <misc> abadger1999: yup, I would be more confortable with a vote
16:48:05 <misc> ( and later, i would open a ticket to clarify "kernel or custom firmware" in the exception automatically granted )
16:48:36 <abadger1999> Proposal: Exception for OpenBIOS to bundle code from libgcc and glibc because it is bios code and can't link to system libraries
16:48:50 <abadger1999> +1
16:48:58 <spot> +1
16:49:03 <Rathann> +1
16:49:05 <geppetto> +1
16:49:09 <abadger1999> err s/glibc/kernel/
16:49:19 <limburgher> +1
16:49:21 * abadger1999 read the last comment on the bguzilla again
16:49:23 <misc> abadger1999: both, gcc, kernel and glibc :)
16:49:31 <limburgher> I don't love it, though.
16:50:02 <misc> mhh no, no glibc, sorry
16:50:18 <spot> #action Exception granted due to the OpenBIOS usage scenario (BIOS can't link to system libs) (+1:5, 0:0, -1:0)
16:50:57 <Smoother1rOgZ> +1
16:51:30 <spot> misc: there you go, exception granted.
16:51:42 <misc> spot: thanks :)
16:52:00 <spot> if there are no other items, i'll close out the meeting in 3 minutes
16:52:28 <Smoother1rOgZ> spot: hey, what about your end-meeting-dance?
16:52:41 * spot does the "end of meeting" dance
16:54:06 <Rathann> :)
16:54:19 <Rathann> ok I have to run, guests incoming
16:54:23 <Rathann> byes
16:54:35 <limburgher> oontz oontz oontz
16:54:44 <spot> And with that, we're done, thanks again everyone.
16:54:46 <spot> #endmeeting