16:02:43 <spot> #startmeeting Fedora Packaging Committee
16:02:43 <zodbot> Meeting started Wed Aug 29 16:02:43 2012 UTC.  The chair is spot. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:02:43 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:02:46 <spot> #meetingname fpc
16:02:46 <zodbot> The meeting name has been set to 'fpc'
16:02:50 <spot> #topic Roll Call
16:03:00 <tibbs> Howdy.
16:03:10 <tibbs> Unfortunately I have a hard stop in 37 minutes.
16:04:04 <racor> here
16:06:43 <tibbs> So....
16:06:54 <spot> yeah, three of us isn't quorum. :/
16:07:34 <spot> we have a light agenda as is, so i'll wait a few more minutes for abadger1999, geppetto, rdieter, Smoother1rOgZ to show up
16:07:42 <spot> and if they don't, well, early lunch for me.
16:07:44 * abadger1999 here
16:08:06 <rdieter> here too,  sorry
16:08:15 <spot> ah, well, so much for early lunch. :)
16:08:19 <tibbs> Good enough.
16:08:20 <spot> that's 5
16:08:45 <spot> #topic Ruby - drop "archive" in Rubygems source guideline - https://fedorahosted.org/fpc/ticket/205
16:08:45 * geppetto is here
16:08:55 <geppetto> just a bit busy with some f18 things
16:09:31 <abadger1999> I'd have to be convinced to switch my vote from -1 on this.
16:09:31 <tibbs> I do not really understand 205.
16:09:59 * spot has no idea why the word archive is incorrect there.
16:10:58 <spot> anyone want to advocate for this?
16:11:02 <tibbs> Not me.
16:11:16 <abadger1999> It sounds to me like vondruch wants people to always build from a gem if it's available.... treating it less of "a means to trasport source code from one place to another" and more of a binary container that the guidelines are forcing us to treat as an archive.
16:11:27 <tibbs> Looks like a single person somehow managed to get confused by a process I can't understand, so of course the guidelines are unclear.
16:11:40 <rdieter> https://bugzilla.redhat.com/show_bug.cgi?id=845107#c14   the example of confusion
16:11:45 <abadger1999> That seems opposite to what I want, at least.
16:11:59 <spot> tibbs: i don't know if that person was confused or if they used an upstream tarball instead of the upstream gem, when both contained the same source
16:12:03 <geppetto> abadger1999: yeh, +1
16:12:12 <spot> imho, either is appropriate.
16:12:17 <rdieter> spot: the example was someone using the tarball instead  of gem, yes
16:12:41 <tibbs> OK, is there some reason to prefer one over the other?
16:12:47 <rdieter> but i  doubt the clarification requested would help any
16:12:57 <spot> rdieter: i agree.
16:13:28 <tibbs> I mean, if there's reason to prefer one over the other, then great.  But if two people are bikeshedding over a personal choice then I can't bring myself to care.
16:13:36 <geppetto> tibbs: I _assume_ the reasoning is something like the fact we require .src.rpm even though .tar.gz can work as an input to rpmbuild
16:13:48 <spot> we could simply s/archive/file, i don't think that changes the intention of the guideline.
16:14:12 <tibbs> If that makes someone's life better, great, I guess.
16:14:55 <geppetto> I guess it comes down to if we want valid rpms to be rejected because their input isn't "correct".
16:15:02 <spot> Proposal: Replace "archive" with "file" to eliminate any confusion as to what we're talking about.
16:15:07 <abadger1999> his argument about regenerating the gem from an upstream .gemspec not being buggy but still being incorrect to use because it is simply different than what the gem itself would yield sounds bogus as well.  (1) If it's not buggy, then there's no reason to fix it.
16:15:12 <abadger1999> (2) That would also mean that things like building from snapshots is being discouraged
16:15:25 <abadger1999> -1 to proposal.... I think archive is more clear.
16:16:17 <tibbs> "Gem file", "Gem archive".  Those two terms appear to be completely synonymous.
16:16:30 <spot> well, due to the numbers in attendance, the vote doesn't matter. Any other proposals on this topic?
16:16:45 * Smoother1rOgZ here now
16:17:02 <abadger1999> There are 7 in attendance.
16:17:16 <spot> okay, i only had 5. one of those days, i guess.
16:17:34 <spot> fwiw, i'm +1 here, as silly as i find this, i think "gem archive" and "gem file" are equivalent.
16:17:44 <rdieter> +1 to proposal
16:18:00 <geppetto> -1
16:18:28 <racor> 0, I am lacking too much knowledge on rubygems to have an opinion
16:18:41 <tibbs> I really just don't care; more pissed that time is being wasted on a triviality.
16:19:05 <abadger1999> vondruch makes the argument that file promotes building from the gem instead of the tarball... so I'm just basing my "these are not equivalent" off of his argument.
16:19:43 <spot> #action okay, with two -1 and one 0, this proposal does not pass.
16:20:01 <spot> any other proposals, before i propose we close this as WONTFIX?
16:20:23 <Smoother1rOgZ> sorry, was reading.
16:20:31 <tibbs> Nothing from me.
16:21:02 <Smoother1rOgZ> I'm fine with having "file" +1
16:22:17 <spot> I hear no other proposals, so i propose we close this bug as WONTFIX.
16:22:18 <spot> +1
16:22:22 <abadger1999> +1
16:23:26 <rdieter> no other option, +1   ... aside, do we really need to vote on that? (what if that fails to pass too?)
16:24:18 <spot> i suppose i could just use my chairman's discretion.
16:24:55 * spot will just close it as WONTFIX.
16:25:15 <spot> #topic Add Policy Recommendation about log and logrotate file - https://fedorahosted.org/fpc/ticket/206
16:25:33 <tibbs> No draft for consideration.
16:25:36 <spot> Without a draft here, i'm not sure we can move forward
16:26:01 <tibbs> I would welcome them to make a page with good ideas that could live outside of the Packaging: hierarchy.
16:26:02 <spot> i bring it up only so that if someone was interested in drafting something here, i think it would have a good chance of success.
16:26:15 <tibbs> Maybe that page of good ideas could evolve into a guideline.
16:26:42 <spot> okay. noted.
16:26:49 <spot> #topic Gargoyle
16:26:53 <tibbs> Ugh.
16:27:06 <tibbs> Well, zero response on that ticket to my summary of our previous discussion.
16:27:10 <spot> i have an open request with RH Legal to review the status of the "emulator" policy
16:27:30 <spot> but that is independent to the bundling issues.
16:28:20 <abadger1999> Well, I didn't get a chance to examine the source code in depth but I did take a look at where the sources are coming from -- some of those categories do have tarballs separate from the gargoyle tarball.
16:28:38 <tibbs> Yes, it's classic forked bundling.
16:28:46 <abadger1999> the upstream may be categorized as dead, but the sources needed are available.
16:28:51 <tibbs> Or in some cases, just plain bundling with no forking.
16:29:04 <abadger1999> (Mostly at the listed ifarchive.org)
16:29:15 <abadger1999> yeah.
16:29:24 <tibbs> As much as I think this software is nice to have, I just don't think the bundling is justified.
16:29:51 <tibbs> I'm sure a famous third party repo would be happy to take it.
16:30:30 <tibbs> To be honest I can't think of a reasonable way to actually fix the bundling.
16:30:59 <rdieter> if you're thinking of something that rhymes with delusion, they don't allow bundling either (and follow fedora policy in general)
16:31:03 * spot kindof hates to toss something out where the upstream is consciously keeping the bundled/forked bits well maintained and there is very minimal benefit to unbundling them.
16:31:09 <abadger1999> tibbs: separate packages and a modification of the build scripts won't work?
16:31:27 <tibbs> You have sources that need to be compiled against gargoyle and will be used only by gargoyle.
16:31:44 <tibbs> I guess you could make gargoyle figure out at runtime what interpreters it has.
16:31:47 <abadger1999> tibbs: Isn't that just a bootstrapping issue?
16:31:59 <abadger1999> <nod>  Or that.
16:32:39 <rdieter> tibbs: so, where is the summary of the last meetings' discussion? mailing list? (it's not in the ticket, afaict)
16:33:01 <tibbs> I put a short summary in the review ticket: https://bugzilla.redhat.com/show_bug.cgi?id=682544
16:33:07 <rdieter> oh  there, thanks
16:33:58 <tibbs> I propose we table this until someone can look into the feasibility of unbundling.
16:34:22 <tibbs> I fear the submitter won't want to bother, but that would then be his choice.  Unfortunately he's waited quite some time for even a review, but that's not our fault.
16:34:33 <Smoother1rOgZ> tibbs: agreed on this
16:35:40 * rdieter agrees with spot, but i don't think there's 5 that agree
16:35:58 * spot is fine. for the record, i'd also be fine with granting them a one-off exception due to the complexity, niche aspect of the package, lack of conflict in fedora, and upstream's level of curation of the bundled/forked items
16:35:59 <tibbs> Well, maybe, but then that's a change of policy.
16:36:19 <rdieter> not really, it's called granting an  exception
16:36:19 <spot> while none of those individually merits an exception, the combination might.
16:36:19 <tibbs> I'm not sure it's our policy to change.
16:36:34 <rdieter> imo
16:36:36 <geppetto> I'd prefer they try to unbundle the stuff which is identical to active upstreams.
16:36:50 <geppetto> But, in general, I mostly agree with spot.
16:36:56 * abadger1999 agrees with spot's sentiment but that doesn't change his vote yet.
16:37:33 <tibbs> Without even knowing how hard it is to do things properly, I'm not prepared to make that decision.
16:37:38 <spot> i'm not proposing it for a vote. i do think an attempt should be made to try to unbundle the interpreters that are useful outside of a gargoyle context
16:37:52 <abadger1999> I think I is fine to bundle and III I'm not sure about.  II, IV, V I currently think should be unbundled.
16:38:00 <tibbs> But there's the rub; even if unbundled, they won't be useful outside of garboyle.
16:38:13 <spot> tibbs: i think some of them are
16:38:16 <tibbs> Or however you spell it.  I just cannot type that word.
16:38:20 * spot could be misreading it though
16:38:32 <tibbs> But they'd have to link against libgagoyle.
16:38:35 <tibbs> Damn it.
16:39:03 <tibbs> Now, admittedly I don't know if they could be standalone executables once linked against the interpreter.  That would be an interesting test.
16:39:03 <spot> https://code.google.com/p/bocfel/ says "a non-Glk “dumb” interface is also available. "
16:39:33 <tibbs> I think it's an either-or kind of thing.  I guess the package could build twice or something.
16:39:41 * spot nods
16:39:45 <tibbs> But that is the kind of thing we'd need to know, I guess.
16:40:10 <spot> just thinking out loud here
16:40:22 <spot> but since none of these interpreters are in fedora yet
16:40:38 <spot> if we required that they go into subpackages (which gargoyle could then Require)
16:40:56 <spot> and any interpreters which can be built without gargoyle support also do so
16:41:14 <spot> thus, making the gargoyle SRPM the canonical home for these items
16:41:32 <spot> would that qualify for a bundling exception?
16:42:07 <tibbs> Maybe.  One thing that bothers me is that the bundled interpreters were stripped of at least build infrastructure and maybe documentation.
16:42:08 <abadger1999> okay --- this is highly preliminary but... it looks like maybe gargoyle doesn't need the terps built or installed to build for itself... I don't see any autodetection of terps at build time or runtime.  I just see a hardcoded list of terps in the code.
16:42:49 <tibbs> Anyway, unfortunately I'm 2 minutes past my hard stop now, so I have to run.
16:42:51 <spot> abadger1999: i don't think gargoyle does anything without the terps
16:42:52 <rdieter> spot: I could go for that too
16:43:07 <spot> its basically just a GUI framework/frontend
16:43:25 <abadger1999> spot: At runtime.  but that can be solved with just a Requires: every-compatible-terp-package
16:44:01 * spot sighs
16:44:23 <abadger1999> we were thinking that there'd be a problem building gargoyle without the terps
16:44:24 <rdieter> this whole discussion is starting to make me dislike our current bundling policy/guidelines more... I think we really do need an  additional requirement that unbundling have some tangible (or likely theoretical) benefit in doing so.
16:44:31 <spot> i think we can table this for next week. it would be nice if someone could take the time to try to unbundle, even as a proof of concept.
16:45:15 * spot can't volunteer. i'm so underwater at work at the moment i might as well be living in a deepsea trench.
16:45:18 <rdieter> cause the benefit in  this case is either zero, or near zero
16:45:40 <abadger1999> Nobody here has experience with Jam buildsystem, do they? ;-)
16:45:47 <spot> abadger1999: i have a tiny bit
16:45:51 <spot> but not at this level
16:45:57 * abadger1999 can try to put it on his radar again but has no experience with it.
16:46:08 <abadger1999> that's why it went to my backburener last week
16:46:10 <rdieter> heh, point of fail accumulating rapidly
16:46:11 <spot> abadger1999: i think Jamfile has everything in it
16:46:16 <spot> iirc.
16:46:23 <spot> i think thats the Makefile equiv
16:46:28 <abadger1999> Well, I'll make another attempt.
16:46:40 <rdieter> abadger1999: you're a saint
16:46:46 <spot> #topic Open Floor
16:46:58 <tibbs> I'm out.  THanks.
16:47:49 <abadger1999> thanks tibbs
16:48:05 <abadger1999> rdieter: I was thinking of another "s" word that's a synonym for lollipop ;-)
16:49:03 <spot> abadger1999: i'm trying to fixup directfb, so i guess i'm also a lollipop.
16:49:04 <rdieter> abadger1999 : there is a fine blurry line between the 2 sometimes
16:49:31 <abadger1999> spot: I think we should rename the FPC the Lollipop Guild
16:49:46 * Smoother1rOgZ loves it
16:49:55 <Smoother1rOgZ> spot: lucky you!
16:51:02 <spot> okay, thanks everyone
16:51:04 <spot> #endmeeting