16:26:12 <abadger1999> #startmeeting fpc
16:26:12 <zodbot> Meeting started Wed Sep  5 16:26:12 2012 UTC.  The chair is abadger1999. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:26:12 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:26:26 <abadger1999> #chair tibbs geppetto limburgher rdieter
16:26:26 <zodbot> Current chairs: abadger1999 geppetto limburgher rdieter tibbs
16:27:13 <abadger1999> Smoother1rOgZ, spot: If you're around we're going to have the FPC meeting
16:27:29 <limburgher> If you're not, we still will.
16:27:35 <abadger1999> #topic Add %{buildtime_libdir} macro https://fedorahosted.org/fpc/ticket/203
16:28:06 <limburgher> So is there another trac from this one?
16:28:11 <abadger1999> So vondruch is proposing that we add a macro that resolves to the libdir of the host being built on.
16:28:12 <abadger1999> nope.
16:28:16 <limburgher> k
16:28:34 <abadger1999> https://fedorahosted.org/fpc/ticket/203#comment:18
16:29:04 <abadger1999> There was some discusssion of this in https://fedorahosted.org/rel-eng/ticket/5257#comment:8
16:29:08 <abadger1999> a rel-eng ticket.
16:29:23 <abadger1999> but I'vesummarized in our ticket.
16:29:41 <limburgher> Yeah.  Ok.  I can vote based on what I see.
16:29:52 <tibbs> Yeah, this also seems like a bad idea.
16:29:56 <geppetto> reading: https://fedorahosted.org/rel-eng/ticket/5257 … I'm +1 with spot.
16:30:00 <geppetto> As I assume we all are.
16:30:03 <limburgher> Ditto.
16:30:24 <geppetto> But I don't think anything has been proposed in fpc#203 which we can really vote on.
16:30:32 <tibbs> The thing is, you can effectively do this yourself anyway; the macro just endorses such things.
16:31:10 <abadger1999> Proposal: FPC declines to propose a general %buildtime_libdir macro that expands to the libdir of the host being built on
16:31:16 <limburgher> +1
16:31:20 <rdieter> +1
16:31:21 <tibbs> +1
16:31:22 <abadger1999> +1
16:32:05 <tibbs> Someone else could propose it, I guess.
16:32:35 <abadger1999> yeah... I wonder if panu should be made aware of this?  geppetto,  want to do that?
16:33:12 <geppetto> +1
16:33:18 <abadger1999> he's free to implement if he thinks it's a good idea but he can use our vote if he agrees it's a bad idea.
16:33:36 <geppetto> abadger1999: I'm going to assume he'd -1 it.
16:33:47 <abadger1999> <nod>
16:34:05 <geppetto> abadger1999: Generally I try to protect everyone else in packaging from FPC stuff :)
16:34:24 <abadger1999> #info Proposal to decline approved (+1: 5, 0: 0, -1: 0)
16:34:27 <limburgher> geppetto: Good of you. :)
16:34:52 <abadger1999> geppetto: Okay, at least you're aware of the vote if it goes to packaging team via some other route.
16:34:55 <abadger1999> :-)
16:35:53 * geppetto nods
16:35:53 <abadger1999> #topic gargoyle bundling terps update: https://fedorahosted.org/fpc/ticket/202#comment:5
16:36:22 <abadger1999> So I played around with building gargoyle and some terps this week.
16:36:55 <abadger1999> At least some classes of terps can be built separately.  The terps can be run standalone.
16:37:29 <limburgher> It seems like you're generally against an outright exception.
16:37:58 <abadger1999> With the present method of coding and linking of terps, I doubt they can be run with an alternate libglk -- there would need to be a separate program binary compiled.
16:38:10 <abadger1999> (But likely no new coding)
16:39:03 <abadger1999> limburgher: Yeah -- My reasoning is that unbundling is something that a lot of packagers find irritating.  So I dislike exceptions that cannot be generalized.
16:39:21 <limburgher> Right.
16:39:36 <tibbs> I agree.
16:40:01 <tibbs> Plus there is a lot of software which bundles and would be considered "obscure" or "niche" to someone.
16:40:01 <limburgher> Any proposition for a partial exception, or just "no"?
16:40:18 * limburgher whistles, looks at his package set
16:40:25 <abadger1999> Anyone want to take on the task of generalizing this?  We can table until someone comes up with a draft if so.
16:40:29 <limburgher> Ok, not bundles, but niche. . .
16:40:32 <tibbs> Well, some of the heavily forked interpreters are probably OK; we talked about that before.
16:41:04 <tibbs> One other thing that sort of gets me is that we've spent a bunch of time on this but the package submitter hasn't replied to anything since he originally opened the ticket.
16:41:31 <limburgher> tibbs:  Likewise.  Which makes me wonder if a draft is worth our time.
16:42:44 <abadger1999> <nod>
16:43:11 <rdieter> proposal: table for week (or 2) pending reporter feedback
16:43:32 <tibbs> +1
16:43:33 <rdieter> (then possibly close if it never comes)
16:43:43 <abadger1999> Do we have specific questions that we'd like to ask the maintainer to answer?
16:44:02 <tibbs> I mean, I understand the guy waited a long time for someone to look at his package, and it's obvious that he did a bunch of work on it.
16:44:10 <limburgher> +1
16:44:17 <limburgher> Totally.
16:44:42 <rdieter> hrm, I guess we don't have any outstanding questions from  the ticket as far as I can tell.  did I miss something?
16:45:19 <abadger1999> yeah, I think I kinda answered the questions we had in the meetings.
16:45:49 <rdieter> so, proposal withdrawn I guess
16:46:18 <limburgher> So shall we just vote on the request then?
16:46:47 <tibbs> At this point I'm still at the same point I was originally.  Bundling of the heavily forked stuff is OK, bundling of the active upstream stuff is not.
16:47:49 <tibbs> In terms of the original request, class 1 and 2 were OK, class 3 was iffy (but I'd go for it) and class 4 and 5 were right out.  But that's just my opinion.
16:48:01 <geppetto> +1 tibbs
16:48:25 <tibbs> BTW, abadger1999, it was pretty awesome that you spent the time to look into this.
16:48:31 <limburgher> tibbs: +1
16:48:33 <abadger1999> One other thing I saw when looking at it is that there seems to be some culture of just uploading modified tarballs to the ifarchive.
16:48:33 <limburgher> Intensive.
16:48:41 <abadger1999> tibbs: thanks.
16:48:42 <limburgher> Eew.
16:49:01 <tibbs> With school starting last week I just haven't had any time at all.
16:49:02 <abadger1999> Which means "upstream dead" is kinda handwavy.
16:49:19 <tibbs> Right, ifarchive is a different culture from what we're used to.
16:49:37 <tibbs> The games are rarely "open" in terms we would use.
16:50:15 <tibbs> Since many are written in actual programming languages and the source is not given out.
16:50:57 <abadger1999> <nod>
16:51:00 <tibbs> Many of the interpreters are still developed according to the old usenet culture where people didn't care about licensing and everyone just stuck up tarballs as they saw fit.
16:51:18 <abadger1999> yeah, that's what it seems like to me.
16:51:49 <tibbs> Merging our culture with theirs is something of a minefield.  I think it can be done pretty well if someone's willing to put in the effort.
16:52:25 <tibbs> Personally I'd like to see Inform packaged properly now that it has a license we can use, but that's completely off topic.
16:52:48 <abadger1999> <nod>
16:53:10 * rdieter is still ok with being relatively permissive here, class 1-3 ok.  if we can get that far at least, then ask reporter seriously consider and investigate unbundling the rest.
16:53:17 <tibbs> So, what, do we want to do any kind of vote here?
16:53:42 <tibbs> rdieter: +1 to allowing bundling of classes 1-3.
16:54:52 <rdieter> +1 classes 1-3, if we're counting.  anyone else?
16:55:01 <limburgher> +1 1-3, sure.
16:55:01 <abadger1999> I'm okay with 1,  might be okay  with 3 (similar idea as our rubygem passenger okay for boost)
16:55:22 <abadger1999> 2 I'm not sure I'm okay with due to there beign glk ported code available on ifarchives.
16:57:47 <tibbs> Seems pretty obvious that we're not going to make progress today in any case.
16:58:00 <limburgher> no
16:58:21 <rdieter> record votes in the ticket, let others not prsent chime in I suppose
16:58:25 <tibbs> Maybe we can work a bit on a proper, full unbundling of 2, 4 and 5 and see about 3 and why the glk ports aren't upstream.
16:59:38 <abadger1999> <nod>
16:59:58 <abadger1999> Or propose a general bundling exception draft :-)
17:00:29 <tibbs> Honestly I'd rather not modify our bundling guidelines, even for this.
17:00:48 * rdieter still thinks this exceptions process is way harder than it needs to be
17:01:02 <tibbs> I still think stricter is better, though it kind of sucks for the poor folks who get stuck just trying to package something.
17:01:34 <abadger1999> #action table this for this meeting.  Will come up with proposals of which classes to fully unbundle for next meeting and which could be granted exceptions.
17:01:44 <limburgher> We're not trying to be evil, just prevent nasty things down the road.
17:01:46 <tibbs> The only thing that's making this difficult is the bad upstream practices.
17:02:25 <rdieter> the bar is too high, for little gain.  (like this case, there's little to gain or risk by allowing the exception here)
17:03:43 <rdieter> meh, I  guess we're done then?
17:04:05 <tibbs> Yeah, fesco is firing up in the other channel.
17:04:23 <tibbs> Plus that was the agenda.
17:04:36 <abadger1999> yeah, there's one more we could do but I'm not in a hurry: https://fedorahosted.org/fpc/ticket/184
17:04:50 <tibbs> Hmm, that again?
17:04:56 <abadger1999> I'll just mention it for people to look at and we can do it next week.
17:05:09 <abadger1999> Yeah -- I think his comment is a little clearer now...
17:05:32 <abadger1999> in that invoking /bin/sh results in different behaviour than invoking /bin/bash
17:05:45 <tibbs> "makes Fedora package non-portable" kind of fails as an argument, though.
17:06:48 <tibbs> But, sure, saying that it actually is bash and actually calling bash does make sense.
17:07:02 <geppetto> I can accept that /bin/bash and /bin/sh do slightly different things … even when they are both bash.
17:07:02 <tibbs> But it's not up to us to fix redhat-rpm-config.
17:07:25 <geppetto> But it's far from obvious to me that there is any need to mandate the /bin/bash behaviour.
17:07:44 <tibbs> But I wouldn't get behind telling folks that they have to stick to /bin/sh if they can even remember what they'd have to leave out.
17:07:47 <geppetto> Also all the "it's not portable" stuff is just noise.
17:08:01 <abadger1999> <nod>
17:08:24 <abadger1999> Well, we're over time -- Add comments to the ticket, ppisar can reply , and then we can vote next time.
17:08:29 <abadger1999> #topic open floor
17:08:45 <abadger1999> If anyone has something to bring up, now's the time.
17:09:10 <limburgher> nothing here.
17:09:10 <abadger1999> Otherwise I'll close the meeting in a few minutes
17:11:04 <tibbs> Nothing from me.
17:11:45 <abadger1999> #endmeeting