16:02:06 <spot> #startmeeting Fedora Packaging Committee
16:02:06 <zodbot> Meeting started Wed Oct  3 16:02:06 2012 UTC.  The chair is spot. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:02:06 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:02:09 <spot> #meetingname fpc
16:02:09 <zodbot> The meeting name has been set to 'fpc'
16:02:11 <spot> #topic Roll Call
16:02:51 * geppetto is here
16:03:33 <spot> abadger1999, limburgher, rdieter, Smoother1rOgZ, tibbs: ping?
16:03:43 * abadger1999 here
16:04:02 <rdieter> here
16:04:10 * rdieter coffee's up quickly
16:04:29 * spot apologizes for missing two weeks in a row, work has been positively insane lately.
16:06:18 <geppetto> no big deal, I don't think we had anything that couldn't wait anyway.
16:06:22 <limburgher> spot: a familiar feeling
16:06:46 <limburgher> Do we have anything other than the not-quite-ready Dunst trac?
16:06:52 <spot> yeah, i have a few items
16:07:26 <spot> since i see quorum, lets get started with the easiest one
16:07:40 <spot> #topic Ruby Guidelines clarification - https://fedorahosted.org/fpc/ticket/215
16:07:55 <limburgher> +1 EASYFIX #doit
16:08:00 <spot> +1
16:08:02 <rdieter> +1
16:08:12 <geppetto> +1
16:08:39 <abadger1999> +1
16:09:00 <spot> #action EASYFIX, will do it (+1:5, 0:0, -1:0)
16:09:26 <spot> #topic Copylibs... (libiberty in Fedora) - https://fedorahosted.org/fpc/ticket/213
16:09:42 <spot> I propose that we ask FESCo to address this issue.
16:09:54 <abadger1999> wfm
16:10:03 <spot> +1 to my proposal. :)
16:10:06 <abadger1999> I'll take care of forwarding it to them.
16:10:10 <spot> abadger1999: thank you
16:10:27 <tibbs> Sh, sorry.
16:10:36 <spot> #topic mp3 legal fun - https://fedorahosted.org/fpc/ticket/214
16:10:46 <spot> Does anyone have any issue with Fedora Legal handling this?
16:10:49 <geppetto> no
16:11:19 <abadger1999> +1 legal
16:11:25 <tibbs> I certainly have issues with us handling this.
16:11:35 <spot> Okay, I'll close it out of the FPC side and address it in the Fedora Legal superdome. ;)
16:12:33 <spot> #topic Systemd tickets
16:12:43 <spot> Lennart opened several tickets on systemd issues
16:12:54 <spot> there is only one that I think is really ready for us to tackle as is
16:13:13 <spot> #topic Change Requires(post): recommendation - https://fedorahosted.org/fpc/ticket/210
16:13:52 <spot> I think both the change to "systemd" in the Requires for the F18+ scriptlets and the typo fix are EASYFIX
16:14:09 <limburgher> Looks ok, as long as the f18+ clarification is in place.
16:14:15 <spot> which we already have.
16:14:50 <spot> so, I'm +1 to these two items in 210
16:14:53 <rdieter> +1
16:15:10 <limburgher> +1
16:15:11 <tibbs> +1, I guess.  I'm sure someone will go filing another round of bugs.
16:15:14 <geppetto> +1
16:15:20 <limburgher> tibbs:  Likely. :)
16:15:35 <spot> #action EASYFIX, will do it (+1:5, 0:0, -1:0)
16:15:51 <spot> #topic 208 & 209 - not ready
16:16:14 <spot> On the other two big recent systemd tickets, i think that lennart has given us the meat we need, but it isn't in a draft format
16:16:22 <abadger1999> (belated +1 to the EAYFIXES)
16:16:24 <spot> so i have "make drafts of 208 and 209" on my todo list
16:16:41 <spot> if anyone else wants to do it before i get to it
16:16:44 <spot> that would be awesome
16:16:50 <spot> but if not, i'll get to it when i get to it
16:17:05 <limburgher> If lennart gets impatient, he could do it. :)
16:17:24 <spot> limburgher: a valid point, but he has never submitted a real draft to date, so i don't expect that to change. :)
16:17:58 <limburgher> spot:  I never meant to imply anything other than a hypothetical. :)
16:18:08 <spot> I think that is everything I had outstanding, so i'll go ahead and open the floor
16:18:12 <spot> #topic Open Floor
16:18:53 <rdieter> http://lists.fedoraproject.org/pipermail/packaging/2012-September/008672.html
16:19:33 <rdieter> was doing a review the other day, came across what seems to be icon-scriptlet inconsistency
16:19:35 <spot> hmm, okay, i seem to recall making that change at the request of someone in the GNOME team
16:19:56 <rdieter> that change kills our optimization of using %posttrans
16:20:12 <spot> okay, so lets undo it. :)
16:20:20 <rdieter> and removes the need for the 'touch''
16:20:24 <limburgher> <headdesk>
16:20:34 <spot> if anyone complains, we'll get better rationale. :)
16:20:38 <abadger1999> +1
16:20:40 <limburgher> +1
16:20:42 <spot> +1
16:20:45 <rdieter> +1
16:21:03 <geppetto> +1
16:21:15 <spot> rdieter: can you open a ticket on this one before you make the change so we have a history on this issue?
16:21:19 <rdieter> ok
16:21:38 <abadger1999> I'm going to (re)close the /bin/sh ticket: https://fedorahosted.org/fpc/ticket/184   for lack of response.
16:22:01 <spot> #action Undo -f from gtk-update-icon-cache scriptlet - (+1:5, 0:0, -1:0)
16:22:01 <tibbs> I'm all for getting our optimizations back, but I'm worried this was done for a reason we just don't remember.
16:23:25 <spot> There are some old old tickets that could be closed due to lack of activity
16:23:45 <spot> i'm thinking 79
16:23:48 <rdieter> fyi, https://fedorahosted.org/fpc/ticket/217  icon scriptlet ticket filed
16:23:57 <spot> and possibly merging 76 and 189
16:24:45 <rdieter> merge++, same topic indeed
16:25:45 <rdieter> 79... probably ok to close.  locale files not in the 'usual' places likely won't get used anyway, iirc.
16:26:34 <abadger1999> hmmm
16:26:36 <spot> it would be nice if someone could also poke the people behind tickets 194, 201
16:26:43 <abadger1999> 79 -- the locales do get used.
16:26:50 <spot> as those tickets are bitrotting waiting for feedback
16:27:22 <limburgher> I'll do the 194, 201 poking
16:27:37 <limburgher> I'll give them a week.
16:27:59 <abadger1999> in python, in particular, I know the code that accesses those pretty thoroughly and a common idiom is to place the locales in the python modules directory (under %{python_sitelib}) and then hand the python gettext api the path to the locales in that directory.
16:27:59 <rdieter> abadger1999: oh?  ok, hmm... %find_lang will need to learn to look in user-defined locations somehow then
16:29:35 <rdieter> abadger1999: or maybe just add some --with-python flag, to look under various the %python_* dirs too
16:29:54 <rdieter> for the case you mentioned anyway
16:30:13 <abadger1999> rdieter: alternative would be to port the code to look for the code in /usr/share/locale as well and then move them in our spec files.
16:30:33 <abadger1999> which I've done for way too many packages :-)
16:30:39 <spot> hey, zombie ticket has new life!
16:30:41 <spot> ;)
16:30:51 <limburgher> abadger1999: fist bump
16:31:00 * rdieter feels it nibbling his brain
16:31:46 <spot> okay, i think that is everything
16:31:51 <abadger1999> rdieter: If you want to modify find-lang.sh that works for me.
16:31:52 <spot> and i am not hearing other open floor issues
16:31:56 <abadger1999> spot: tangent
16:31:57 <limburgher> nothing here.
16:32:04 <spot> abadger1999: yes? :)
16:32:05 <abadger1999> is redhat-rpm-config alive?
16:32:11 * spot thinks he owns it
16:32:21 <rdieter> abadger1999: not really. :-/  though that does seem like the best long-term solution, imo
16:32:24 <spot> if not, i may be the last committer
16:32:35 <tibbs> Weren't we supposed to be getting rid of redhat-* packages?
16:32:42 <spot> abadger1999: so, i'd say "yes, for some definition of alive"
16:32:50 <limburgher> maybe not self-aware, though
16:33:03 <spot> tibbs: there's no mandate for that, its not a trademark concern
16:33:11 * limburgher shudders at thought of a sentient rpmlint
16:33:18 <abadger1999> spot: okay -- there's some easyfix bugs on it.  I've been unsuccessful pinging on the bugs
16:33:24 <spot> limburgher: "OH GOD. WHY DID YOU DO THAT. PLEASE LET ME DIE."
16:33:29 <abadger1999> spot: Wasn't sure if I should exercise provenpackager to fix them
16:33:35 <spot> abadger1999: just do it.
16:33:41 <abadger1999> spot: will do.  Thanks
16:33:44 <limburgher> spot: "I'm sorry.  I'm so, so sorry."
16:33:57 <tibbs> Hmm, I thought people frowned upon it.  But then some people don't want you having things like README.Fedora in your packages, either, in case something non-Fedora wants to consume the packages.
16:34:29 <limburgher> abadger1999: Be Bold(tm). :)
16:34:35 <spot> lemme put it this way, no one at RH Legal cares about redhat-* packages existing.
16:34:47 <spot> they care about Red Hat Logos in random Fedora packages
16:34:59 <spot> but not so much what the packages are called (when they involve the string "redhat")
16:35:12 <spot> i'm not sure they'd be crazy about new ones
16:35:19 <spot> but existing packages like this, meh.
16:35:29 <spot> if someone got a bee in their bonnet about renaming it, i'd just do it.
16:35:46 <spot> but i do not believe anyone's bonnet has that bee atm.
16:36:28 <limburgher> I smell nomenclature for an etymologically awesome new bug-tracking system.
16:36:36 <limburgher> and entomologically awesome.
16:37:03 <limburgher> "Want it fixed?  Log a Bee for me in Bonnet"
16:37:12 <spot> hehe
16:37:20 <spot> okay, i think with that we're really really done
16:37:22 <spot> thanks everyone
16:37:26 <limburgher> thanks!
16:37:27 <spot> #endmeeting