19:00:18 <jreznik> #startmeeting F18 Beta Readiness Meeting
19:00:18 <zodbot> Meeting started Thu Nov  1 19:00:18 2012 UTC.  The chair is jreznik. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:18 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:00:33 <jreznik> #meetingname f18-beta-readiness-meeting
19:00:33 <zodbot> The meeting name has been set to 'f18-beta-readiness-meeting'
19:00:44 <jreznik> #topic Roll call
19:00:52 <jreznik> hi! who's here today/tonight?
19:01:24 * nirik is still here.
19:01:38 * noriko is here
19:01:40 * jreznik already received status from shaiton_ and rbergeron
19:02:19 <jreznik> let's wait a moment to ping folks
19:03:30 <jreznik> mizmo, spot, are you around?
19:03:39 * spot is
19:04:33 <mizmo> hi
19:05:17 <jreznik> #info nirik, noriko, spot, mizmo, cwickert present, shaiton_ and rbergeron sent status updates
19:05:31 <jreznik> #topic Purpose of this meeting
19:05:37 * cwickert is just lurking because he is busy
19:05:40 <jreznik> #info "Before each public release all of the groups participating the development of Fedora's next release meet to make sure the release is well coordinated."
19:05:54 <jreznik> #link https://fedoraproject.org/wiki/Release_Readiness_Meetings
19:06:13 <jreznik> #topic Current status
19:07:11 <jreznik> today at Go/No-Go meeting we decided to slip F18 Beta by one week because of unresolved blocker bugs (and still waiting for upgrade tool)
19:07:30 <jreznik> #info today at Go/No-Go meeting we decided to slip F18 Beta by one week because of unresolved blocker bugs (and still waiting for upgrade tool)
19:08:37 <jreznik> #info in cooperation with FESCo it was decided to move only Beta release forward and cut out one week between Beta Release and Final Change Deadline to avoid Christmas holidays colision
19:09:04 <jreznik> if anybody objects, please, let me know, seems most people were ok with the change
19:10:08 <jreznik> so the rest of schedule would be untouched by Beta slip
19:10:28 <jreznik> #topic Ambassadors
19:10:35 <jreznik> cwickert: ?
19:10:49 <cwickert> what do you want to know?
19:11:11 <jreznik> cwickert: ready for Beta (as I said, for Ambs. it's more question for Final)
19:12:08 <cwickert> this question is stupid because we cannot delay anything, can we? Does beta depend on the ambassadors?
19:12:48 <jreznik> cwickert: it's not about delay, but status update
19:13:10 <cwickert> we are ready when beta is ready
19:13:27 <cwickert> according to http://jreznik.fedorapeople.org/schedules/f-18/f-18-ambassadors-tasks.html the only thing that might be problematic is
19:13:33 <cwickert> FAmSCo Coordinate Media/Swag/Poster artwork with Design team
19:13:43 <cwickert> I have no clue what the status of the design team is
19:13:48 <jreznik> #info Ambassadors ready when Beta is ready
19:13:55 <jreznik> cwickert: let's check with mizmo
19:14:15 <cwickert> but I don't think that should be a problem, we'll just fire our requests at them :)
19:14:23 <jreznik> #info the only problemtatic "FAmSCo Coordinate Media/Swag/Poster artwork with Design team" to check with mizmo
19:14:26 <jreznik> cwickert: thanks!
19:14:36 <jreznik> #topic Design
19:14:50 <jreznik> mizmo: your turn + ^^^
19:15:23 <mizmo> hi
19:15:28 <jreznik> hi
19:15:32 <mizmo> one big thing im worried about with beta is the website banners
19:15:38 <mizmo> we don't have them planned out at all
19:16:12 <mizmo> we normally have them done by beta
19:16:35 <mizmo> other than that, i dont know of any issues
19:16:40 <mizmo> if the ambassadors need a poster let me know
19:17:07 <jreznik> mizmo: beta website banner? or website banners in general?
19:18:25 <mizmo> jreznik, the website banners in general
19:18:36 <mizmo> we normally have a plan for what will be featured, etc.
19:18:45 <mizmo> i dont even know if we have a photo from fudcon paris for the last one at this point
19:18:47 <jreznik> mizmo: ok
19:19:02 <jreznik> mizmo: I can check with shaiton_ if we have photo from paris
19:19:06 * nirik can try and coordinate that
19:19:29 <mizmo> jreznik, that would be *awesome*
19:19:39 <mizmo> nirik, any help is really welcome!
19:19:47 * mizmo knee-deep in anaconda stuff :(
19:19:48 <jreznik> #info websites banners are usually done by beta, not yet done
19:19:55 <nirik> I know I have seen pics, will have to find out who made them and what license, etc
19:20:07 <jreznik> and I can ask Brno folks too
19:20:19 <jreznik> #action nirik and jreznik to look for FUDCon Paris photos
19:20:31 <jreznik> anything else?
19:21:05 <jreznik> let's move
19:21:08 <jreznik> #topic Documentation
19:21:16 <jreznik> bcotton: and now you
19:21:45 <bcotton> so this is where i fall on my sword and say that the release notes schedule got way behind
19:22:04 <bcotton> the good news is that we have the RN written now and they'll be available on the web
19:22:14 <bcotton> but there's no RPM for beta
19:22:39 <bcotton> EOF
19:22:44 <jreznik> #info Release Notes written and will be available for the web
19:22:49 <jreznik> #info no RPM for Beta
19:23:02 <jreznik> bcotton: what's needed for RPM?
19:23:50 <bcotton> well i think at this point we just need someone to roll it up (there are a few appropriately blessed people in docs), though it was my understanding that we're too late?
19:24:17 <jreznik> bcotton: nth process could be used to get a rpm in
19:25:06 * nirik nods
19:25:10 <bcotton> i guess the other question would be if people really care about the RN rpm. i don't know if they do or not. I suppose low-bw users would like to have it
19:25:42 <jreznik> ok, I'll let it on you docs guys to decide, it's possible :)
19:25:44 <jreznik> thanks
19:26:14 <nirik> feel free to create the update and propose a NTH bug on it.
19:26:15 <jreznik> #info could be pulled in as NTH, not sure there's interest in RPM RN
19:26:18 <nirik> qa can discuss
19:26:44 <bcotton> ok
19:26:49 <jreznik> moving on
19:26:55 <jreznik> #topic FESCo
19:27:11 <jreznik> nirik: ?
19:27:12 <nirik> I think things are ready...
19:27:18 <nirik> there were a few features not 100%...
19:27:32 <nirik> but we repointed a few to f19 and the last ones are hopefully done in time for beta.
19:27:40 <nirik> (secure boot, new ui)
19:28:23 <jreznik> #info a few features not 100%, a few repointed to f19, last ones hopefully done in time for beta (SB, Anaconda New Installer UI)
19:28:42 <jreznik> ok, thanks
19:29:05 <jreznik> #info otherwise FESCo is ready
19:29:08 <jreznik> #topic Fedora Engineering Manager
19:29:15 <jreznik> spot: ?
19:29:49 <spot> i don't have anything to add that hasn't been covered.
19:30:16 <jreznik> #info  Fedora Engineering Manager does not have anything to add that hasn't been covered
19:30:17 * spot continues to hope for miracles in anaconda. :)
19:30:37 <mizmo> if anybody is a gtk expert and has cycles to spare, you can help with anaconda :)
19:30:38 <jreznik> spot: thanks and same here, we need (beefy) miracles
19:31:18 <jreznik> mizmo: ops, gtk, sorry... :)
19:31:24 <jreznik> have you asked devel guys?
19:31:31 <jreznik> sorry desktop guys?
19:31:43 <mizmo> i get bits and pieces of help from them yes
19:32:09 <jreznik> ok
19:32:22 <mizmo> it would be easier to have a committment from a particular person to help though
19:32:43 <jreznik> mizmo: ok, I'll try to ask desktop guys if they can commit into anaconda and help!
19:32:46 <jreznik> good to know
19:33:04 <jreznik> #topic Fedora Project Leader
19:33:06 <mizmo> it would be more commiting to help with gtk issues specifically
19:33:10 <mizmo> not commiting into anaconda
19:33:26 <jreznik> mizmo: I used bad words, but I understand you
19:33:34 <mizmo> +1
19:33:42 * jreznik is aware of some gtk issues...
19:34:08 <jreznik> rbergeron is (double) on call, maybe she's around? :)
19:34:52 <jreznik> otherwise no issues reported from FPL
19:35:25 <jreznik> #info rbergeron not availabe (on call), no issues reported by FPL
19:35:31 <jreznik> #topic Infrastructure
19:35:42 <jreznik> nirik: and something for you
19:35:56 <nirik> I think we are all ready, we just need the beta bits ready to stage. ;)
19:36:41 <jreznik> #info Infrastructure ready, beta bits needed to stage
19:36:52 <jreznik> thanks
19:36:57 <jreznik> #topic Marketing
19:37:13 <jreznik> suehle: around? your turn, otherwise I have an update from robyn
19:38:53 <jreznik> #info Beta announce will be firmed up for Tuesday (reported by rbergeron)
19:39:05 <jreznik> #topic QA
19:39:27 <jreznik> tflink: could you for QA? or should I ping adamw?
19:39:44 <tflink> we're working on blockers and nth, not sure there's much to say
19:40:00 <jreznik> #info QA working on blockers and nth
19:40:07 <jreznik> tflink: sure, thanks
19:40:13 <tflink> was the fedup initrd hosting issue brought up @ go/no-go?
19:40:21 <tflink> hosting/building
19:40:27 <jreznik> tflink: no, it wasn't
19:40:44 <tflink> at some point, we need to figure out what the plans are for the fedup initrd
19:40:45 <jreznik> any action needed?
19:41:04 <tflink> the current process is me building the initrd and hosting a custom side repo that's used during upgrade
19:41:41 <tflink> I think that the plan is to eventually use the initrd created by lorax but I'm not sure when that's planned for
19:41:57 <jreznik> nirik: any idea on hosting?
19:42:11 <nirik> hum?
19:42:20 <tflink> if it's after beta, we need to figure out what's acceptable for building and hosting the initrd - I'm a little way of just pointing users to stuff I've built
19:42:27 <tflink> s/way/wary
19:42:33 <nirik> it uses a generic initramfs for everyone? I thought it generated one?
19:42:53 <tflink> it pulls the initramfs from a repo
19:43:19 <tflink> they're arch-specific but not everyone needs to generate their own
19:43:45 <tflink> actually, I don't think it's possible to do an upgrade without pulling the initramfs and kernel from somewhere
19:43:55 <nirik> lovely.
19:43:59 <tflink> you can replace them with something you've built yourself, though
19:44:13 <nirik> ok, we can work something out I'm sure... we should figure out what we need
19:44:17 <jreznik> tflink: I can recheck with wwoods what's the idea here, just a little bit more difficult to get any info :(
19:44:44 <jreznik> nirik: could you try to work with tflink on it? and even better wwoods...
19:44:52 <nirik> sure.
19:44:54 <tflink> there are options, I just don't want to release beta without bringing the issue up
19:45:05 * tflink has scripts for building and creating the side repo if that helps
19:46:23 <nirik> if we are delivering that... it probibly needs to be added to the compose tasks.
19:46:26 <jreznik> #info QA is concerned with fedup initrd distribution, to work with nirik and wwoods to clarify it
19:46:29 <nirik> so, we should ping dgilmore as well.
19:46:56 <tflink> personally, I don't have an issue with the concept of using a siderepo for beta
19:47:09 <jreznik> #info to ask dgilmore too, it probably needs be added to the compose tasks
19:47:13 <jreznik> tflink: ok
19:47:15 <tflink> I would just rather see releng building, hosting and signing the images
19:47:17 <nirik> tflink: perhaps not...
19:47:29 <nirik> but for final it should be composed by rel-eng and mirrored, etc.
19:47:34 <jreznik> tflink: it definitely makes sense for final
19:47:58 <tflink> I can keep building the initramfs and updating the repo if that's what the decision is for beta
19:48:27 <jreznik> tflink: ok, at least we would have something ready - and let's try to figure out, thanks, moving on
19:48:32 <suehle> jreznik, sorry I'm here
19:48:59 <jreznik> suehle: so you have something to add? /me used the short status from robyn
19:49:00 <tflink> I'd probably move the repo to dl.fp.o if that's what the decision is, though
19:49:17 <suehle> We're rolling as the schedule rolls, so I don't think I have anything substantive to contribute.
19:49:31 <jreznik> suehle: ok :) thanks
19:49:38 <jreznik> #topic Release Engineering
19:50:02 <jreznik> dgilmore: are you around or maybe what's the time in australia :)
19:50:20 <jreznik> or nirik: ?
19:50:46 <nirik> I think things are running along fine. Just need blockers done so we can build rc's
19:51:07 <jreznik> #info blockers done are needed for rc build
19:51:17 <nirik> branched should be fixed to be doing images ok again (it broke for a few days due to lorax changes)
19:51:18 <jreznik> #topic Translation
19:51:27 <jreznik> nirik: sorry, was too fast
19:51:39 <nirik> no worries.
19:51:41 <jreznik> anything else to add?
19:51:55 <jreznik> if not, noriko, it's your turn
19:52:06 <noriko> one conern on anaconda.
19:52:14 <noriko> We see many strings not-localized in anaconda during l10n-qa-test. Do we still have a chance to receive updated file to translate for final?
19:52:55 <jreznik> ah, anaconda is tough one, still under heavy development I'd say...
19:53:22 <jreznik> mizmo: do you have an overview of a new strings needed for Anaconda?
19:53:56 <jreznik> otherwise I'll try to poke anaconda folks to talk with you
19:54:16 <noriko> yes, please :)
19:54:29 <jreznik> #info many strings not-localized in anaconda (as seen during l10n-qa-test), update needed for final
19:54:43 <jreznik> noriko: ok, I'll do
19:55:21 <mizmo> jreznik, there was a bug chris fixed today -
19:55:31 <jreznik> mizmo: I heard about it
19:55:34 <mizmo> gtk wasn't pulling in the translations from strings in the glade ifles, he fixed that
19:55:37 <mizmo> he is proposing it for beta
19:55:43 <mizmo> noriko, that is probably why you didn't see the strings
19:55:51 <jreznik> oh, it could be that
19:56:04 <mizmo> so the translations were there, just some kind of gtk issue
19:56:29 <mizmo> at some point either tomorrow or next week we're going to freeze the anaconda strings temporarily
19:56:39 <mizmo> so i can go in and manually fix some of the capitalization issues we had in the source
19:56:54 <mizmo> i'm going to do the conversion myself so it shouldn't impact translators, and ill do it as fast as i can so it won't be frozen very long
19:57:14 <jreznik> #info gtk bug that prevented pulling all strings from glade files
19:57:23 <noriko> mizmo, thanks a lot for your update.
19:57:32 <mizmo> jreznik, the strings were in the pot from glade -
19:57:39 <mizmo> jreznik, the problem was that gtk wasn't displaying the translated strings
19:57:42 <mizmo> they are translated though
19:57:48 <mizmo> it was more a display issue than a pot issue
19:57:50 <jreznik> #undo
19:57:50 <zodbot> Removing item from minutes: <MeetBot.items.Info object at 0x2e57b450>
19:58:15 <noriko> ah... good to know
19:58:26 <jreznik> #info gtk wasn't pulling in the translations from strings in the glade files
19:58:42 <mizmo> there shouldn't be a huge flood of untranslated strings, because they have been in the pot the whole time thankfully :)
19:58:43 <jreznik> #info either tomorrow or next week we're going to freeze the anaconda strings temporarily
19:58:59 <jreznik> mizmo: cool
20:00:08 <jreznik> noriko: is it ok for you? otherwise I can start poking folks, I'll let you know once we have fixed build
20:00:31 <noriko> jreznik, yp, thanks :)
20:01:18 <jreznik> #topic Websites
20:01:49 <jreznik> #info The Websites are going to be ready by Thursday. Just have to check the availability  of the beta release banner and the count down one. (reported by shaiton_)
20:01:53 <jreznik> mizmo: ^^^
20:02:43 <mizmo> sec
20:03:13 <mizmo> hum, im not sure about the beta release banner + countdown banner
20:03:38 <mizmo> it didn't get posted to the usual spot on the wiki
20:04:03 <mizmo> it looks like shaiton_ has one though, i see a commit from him
20:04:16 * robyduck is around if needed
20:04:41 <jreznik> mizmo: ah, yeah, I remember talking him about it later, so it's probably ok now
20:04:53 <mizmo> okay cool
20:05:04 <jreznik> robyduck: anything you want to add?
20:05:30 <robyduck> jreznik: no, confirm we need the countdown banner
20:05:54 <mizmo> you dont have a countdown banner?
20:05:57 <robyduck> all the rest is ready since yesterday evening (shaiton_ committed)
20:06:18 <robyduck> I saw the beta banner
20:06:20 <mizmo> okay, ill talk with the design team and get you guys one -
20:06:25 <mizmo> when do you need it by the latest?
20:06:32 <robyduck> mizmo: thank you
20:07:29 <jreznik> mizmo: I'd say it's hard to say (from where we should contdown... from go decision?)
20:07:35 <robyduck> even tuesday before building beta branch
20:07:59 <robyduck> the pages are just ready
20:09:09 <jreznik> thanks for info, please work with mizmo on it
20:09:20 <jreznik> otherwise I think we are done today
20:09:53 <jreznik> #topic open floor
20:09:58 <jreznik> anything to add?
20:11:21 <jreznik> #info Go/No-Go meeting #2 next Thursday, time to be announced
20:11:35 <jreznik> setting fuse...
20:11:40 <jreznik> 3...
20:12:26 <jreznik> 2...
20:13:17 <jreznik> 1...
20:13:23 <jreznik> #endmeeting