21:00:59 <pwhalen> #startmeeting
21:00:59 <zodbot> Meeting started Wed Dec  5 21:00:59 2012 UTC.  The chair is pwhalen. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:59 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
21:01:00 <pwhalen> #chair pwhalen jonmasters bconoboy ctyler pbrobinson dgilmore
21:01:00 <zodbot> Current chairs: bconoboy ctyler dgilmore jonmasters pbrobinson pwhalen
21:01:29 <pwhalen> .fas pwhalen
21:01:30 <zodbot> pwhalen: pwhalen 'Paul Whalen' <pwhalen@redhat.com>
21:01:37 <pwhalen> good afternoon everyone
21:01:48 <bconoboy> .fas blc@
21:01:48 <zodbot> bconoboy: blc '' <blc@redhat.com>
21:01:55 <dmarlin> .fas dmarlin
21:01:55 <zodbot> dmarlin: dmarlin 'David A. Marlin' <dmarlin@redhat.com>
21:02:19 * masta waves
21:02:23 <masta> .fas parasense
21:02:27 <zodbot> masta: parasense 'Jon Disnard' <jdisnard@gmail.com>
21:02:30 <Frojoe> .fas frojoe
21:02:33 <zodbot> Frojoe: jacwang 'Jordan Cwang' <jordan.cwang@gmail.com> - burningfool 'Jordan Cwang' <frojoe.21@gmail.com>
21:02:57 <pwhalen> #topic 1) Current Problem packages
21:03:06 <smooge> what is this meeting?
21:03:25 <pwhalen> smooge, Fedora ARM status meeting
21:03:28 <fossjon_home> the fedora arm meeting
21:03:40 <smooge> ah ok. wasn't set at the beginning so I didn't see
21:03:45 <smooge> back to lurking
21:03:56 <pwhalen> Peter won't be joining us today, is anyone aware of our current problem packages?
21:04:39 <masta> we might do a '#meetingname fedora-arm'
21:04:50 <bconoboy> #meetingname fedora-arm
21:04:50 <zodbot> The meeting name has been set to 'fedora-arm'
21:04:52 <BobJensen> Tip "#startmeeting Fedora Arm Meeting 2012-12-05" would make it clear
21:05:04 <pwhalen> thanks, noted
21:05:07 <fossjon_home> did the texlive pkg build?
21:05:09 <BobJensen> ;)
21:05:18 <bconoboy> it built for armv5tel...
21:05:24 <fossjon_home> we tried setting up more large builders for arm koji
21:05:29 <bconoboy> armv7hl hasn't been so lucky
21:05:35 <fossjon_home> hmm
21:05:54 <bconoboy> there is a new build happening now:
21:05:55 <bconoboy> https://arm.koji.fedoraproject.org/koji/taskinfo?taskID=1284029
21:06:14 <bconoboy> if this one fails we'll need somebody to figure out what the problem is
21:06:25 <bconoboy> it's probably a builder configuration issue though- something that the v5 system has set
21:06:34 <bconoboy> maybe a ulimit or similar
21:06:51 <fossjon_home> oh ok then, im not sure if dmitry set the limit
21:06:52 <bconoboy> do we have a list of post-install configuration tweaks?
21:07:10 <bconoboy> (dmitry==darthjava?)
21:07:16 <fossjon_home> ya sorry darthjava
21:08:13 <fossjon_home> i havent verified any builder setups cause im not on infrastructure duty as much anymore but i can ssh in and double check things
21:08:20 <Frojoe> I can do that though
21:08:38 <bconoboy> I wanted to check myself but was unable to login
21:08:46 <bconoboy> frojoe: do you have a checklist?
21:09:01 <bconoboy> frojoe: if so can you share it?  It'd be nice to check the HSV builders too.
21:09:15 <fossjon_home> we really need to generate keys for everyone so that they can ssh in automatically to all the builders
21:09:21 <pwhalen> perhaps a builder SOP for all to follow?
21:09:39 <Frojoe> I was just going to check if ulimit was set and see if there were some outstanding things in the logs
21:09:50 <masta> +1 builder SOP
21:10:09 <bconoboy> fossjon_home: I have keys, can ssh in, but it just provides an option to see what time it is, who is logged in, or log out... some sort of restricted shell
21:10:26 <bconoboy> #info texlive is still an issue, but it may be a builder issue
21:10:56 <fossjon_home> really? thats kinda crazy, im not sure who had the idea for a restricted shell but thats kind of lame
21:10:58 <bconoboy> #action frojoe to check configuration on armv7hl builder
21:11:00 <Frojoe> Bah!  DarthJava forgot to set up accounts on one that builder
21:11:14 <bconoboy> anything else besides texlive?
21:11:22 <bconoboy> (EG, anything from the vfad?)
21:11:57 <pwhalen> nothing beyond anaconda that I'm aware of
21:12:27 <bconoboy> #info anaconda had issues that prevented creating a highbank installer tree
21:12:58 <pwhalen> any other packages?
21:13:15 <pwhalen> #topic 2) F18 ARM VFAD - additional feedback, blockers?
21:13:46 <pwhalen> the VFAD went well, thanks to everyone who helped test. The small issues identified should be addressed in the next round of images
21:14:26 <pwhalen> #link VFAD link - https://fedoraproject.org/wiki/Architectures/ARM/Quality_Assurance/2012-12-03-VFAD-Fedora_18_Beta
21:14:33 <masta> for panda the network manager interaction with dbus while selinux enforcing
21:15:20 <pwhalen> I think that was related to login via serial when the system was booting to graphical
21:15:34 <masta> before we hoped the map_zero thing was responsible for that, but guess not... still investigating
21:15:40 <bconoboy> masta: is that on a panda or a panda-es?
21:15:54 <masta> panda-es
21:16:35 <pwhalen> ok, my tests were on a panda.. perhaps thats the difference
21:16:38 <masta> pwhalen: yes, it was over serial... no idea if the graphics was enabled (probably was)
21:17:19 <bconoboy> do we need to split out the panda into a graphical and nongraphical image set?
21:17:24 <pwhalen> by default it boots to graphical.target, if changed to multiuser the network is available when logging into serial
21:17:37 <pwhalen> we could create another image, or a note in the release notes
21:17:41 <dmarlin> masta: could you test with pwhalen's workaround ?
21:17:43 <bconoboy> prefer release notes
21:17:51 <pwhalen> agreed on release notes
21:17:53 <masta> dmarlin: sure... I'll do it right now
21:18:09 <dmarlin> masta: thanks... just to make sure it addresses the issue on an ES
21:18:27 <jonmasters> .fas jonmasters
21:18:27 <zodbot> jonmasters: jcm 'Jon Masters' <jonathan@jonmasters.org>
21:19:28 <pwhalen> did anyone else have issues with the Beta TC1 images that is not documented on the wiki?
21:19:42 <jonmasters> just to note, the ulimit issue with v5 was an file limit that was changed in the builder config
21:19:46 <masta> I threw the beta on the chromebook, works well there
21:19:51 <jonmasters> (for texlive - sorry catching up)
21:20:05 <jonmasters> masta: did you get X?
21:20:19 <masta> jonmasters: of course, I copied over the bits form the panda image
21:20:25 <masta> just works
21:20:35 <jonmasters> masta: I installed rawhide (F19) to see how much work is ahead - we need to poke at xorg and alsa along with some more stuff
21:20:50 <jonmasters> masta: strong caution that you not use sound on your chromebook
21:21:14 <bconoboy> jonmasters: we're still on vfad results
21:21:25 <masta> ok, we can chat about that later.... just wanted to mention the beta is working on that platform
21:21:28 <jonmasters> ok
21:21:52 <jonmasters> I tried a GuruPlug. There was an issue with U-Boot related to booting from a USB flash stick
21:22:06 <jonmasters> I just received a new stick that is detected properly by U-Boot, so I am retesting as I type
21:22:20 <jonmasters> otherwise kirkwood seems ok
21:22:39 <dmarlin> jonmasters: thanks for testing that.
21:22:54 <pwhalen> any other feedback on the Beta TC1 images?
21:23:04 <bconoboy> #info Masta will test workaround for panda-es issue
21:23:27 <pwhalen> #topic 3) Ownership of non-release blocking images (Beagleboard XM, etc)
21:24:54 <pwhalen> we're looking for people to support a platform that they care about, maintain a ks and provide testing on images not considered blockers
21:25:27 <pwhalen> which brings up the Beagleboard XM and Peter's email. Was this considered a blocker?
21:25:55 <dmarlin> I will post updated kickstart files used for beta when we release those images (when they are verified correct)
21:26:17 <dmarlin> they can be used as examples for creating other (similar) images
21:26:23 <jonmasters> do we consider the BeagleBoard XM a supported target?
21:26:37 <bconoboy> It was supported in F17
21:26:41 <jonmasters> Actually, backing up, what are our supported targets going to be? For the record :)
21:26:47 <bconoboy> but I don't think it was listed as being such in the F18 criteria
21:27:31 <dmarlin> we are creating images for Panda, TrimSlice, VExpress, and Highbank
21:27:45 <dmarlin> well, an install tree for Highbank
21:28:41 <pwhalen> Pandaboard, Highbank and vexpress were the only blocker targets
21:29:51 <bconoboy> Beyond official targets, we need to start moving toward a remix ownership model so we can support a wider array of boards like the chromebook, beaglebaord xm... or even the beaglebone
21:30:08 <bconoboy> 99.9% of the work on supporting one of these is already done, we just need somebody who cares about it to take ownership
21:30:46 <fossjon_home> trimslices should be supported as well
21:31:16 <fossjon_home> oh wait thats mentioned
21:31:18 <fossjon_home> :)
21:31:19 <jonmasters> (side note that the boot filesystem on the kirkwood image is ext3, needs to be fat for U-Boot)
21:31:54 <pwhalen> perhaps this one is better directed at the list
21:32:09 <jonmasters> ok, pwhalen please start a thread
21:32:43 * jonmasters is concerned that we spell out the remix aspect, and that we're cautious. The Chromebook example reminds me that people can blow up hardware installing Fedora ARM and I don't want to be associated with that officially
21:33:02 <jonmasters> so we should not just fling open the gates to any and all remixes without some thought
21:33:37 <fossjon_home> are the most popular or powerful types of chips omap and tegra at the moment?
21:33:40 <pwhalen> #action pwhalen to send an email to the list requesting help with non-release blocking images
21:33:58 <masta> that sounds good
21:34:09 <pwhalen> #topic 4) aarch64 update
21:34:43 <bconoboy> fossjon_home: I'd say exynos is well on its way to supplanting both
21:35:46 <dmarlin> I have set up a model and pulled in the work that ahs3 completed (from git) and will be working on building the packages in stage2 while he is away.
21:36:39 <dmarlin> if anyone else is working on this, please commit your changes to a git branch (from stage2) so we can merge them in
21:37:13 <masta> quick questions for the novice here, can somebody explain to me (like I'm 5) what is all thsi foundation stuff? is it a qemu thing like vexpress?
21:37:23 <dmarlin> I'm currently working on glib2, which is where ahs3 left off
21:38:06 <bconoboy> masta: foundation model is a fancy name for "arm's proprietary simulator that they give out for free".  It is not based on qemu.
21:39:44 <pwhalen> #topic 5) Your topic here
21:39:45 <masta> so we cross compile glibc, gcc, then rebuild those over and over ?
21:40:12 <Frojoe> masta, pretty much
21:40:48 <jonmasters> masta: we don't cross compile at this stage (2), we are now building natively
21:41:01 <jonmasters> masta: however, it is allowed to use distcc
21:41:20 <fossjon_home> ya i was wondering how you get gcc to produce v8 instructions
21:41:23 <jonmasters> bconoboy: hey, on that other list of things we were discussing elsewhere earlier, add that I am to look at the model networking issues
21:41:38 <bconoboy> jonmasters: ok
21:41:48 <jonmasters> fossjon_home: we have a gcc that supports v8 built in stage 1
21:42:02 <fossjon_home> sounds good then
21:42:04 <Frojoe> Oh yeah, i mentioned this in channel earlier, but the much maligned repo issue seems to be resolved.   An outdated version of createrepo seems to be the culprit, but it looks like it might be fixed
21:42:06 <jonmasters> fossjon_home: that was used to build what is booting on stage 2
21:42:20 <dmarlin> right, but we are still using 'configure; make, ... ', not up to building rpm packages
21:42:27 <dmarlin> (yet)
21:42:28 <jonmasters> as an aside, note that I am writing two articles to LWN on AArch64, the first of which will explain all the toolchain issues
21:42:35 <Frojoe> There is another issue regarding tagging, but pwhalen is better at explaining it than I :P
21:42:36 <jonmasters> expect that to be out in two weeks
21:42:43 <fossjon_home> jonmasters: oh if you do let me know
21:42:46 <fossjon_home> i'd like to read that
21:42:49 <pwhalen> while watching the repo issues I noticed this build - http://arm.koji.fedoraproject.org/koji/buildinfo?buildID=101651
21:42:51 <masta> that for the record, pwhalen's suggestion to set the default.target to multi-user.target caused the panda-es to have networkign while selinux enforcing.
21:43:49 <pwhalen> build finished but didnt get tagged
21:44:44 <pwhalen> causign this to fail - http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=1284671
21:44:51 <jonmasters> on builds, netcdf does now build
21:45:05 <jonmasters> pbrobinson: http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=1284390
21:45:19 <jonmasters> pbrobinson: we need to get to the -3 release anyway as they bumped for sonames
21:45:42 <jonmasters> ^^^ scratch build link that passed, also built locally in a v5 and v7 chroot, and in a v5 and a v7 mock
21:45:49 <fossjon_home> pwhalen: are there more koji problems?
21:45:51 <jonmasters> so I tried every combination
21:46:30 <pwhalen> not a koji problem, but the build looks like it didnt get tagged
21:48:05 <pwhalen> anything else for today folks?
21:48:29 <masta> dmarlin: did you ever reasearch into having an install image, with anaconda booting and installing?
21:48:57 <dmarlin> masta: what type "install image"?
21:49:13 * masta is thinking of ways to create a chromebook install image... that blws away chromeOS on the internal ssd
21:49:45 <masta> dmarlin: I think the stuff I read about was PXE for trimslice
21:49:52 <dmarlin> masta: currently, I don't think we have anything that supports chromebook
21:50:11 <pwhalen> looking into the tagging issue, it must have been fixed, jonmasters scratch build used that package
21:50:11 <dmarlin> masta: we install highbank using pxe and a kickstart file
21:50:13 <masta> dmarlin: well yea... just thinkign ahead
21:50:32 <jonmasters> :)
21:50:39 <masta> dmarlin: thanks, I'll take a look at that
21:51:04 <masta> last thing, then I'm done
21:51:10 <jonmasters> hdf5 was needed for netcdf to build correctly indeed
21:51:15 <masta> when can we expect the exynos to be enabled?
21:51:33 <masta> might be a dgilmore or pbrobinson question
21:51:40 <jonmasters> masta: your question really is "when can w expect to support chromebook?"
21:51:45 <jonmasters> because they are not the same
21:52:02 <jonmasters> Exynos is something Peter and I have talked about. We can make a multiplatform kernel that includes that
21:52:12 <jonmasters> the issue will be that not all the chromebook bits are upstream
21:52:12 <pwhalen> jonmasters, its odd that the build just failed because of it though, I wonder what will happen when another tagged build is done
21:52:16 <jonmasters> I'm going to check on that
21:53:14 <pwhalen> last call for pending issues to be discussed
21:53:49 <pwhalen> #endmeeting