16:56:38 <spot> #startmeeting fpc
16:56:39 <zodbot> Meeting started Wed Apr 10 16:56:38 2013 UTC.  The chair is spot. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:56:39 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:56:46 <spot> #meetingname fpc
16:56:46 <zodbot> The meeting name has been set to 'fpc'
16:56:52 <spot> #topic Roll Call
16:57:14 <tibbs> Still a few minutes early, but I'm around.
16:57:32 * spot wonders if his laptop clock has drifted
16:58:22 * limburgher here
16:58:55 <limburgher> You down with NTP?
16:59:05 <spot> yeah, you know me.
16:59:17 <limburgher> Thanks, we'll be here all week, try the veal.
16:59:19 <spot> but my phone agrees with tibbs, says it is 12:59
16:59:30 <limburgher> I have 11:59 CST
16:59:34 * spot shrugs
16:59:45 <tibbs> I have 11:59 CDT.
17:00:03 <limburgher> s/S/D/ frick.
17:00:09 <spot> just reran ntpdate, says it is 1:03 Eastern
17:00:25 * geppetto is here
17:01:02 <geppetto> http://www.worldtimebuddy.com/ says it's 1pm now :)
17:01:06 * abadger1999 here
17:01:11 <racor> date -u ?
17:01:55 <spot> racor: sorry, we're just discussing how my laptop clock appears to be a few minutes fast. :)
17:03:08 <spot> i count six with racor, but I'm assuming he won't be able to stay
17:03:22 <spot> rdieter, Smoother1rOgZ: ping?
17:03:26 <limburgher> So per our discussion last week I did a lot of triaging and issuing of 2-week warnings.  The catch is that I'm travelling next week and will have to close the stragglers when I get back.
17:03:36 <limburgher> And will miss the FPC meeting.
17:03:48 <spot> limburgher: okay, no worries, they can wait. :)
17:03:55 * Smoother1rOgZ here
17:04:04 <tibbs> Or I can scrape together some time to check.
17:04:10 <limburgher> spot:  Well, it bothers *me*. :)
17:04:32 <limburgher> Basically anything last modified 4/3/13 with me as the last commented that's still open.
17:04:45 <spot> #topic Python Naming Change Proposal - https://fedorahosted.org/fpc/ticket/271
17:04:48 <racor> spot: correct, I'll have to leave early.
17:04:50 <limburgher> I left alone anything newer than about 3/1/13, and anything older that I felt we needed to discuss.
17:05:20 <limburgher> And I see spot closed and announced another batch. :)
17:05:34 <rdieter> here, hi
17:05:34 <spot> limburgher: i did! it was on my todo list. :)
17:05:53 <limburgher> spot:  <happydance>
17:05:53 * Smoother1rOgZ thought we did cover that one already.
17:06:19 <tibbs> Is there a ticket state for "needs announcement"?  Or, to put it differently, how do you know which are ready to be announced?
17:06:25 <spot> I'm +1 to dropping the exception for things with "py" in the name and requiring a "python-" prefix.
17:06:32 <limburgher> Me too, +1.
17:06:35 <spot> tibbs: i flip the ones that are ready to "assigned" to me
17:06:46 <geppetto> +1
17:06:52 <tibbs> I was +1 in the ticket; still that way unless anyone came up with any kind of counterargument.
17:08:04 <Smoother1rOgZ> nm, not the same I was thinking of. so +1 for python-%{basename}
17:08:05 * abadger1999 was +1 to the removal of the "py" exception and -1 to the runtime portion in the ticket.
17:08:38 <spot> abadger1999: yeah, i'm -1 on the runtime part too (additional naming schema for non cpython interpreters)
17:09:05 <limburgher> Right, I'd think they'd all want to converge on compatibility anyway.
17:09:05 <spot> the whole point of them is that they parse the _exact_ same python files. :)
17:09:10 <geppetto> abadger1999: Yeh, that wasn't obvious … on the one side if something is only going to work with pypy … then using that as a prefix seems fine.
17:09:32 <tibbs> Indeed, same as my position in the ticket; needs to get done and we should talk about it at some point, but it's a bit early and shouldn't hold up the other bit.
17:09:47 <spot> I see +5 for dropping the py exception and requiring a python- prefix.
17:09:48 <abadger1999> geppetto: yeah -- possibly... Working that out when we work out guidelines for those seems the most sane to me.
17:09:49 <racor> +1 to dropping "py", "0" on the "alternatives"
17:09:54 <geppetto> But I doubt anyone wants stuff to randomly be python-/pypy-/jython- just depending on which interp. it got packaged for first.
17:09:59 <spot> +6 now.
17:10:18 <spot> +7, actually.
17:10:26 <spot> rdieter, want to make it 8? :)
17:10:42 <racor> geppetto: I am not sufficiently familiar with these, but wouldn't the keypoint be "compatibility"?
17:11:06 <tibbs> Pretty much, just like ruby.
17:11:14 <limburgher> I'd think that something that specifically needed one interp. to be of limited value.
17:11:14 <rdieter> ok, +1
17:11:15 <geppetto> yeh, I think I'd want to see a bunch of examples of what they expect things to be pypy- and jython-
17:11:39 <spot> #action (+1:8, 0:0, -1:0) Drop the "py" naming exception, require the use of "python-" prefix.
17:11:57 <spot> Now, the logical followup question: Do we grandfather existing packages?
17:12:08 <tibbs> We pretty much always do.
17:12:14 * spot nods
17:12:27 <rdieter> grandfather++
17:12:27 <spot> but we could push for a flag day for a mass renaming if someone was so motivated.
17:12:28 <tibbs> Obviously maintainers can rename if they want, but the procedure is kind of annoying.
17:12:36 <geppetto> It'd be nice to rename … and people can use provides to make it an easier transition
17:12:54 <tibbs> The review queue is absolutely huge at this point, so getting a re-review for the rename is always iffy.
17:12:57 <spot> I think that might be FESCo territory though.
17:13:05 <limburgher> I agree, but rename reviews are tedious.  On the plus side, they're a great time to decruftify things.
17:13:07 <geppetto> At least it'd be nice to require a new provide of the python-* name if they don't rename
17:13:08 <spot> Asking for permission to do a mass rename of violating packages without reviews.
17:13:45 <limburgher> Yeah.
17:13:55 <tibbs> The problem is that the re-reviews are often quite useful, and people keep screwing up the obsoletes even with the review.
17:14:04 <abadger1999> There is a reason for a flag day (or just renaming in general) => to clear up the relation to "python3-package" subpackages
17:14:43 <abadger1999> Personally -- I don't think this needs a flag day but if someone(s) want to go through and fix things piecemeal that would be appreciated.
17:15:02 * abadger1999 could add to his todo but is currently bogged down in the "de-vendorize .desktop files" thing.
17:15:29 <limburgher> HmmmMmmm. :)
17:16:38 <tibbs> I could make a separate report for rename reviews and folks who are good with making sure the obsoletes are done right could form a hit squad and take care of them.
17:17:24 <abadger1999> tibbs: that seems very appealing to me.
17:17:25 <limburgher> The Rename Posse.  Make it a spaghetti western.
17:17:54 <tibbs> I'll add it to the todo list.
17:18:18 <spot> #topic Permission to build sagemath with bundled pexpect - https://fedorahosted.org/fpc/ticket/238
17:18:52 <tibbs> Why did I think we were done with that?
17:18:54 <spot> So this one is back, the maintainer has resolved the issues with ipython and cython, but tried without success to unbundle pexpect.
17:19:13 <spot> Before, we said "No exception for pexpect, unless it is impossible to get the system pexpect fixed such that it can be used by sagemath "
17:19:28 <tibbs> Ah, right, and I guess it was deemed "impossible".
17:19:29 <limburgher> Which it seems to be.
17:19:39 <spot> And I think the maintainer feels that it is not possible to use the system pexpect, so I'd like to propose we grant an exception here.
17:19:42 <spot> +1 from me
17:20:08 <tibbs> I'm swapping back in.
17:20:11 <limburgher> +1
17:20:33 <rdieter> +1 pexpect exception
17:20:33 <geppetto> +1
17:20:34 <limburgher> tibbs:  Are you compressed? :)
17:20:56 <tibbs> Encrypted.
17:21:05 <abadger1999> +1
17:21:22 <tibbs> +1 to the pexpect exception.
17:21:27 <Smoother1rOgZ> +1 from me
17:21:41 <tibbs> I don't see any point to making the exception time-limited, though of course we should revisit all of these occasionally.
17:21:59 <racor> 0 from me
17:22:18 <racor> anyway, I've got to go now ;)
17:22:31 <spot> I saw Rathann come in, if you'd like to vote, feel free
17:22:57 <limburgher> racor:  <waves>
17:23:10 <Rathann> 0 from me
17:23:22 <spot> #action Exception to bundle pexpect in sagemath granted (+1:7, 0:2, -1:0)
17:23:38 <Rathann> I have to leave for a few minutes
17:23:47 <Rathann> maybe even half an hour
17:23:49 <Rathann> sorry
17:24:06 * abadger1999 wishes there was a link to which upstream pexpect the maintainer attempted to contact but oh well.
17:24:09 <limburgher> Happens.
17:24:16 <spot> #topic Bundling exception request: numptyphysics and Box2D - https://fedorahosted.org/fpc/ticket/221
17:24:27 * limburgher groans
17:24:28 <abadger1999> because I'm not certain he's talked to pexpect-u or only pexpect.
17:24:41 <spot> limburgher: couldn't pull out Box2D?
17:24:55 <limburgher> spot: Nightmare fuel.  No.
17:25:25 <tibbs> This is kind of a tough problem
17:25:40 <abadger1999> what kind of problems did you run into?
17:25:43 <tibbs> box2d has never really been a stable target.
17:25:47 <limburgher> Right.
17:26:24 <limburgher> That's the problem.  It's based on an older version, but I'm really not sure which one, because there are differences from most of them.
17:26:25 <tibbs> I am confused, though, as to why the compat package didn't work.
17:26:35 <tibbs> I guess they actually modified it somehow.
17:26:45 <spot> So its not a straight bundle, its a fork?
17:26:52 <limburgher> More or less.
17:27:24 <limburgher> I wish people would stop doing this stuff.
17:27:34 <spot> Upstream mentioned "updating Box2D" previously, so I'm +1 for an exception here, given that it is a somewhat maintained fork.
17:27:43 <tibbs> It's game stuff.  That's just par for the course.
17:27:59 <limburgher> Sadly, that's true.
17:27:59 <tibbs> But it would be nice to know what they actually changed, I guess.
17:28:38 <tibbs> I don't particularly have any problem with this kind of thing, though as long as everyone is actually trying.
17:29:55 <limburgher> Ugh.  I just went looking for it, but I think I wiped out that particular git clone for some reason.  I can try to recreate it if you like.
17:30:10 <spot> So, I see +1 on the floor for an exception for bundling Box2D in numptyphysics
17:30:19 <rdieter> +1
17:30:54 * abadger1999 diffing the 2.0.1 vs bundled version now
17:31:05 * limburgher abstaining unless everyone else is in favor and I need to put it over the top.
17:31:16 <geppetto> so … numptyphysics is a module for games to use, right? And not an actual game?
17:31:23 <limburgher> No, it's a game.
17:31:35 <geppetto> Ok … Wrost. Name. Ever.
17:31:51 <geppetto> But given it's a game, meh. +1
17:31:55 <limburgher> Very true.
17:32:13 <tibbs> +1, though I'm kind of on the edge since normally we'd want that info before considering the request.
17:32:16 <Smoother1rOgZ> i'm +1 to that as well.
17:32:32 <limburgher> Understood.
17:32:51 <Smoother1rOgZ> unless abadger1999 found something interesting by diffing the version? :)
17:34:05 <abadger1999> Eh....
17:34:20 <abadger1999> The changes to the files that are in the 2.0.1 release are very minor.
17:34:29 <abadger1999> with one possible exception
17:34:36 <abadger1999> Add cstring to several places.
17:34:45 <abadger1999> #include<cstring>
17:34:49 <abadger1999> (That's the easy part)
17:35:08 <abadger1999> the possible exception is:
17:35:10 <abadger1999> -#define B2_NOT_USED(x) x
17:35:13 <abadger1999> +#define B2_NOT_USED(x)
17:35:39 <abadger1999> Which would need to be looked at in the code to see what logic that changes.
17:36:13 <abadger1999> I see 9 lines that have that so evaluating it isn't impossible but it could also be a rabbit hole
17:36:32 * spot notes that we have +5 for an exception
17:36:45 <abadger1999> In addition, there is an added file (and header): b2Shape.cpp and b2Shape.h
17:37:01 <abadger1999> A quick look at those seem like they could be compiled and linked in separately.
17:37:28 <spot> limburgher: i suppose it is up to you, do you want to keep poking at this with abadger1999?
17:38:28 <limburgher> If abadger1999 is willing, I'd rather not bundle.  If you can get it to work, I'll happily support compat-Box2D.
17:39:06 <spot> okay then, we'll table this for now. limburgher, please toss a comment in the ticket to let us know how it comes out.
17:39:09 <limburgher> I can put up what I have for compat.
17:39:35 <spot> #topic Static [UG]ID assignments - https://fedorahosted.org/fpc/ticket/269
17:39:53 <abadger1999> I'd vote +0 -- I think we could make an attempt to unbundle but I also trust limburgher more than msot maintainers to do the right thing here :-)
17:39:53 <spot> the draft author replied to toshio's comment with our concerns
17:40:10 * abadger1999 notes that he replied to that reply a little before hte meeting.
17:40:17 <spot> namely, he doesn't think cross-distribution collab is possible (since Debian/Ubuntu use different ranges)
17:40:43 <abadger1999> This is feeling like a rabbit hole that leads back to the original discussion that lead to the current guidelines as the right answer.
17:41:11 <spot> What if we set FESCo as the voting body, since GID/UID assignment isn't packaging.
17:41:23 <spot> (for whether a package needs a static assignment or not)
17:41:53 <abadger1999> I think it should be fpc.  Historically, fesco isn't a great place to put decisions where you have to say no a lot.
17:42:00 <spot> Heh.
17:42:06 <geppetto> Yeh, or say anything a lot really
17:42:15 <abadger1999> because after elections, last years no vote might now be a yes.
17:42:26 <abadger1999> and vice versa
17:42:42 <spot> That fact not withstanding, this is definitely a gray area as to whether it is a packaging detail or not.
17:43:00 <tibbs> Could ask fesco if they want us to deal with it.
17:43:14 <tibbs> But then I have little doubt as to what the decision would be.
17:43:53 <spot> I think we can ask FESCo if they wish to permit soft-static allocation.
17:44:02 <abadger1999> <nod>  But I do think we could argue it is a packaging detail.... personally, I would have liked FPC to have reviewed the 1000SystemAccountsFeature... I think we missed an opportunity in not allocating more to the static range then.
17:44:12 <spot> If they do, then all we have to focus on is how to implement it.
17:44:17 <abadger1999> Ugh.
17:44:25 <geppetto> spot: So … it already happens, and it might happen in the future
17:44:27 <abadger1999> I think that goes entirely against precedent.
17:44:32 <geppetto> spot: It's not like they can say no
17:44:40 <abadger1999> The current uid guidelines being that precedent.
17:44:49 <spot> if we say no, does anyone think they won't go to FESCo for an override? ;)
17:45:12 <tibbs> I think they'd just go to the setup maintainer.
17:45:13 <geppetto> it depends … I think in all the cases we'd say no, they shouldn't.
17:45:28 <abadger1999> ie: we (FPC) had a big discussion about whether and how to do static allocation with the present: "dynamic in packaging, sysadmin can make it static via preallocation" policy being the outcome.
17:46:09 <tibbs> I realize anything I say here will just come back to the reasons why that was ignored in the first place.
17:46:14 <tibbs> And thus won't be productive.
17:46:49 <abadger1999> Like I say I would be willing to go back to discussing this and reevaluating it... but  I don't think we should vote on this until we do that.
17:47:08 <spot> fwiw, i don't hate this draft. it is better than what people are doing today. I'd prefer FESCo review the UID/GID assignment (as opposed to us or the setup maintainer).
17:47:43 <spot> abadger1999: do you want to work on an alternate draft?
17:48:26 <geppetto> I like the draft … I'd prefer FPC do the uid assignment, then FESCO, then setup maintainer … but that's just a preference.
17:48:27 <abadger1999> spot: I could -- how about I start discussion on the list and work on that.
17:48:40 <spot> abadger1999: works for me.
17:48:56 <abadger1999> geppetto: <nod>  I suppose I could vote for the present draft if FPC was the gatekeeper.
17:49:17 * spot would vote +1 on the current draft with FPC as the gatekeeper.
17:49:53 <abadger1999> #action toshio will work on opening discussion and a new draft (possibly very similar to the present on with FPC as gatekeeper) for next week.
17:49:59 * abadger1999 might not be chaired.
17:50:05 <spot> #action toshio will work on opening discussion and a new draft (possibly very similar to the present on with FPC as gatekeeper) for next week.
17:50:14 <spot> #topic Meeting Time
17:50:39 <spot> racor cannot attend at 1700 UTC (hooray for daylight savings time). He asks if we can move to 1600 UTC.
17:50:42 <limburgher> I'm in favor.  We should have one.
17:50:51 <spot> So... is anyone present unable to attend at 1600 UTC?
17:50:52 <limburgher> That's fine with m.
17:50:53 * abadger1999 can meet at 1600 UTC
17:51:00 <limburgher> ^e
17:51:09 <tibbs> As usual, I have significant flexibility as long as we meet Wednesday, though for eight weeks I will have a hard stop at 1900Z.
17:51:19 <tibbs> 1600Z is quite fine with me.
17:51:19 <Smoother1rOgZ> ok for me.
17:51:35 <spot> it is fine with me, i just have to eat lunch early or late on that day. :)
17:52:02 <limburgher> I eat during our meeting, it's why I'm hard to understand sometimes.
17:52:19 <spot> since I'm not hearing any objections, we'll move to 1600 UTC starting next week.
17:52:46 <spot> #topic Open Seat
17:53:18 <spot> rdieter is giving up his seat on the FPC. rdieter, thank you for your many many meetings worth of service. :)
17:53:42 <limburgher> Seconded.  Unless he's willing to reconsider? :))))))
17:53:44 <spot> I will send out an announcement for candidates, the FPC will review them.
17:54:19 <rdieter> thanks guys.  now my plate will run over a little less hopefully
17:54:44 <spot> I believe John Yerbar has already edited the wiki to claim that he is on the FPC (and always has been)
17:54:57 <limburgher> Nah, it's like a goldfish, it will grow to fill the bowl.
17:55:00 <spot> But we'll ask him to submit a proper entry form. ;)
17:55:07 <abadger1999> Ahh.... rdieter I wish you were staying but I understand your need to remove some things to stay sane.
17:55:09 <tibbs> Is that an inside joke I don't get?
17:55:24 <geppetto> tibbs: If so I'm as clueless
17:55:30 <abadger1999> tibbs: he added himself to the Board wiki page yesterday.
17:55:32 <spot> tibbs: sometime in the last week or so, a "John Yerbar" created a wiki account, and added himself to the Fedora Board members list.
17:55:33 <limburgher> No, if you feed them too much they can get like 5 inches long.
17:56:11 <spot> #topic Open Floor
17:56:25 <limburgher> Google is silent on Mr. Yerbar.  I wonder if he has the Amulet of Yendor.
17:56:27 <abadger1999> (and tried to get some sort of special deal from another service because "he was a fedora board member")
17:56:42 <limburgher> abadger1999: Classy.
17:57:06 * spot had no idea Fedora involvement gave you discounts, I thought it just gave you headaches. :)
17:57:06 <geppetto> abadger1999: wow … so it wasn't just a random mistake then … nice!
17:57:28 <geppetto> spot: discounts on motrin at Walgreens?
17:57:42 <Smoother1rOgZ> spot: hah hah!
17:57:51 <limburgher> I get great pricing on RHEL pre-pre-pre-pre-releases. . .
17:58:22 * spot sees no other topics, so I'll close out the meeting
17:58:24 <tibbs> Must be growing the good stuff down in Palau.
17:58:24 <spot> thanks everyone
17:58:38 <spot> #endmeeting