16:01:26 <spot> #startmeeting Fedora Packaging Committee
16:01:26 <zodbot> Meeting started Wed Apr 17 16:01:26 2013 UTC.  The chair is spot. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:26 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:01:42 <spot> #meetingname fpc
16:01:42 <zodbot> The meeting name has been set to 'fpc'
16:01:42 <tibbs> I guess that answers my question.
16:01:52 <spot> #topic Roll Call
16:02:05 * racor is here
16:03:54 <spot> ping: abadger1999, rdieter, Smoother1rOgZ
16:04:06 * spot realizes that some people may not have noted the time change decision from last week
16:04:23 * abadger1999 here
16:04:30 <rdieter> yo
16:05:04 <spot> i count 5 (tibbs, racor, abadger1999, rdieter, and spot)
16:05:28 <rdieter> (time to go crazy being a lame-duck session member)
16:05:35 <spot> rdieter: hehe.
16:05:59 <spot> #topic Bundling exception for nodejs-vows - https://fedorahosted.org/fpc/ticket/272
16:06:22 <spot> This is the same situation (almost exactly) as the approved exception for nodejs-should (ticket 264)
16:06:29 <abadger1999> +1
16:06:48 <spot> +1
16:06:50 * abadger1999 still needs to write up the code snippets generic exception criteria
16:06:56 <tibbs> Indeed, seems the same thing.  +1.
16:06:58 <rdieter> +1
16:09:00 <spot> we are at +4 on the exception, racor, we're waiting on you here. take your time. :)
16:10:35 <racor> +1, sorry was temporarily distracted
16:10:52 <spot> #action Exception granted (+1:5, 0:0, -1:0)
16:11:38 <spot> #topic Static UID/GID assignments in Packaging:UsersAndGroups - https://fedorahosted.org/fpc/ticket/269
16:12:09 <spot> abadger1999 has written a new draft for this item here: https://fedoraproject.org/wiki/User:Toshio/UsersAndGroups
16:12:23 <abadger1999> Summary of changes is here: https://fedorahosted.org/fpc/ticket/269#comment:14
16:13:14 * rdieter likes that, definitely a good improvement over status-quo
16:13:26 <abadger1999> geppetto: welcome, we're talking about the updated uid/gid draft: https://fedorahosted.org/fpc/ticket/269#comment:14
16:14:17 * spot is happy with this draft, very thorough.
16:14:45 <tibbs> I still think that it's wrong for the packages to even care; if setup was guaranteed to have preallocated a UID, then the packages wouldn't need different scriptlets.
16:15:17 <abadger1999> tibbs: <nod>  Do you want to go the %trigger route then?
16:15:20 <tibbs> But I see the problems with that, too, and understand that it's all because we're stuck with /etc/passwd.
16:15:27 <abadger1999> k
16:15:53 <tibbs> I wasn't sure there was a proposal around triggers.  I thought it was all doable by setup growing some scriptlets.
16:16:15 <geppetto> abadger1999: Gah, sorry I thought it was another 45 mins. off
16:17:02 <spot> triggers hurt my brain. this, I at least understand.
16:17:41 <abadger1999> tibbs: setup can't do it in its %pre/%post/etc scripts since bash and shadow-utils isn't guaranteed to be on the system before setup is installed.
16:17:51 * rdieter is getting distracted @ work, consider me +1 to the draft (ping me otherwise)
16:17:52 <abadger1999> tibbs: so it would need to be done inside of a setup trigger
16:17:58 <tibbs> Ugh.
16:18:09 <abadger1999> yeah.
16:18:28 <tibbs> OK, in lieu of a sane method like /etc/passwd.d I guess this is as good as it gets.
16:18:32 <geppetto> abadger1999: Your draft looks fine to me.
16:18:53 <spot> +1 from me
16:19:03 <geppetto> +1
16:19:15 <tibbs> But I'm still disappointed because almost all of this is entirely unnecessary.  But we can address that when people come to ask for their unnecessary UID allocations.
16:19:20 <tibbs> So +1, I guess.
16:19:20 <abadger1999> anyone want to propose what to do about: "@mitr: why do we check both USERNAME and ALLOCATED_UID but for groups we only check GROUPNAME?"
16:19:37 <abadger1999> or just let me fix it as a clarification when mitr gets back to me?
16:19:45 <spot> abadger1999: he replied already, groupadd -f is the check
16:19:49 <abadger1999> ah okay.
16:20:07 <geppetto> I'd guess it's just much more common to create new users, but not so much to create new groups?
16:20:24 <abadger1999> +1 from me.
16:20:31 <tibbs> geppetto: Actually it's the other way around.
16:20:45 <geppetto> tibbs: Fair enough
16:20:48 <spot> I see +5 on this draft, racor, if you'd like to vote for the record, you can.
16:20:59 <tibbs> Just that the options for useradd and groupadd aren't symmetric, I guess.
16:21:12 <racor> +1
16:21:18 <spot> #action abadger1999's draft approved (+1:6, 0:0, -1:0)
16:21:36 * Smoother1rOgZ is here
16:21:51 <spot> #topic Adapt FESCO Schedule/Summary/Minutes mailing list announcement for FPC meetings - https://fedorahosted.org/fpc/ticket/270
16:22:49 <spot> The main reason I don't do this is... a lack of time.
16:22:54 <abadger1999> in theory this is nice... but it requires more time input for someone to make it happen.
16:23:10 <spot> I don't suppose anyone wants to do this for me? :)
16:23:41 <spot> I do think I should be emailing the minutes to the list for review, thats easy and minimal.
16:23:49 <racor> Not being familiar with what FESCo does, I don't have the faintest clue what this request is about.
16:23:55 <tibbs> I as well.
16:24:13 <spot> racor: this is a request for us to send out a pre-meeting email with the agenda, then a follow-up email with the minutes from the meeting.
16:24:52 <geppetto> Are the minutes just the IRC log?
16:25:03 <abadger1999> and allowing people to add items to the agenda by replying to the agenda email.
16:25:03 <racor> spot: thanks
16:25:04 * spot has a query in trac that he runs (usually 15 minutes before the meeting) that shows all open tickets.
16:25:14 <spot> It's mostly lies because of all the stale tickets
16:25:22 <abadger1999> and somewhat sticking ot hte agenda.
16:25:26 <tibbs> I can't argue against the idea that people should know in advance what we're going to discuss.
16:25:35 <Smoother1rOgZ> can fesco just read from meetbot's page?
16:25:38 <spot> but in theory, once those tickets are closed out, the query should make a sensible agenda
16:26:30 <geppetto> The stale tickets are mostly in a needinfo state … so can't you filter those out?
16:26:36 <tibbs> Could also do something fancy with "meeting" keywords or something; I'm not sure what trac can actually do.  But it's overhead that's going to consume human time.
16:26:42 <spot> geppetto: i could.
16:26:56 <spot> how about this.
16:27:11 <spot> I will try to do this going forward, and if i forget, feel free to flame me publicly. :)
16:27:42 <abadger1999> heh :-)
16:28:42 <geppetto> If there's a script/etc., and a process I can read for what FESCO does, I don't mind doing this … assuming it'll take an hour or so a week.
16:28:42 <spot> #action Spot is going to start doing this.
16:29:13 <nirik> http://fedoraproject.org/wiki/FESCo_meeting_process
16:29:21 <geppetto> nirik: thanks
16:29:43 <spot> geppetto: brilliant, this is all yours then. thanks!
16:30:03 <geppetto> spot: I thought you might appreciate that :)
16:30:07 <spot> #action geppetto will take point on this.
16:30:14 <spot> geppetto: Spot's Meeting Agenda Report is the name of the trac query
16:30:22 <spot> feel free to edit it as you'd like
16:30:26 * geppetto nods
16:30:50 <spot> #topic Open Floor
16:32:21 <spot> I'll give it 5 more minutes, then close out the meeting.
16:34:26 <abadger1999> ph
16:34:31 <abadger1999> quick thing
16:34:44 <abadger1999> for implementing the FPC gatekeepers for uid, what do we need to do next?
16:34:58 <abadger1999> there's enough of us as provenpackagers to do it in the Fedora package.
16:35:14 <spot> I think that should be sufficient.
16:35:16 <abadger1999> but the upstream is on fedorahosted so perhaps its better to do it there?
16:35:29 <spot> maybe ask the setup maintainer which he prefers.
16:35:58 * spot sincerely hopes this is something we are doing very very very infrequently.
16:36:03 <abadger1999> Will do.   I think it's ovasik so I'll ask in the ticket.
16:36:40 * abadger1999 hopes so too.
16:37:41 <spot> Okay, I think thats all, thanks everyone.
16:37:45 <spot> #endmeeting