15:59:56 <spot> #startmeeting Fedora Packaging Committee
15:59:56 <zodbot> Meeting started Wed Apr 24 15:59:56 2013 UTC.  The chair is spot. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:59:56 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:01 <spot> #meetingname fpc
16:00:01 <zodbot> The meeting name has been set to 'fpc'
16:00:11 * abadger1999 is present
16:00:14 * geppetto is here
16:00:46 <tibbs> Howdy.
16:01:44 <spot> #topic Roll Call
16:02:03 <racor> here
16:02:35 <spot> with me, that makes 5
16:02:48 * abadger1999 notes that Rathann showed up last week to say that he can't make this meeting time.
16:03:22 * spot sighs. this seems to be a game where we can't make it work for everyone. :/
16:03:40 <tibbs> It's not as if that's anything new.
16:03:45 <spot> tibbs: indeed.
16:03:46 * Smoother1rOgZ is around
16:03:51 <abadger1999> <nod>
16:03:58 <tibbs> We basically have to randomly choose who gets left out.
16:04:11 <spot> just to be sure, i'll send out a new "whenisgood"
16:05:02 * limburgher is here, lost track of time, we meeting?
16:05:13 <Smoother1rOgZ> limburgher: we are.
16:05:19 <abadger1999> limburgher: yep, just starting and noting that rathann can't make this meeting time.
16:05:31 <abadger1999> so spot will send out a whenisgood for us to fill in.
16:05:34 <limburgher> So I've missed very little.  Excellent.
16:07:34 <spot> sorry, people are stopping off at my desk
16:08:02 <spot> #topic Bundling exception request for Cura - https://fedorahosted.org/fpc/ticket/244
16:08:31 <spot> fwiw, i think it is safe for us to consider this a full fork of skeinforge
16:08:50 <limburgher> Looks that way.
16:08:53 <spot> so, no bundling request needed.
16:09:18 <abadger1999> Looks like a fork so I'm +1.
16:09:36 <Smoother1rOgZ> I agree
16:09:39 <limburgher> s/request/exception?
16:09:45 * abadger1999 needs to finish writing up something to make "forks are different from bundling" explicit
16:09:59 <limburgher> #lesserevil
16:10:17 <racor> looks like a case of a private app to be installed to libexecdir to me.
16:10:27 <limburgher> If I use a hashtag in IRC, what sort of abomination is that, exactly.  -OT
16:10:40 <limburgher> racor:  Possibly.
16:10:51 <tibbs> Ugh, the skeinforge package description is so brain melting.
16:11:01 <Smoother1rOgZ> :)
16:11:04 <geppetto> abadger1999: Have to be careful, Eg. the recent libevent ticket.
16:12:08 <abadger1999> <nod>  yeah I need to look at the code there...
16:12:24 <tibbs> Anyway, I agree this is a plain fork.  Would still be nice if upstreams would stop doing this kind of thing, of course.
16:12:46 * geppetto nods … I'm +1 on 244.
16:13:10 <spot> i see no one that thinks this is a bundling exception case
16:13:27 <spot> #action No bundling exception needed, this is a pure fork.
16:13:36 <tibbs> So either +1 or "needn't have asked, but our apologies for taking three months to answer that"
16:15:18 <limburgher> :)
16:15:19 <spot> I don't think any of the other tickets are ready for us to consider.
16:15:32 <abadger1999> geppetto: the libevent is bundling -- differences:  library.  not making the library publically visible.  Syncing from the upstream code  base.  Changes to the code are superficial in nature.
16:15:35 <tibbs> The ticket count is so nice now.
16:15:37 * spot reminds abadger1999 that he was going to write something for #265
16:16:07 <abadger1999> yeah.  I have to write up something for that and also for "code snippets"
16:16:41 <spot> Oh wait, I suppose we can talk about libevent/openmpi
16:16:52 <spot> #topic Bundling exception for libevent in openmpi - https://fedorahosted.org/fpc/ticket/273
16:17:10 <geppetto> abadger1999: yeh, I'd agree … just that upstream might try to say it's a fork to get around stuff.
16:17:17 <abadger1999> <nod>
16:17:35 <abadger1999> yep, I recall various upstreams making that assertion before.
16:17:39 <limburgher> Erk.
16:18:38 <geppetto> So, I'm pretty heavily -1 … additional tests are "who cares, get it upstream if you do" … bundling to recompile for "performance", if we allowed that half the OS would bundle the other half.
16:19:23 <spot> I'm inclined to agree. It seems their only changes are "disabling stuff we don't use" and "don't build with threading"
16:19:34 <tibbs> This seems terrible, but libevent is kind of a mess.
16:19:49 <geppetto> If they have actually added APIs, and upstream won't accept them I could think about it a bit more, but as is …
16:19:51 <spot> I think it should be straightforward to build a libevent-nothreads.so
16:20:19 <tibbs> And if that doesn't work for some reason, we'd at least have some concrete reason why bundling would be needed.
16:20:22 <geppetto> Yeh, if it really matters then working with the libevent maintainer to do that seems viable.
16:20:41 <Rathann> further questions: what is the performance difference between threaded and non-threaded build?
16:20:53 <limburgher> spot: +1 to that idea
16:21:23 <geppetto> Rathann: My guess would be nobody has ever measured it :)
16:21:29 <limburgher> Maybe I'm naive, but for openmpi, why would you *not* want threading?
16:21:47 <tibbs> Same reason you want -O9999999, I guess.
16:21:56 <geppetto> tibbs: yeh, that too.
16:22:14 <geppetto> I hear staticx linking glibc gives you massive speed improvements.
16:22:25 * geppetto stops trolling, now.
16:22:30 <tibbs> "Somebody once said it meant -Ogofasterrrrr"
16:22:32 <spot> </gentoo>
16:22:34 <Smoother1rOgZ> heh heh
16:22:51 <spot> So, I'm -1 here, this seems like a case where bundling isn't necessary.
16:22:52 <abadger1999> :-)
16:22:54 <abadger1999> -1
16:22:58 <Rathann> I'm looking at README.openmpi and some of that stuff looks very much upstreamable
16:22:58 <Smoother1rOgZ> good idea to a nothread lib though
16:23:01 <limburgher> They could use dietlibc. . .
16:23:06 * limburgher ducks
16:23:15 <tibbs> It is really tough for a lot of people to understand that distro maintainability does trump some unmeasurable performance increase.
16:23:20 <geppetto> limburgher: hey, we ship it!
16:23:28 <abadger1999> .whoowns dietlibc
16:23:28 <zodbot> abadger1999: limb
16:23:31 <abadger1999> :-)
16:23:33 <limburgher> geppetto:  I know, I took it over. :)
16:23:46 * spot will look into making a -nothread lib and updating libevent.
16:23:48 * geppetto points at limburgher and says "ha. ha."
16:23:55 <limburgher> tibbs: <nods until nauseous>
16:23:59 <spot> since i opened my big mouth.
16:24:18 * Rathann is -1 here as well
16:24:21 <limburgher> geppetto:  What can I say, I'm a masochist.
16:24:52 <tibbs> steved owns libevent, and he's reasonable.  I thought he mostly stuck to NFS stuff, though.
16:25:35 <spot> i see -4 on this one.
16:25:48 <spot> so lets give me a week to try to fixup libevent
16:25:58 <racor> -1
16:26:01 <limburgher> -1 as well, in case I missed it.
16:26:38 <spot> #action FPC is pretty universally against this bundling, spot will try to make a libevent-nothread.so and update libevent.
16:26:53 <spot> #topic Open Seat on the FPC
16:27:17 <tibbs> Anyone put their head on the block yet?
16:27:24 <spot> We received three candidates for the open seat. I will send that information to all FPC members via email and we will discuss it there.
16:27:36 <tibbs> Coo.
16:27:38 <tibbs> l
16:27:46 <limburgher> Sounds like a plan.
16:27:48 <spot> I think that may be more polite than doing it openly, and I seem to recall thats how we did it last time.
16:28:21 * Smoother1rOgZ nods
16:28:26 <spot> #topic Open Floor
16:28:30 <limburgher> spot:  Right.
16:28:50 <limburgher> So, about the trac cleanup I was doing. . .
16:29:22 <limburgher> Round 1 is done, and it looks a lot more manageable.  Anything left is either something we should look at at some point or fairly recently updated.
16:29:27 <limburgher> Should I keep going?
16:30:10 <tibbs> Obviously the goal is to have no pending tickets.
16:30:38 <limburgher> So close them all?  Cool.  Will do.
16:30:42 <limburgher> :)P
16:30:43 <tibbs> Not entirely realistic, but still it's great that we're down to under 20.
16:30:56 <tibbs> At least that's a small enough number to scan.
16:31:05 <geppetto> Yeh, it makes my job a lot easier.
16:31:05 <abadger1999> <nod>
16:31:07 <geppetto> :)
16:31:10 <abadger1999> Thanks limburgher!
16:31:17 <tibbs> But we do still have a few things pending, like https://fedorahosted.org/fpc/ticket/236
16:31:19 <limburgher> np.
16:31:34 <limburgher> Right.  And now we can find them.
16:31:48 <spot> I think owncloud unbundled everything, iirc
16:31:52 <spot> i think thats just a stale ticket
16:32:22 <limburgher> Cool, we can just inquire in the ticket to confirm.
16:32:24 <geppetto> Also kind of related, I added: https://fedoraproject.org/wiki/FPC_meeting_process … which is mainly the agenda/pre-meeting part atm.
16:33:01 <tibbs> I think things would be far more obvious if we could modify status values.
16:33:07 <limburgher> Looks good.
16:33:11 <spot> https://bugzilla.redhat.com/show_bug.cgi?id=858841
16:33:42 <limburgher> Ah.
16:34:22 <spot> looks like smbphp was left bundled
16:36:24 <Rathann> spot: could you take another look at https://bugzilla.redhat.com/show_bug.cgi?id=676858 ? There's new evidence of bundling non-free code.
16:36:41 <limburgher> Looks like it should be unbundled.
16:37:09 <spot> Rathann: okay
16:38:13 <tibbs> An, TracWorkflowAdmin I think allows custom statuses to be added.
16:38:20 <spot> if someone wants to dig into that owncloud ticket, it would be helpful.
16:43:39 <spot> okay, i'm not seeing anything else for this week
16:43:41 <spot> thanks everyone.
16:44:15 <spot> #endmeeting