20:00:06 <pwhalen> #startmeeting Fedora ARM weekly status meeting
20:00:06 <zodbot> Meeting started Wed May  1 20:00:06 2013 UTC.  The chair is pwhalen. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:06 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
20:00:06 <pwhalen> #chair pwhalen jonmasters bconoboy ctyler pbrobinson dgilmore
20:00:06 <zodbot> Current chairs: bconoboy ctyler dgilmore jonmasters pbrobinson pwhalen
20:00:14 <pwhalen> .fas pwhalen
20:00:14 <zodbot> pwhalen: pwhalen 'Paul Whalen' <pwhalen@redhat.com>
20:00:17 <pwhalen> afternoon all
20:00:17 <jcapik> .fas jcapik
20:00:18 <zodbot> jcapik: jcapik 'Jaromír Cápík' <jcapik@redhat.com>
20:00:20 <bconoboy> .fas blc@
20:00:21 <zodbot> bconoboy: blc '' <blc@redhat.com>
20:00:28 <j_dulaney> .fas jdulaney
20:00:28 <zodbot> j_dulaney: jdulaney 'John Dulaney' <j_dulaney@live.com>
20:00:46 <j_dulaney> Wow, first non-RH email
20:01:24 * pbrobinson is here
20:01:36 <dmarlin> .fas dmarlin
20:01:40 <zodbot> dmarlin: dmarlin 'David A. Marlin' <dmarlin@redhat.com>
20:01:47 <pwhalen> #topic 0) Status of ACTION items from our previous meeting
20:01:48 <pwhalen> #link http://meetbot.fedoraproject.org/fedora-meeting-1/2013-04-24/fedora-meeting-1.2013-04-24-20.00.html
20:02:06 <pwhalen> #info dgilmore to experiment with making images via anaconda to work around current lmc/anaconda issues
20:02:21 <pwhalen> dgilmore, any update?
20:02:33 <pbrobinson> s/anaconda/appliance-tools
20:02:47 <dgilmore> pwhalen: not making any using anaconda
20:02:49 <pwhalen> #undo
20:02:50 <zodbot> Removing item from minutes: <MeetBot.items.Info object at 0x13503290>
20:02:53 <dgilmore> going to use appliance-tools
20:02:59 * masta is here
20:03:10 <dgilmore> need to tweak some stuff in the kickstart
20:03:10 <pwhalen> #info dgilmore to experiment with making images via appliance-tools to work around current lmc/anaconda issues
20:03:22 <dgilmore> but i plan to have images out for testing this week
20:03:23 <masta> hey dgilmore we fixed the anaconda problem
20:03:30 <dgilmore> masta: and hit another
20:03:33 <masta> lmc works again
20:03:45 <jonmasters> .fas jonmasters
20:03:46 <masta> one line patch from anaconda guys
20:03:46 <zodbot> jonmasters: jcm 'Jon Masters' <jonathan@jonmasters.org>
20:04:10 <dmarlin> masta: I installed all the latest yesterday, and it is broken for me
20:04:13 * ahs3 checks in
20:04:17 <masta> appliance-tools - acknowledged
20:04:37 <masta> dmarlin: I applied the fixes from anaconda guys and works for me
20:04:50 * masta has made several images since
20:04:50 <dgilmore> masta: it got past where it was stuck and blew up elsewhere
20:05:01 <dmarlin> masta: have you tried on an fully updated system (latest of all tools) ?
20:05:19 <masta> yep, of course dmarlin ... well as of last week fully bakes
20:05:36 <dgilmore> masta: tahts ancient in release development world
20:05:40 <dmarlin> masta: then you are the only one it's working for
20:05:48 <masta> dmarlin: =(
20:05:48 <dgilmore> masta: its broken on arm and x86
20:06:31 <masta> dgilmore: I'd like to sync with you on getting your setup fixed, and for myself learn appliance-tools
20:06:37 <bconoboy> let's sort this out after the meeting
20:06:44 <pbrobinson> +1
20:06:46 <pwhalen> alright, next?
20:06:59 <pwhalen> #topic 1) Problem packages
20:07:10 <pbrobinson> cups is a problem on rawhide
20:07:19 <bconoboy> is there a bz?
20:07:23 <pbrobinson> yes
20:07:34 <pbrobinson> https://bugzilla.redhat.com/show_bug.cgi?id=957737
20:08:06 <bconoboy> #link f20's cups is broken: https://bugzilla.redhat.com/show_bug.cgi?id=957737
20:08:46 <bconoboy> anything else?
20:09:15 <pbrobinson> there's a few problems in R-* packages and I'll do a BZ for them this evening
20:09:21 <pbrobinson> all looking reasonably good actually
20:09:42 <pbrobinson> I'm awaiting to hear what the upstream status is on tog-pegasus
20:10:12 <dmarlin> patch is being evaluated (regression testing)
20:10:39 <bconoboy> #info tog-pegasus patch is written, working, in regression testing
20:11:16 <pwhalen> #topic 2) Kernel Status update
20:11:50 <pbrobinson> 3.9 is looking good on f18 targets
20:12:14 <pbrobinson> we've got a few crashes and corner cases people a looking at like highbank
20:12:22 <bconoboy> where do we have graphics support working on 3.9?
20:12:40 <pbrobinson> no a kkernel problem
20:12:51 <pbrobinson> so omap/vexpress/tegra/highbank aren't bad
20:13:17 <pwhalen> I've filed a bug on qemu graphics, omap isnt working.. apparently trimslice is
20:13:28 <pbrobinson> I'm looking at a patch set for am33xx chipset
20:13:38 <pbrobinson> there's a few people looking at mvebu
20:13:48 <jonmasters> pwhalen: it'll be good to figure out what's up with qemu
20:14:17 <jonmasters> #info jonmasters to review highbank config and outstanding issue with Mark/Paul
20:14:20 <pbrobinson> for 3.10 we're already starting to rebase
20:14:34 <jonmasters> #info jonmasters to poke at cpuidle for Peter (who will make a scratch kernel)
20:14:35 <pbrobinson> jonmasters: where did that point come from
20:15:03 <jonmasters> pbrobinson: sorry, I spoke with Paul earlier about it. Should have noted that first, apologies.
20:15:08 <pbrobinson> the major 3.10 arm-soc branch hasn't landed yet, that's when the shit will hit the fan
20:15:33 <pbrobinson> jonmasters: Mark has been reviewing it through out so I'm not sure what's missing, else he's been lying
20:16:08 * j_dulaney notes that 3.10 will be landing a crapton of Exynos fixes
20:16:41 * pbrobinson notes that j_dulaney is still to provide me a diff for fedora 3.9 kernel first ;-)
20:17:03 <masta> so did does panda not have graphics anymore in 3.9? but trimslice does?
20:17:35 <pbrobinson> masta: panda was using fbdev, that might still work, we should really go to the proper driver
20:17:36 <j_dulaney> pbrobinson:  Dude, I was at a music festival all last week :)  Charlie Daniels FTW
20:18:17 <pwhalen> anything else for the kernel?
20:18:26 <pbrobinson> not from me
20:18:31 <jonmasters> pbrobinson: I mean the impact of FSL_DMA and why that's causing highbank instability. I want to take a ponder
20:18:43 <masta> pbrobinson: ah so we are waitting for amr-soc then
20:19:02 <pbrobinson> masta: for what?
20:19:08 <masta> panda
20:19:13 <pbrobinson> masta: no
20:19:49 <pbrobinson> masta: we have xorg-x11-drv-omap and have had since f17 or there abouts
20:20:24 <pwhalen> #topic 3) LPAE A15 support
20:20:29 <masta> ok I suppose i might have understood poorly before, got the idea panda lost graphics, my bad
20:20:37 <pbrobinson> I'm not sure why this is on the agenda
20:21:12 <jonmasters> pbrobinson: I asked that we just discuss what the plan is going to be
20:21:29 <pbrobinson> jonmasters: this has already been discussed to hell
20:22:04 * j_dulaney notes that the PAE kernel as built in Fedora infra is very unstable
20:22:14 <j_dulaney> Seemingly randomly so
20:22:30 <pbrobinson> the lpae or the pae kernel?
20:22:40 <j_dulaney> lpae, sorry
20:23:04 <pbrobinson> j_dulaney: that's the first I've heard of it
20:23:24 <j_dulaney> This is on Chromebook; I don't know what others are testing on
20:23:24 <pbrobinson> jonmasters: so you want it discussed.... what are we discussing?
20:23:44 <jonmasters> plan is/was to retain Exynos as the target. I'm wondering though, given that nobody can get an Arndale board does that change anything for F19?
20:23:56 <pbrobinson> chromebook?
20:24:09 <pbrobinson> and what other HW is currently available on the market?
20:24:40 <j_dulaney> Galaxy S4
20:25:09 <pbrobinson> that's not usable as lpae because it doesn't have expandable RAM and isn't a usecase
20:25:31 <jonmasters> I guess what I'm saying is that we might find more hacker friendly A15 hardware appears in the next few months. If that's the case, are we ok with being fluid on plans? It's a shame nobody can buy an Arndale
20:26:23 <pbrobinson> well in the next few weeks we'll have 3.10rc1 where exynos will be MP and we have all the bloody A15 kernel options we want
20:26:40 <pbrobinson> so I still don't see the argument
20:26:42 * j_dulaney notes that once leads have been soldered to the uart pads on the Chromebook board, it becomes very hacker-friendly
20:26:57 <jonmasters> ok, I'm being silly, you're right. We're likely going out with 3.10 and it'll be MP. Ok, I rescind this item.
20:27:09 <bconoboy> are we going to have 3.10rcX in f19 ga?
20:27:19 <bconoboy> (IE, is it a consideration?)
20:27:21 <pbrobinson> the only other LPAE capable device that has _upstream_ support that would be usable is from a company where you can't buy it yet
20:27:45 <pbrobinson> bconoboy: no, but it'll be in rawhide (is in rawhide)
20:27:49 <jonmasters> bconoboy: the discussion we had before was that it's likely F19 on ARM won't ship until the 3.10 update is ready for PA, so it'll likely be that we go out with 3.10
20:28:04 <bconoboy> nevermind, let's move on
20:28:05 <pbrobinson> bconoboy: and it'll be landing in mainline very shortly after release just like 3.7 did with F-18
20:28:11 <jonmasters> right, yea, let's do move on
20:28:13 <pwhalen> ok
20:28:18 <pwhalen> #topic 4) Aarch64 Bootstrap update
20:28:33 <pbrobinson> jonmasters: no we'll go out with 3.9 and it'll rebase to 3.10 shortly after release
20:28:55 <bconoboy> msalter: That's you unless we just want stats (that's me)
20:29:15 <msalter> what are the stats?
20:29:30 <bconoboy> We have 1240 source rpms for aarch64 packages rebuilt at the moment
20:29:43 <bconoboy> that's about 20% of the total
20:29:54 <jonmasters> what letter are we on now?
20:29:58 <pbrobinson> are they unmodified non bootstrap?
20:30:21 <bconoboy> pbrobinson: this is stage4 packages.  there are a few carrying local packages, but more than 1000 are straight from f19
20:30:31 <bconoboy> er local patches
20:30:33 <msalter> most of them would have to be. I think well less than 200 are bootstrap
20:30:50 <bconoboy> the enqueueing script is currently on the letter 'p'
20:30:56 <jonmasters> fun
20:30:58 <bconoboy> (It's going in alphabetical order)
20:31:11 <bconoboy> there are about 450 packages in the build-queue
20:31:19 <msalter> most patched ones now are patched to avoid requiring doc-building packages
20:31:32 <bconoboy> tnx to jcapik for writing a sensible dependency checker, we're getting a very high success rate on builds
20:31:58 * j_dulaney has a build going right this second
20:32:01 <jcapik> dgilmore: helped too
20:32:03 <bconoboy> #info 1240 aarch64 source rpms are built, about 20% completion
20:32:21 <jonmasters> an idea we want to explore is to have David and Paul tag team taking the failure list and curating a wiki page with packages known to succeed, fail, and those that we know have a non-dependency actual build failure and require attention
20:32:47 <bconoboy> I'll be automating the generation of a failed-build script that pwhalen/dmarlin will curate on the wiki
20:33:00 <bconoboy> (IE, builds that failed in %build)
20:33:07 <jonmasters> bconoboy: info that item please
20:33:26 <bconoboy> #action bconoboy will be automating the generation of a failed-build script (Where %build failed)
20:33:40 <bconoboy> #action pwhalen/dmarlin will curate the fedora wiki to reflect new build failures
20:33:52 <bconoboy> #info anybody can take ownership of a failed build on the wiki
20:34:43 <bconoboy> anything else?
20:35:28 <pwhalen> #info For those interested and not currently take part in the bootstrap
20:35:34 <pwhalen> #link https://fedoraproject.org/wiki/Architectures/ARM/AArch64/QuickStart
20:35:39 <jonmasters> er yea, *awesome* amounts of progress so far!
20:35:47 <jonmasters> I think that's worth noting
20:36:07 <pwhalen> #topic 5) F19 Alpha Planning
20:36:33 <jonmasters> I saw Paul started release criteria based on PA. Do those need collective pruning again?
20:36:39 <bconoboy> I think we roughly covered this at #0- dgilmore is going to make an image with appliance-creator
20:36:46 <pwhalen> sounds like we'll have images to test later this week
20:37:05 <j_dulaney> jonmasters:  I think current release criteria are good
20:37:12 <pwhalen> jonmasters, iirc, we didnt want to prune them
20:37:18 <bconoboy> #action per earlier, dgilmore to create appliance-creator based image (or lmc if masta's success can be replicated)
20:37:26 <jonmasters> ok, if what we have is good, then cool
20:37:48 * j_dulaney notes that if we get images this week, we should have a formal blocker meeting next week
20:38:01 <j_dulaney> Seperate from this meeting, as they can go on for quite some time
20:38:05 <pwhalen> as soon as we have images, we'll do a vfad, see how it goes
20:38:12 <pbrobinson> lets cross that bridge when we get there
20:38:15 <bconoboy> #info vfad to follow image creation
20:38:16 <pbrobinson> what's next
20:38:19 * j_dulaney can run said meeting, having experience in that department
20:38:24 <pwhalen> open floor is next
20:38:47 <pwhalen> j_dulaney, lets coordinate on that one
20:39:10 <pwhalen> #topic 6) Open Floor
20:40:06 <pwhalen> worth noting there is now a remix for the Cubieboard
20:40:24 <pbrobinson> there was a remix for the Cubieboard
20:40:27 <pbrobinson> what's the difference with this one?
20:40:27 <j_dulaney> pwhalen:  Roger
20:40:35 <pwhalen> #link F18 Cubieboard Remix - https://fedoraproject.org/wiki/Architectures/ARM/F18/Remixes#Cubieboard
20:40:48 <dmarlin> there is a remix 'image' for the cubieboard
20:41:06 <pbrobinson> I still don't see the difference
20:41:17 <dmarlin> try them both and see
20:41:24 <pbrobinson> hans produced a remix image that works fine on the CubieBoard
20:42:49 <pwhalen> 18 minutes left, anything else for today?
20:44:01 <bconoboy> sounds like we're all done
20:44:29 <pwhalen> #endmeeting