20:00:03 <pwhalen> #startmeeting Fedora ARM weekly status meeting
20:00:03 <zodbot> Meeting started Wed May  8 20:00:03 2013 UTC.  The chair is pwhalen. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:03 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
20:00:03 <pwhalen> #chair pwhalen jonmasters bconoboy ctyler pbrobinson dgilmore
20:00:03 <zodbot> Current chairs: bconoboy ctyler dgilmore jonmasters pbrobinson pwhalen
20:00:08 <jonmasters> .fas jonmasters
20:00:08 <zodbot> jonmasters: jcm 'Jon Masters' <jonathan@jonmasters.org>
20:00:21 <ahs3> .fas ahs3
20:00:22 <zodbot> ahs3: ahs3 'Al Stone' <ahs3@redhat.com>
20:00:31 <pwhalen> .fas pwhalen
20:00:34 <pwhalen> good afternoon all
20:00:35 <bconoboy> .fas blc@
20:00:38 <zodbot> pwhalen: pwhalen 'Paul Whalen' <pwhalen@redhat.com>
20:00:45 <zodbot> bconoboy: blc '' <blc@redhat.com>
20:01:00 * j_dulaney comes in from tanning goat hides
20:01:32 * masta is here
20:01:37 <dmarlin> .fas dmarlin
20:01:38 <zodbot> dmarlin: dmarlin 'David A. Marlin' <dmarlin@redhat.com>
20:02:08 * pbrobinson is here
20:02:12 <pwhalen> #topic 0) Status of ACTION items from our previous meeting
20:02:21 <pwhalen> #info COMPLETE - bconoboy will be automating the generation of a failed-build script (Where %build failed)
20:02:30 <pwhalen> #info INPROGRESS - pwhalen/dmarlin will curate the fedora wiki to reflect new build failures
20:02:43 <pwhalen> #info INPROGRESS - dgilmore to create appliance-creator based image
20:03:05 <pwhalen> #link http://meetbot.fedoraproject.org/fedora-meeting-1/2013-05-01/fedora-meeting-1.2013-05-01-20.00.html
20:03:13 <pbrobinson> build failures for what? arm or arm64?
20:03:17 <pwhalen> anything else from last week?
20:03:21 <jonmasters> pbrobinson: aarch64
20:03:40 <jonmasters> Brendan's script sent the first email last night - very useful
20:03:41 <pbrobinson> oh so we're going to get that spam every day! joy :-/
20:03:53 * dgilmore is here
20:04:11 <jonmasters> the idea was to provide more info for folks, but it could also be sent somewhere else, if there's somewhere better for it
20:04:41 <pbrobinson> a web page where people that are interested could go?
20:04:57 <pwhalen> we're going to put that together as well
20:05:14 <bconoboy> Is 1 status message a day a big deal?
20:05:41 <pbrobinson> probably not
20:05:49 <pwhalen> anything else from last week, or shall we go on?
20:06:04 <bconoboy> since dgilmore is here an update on image creation, unless that's covered elsewhere
20:06:17 <pwhalen> we have that on the agenda, we could do it now too
20:06:25 <dgilmore> i have appliance-creator making images
20:06:38 <dgilmore> getting patches upstream
20:06:48 <jonmasters> dgilmore: awesome
20:06:51 <pwhalen> excellent
20:06:52 <dgilmore> they dont have a working boot.scr right now
20:06:55 <bconoboy> dgilmore: Evidently livemedia-creator is now more or less functional as well.
20:07:01 <dgilmore> I need to tweak the kickstart some
20:07:13 <pbrobinson> dgilmore can you publish rc builds somewhere so people can start to play
20:07:20 <pbrobinson> if they know about boot.scr etc
20:07:41 <masta> dgilmore: nice
20:07:45 <dgilmore> need to add some more packages to the image and make a new one
20:07:54 <dgilmore> but will then post a link to the list
20:08:05 <pbrobinson> perfect!
20:08:15 * masta notes to give appliance-creator a whirl
20:08:16 <jonmasters> great
20:08:19 <dmarlin> dgilmore: will there just be one image, and if so, what platforms are supported?
20:08:27 <pbrobinson> two images
20:08:38 <pbrobinson> one for omap style systems that need vfat
20:08:44 <pbrobinson> and one for those that don't
20:08:54 <dgilmore> dmarlin: what pbrobinson said
20:08:57 <dmarlin> what platforms are supported?
20:09:07 <dgilmore> dmarlin: all of them that the kernels support
20:09:20 <bconoboy> dgilmore: Are you installing both kernel and kernel-tegra?
20:09:24 <dgilmore> it has kernel kernel-lpae and kernel-tegra installed
20:09:31 <bconoboy> awesome.
20:09:34 <pbrobinson> at the moment we're testing omap (panda), trimslice and vexpress
20:09:53 <pbrobinson> which is what we'll "support" for alpha
20:09:53 <bconoboy> I need to get arm-boot-config into rpm format and submitted
20:10:03 <pbrobinson> from there we'll expand out as people test and confirm
20:10:10 <dmarlin> does it use  arm-boot-config  ?
20:10:17 <bconoboy> dmarlin: probably not yet
20:10:17 <pbrobinson> there should be support for BBone shortly after alpha
20:10:25 <dgilmore> dmarlin: nope its not packaged
20:10:52 <j_dulaney> Are we going to get just a basic filesystem for remixing?
20:11:08 <masta> yes
20:11:20 <pbrobinson> j_dulaney: you should be able to use the standard images for remixing, I'm doing it all the time
20:11:24 <masta> anytime an image existsit's trivial to make a rootfs tarball
20:11:33 <bconoboy> I could use some help getting it packaged, honestly.
20:11:47 <pbrobinson> bconoboy: happy to help, ping me offline
20:11:56 <bconoboy> tnx pbrobinson
20:11:58 <j_dulaney> pbrobinson:  Roger
20:12:06 <pwhalen> next?
20:12:08 <pbrobinson> bconoboy: or on arm channel
20:12:16 <pwhalen> #topic 1) Problem packages
20:12:32 <pbrobinson> there are none to report \0/
20:12:48 <pwhalen> excellent!
20:12:49 <j_dulaney> And there was much rejoicing
20:13:03 <dgilmore> i really dont like a generic rootfs tarball
20:13:09 <pwhalen> we'll have to include aarch64 to this section in the future as well
20:13:26 <dgilmore> pwhalen: i suggest we keep it seperate
20:13:34 <pbrobinson> the tar ball has all sorts of issues like selinux labels, xattr etc
20:13:46 <pwhalen> dgilmore, sure np
20:13:53 <dgilmore> pwhalen: exactly
20:14:01 <dgilmore> pbrobinson: exactly
20:14:08 * j_dulaney just realized something for open floor
20:14:11 <pwhalen> #topic 2) Kernel Status update
20:14:25 <masta> I always make my rootfs's as pure ext4 dumps using dd, then simply resize them when they are put in a partition
20:14:38 <pbrobinson> the 3.10 kernel is moving forward, surprisingly better than I would expect pre rc1.
20:14:40 <dgilmore> i tested 3.9.1 on guruplug it worked okay
20:14:52 <pbrobinson> I'm waiting for something to come and bite us in the arse
20:15:01 <pbrobinson> 3.9 is looking pretty good
20:15:15 <bconoboy> what's left before 3.9 is considered the gold standard kernel for fedora arm?
20:15:17 <pbrobinson> awaiting a response from jonmasters on his opinion on a highbank issue
20:15:32 <pbrobinson> just the jonmasters response
20:15:40 <dgilmore> jonmasters
20:15:46 <pbrobinson> we've already rebased it for f18 and builds are likely to appear shortly
20:16:16 <pbrobinson> and f17 will likely follow around 3.9.2/3
20:16:21 <bconoboy> great
20:16:26 <bconoboy> I think jonmasters is stuck in another meeting atm
20:16:43 <pbrobinson> I've already spoken with him today so we're aligned
20:16:55 <bconoboy> great
20:17:05 <pbrobinson> basically 3.8.x is nicely stable afaik and is now basically dead to me
20:17:15 * pbrobinson goes to grab another beer
20:17:44 <pbrobinson> back
20:17:53 <pwhalen> anything else we want to talk about here?
20:17:58 <pbrobinson> 3.10 is looking reasonable, pwhalen and I are testing
20:18:07 <pbrobinson> we've added a whole bunch of new hosts
20:18:13 <bconoboy> 3.10 will not be in F19 GA will it?
20:18:18 <pbrobinson> nope
20:18:21 <dgilmore> bconoboy: doubtful
20:18:38 <bconoboy> that's too bad- would be lovely to drop kernel-tegra
20:18:47 <pbrobinson> exynos multiplatform didn't land in 3.10 but the patch to enable it is apparently trivial and will be provided to me once rc1 is out
20:18:49 <jonmasters> bconoboy: I am here
20:19:00 <pbrobinson> once that happens I'll move lpae to MP too
20:19:07 <dgilmore> :)
20:19:16 <jonmasters> bconoboy: I spoke with Peter earlier and I am going to poke highbank this evening EDT and provide an update
20:19:35 <jonmasters> (since it's already 4pm)
20:19:39 <pbrobinson> it's also been suggested to me that the upstream mainline kernel for mp testing is based on my config
20:19:40 <bconoboy> #action jonmasters to probe highbank 3.9 instability issue and send update
20:19:59 <pbrobinson> so once rc1 is out and things start to settle I'll start to work to get that pushed upstream proper
20:20:29 <pbrobinson> so we get much wider and better cross distro multiplatform testing
20:20:33 <jonmasters> #action jonmasters to help review 3.10 test kernels, and assist pwhalen with vexpress
20:20:53 <jonmasters> pbrobinson: this was kinda NDA but I guess not any more. So quick extra thing from me:
20:21:08 <jonmasters> Linaro have someone joining the kernel team to assist with testing who will be using the Fedora kernel configs
20:21:18 <pbrobinson> jonmasters: well it's on G+ by others and not me so I guess not :-P
20:21:41 <jonmasters> ah ok, if it's public then cool. I talked with Deepak about it a bunch
20:21:49 <jonmasters> so I hope that will help
20:21:54 <masta> nice
20:22:32 <pwhalen> next?
20:22:39 <bconoboy> y
20:22:41 <pwhalen> #topic 3) Flock (formerly FUDcon)
20:22:44 <pbrobinson> well it looks like other distros are starting to look to MP kernels (finally)
20:23:08 <pbrobinson> so for those that don't know Flock will be a big week long conf
20:23:21 <pbrobinson> similar to the Ubuntu one (what ever it's called)
20:23:24 <pwhalen> #link http://fedoraproject.org/wiki/Flock
20:23:37 <pbrobinson> so we should start to plan talks
20:23:37 <jonmasters> pbrobinson: funnily enough Ubuntu aren't doing another in-person UDS :)
20:23:38 <pbrobinson> etc
20:23:52 <jonmasters> so I rather hope Flock can become a good replacement for that :)
20:24:11 <pbrobinson> I plan on putting down a number of talks/hack fests etc
20:24:16 <bconoboy> flock will be during f20 development- how will this relate to PA push?
20:24:20 <pbrobinson> so we should likely co-ordinate
20:24:34 <pbrobinson> it's designed to be a planning for F-20 etc
20:25:05 <dgilmore> its probably going to be more f21 planning
20:25:11 <pbrobinson> and it might mesh well but we should be building ARM long before that time as PA if we go for F-20
20:25:18 <dgilmore> depending on actual f20 schedules
20:25:19 <pbrobinson> in fact we should be building it now
20:25:33 <bconoboy> ah, so let's discuss that during open floor
20:25:34 <dgilmore> I need to finish my request to fesco
20:25:45 <pbrobinson> dgilmore can we do it at the end
20:26:14 <dgilmore> pbrobinson: sure,
20:26:20 <pwhalen> we dont have much left, next?
20:26:51 <pwhalen> #topic 4) Fedora 19 ARM Alpha - creating images
20:27:22 <pwhalen> we discussed this already.. any eta for the images?
20:27:28 <bconoboy> When dgilmore posts images I'll test arm-boot-config out on them then people can take them for a ride
20:27:30 * pbrobinson wants!
20:27:32 <dgilmore> there will be some today
20:27:46 <pwhalen> nice
20:27:55 <bconoboy> dgilmore: Are you going to switch to livemedia-creator?
20:27:56 <masta> dgilmore: so what kind of patches were involved to appliance-utils or whatever?
20:27:58 <j_dulaney> Sweet
20:28:04 <dmarlin> will they be linked off the wiki with any necessary instructions for use?
20:28:09 <pbrobinson> I think we need to get alpha out the door already
20:28:18 <dgilmore> bconoboy: i am not
20:28:26 <pbrobinson> we will for beta
20:28:40 <pbrobinson> and we need to not stop testing and feeding back to upstream as a result
20:28:54 <pwhalen> dgilmore, I can take care of the wiki with proper pointers
20:28:58 <dgilmore> masta: the patches i added were to write out fstab with disk labels and not partitions
20:29:00 <jonmasters> bconoboy, dgilmore: in that case ignore my question on #fedora-arm about posting the image
20:29:18 <masta> maybe continuous image creation on one of those many highbank sysems in PHX??
20:29:22 <dgilmore> bconoboy: im not planning on using livemedia-creator for f19 at all
20:29:40 <bconoboy> dgilmore: why is that?
20:29:54 <dgilmore> bconoboy: not switching mid release cycle
20:30:12 <pbrobinson> still need to keep testing
20:30:40 <masta> dgilmore: I guess appliance-tools is just another wrapper around anaconda like LMC?
20:30:51 <j_dulaney> +1 to not switching mid-release
20:30:59 <dgilmore> masta: nope, it doesnt use anaconda at all
20:31:14 <masta> whoa... that is  interesting
20:31:26 <dgilmore> masta: it uses livecd-creator and python-img
20:31:46 <dgilmore> i think its called python-img
20:32:08 <dgilmore> a nice thing is that ill be able to make images as koji tasks
20:32:29 <pbrobinson> is that's what's used to make the mainline live images?
20:32:32 <dgilmore> its the same tool used to make ec2 images for x86
20:33:03 <dgilmore> pbrobinson: livecd-creator makes primary lives and appliance-creator makes primary cloud images
20:33:12 <pbrobinson> OK
20:33:16 <pbrobinson> so moving on
20:33:39 <pwhalen> #action dgilmore to post TC Images to list later today/tomorrow
20:33:53 <pwhalen> #action pwhalen to update wiki with pointers/instructions
20:33:59 <pwhalen> anything else?
20:34:19 <pbrobinson> nope
20:34:22 <pwhalen> #topic 5) Open Floor
20:34:38 <pbrobinson> what was the other thing dgilmore wanted to discuss?
20:34:42 <bconoboy> PA push.
20:34:54 <pbrobinson> let's do it.... :-D
20:35:31 <dgilmore> i actually dont want to discuss it. I want to just get it moving
20:35:42 <pbrobinson> great
20:35:54 <pbrobinson> so dgilmore you're doing to proposal
20:36:04 <pbrobinson> let me know where you need help from me or others
20:36:09 <pbrobinson> correct?
20:36:16 * j_dulaney does have a note for this
20:36:19 <pbrobinson> what do we believe are blockers?
20:36:22 <dgilmore> right
20:36:29 <dgilmore> blocker right now is anaconda
20:36:34 <dgilmore> which is being worked on
20:36:39 <j_dulaney> Technically, should not armv7 and armv8 be pushed seperatelly?
20:36:50 <pbrobinson> j_dulaney: yes
20:36:55 <jonmasters> yes
20:36:57 <dgilmore> j_dulaney: yes
20:36:58 <pbrobinson> j_dulaney: armv8 isn't in the discussion
20:36:59 <bconoboy> also documentation
20:37:05 <j_dulaney> Okay
20:37:18 <pbrobinson> j_dulaney: we're talking arm-hfp
20:37:29 <j_dulaney> Roger
20:37:49 <dgilmore> documentation is needed
20:37:50 <pbrobinson> I believe kernel is in a good spot
20:38:10 <pbrobinson> we need to close out some of the packaging/builds but there's a very small amount there
20:38:24 <dgilmore> we are around 20 packages behind
20:38:29 <pbrobinson> documentation for things like builds and QA etc
20:38:58 <pbrobinson> dgilmore: yes, until we get to mainline that's always a moving target backwards/forwards
20:39:06 <bconoboy> also releases- we don't have any integration with the main fedora wiki
20:39:08 <dgilmore> yep
20:39:18 <dgilmore> but we are pretty consistently close
20:39:46 <dgilmore> bconoboy: wiki is not really used for release documentation
20:39:56 * j_dulaney also thinks it may be a good idea to do Rawhide nightly images just like primary
20:40:08 <dgilmore> j_dulaney: what are you talking about
20:40:20 <dgilmore> we dont do any nightly rawhide images on primary
20:40:29 <pbrobinson> j_dulaney: even mainline doesn't do rawhide images, only composes
20:40:38 <j_dulaney> dgilmore:  Primary has nightly lives prior to branching
20:40:55 <dgilmore> j_dulaney: thats done by the spins sig and not releng
20:41:03 <j_dulaney> Ah
20:41:07 <pbrobinson> j_dulaney: if you want rawhide from mainline you yum upgrade
20:41:08 <j_dulaney> NVM, then
20:42:28 <pbrobinson> right, anything else?
20:42:33 <pwhalen> anything else?
20:42:54 <dgilmore> nothing
20:42:59 <pwhalen> going once..
20:43:01 * j_dulaney is good
20:43:05 <pwhalen> sold
20:43:08 <pwhalen> #endmeeting