20:18:19 <pwhalen> #startmeeting Fedora ARM weekly status meeting
20:18:19 <zodbot> Meeting started Wed May 15 20:18:19 2013 UTC.  The chair is pwhalen. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:18:19 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
20:18:19 <pwhalen> #chair pwhalen jonmasters bconoboy ctyler pbrobinson dgilmore dmarlin masta j_dulaney msalter ahs3 agreene jcapik ddd
20:18:20 <zodbot> Current chairs: agreene ahs3 bconoboy ctyler ddd dgilmore dmarlin j_dulaney jcapik jonmasters masta msalter pbrobinson pwhalen
20:18:26 <pwhalen> .fas pwhalen
20:18:27 <jonmasters_> .fas jonmasters
20:18:30 <j_dulaney> .fas jdulaney
20:18:30 <jcapik> .fas jcapik
20:18:34 <ahs3> .fas ahs3
20:18:36 <bconoboy> .fas blc@
20:18:36 <dmarlin> .fas dmarlin
20:18:50 <dgilmore> hola amigos
20:18:56 * nirik notes it's still rejoining, but probibly will now spew that when it gets caught up. ;)
20:18:57 <pwhalen> a little delayed it seems
20:19:05 * masta high fives nirik
20:19:10 <pwhalen> nirik, cool, thanks
20:19:17 <dgilmore> cheers mate
20:19:19 <bconoboy> pwhalen: go ahead
20:19:20 <pwhalen> #topic 0) Status of ACTION items from our previous meeting
20:19:20 <pwhalen> #link http://meetbot.fedoraproject.org/fedora-meeting-1/2013-05-08/fedora-meeting-1.2013-05-08-20.00.html
20:19:30 <pwhalen> #info COMPLETE - dgilmore to post TC Images to list later today/tomorrow
20:19:31 <pwhalen> #info COMPLETE - pwhalen to update wiki with pointers/instructions (to be updated for Beta)
20:19:31 <pwhalen> #info INPROGRESS - jonmasters to help review 3.10 test kernels, and assist pwhalen with vexpress
20:19:31 <pwhalen> #info INPROGRESS - jonmasters to probe highbank 3.9 instability issue and send update
20:19:59 <bconoboy> jonmasters: isn't the 3.9 instability complete now?
20:20:49 <pwhalen> bconoboy, it is, not sure if jonmasters_ was still looking at it
20:21:20 <pwhalen> next? or anything to add here?
20:21:40 <bconoboy> will be interested in 3.10 status- assume that's later though
20:22:22 <pwhalen> #topic 1) Problem packages
20:22:26 <jonmasters_> bconoboy: 3.9 kernel is complete for now
20:22:34 <jonmasters_> bconoboy: sorry, laggy network
20:22:37 <pwhalen> #undo
20:22:37 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x21356550>
20:23:12 <jonmasters_> We discussed the 3.9 kernel (highbank in particular) and I suggested to Peter that we turn off the Primecell DMA controller support that was offending, and only affected highbank+some A15 targets
20:23:24 <jonmasters_> Peter left it on in rawhide and we'll followup, etc. But 3.9 is ok for now
20:23:38 <jonmasters_> 3.10 I took a quick pass but I won't have a good update until Friday or Saturday
20:23:47 <jonmasters_> I will be spending this weekend giving Fedora kernel some love though
20:23:59 <jonmasters_> so keep a 3.10 action for me
20:24:22 * j_dulaney just wgeted the latest kernel 3.10 srpm
20:24:24 <pwhalen> #action jonmasters to help review 3.10 test kernels, and assist pwhalen with vexpress
20:24:36 <jonmasters_> thanks Paul
20:24:39 * j_dulaney is now wgeting the 3.10 lpae
20:24:41 <pwhalen> #topic 1) Problem packages
20:25:05 <pwhalen> not sure if Peter is joining us, is anyone else aware of any current problem packages?
20:25:16 * jonmasters_ is at the NYSE today - spoke about Hyperscale ARM servers and met with the production IT folks at NYSE. Also saw closing bell just now. Just wow. Now in an awesome Paul McKenney RCU kernel talk :)
20:25:17 <jonmasters_> 837830
20:25:27 <jonmasters_> oops - ignore that :)
20:26:06 <zodbot> pwhalen: pwhalen 'Paul Whalen' <pwhalen@redhat.com>
20:26:09 <zodbot> jonmasters_: jcm 'Jon Masters' <jonathan@jonmasters.org>
20:26:11 <zodbot> j_dulaney: jdulaney 'John Dulaney' <j_dulaney@live.com>
20:26:12 <dgilmore> we had issues with java-1.7.0-openjdk
20:26:17 <zodbot> jcapik: jcapik 'Jaromír Cápík' <jcapik@redhat.com>
20:26:20 <zodbot> ahs3: ahs3 'Al Stone' <ahs3@redhat.com>
20:26:23 <zodbot> bconoboy: blc '' <blc@redhat.com>
20:26:25 <bconoboy> the dev says it's fixed, so we just need to retest the build
20:26:27 <dgilmore> but they got resolved today
20:26:29 <zodbot> dmarlin: dmarlin 'David A. Marlin' <dmarlin@redhat.com>
20:27:24 <dgilmore> pwhalen: rawhide should catch up again now
20:27:49 <bconoboy> next?
20:27:56 <dgilmore> yep
20:28:08 <pwhalen> #topic 2) Kernel Status Update
20:28:34 <pwhalen> this is Peter's weekly topic, as of now I do not think anything is booting, shall we move on?/
20:28:34 <j_dulaney> See my above regaurding d/l 3.10
20:28:52 <j_dulaney> Otherwise, nothing to add
20:28:54 <bconoboy> what about graphics support in 3.9?
20:29:05 <pwhalen> add to the f19 topic
20:29:07 <pwhalen> added
20:29:09 <bconoboy> ok
20:29:11 <dgilmore> bconoboy: i think we have trimslice only
20:29:24 <pwhalen> #topic 3) Aarch64 Status Update
20:29:45 <bconoboy> We've currently rebuilt 9278 aarch64 source rpms, 2823 of which produced aarch64 specific packages.
20:29:53 <jonmasters_> beautiful progress
20:29:54 <bconoboy> So about 4000 to go
20:30:08 <masta> bconoboy: fantastic
20:30:14 <ctyler> Yay!
20:30:19 <pwhalen> nice, screen just finished, will be deploying image/systemd builders in place of all nfs shortly
20:30:20 <bconoboy> msalter has been clearing out dependency loops with great speed
20:30:24 <j_dulaney> And there was much rejoicing
20:30:41 <bconoboy> We're going to try getting ourselves weened off stage3 this week.
20:30:46 <msalter> linuxconsoletools built and vim is building now
20:31:07 * j_dulaney has built ghc
20:31:19 <bconoboy> #info 9278 packages built, 4000 to go
20:31:29 <dgilmore> pwhalen: we have a new image?
20:31:33 * j_dulaney did it outside of the script, however, so is manually uploading to Fedora People
20:31:46 <masta> j_dulaney: wow... that is the one that requires ghc to build ghc, right?
20:31:52 <bconoboy> #info documentation processing packages such as texlive and doxygen are now built
20:32:09 <bconoboy> #info j_dulaney has bootstrapped ghc
20:32:10 <jonmasters_> yea, that was awesome to see
20:32:10 <pwhalen> dgilmore, I can post the image with some edits
20:32:16 <jonmasters_> (esp. texlive)
20:32:23 <dgilmore> pwhalen: cheers, ill try again
20:32:27 <j_dulaney> masta:  Indeed
20:32:37 <bconoboy> #info new foundation model is available which fixes crash issue with image-based rootfs
20:32:52 <j_dulaney> Oh, it is?
20:32:55 <j_dulaney> Link?
20:33:08 <bconoboy> should be at the same place as previous version
20:33:13 <bconoboy> (I don't have a link handy)
20:33:23 <pwhalen> #action pwhalen to post new image/instructions to the wiki for aarch64 quickstart
20:33:37 <bconoboy> j_dulaney: Link is at https://fedoraproject.org/wiki/Architectures/ARM/AArch64/QuickStart
20:33:42 <j_dulaney> Thanks
20:33:52 <bconoboy> #link Participating on the bootstrap starts at https://fedoraproject.org/wiki/Architectures/ARM/AArch64/QuickStart
20:34:30 <bconoboy> msalter: what're you planning on tackling next?
20:35:25 <msalter> php, then whatever seems to be blocking the most.
20:35:48 <bconoboy> I updated the missing dependency email to use more current data
20:36:09 <msalter> I wonder if we have enough built to provision a koji builder...
20:36:29 <bconoboy> ooh, that's a good question
20:36:41 <msalter> I bet we do or are very close
20:36:50 <bconoboy> we do have the koji-builder rpm built
20:37:02 <bconoboy> (as of may 2)
20:37:08 <jonmasters_> battery in this laptop is dying and I seem to have left power adapter in hotel so I might have to drop (and be back online later) - have another laptop, but it's not configured for freenode and so on
20:37:20 <dgilmore> we want to build everything before moving to koji
20:37:37 <j_dulaney> jonmasters_:  webchat.freenode.net
20:37:41 <jcapik> the current way is faster with emulators
20:37:50 <j_dulaney> jonmasters_:  WebUI for irc
20:38:06 <jonmasters_> j_dulaney: yea, I know, might do that
20:38:18 <pwhalen> bconoboy, msalter we do have koji-builder
20:38:24 <pwhalen> (noarch)
20:38:33 <bconoboy> anything else for this topic? questions?
20:38:42 <pwhalen> anything else for aarch64?
20:39:15 <pwhalen> #topic 4) Fedora 19 Beta for ARM
20:39:21 <pwhalen> #topic 4a) Fedora 19 for ARM - Skipping Alpha, releasing Beta with PA
20:39:47 <bconoboy> dgilmore and I discussed- we think it's better to skip alpha and ship beta at the same time PA does
20:40:02 <jonmasters_> +1
20:40:03 <bconoboy> that gives us just under 2 weeks to get it done
20:40:09 <masta> ok so we can use vfad
20:40:17 <jonmasters_> masta: good idea
20:40:23 <jonmasters_> maybe a Friday one again?
20:40:24 <pwhalen> we've had a bit of a closed alpha to get to Beta, sounds good to me
20:40:51 <bconoboy> pwhalen: okay, what's 4b? :-)
20:40:59 <masta> friday sounds good
20:41:05 <pwhalen> #topic 4b) Fedora 19 for ARM - Graphics support
20:41:21 * j_dulaney is +1 for Friday
20:41:37 <jonmasters_> we'll need to have TCs in place for Friday if we want to whack-a-mole stuff
20:41:49 <pwhalen> vfad is coming up
20:41:55 <pwhalen> 4d :)
20:41:59 <jonmasters_> ok
20:42:12 <bconoboy> for f19 it appears we're talking about just using tegra for graphics support, dropping vexpress and omap. yes?
20:42:13 <pwhalen> for graphics I think we only have tegra, but I havent tested it
20:42:33 <dmarlin> dropping vexpress?
20:42:51 <pwhalen> dmarlin, for graphics only iiuc
20:42:52 <jonmasters_> I'll poke vexpress over the weekend for you but I am not opposed
20:42:55 <bconoboy> evidently it doesn't work
20:43:06 <bconoboy> I would really like to include vexpress support, but don't have anybody on hook to fix it
20:43:47 <ctyler> >> crickets <<
20:44:02 <jonmasters_> bconoboy: put me on hook for update on Monday on vexpress graphics
20:44:04 <bconoboy> Okay, so unless jonmasters pulls a rabbit out of his hat let's assume we're tegra only, if that
20:44:05 <j_dulaney> Any idea what's up with it?
20:44:16 <jonmasters_> bconoboy: I'll triage before Monday, provide an update on what I think is possible
20:44:17 <pwhalen> I filed a bz on vexpress graphics, but no action on it
20:44:20 <j_dulaney> Just curios
20:44:31 <bconoboy> So, beta-> might not have graphical support
20:44:44 <bconoboy> #info beta might not have support for graphics hardware
20:44:59 <bconoboy> #action jonmasters will check vexpress or omap over weekend
20:45:05 <bconoboy> #action pwhalen will investigate tegra options
20:45:10 <jonmasters_> I promise an update before Monday
20:45:12 <dgilmore> in my testing ive had graphical console only on trimslice
20:45:15 <jonmasters_> pwhalen: please ping me on Monday for said update
20:45:28 <bconoboy> 4c?
20:45:30 <pwhalen> jonmasters_, will do
20:45:40 <pwhalen> #topic 4c) Fedora 19 for ARM - Image format
20:46:04 <bconoboy> what is this?
20:46:12 <masta> image format?
20:46:21 <pwhalen> I more had a question of what we're shipping, partitioning layout
20:46:42 <pwhalen> the Beta image posted had vfat on the 2nd partition, which didnt work for omap
20:46:46 <dgilmore> i going to try see if we can make a single image for everything
20:46:55 <masta> oh.. so we have a unified image now...
20:47:03 <dgilmore> pwhalen: need to test some more
20:47:04 <pwhalen> the Beta did work on the trimslice and vexpress
20:47:06 <masta> ok so do we want a swap partition?
20:47:14 <dgilmore> masta: it was 3rd
20:47:39 * j_dulaney notes he had trouble with kernel modules auto-loading
20:47:48 * j_dulaney is going to poke that some more
20:47:50 <dgilmore> i made a image /boot 500mb /boot/uboot 20mb swap 500mb / 6500mb
20:48:15 <bconoboy> dgilmore: Let's not waste too much time on this- we can still have partition 1 be vfat and then use partition 2 for /boot
20:48:33 <bconoboy> chain leading a uEnv.txt or boot.scr from partition 1 to partition 2 is fast and easy
20:48:34 <dgilmore> omap spec says it reads the partition table and loads from first fat partition
20:48:51 <bconoboy> first fat partition or first partition which needs to be fat? :-)
20:49:08 <dgilmore> first fat partition
20:49:17 <bconoboy> There's also the weird boundary alignment issues to be considered
20:49:22 <masta> I thought the first partition, and it can be a raw offset or vfat
20:49:36 <pwhalen> ok, so we do need some more testing on this prior to a vfad, I think friday may be a little early, dgilmore?
20:49:59 <bconoboy> perhaps vfad monday?
20:50:01 <pwhalen> perhaps Tuesday? (monday is a holiday here)
20:50:02 * masta is happy to test before vfad - fyi
20:50:08 * jonmasters_ ok with Monday
20:50:10 <bconoboy> or tuesday
20:50:12 <dgilmore> #info  docs on omap booting http://www.omappedia.com/wiki/Bootloader_Project
20:50:13 <masta> +1 monday
20:50:46 <pwhalen> +1 tuesday
20:50:51 <j_dulaney> Only problem with Monday is QA conflicts
20:50:56 <pwhalen> which is next
20:50:57 <j_dulaney> +1 Tuesday
20:50:59 <masta> alright well dont' wait for vfad to release images. I'd be happy to test them instead of doing $dayjob anytime
20:51:02 <bconoboy> pwhalen is out monday, so tuesday it is
20:51:02 <pwhalen> #topic 4d) Fedora 19 for ARM - Scheduling a VFAD
20:51:22 <dgilmore> we will have a test compose today
20:51:31 <pwhalen> #info Fedora 19 Beta VFAD on Tuesday May 21st (provided we have images)
20:51:31 <bconoboy> How about tuesday for vfad, informal testing earlier?
20:51:38 <dgilmore> primary should have a rc today or tomorrow
20:51:44 <pwhalen> #undo
20:51:44 <zodbot> Removing item from minutes: <MeetBot.items.Info object at 0x21dd8350>
20:51:46 <dgilmore> so ill do a matching compose
20:51:52 <pwhalen> #info Fedora 19 Beta VFAD on Tuesday May 21st @ 11am (provided we have images)
20:52:01 <bconoboy> dgilmore: you going to use 0.43 arm-boot-config?
20:52:20 <dgilmore> bconoboy: unless we have something newer
20:52:35 <bconoboy> dgilmore: 0.44 is done but not pushed.  the interesting fix will be in 0.45.
20:52:58 <dgilmore> bconoboy: okay
20:53:03 <masta> dgilmore: ok sounds great.. I'd check back later for those iamges and start working
20:53:04 <pwhalen> bconoboy, would be great to have the .45 , any eta on that?
20:53:13 <bconoboy> pwhalen: I'll work on it today
20:53:22 <pwhalen> cool, thanks!
20:53:43 <bconoboy> .44 and earlier will blindy try to boot the most recently installed kernel instead of one that definitely has a matching dtb.  .45 will fix this.
20:53:43 <pwhalen> alright, anything else for f19?
20:54:28 <pwhalen> #topic 5) Pidora Status Update
20:54:39 <ddd__> just fyi: if tuesday 5/28 vfad, that's the currently scheduled Virt vfad for f19
20:54:41 <pwhalen> ctyler, take it away
20:54:57 <pwhalen> ddd__, would be the 21st
20:55:10 <ctyler> Do we have a Pidora 18 final image.
20:55:11 <ctyler> But!
20:55:16 <dgilmore> beta release day is 5/28
20:55:25 <ddd__> pwhalen: 21st is holiday?
20:55:30 <ctyler> The foundation updated the firmware on Monday, and we have some breakage.
20:55:34 <bconoboy> ddd: 20 is holiday
20:55:35 <pwhalen> ddd__, 20th here
20:55:41 <j_dulaney> Memorial Day
20:55:54 <masta> ctyler: I like that name: Pidora
20:55:54 <dgilmore> ctyler: what kinda breakage?
20:55:55 <ddd__> No, Memorial day on 27th....
20:56:02 <ctyler> Should have that fixed in the next few hours. Once we have final image, we'll schedule the release announcement.
20:56:04 <j_dulaney> ctyler:  You speak of v6 Pidora?
20:56:10 <ctyler> dgilmore: firstboot doesn't run
20:56:16 <dgilmore> ddd__: pwhalen is canadian
20:56:20 <ctyler> Pidora is the Raspberry Pi Fedora Remix armv6hl version
20:56:23 <pwhalen> Canadian :)
20:56:25 <dgilmore> ctyler: okay
20:56:34 <j_dulaney> Coolio
20:56:39 <ctyler> Looks like an issue accessing the vfat /boot partition.
20:56:50 <ctyler> We would have shipped with the previous firmware rev, but the new firmware
20:56:56 <pwhalen> ctyler, agreene fossjon oatley awesome work, I look forward to checking it out!
20:57:04 <ctyler> enables Pidora to be included on a new multi-distro card image
20:57:10 * ddd__ nix's pwhalen if he's a (Montreal) Canadien fan ... :{=}
20:57:16 <ctyler> that will be bundled with the HW for a few dollars.
20:57:27 <ctyler> And we really want to be there.
20:57:31 <pwhalen> ddd__, sadly Toronto.. :(
20:57:45 <ddd__> pwhalen: my sincere condolences
20:57:57 * ddd__ doing happy feet dance....
20:58:41 <pwhalen> ctyler, great, any features we can look for, cool things? or should we wait for the announcement?
20:59:16 <ctyler> Reasonable performance of the GUI, full toolchain on the card, nice firstboot,
20:59:28 * pwhalen ignores anything Boston
20:59:32 <ctyler> headless mode, many other fun things.
20:59:37 <bconoboy> nice
21:00:08 <ddd__> Boston Strong...
21:00:19 <j_dulaney> cyler:  I note that the last test image I tried, I had to manually enable ssh
21:00:25 <j_dulaney> ctyler, even
21:00:32 <ahs3> oooo....headless rpi... i like that
21:00:44 <masta> ctyler: that sounds really good.
21:00:46 <ctyler> j_dulaney: We've got that one covered
21:00:57 <j_dulaney> ctyler:  I plugged in a keyboard and typed everything from memory, since I don't have anything to plug it in to
21:01:21 <masta> ctyler: do we get a sneak peak of Pidora to try it out?
21:01:23 <pwhalen> j_dulaney, lol
21:01:28 * j_dulaney likes it when make gives exit 0
21:01:32 <ctyler> headless mode: drop an empty file "headless" in the vfat partition and it adjusts for headless operation. IP paramters can be specified in that file, too, if you don't want DHCP.
21:01:50 <ahs3> nice
21:01:52 <pwhalen> cool
21:01:54 <j_dulaney> Nice
21:02:07 <ctyler> masta: I'll send the link to the image as soon as we beat this firmware into submission.
21:02:24 <j_dulaney> ctyler:  Is there a way to tell the kernel to reduce/remove ram dedicated to vid memory?
21:02:37 <j_dulaney> ctyler:  I'd like new image, too
21:02:37 <ctyler> j_dulaney: it's dynamic now
21:03:00 <pwhalen> #action ctyler to send an email to the list with Pidora (Raspberry Pi Fedora 18 Remix armv6hl version) image link
21:03:06 <j_dulaney> tyler:  So, if I go into runlevel3, it does it automagically?
21:03:51 <ctyler> j_dulaney: oh, it doesn't go to zero, since the GPU is needed for some ops (it does have 97% of the chip), but it drops low.
21:04:08 <j_dulaney> Cool
21:04:37 <pwhalen> ctyler, anything else to add ?
21:05:20 <pwhalen> thanks for the update as well, congrats to the team at Seneca
21:05:31 <j_dulaney> +1
21:05:33 <masta> yes great work Seneca!
21:05:53 <pwhalen> #topic 6) Open Floor
21:06:04 <pwhalen> anything else folks?
21:06:18 <masta> so I just got my omap5 pandaboard, does our 3.9 have that enabled?
21:06:42 <dgilmore> masta: nope
21:06:43 <ctyler> (Oooh, shiny. How do you like it?)
21:06:44 <bconoboy> masta: pointer?
21:07:03 <masta> it jsut arrived, durring this meeting it wa sunboxed
21:07:08 <masta> just even...
21:07:19 * kwizart wishes to have support for paz00 in a-b-c (aka toshiba ac100), will probably make a patch
21:07:23 <masta> bummber about the kernel =(
21:07:36 <pwhalen> masta, it will in 3.10
21:08:17 <dgilmore> masta: 3.10 will have it in lpae when we get exynos multiplatform patches
21:08:27 <masta> hey I was wondering do we have any funding in sencondary SIG for Fedora community FADs, for say.... people who want to hackathon on their Raspberry Pi's in San Francisco??
21:08:54 <dgilmore> masta: no idea
21:09:07 <ctyler> masta: the ambassadors would know
21:09:18 <masta> ok I'll ask rbergeron
21:09:30 <masta> ctyler: acknowledged
21:09:37 <ctyler> Do we have BB-Black support?
21:10:01 <dgilmore> no idea
21:10:15 <masta> ctyler: I've been trying to get BBB working using their kerrnel and boot bits... without rootfs... no luck so far
21:10:20 <bconoboy> bb and bb-black support are one in the same aren't they?
21:10:27 <ctyler> bconoboy: Not sure
21:10:30 <masta> err.. with our rootfs
21:10:39 <pwhalen> ctyler, Peter mentioned adding some patches for bb black uboot support
21:10:42 <masta> bconoboy: yes
21:10:58 <pwhalen> and I think 3.10 for the kernel
21:11:01 <ctyler> (I thought the on-board peripherals varies slightly)
21:11:05 <masta> the BB and BB/B we will carry some patches until 3.11
21:11:14 <ctyler> k
21:11:28 <masta> but the patches are happy upstream so we are good
21:12:18 <ctyler> 'Cuz if f upstream ain't happy, ain't nobody happy.
21:12:41 <pwhalen> anything else for today?
21:12:55 <dgilmore> nope
21:13:01 <masta> none
21:13:08 <pwhalen> #endmeeting