19:01:08 <jreznik> #startmeeting Fedora 19 Beta Readiness Meeting
19:01:08 <zodbot> Meeting started Thu May 23 19:01:08 2013 UTC.  The chair is jreznik. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:08 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:01:21 <jreznik> #meetingname f19-beta-readiness-meeting
19:01:21 <zodbot> The meeting name has been set to 'f19-beta-readiness-meeting'
19:01:41 <jreznik> #topic Purpose of this meeting
19:01:43 <jreznik> #info "Before each public release all of the groups participating the development of Fedora's next release meet to make sure the release is well coordinated."
19:01:44 <jreznik> #link https://fedoraproject.org/wiki/Release_Readiness_Meetings
19:02:19 <jreznik> #topic Current status
19:02:21 <jreznik> #info at the Go/No-Go meeting today, it was agreed to Go with Fedora 19 Beta by Fedora QA, FPL, FPGM and developers
19:02:54 <jreznik> so it's really the right time to be prepared for the release!
19:03:22 * randomuser cheers
19:03:52 <jreznik> well, let's start and let's see how many people will join us today
19:04:07 <jreznik> #topic Ambassadors
19:04:20 * nirik is here.
19:05:24 <jreznik> well, I think we would not get a status from Ambassadors as sesivany and company are at LinuxTag this week, I'll try to follow with them offline (or usually there's not so much from Ambassadors for Beta)
19:06:08 <jreznik> #info no status from Ambassadors, sesivany is at LinuxTag this week, not a blocker for Beta release
19:06:25 <jreznik> #action jreznik to follow up with sesivany offline before the actual release
19:06:49 <jreznik> #topic Design
19:08:06 <rbergeron> oh, i'm in the wrong channel. woo
19:08:16 <jreznik> :)
19:08:30 <suehle> Ha! I just flipped over here because I was in the wrong channel.
19:08:53 <jreznik> which one? :)
19:09:19 * suehle goes to any meeting where cupcakes are served. Anybody bring cupcakes to this one?
19:09:20 <jreznik> not sure we have ryan here or anybody from design :(
19:09:39 * suehle pings him
19:09:51 * jreznik pinged him too
19:10:25 <jreznik> robyduck: do we have anything needed from design team for websites?
19:11:39 <jreznik> #action jreznik to follow up with Design team offline (or later today)
19:12:01 <jreznik> #topic Documentation
19:12:08 <jreznik> randomuser: your turn
19:12:32 <randomuser> sorry, a little distracted
19:12:41 <jreznik> np
19:12:50 <randomuser> we're looking good on the release notes, and have steady progress on guides
19:13:29 <randomuser> The release announcement needed work last I checked, not sure if you prefer to discuss that here or during marketing's segment
19:13:56 <jreznik> randomuser: suehle already started working on it, what do we want to do with https://fedoraproject.org/wiki/Fedora_19_Beta_release_notes for Beta?
19:14:17 <jreznik> #info documentation is looking good on the release notes, and have steady progress on guides
19:14:28 <rbergeron> suehle: are we doing beta release notes in lieu of releas eannouncement
19:14:31 <rbergeron> or in addition to?
19:14:46 <randomuser> Nothing. I'll push what we have on RNs to docs.fp.o, any announcements can link there directly
19:15:03 <suehle> no - here's what I've got for the announcemnet
19:15:04 <suehle> https://fedoraproject.org/wiki/F19_Beta_release_announcement
19:15:18 <suehle> I changed up some of the features from what was listed on the alpha announcement but of course, open to more changes
19:15:35 <jreznik> so it means more like we are going to abandon https://fedoraproject.org/wiki/Fedora_19_Beta_release_notes in favour of Announcement and RNs as docs.fp.o?
19:15:40 <rbergeron> where did federated voip come from?
19:15:46 <suehle> the list of features
19:16:01 <suehle> http://fedoraproject.org/wiki/Releases/19/FeatureList
19:16:23 <randomuser> jreznik, yes, unless we feel there is a compelling reason to wikify the RNs that are now ready for publication
19:16:37 * jreznik will review the list of features in the announcement to make sure it reflects current status but everything on FeatureList should be 100% ready now (First Cloud Images probably need some checking)
19:16:40 <rbergeron> wow - i have looked at that list endlessly and apparently was blind to that one
19:16:56 <suehle> Better than I looked at that list and read words that weren't there ;)
19:17:08 <randomuser> hmm.. I should probably do the same review, jreznik
19:17:16 <jreznik> randomuser: do we want to redirect again or get rid of the wiki completely (or do it from F20+?)
19:17:37 <jreznik> randomuser: more eyes, better!
19:17:54 <randomuser> heh, i meant for the RNs
19:18:22 <jreznik> randomuser: ok - I'll do :) could you link me to the current version?
19:18:27 <randomuser> jreznik, the redirect was a one-time solution that we hopefully will not require again
19:18:44 <jreznik> randomuser: so just get rid of it completely now?
19:19:07 <randomuser> We're talking about the redirect in the release announcement wiki page, right?
19:19:31 <jreznik> #info the initial version of announcement available for additions/review
19:19:46 <randomuser> http://fedorapeople.org/groups/docs/release-notes/ - there are corrections that have not been pushed here, will do later today
19:19:58 <jreznik> randomuser: this redirect https://fedoraproject.org/wiki/F19_Alpha_release_announcement?rd=Fedora_19_Alpha_release_notes we did for Alpha
19:20:11 <randomuser> feature status review would be appreciated though
19:20:32 <randomuser> ah
19:20:38 <randomuser> we don't need that for beta, no
19:21:27 <jreznik> randomuser: ok
19:21:41 <jreznik> #action jreznik to review status of feature in release notes and announcement
19:21:59 <randomuser> #action randomuser put a link in the announcement wiki page to beta release notes on docs.fp.o pnce they are published
19:22:10 <jreznik> anything else for docs? we can cover announcements later in the appropriate section
19:22:32 <randomuser> I'll try and push fixes in the RPM too, but that doesn't stop a go from docs
19:22:40 <jreznik> ok
19:22:51 <jreznik> thanks
19:22:57 <jreznik> moving on
19:23:13 <jreznik> ping me in case of any emergency
19:23:18 <jreznik> #topic FESCo
19:23:19 <randomuser> will do, thanks
19:23:31 <jreznik> nirik: and your turn for FESCo
19:23:52 <nirik> we should be all ready that I know of.
19:23:57 <nirik> no causes for concern on our end.
19:24:26 <jreznik> #info no causes for concerns from FESCo
19:24:27 <jreznik> thanks
19:24:41 <jreznik> #topic Fedora Engineering Manager
19:24:59 <jreznik> spot: are you around? your turn if you have anything
19:26:56 <jreznik> let's skip it for now, usually no concerns from spot, I'll follow up offline
19:27:12 <jreznik> #topic Translation
19:27:35 <jreznik> do we have anyone from translations team here?
19:28:51 * jreznik is trying to ask in #fedora-l10n
19:30:29 <jreznik> #action jreznik to follow up with translation team offline (or later today)
19:31:09 <jreznik> #topic Fedora Project Leader
19:31:25 <jreznik> rbergeron: just a sec from you :) while listening to you
19:31:41 <rbergeron> hi!
19:33:15 <rbergeron> I have no concerns.
19:33:29 <jreznik> #info no concerns from FPL
19:33:33 <jreznik> thanks rbergeron
19:33:35 <rbergeron> Hallelujah for an on-time release of something
19:33:36 <rbergeron> :)
19:33:52 <rbergeron> (jreznik: it's an awesome feeling)
19:34:17 <jreznik> rbergeron: and we were so close with alpha too! still a lot of work behind us for final
19:34:26 <jreznik> rbergeron: yes, it is!
19:34:41 <jreznik> #topic Marketing
19:35:05 <jreznik> suehle: you started the announcement page, we need to coordinate the actual announcement
19:35:21 <jreznik> but I'd say - having it ready is enough for dgilmore to pick it up
19:36:10 <suehle> jreznik, woot readiness :)
19:37:37 <jreznik> #link https://fedoraproject.org/wiki/F19_Beta_release_announcement
19:38:10 <jreznik> randomuser is going to put there RN link
19:38:45 <randomuser> It's a predictable URL, if anyone else happens to have the editor open :)
19:38:54 <jreznik> suehle: do you have anything more from marketing pov?
19:39:20 * jreznik will be checking updates to the announcement
19:41:42 <suehle> Well, fedoramagazine.org is alive and kicking, so it's the first release we can announce there. (Woo!)
19:41:56 <jreznik> cool!
19:41:59 * suehle will try to start reducing the number of "woos" in her typing now.
19:42:11 <jreznik> #info fedoramagazine.org is alive and kicking
19:42:15 <jreznik> will you take care of that?
19:42:18 <suehle> yup
19:43:15 <jreznik> thanks
19:43:28 <jreznik> #topic Infrastructure
19:43:34 <jreznik> nirik: you again
19:43:53 <nirik> we are all set. ;) Just need the bits in place from releng and ready to mirror and distribute. ;)
19:44:31 <jreznik> #info infrastructure all set, needs the bits from releng and are ready to mirror and distribute
19:44:44 <rbergeron> hi!28
19:44:45 <jreznik> it's great to have bits to distribute on time :)
19:44:46 <rbergeron> woops
19:45:12 <jreznik> #topic Websites
19:45:26 <robyduck> Websites are ready for beta release
19:45:34 * nirik cheers
19:45:34 <robyduck> Still need to add checksums and hope download filenames don't change ;)
19:45:45 <robyduck> Which live ISOs will we provide? This time we'll have again LXDE, but also SoaS and MATE, right?
19:46:04 <nirik> yes.
19:46:09 <robyduck> To add them I need an icon (or two?) from design team like the others on get-prerelease page.
19:46:13 <jreznik> #info websites are ready for Beta release, still need to add checksums and check filenames
19:46:30 <nirik> I think MATE-Compiz is the only new one.
19:46:37 <robyduck> Just told to ryanlerch
19:46:46 <robyduck> no SoaS then?
19:47:10 <dgilmore> robyduck: no idea if its working
19:47:12 <jreznik> robyduck: I'll add it to my "check desing status" mail
19:47:22 <dgilmore> it will be there if tested as working
19:47:23 <robyduck> jreznik: thnaks
19:47:38 <robyduck> dgilmore: so I'll add only MATE?
19:47:51 <robyduck> just to know what I have to do... ;)
19:47:56 <dgilmore> robyduck: afaik it doesnt have board approval yet
19:48:04 <dgilmore> robyduck: so no idea
19:48:18 <robyduck> oh, I see
19:48:38 <jreznik> well, secondary spins are probably not a blocker for Beta but would be great to sort it out asap
19:48:39 <nirik> SoAS and LXDE should both be working.
19:49:00 <nirik> MATE-Compiz is also working, but we probibly need to make sure the Board has acked it.
19:49:10 <robyduck> ok
19:49:25 <robyduck> It's not a problem to add them also tuesday 28th
19:49:32 <robyduck> before release time
19:50:00 <robyduck> but I'd like to have an icon to do it at the last moment, will turn back to you nirik and dgilmore, ok?
19:50:03 <dgilmore> robyduck: MATE would need a brand new page though
19:50:07 <jreznik> or even after, not sure about Board status on that even Board member :(
19:50:24 <robyduck> dgilmore: oh yes, adding it to my todo list then
19:50:40 <dgilmore> we have pages for everything else
19:50:46 <jreznik> with the description etc
19:50:57 <jreznik> I'd say Dan could help there
19:51:20 <robyduck> jreznik: ok, thanks, will check out the pages
19:51:45 <jreznik> and thanks for removal of that sad counter from spins page!
19:52:12 <robyduck> I'll prepare the page (we have also Jam ready for final release), then we can push it at every moment
19:52:15 <jreznik> anything else for websites?
19:52:29 <robyduck> ^^
19:52:33 <jreznik> #action robyduck to prepare mate page
19:52:37 <robyduck> no, thx
19:52:39 <jreznik> #undo
19:52:39 <zodbot> Removing item from minutes: <MeetBot.items.Action object at 0x21a94f10>
19:52:50 <jreznik> so also for jam too?
19:53:09 <robyduck> no, Jam spin is approved only for F19 final AFAIK
19:53:15 <jreznik> ok
19:53:22 <jreznik> #action robyduck to prepare mate page
19:53:30 <jreznik> and I'll check with Board the status of MATE
19:53:35 <dgilmore> not sure what jam is
19:53:48 <tflink> gsoc project from last year, I think
19:53:49 <robyduck> dgilmore: music
19:53:52 <jreznik> #action jreznik to check the MATE spin status
19:54:12 <dgilmore> not planning to make any spins for final not made for beta
19:54:35 <dgilmore> but thats off topic for here
19:55:02 <jreznik> ok, so also time to check jam spin status
19:55:27 <jreznik> let's move on for now, we are running out of time
19:55:28 <jreznik> #topic QA
19:55:50 <jreznik> tflink: do you want to give status or is it enough to copy it from Go/No-Go?
19:57:16 <tflink> jreznik: either way
19:57:27 <jreznik> so go on :)
19:57:51 <tflink> not much to say, we cleared up the last of the proposed and accepted blockers earlier today
19:58:26 <tflink> the test matrices look good for beta
19:58:41 <tflink> we need to make sure that a grub2 update goes out and some documentation gets done
19:59:14 <jreznik> #info QA is ready, proposed and accepted blockers were cleared up
19:59:15 <tflink> but other than that, it's just the usual tasks between 'GO' and actual release - mostly commonbugs
19:59:23 <jreznik> #info test matrices are good for beta
19:59:46 <jreznik> #info need to make sure that a grub2 update goes out and some documentation gets done and commonbugs has to be done
19:59:49 <jreznik> tflink: thanks
19:59:49 <randomuser> tflink, grub documentation, you say?
20:00:04 <tflink> randomuser: it's an upgrade issue with uefi systems
20:00:12 <jreznik> randomuser: the workaround for possible issue in case update would not work
20:00:50 <randomuser> okay, let me know if I can help or should note somewhere
20:00:50 <tflink> or in case someone doesn't update prior to upgrading
20:01:03 * randomuser now has a uefi system to test with, even
20:01:43 <tflink> oh the wonderful fun that is uefi :)
20:01:50 <tflink> I think that's all for QA, though
20:02:04 <jreznik> bios forever (I never thought I'll say something like that)
20:02:37 <tflink> either that or start a pitchfork-and-torch mob for the bad fw developers :)
20:03:17 * randomuser +1 for mob
20:03:21 <dgilmore> tflink: that could go on forever
20:03:58 <jreznik> #topic Release Engineering
20:04:02 <tflink> dgilmore: unfortunately, true
20:04:08 <jreznik> dgilmore: your turn
20:04:31 <dgilmore> well im staging cloud images right now that needs testing
20:04:48 <dgilmore> need to do all the usual things like make torrents etc
20:04:55 <dgilmore> but otherwise okay
20:06:32 <jreznik> #info releng is ok, need to do the usuall things and are staging cloud images that need testing
20:06:34 <jreznik> thanks
20:06:55 <jreznik> #topic Open floor
20:07:03 <jreznik> anything else to add?
20:08:42 <jreznik> if not, I'll set fuse now
20:08:47 <jreznik> thanks for coming!
20:08:48 <jreznik> 3...
20:09:27 <jreznik> 2...
20:10:15 <jreznik> 1...
20:10:20 <jreznik> #endmeeting