16:01:40 <spot> #startmeeting Fedora Packaging Committee
16:01:40 <zodbot> Meeting started Thu May 30 16:01:40 2013 UTC.  The chair is spot. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:40 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:01:43 <spot> #meetingname fpc
16:01:43 <zodbot> The meeting name has been set to 'fpc'
16:01:48 <spot> #topic Roll Call
16:02:14 * RemiFedora is here
16:02:34 * geppetto is here
16:03:05 * SmootherFrOgZ here
16:03:53 * abadger1999 here.
16:04:24 * SmootherFrOgZ loves that fedmsg-notify for meeting
16:04:26 <abadger1999> meeting with someone in another channel as well so I'm only half here.
16:04:55 <spot> so we're missing racor, limburgher, Rathann, tibbs
16:05:31 * limburgher is here, apparently.
16:05:47 <limburgher> Didn't know that.
16:05:59 <tibbs|w> I'm around.
16:06:54 <spot> okay, thats well over quorum
16:06:54 <spot> #topic Bundling libxdiff in libgit2 - https://fedorahosted.org/fpc/ticket/276
16:06:54 <spot> I have the code 99% done, but then I got busy with other stuff.
16:07:03 * spot will try to get this done asap.
16:07:11 <spot> #action spot needs more clones.
16:07:39 <spot> kalev: feel free to keep prodding me to get that done and packaged.
16:08:12 <spot> #topic Add note about network access to guidelines - https://fedorahosted.org/fpc/ticket/295
16:08:40 <abadger1999> Not sure where to put that but I'm +1 to it.
16:08:44 <tibbs|w> I think this is a pretty good idea.
16:08:51 <tibbs|w> +1
16:08:56 <spot> +1
16:09:06 <limburgher> +1 also.  Thought this was in there, and not just good practice.
16:09:09 <geppetto> Yeh, seems kind of obvious … but +1
16:09:24 <RemiFedora> obvious rule
16:09:31 <tibbs|w> Probably just needs a simple section somewhere in the first quarter of the main guidelines page.
16:09:36 <SmootherFrOgZ> +1
16:09:39 <RemiFedora> +1
16:09:40 * spot idly wonders when people will ask for the guidelines to say "packages must be in rpm format" ...
16:09:51 <limburgher> geppetto:  You'd be amazed the people that come to me at $DAYJOB and are like, "well we don't do tarballs, so start the build with git clone. . ."
16:10:46 <geppetto> spot: I wouldn't be shocked if someone tries to get a klick build in this year.
16:10:46 <spot> #action approved (+1:7, 0:0, -1:0)
16:11:08 <abadger1999> spot: it'll be the opposite -- we'll get people trying to submit packages in other formats and we'll havee to step in to tell them "No!"
16:11:08 <RemiFedora> github disease .... no more release
16:11:27 <limburgher> RemiFedora: <shudder>
16:11:30 <spot> okay, lets get to the fun one.
16:11:43 <spot> #topic Simplifying Ruby Guidelines - https://fedorahosted.org/fpc/ticket/296
16:12:26 <spot> summarized: they want to unpack tests in %check and not in %prep.
16:12:31 <tibbs|w> Not a fan of this, and really not a fan of the attitude in the last comment there.
16:12:47 <geppetto> yeh … no
16:12:50 <spot> I disagree with that last comment as well.
16:12:52 <tibbs|w> "Doesn't break anything for me; anything I don't use is not useful."
16:13:15 <limburgher> Am I misreading this, or wouldn't this mean that the %check section could potentially test something other than the actual build?
16:13:24 <spot> since i cannot count how many test suites i've had to patch in Fedora...
16:13:31 <tibbs|w> But the "you can't patch a test" argument would seem to override all of the other considerations anyway.
16:13:32 <limburgher> spot, tibbs|w: Nod.
16:13:33 <abadger1999> yeah, the original submitter probably just doesn't know the reason that we don't do things like that... vondruch has been told multiple times and still doesn't get it...
16:13:51 <spot> limburgher: eh, unlikely. I think its more that they don't want to have to keep the test files from ending up in the gem
16:14:08 <limburgher> spot:  OIC.  Still not a fan.
16:14:31 <spot> source tree (including tests) should be unpacked in prep. -1 from me.
16:14:40 <abadger1999> -1
16:14:43 <limburgher> -1 here as well.
16:14:56 <SmootherFrOgZ> -1 as well
16:14:57 <tibbs|w> -1
16:15:01 <RemiFedora> agree, must be done in %prep
16:15:12 <RemiFedora> -1
16:15:18 <geppetto> yeh, -1 … I'd also like it if we had a way to make people choose better ticket names than a generic "simplify XYZ guidlines" N times.
16:16:05 * spot counts -7.
16:16:32 <spot> #action draft rejected, tests must be unpacked in %prep to allow for patching. (+1:0, 0:0, -1:7)
16:16:39 <spot> #topic Open Floor
16:17:53 * SmootherFrOgZ has nothing to add/talk about more
16:17:53 <RemiFedora> at least I think packager should request upstream to "please include unit test in official tarball" (which I have done so many time)
16:19:13 <RemiFedora> I think we have nothing yet in Guidelines about the use of /etc/systemd/system/foo.service.d  ?
16:19:45 <spot> RemiFedora: i think you are correct. would you like to draft something? :D
16:20:07 <RemiFedora> probably the systemd guys could submit something to us
16:20:23 <RemiFedora> but I will have a look (at least I will ask for their comment)
16:20:46 <tibbs|w> I'm not even sure what that does.
16:21:03 <RemiFedora> we have some package which start using it (or giving ref to this folder) => httpd, php-fpm
16:21:44 <RemiFedora> tibbs|w: instead of copying the /lib/systemd/system/foo.service to /etc/ and using or using an include
16:22:23 <RemiFedora> systemd merge the /lib/systemd/system/foo.service  + /etc/systemd/system/foo.service.d/*.conf
16:22:29 <tibbs|w> Ah, that.
16:22:33 * spot tries not to get too excited about more systemd drafts.
16:22:37 <RemiFedora> (very usefull for Env)
16:22:52 <tibbs|w> But I'm not sure why it needs a guideline; that's something that the end user/administrator can create.
16:24:20 <RemiFedora> tibbs|w: I think the guildelines could usefulll only if we plan to encourage the use of this solution, and thus discourage the use of /etc/sysconfig
16:24:41 <tibbs|w> I'm not entirely sure that's our business.
16:25:29 <tibbs|w> If FESCo sets the distro in that direction, we would draft the guidelines to implement it.
16:26:11 <RemiFedora> ok, so it's probably to systemd guys to propose something
16:29:15 <spot> okay... i'm not hearing anything else, so lets close out early and i'll go work on libxdiff. :)
16:29:24 <spot> thanks everyone.
16:29:24 <spot> #endmeeting