20:01:21 <bconoboy> #startmeeting Fedora ARM weekly status meeting
20:01:21 <zodbot> Meeting started Wed Jun 26 20:01:21 2013 UTC.  The chair is bconoboy. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:01:21 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
20:01:21 <jsmith> Howdy howdy!
20:01:24 * jsmith waves
20:01:31 <ahs3> greeting and salutations
20:01:31 <bconoboy> #chair pwhalen jonmasters bconoboy ctyler pbrobinson dgilmore dmarlin masta j_dulaney msalter ahs3 agreene jcapik ddd
20:01:31 <zodbot> Current chairs: agreene ahs3 bconoboy ctyler ddd dgilmore dmarlin j_dulaney jcapik jonmasters masta msalter pbrobinson pwhalen
20:01:38 <bconoboy> I will be your replacement pwhalen today.
20:01:45 <bconoboy> #topic 0) Status of ACTION items from our previous meeting
20:01:46 <jcapik> .fas jcapik
20:01:47 <zodbot> jcapik: jcapik 'Jaromír Cápík' <jcapik@redhat.com>
20:02:06 <bconoboy> #link http://meetbot.fedoraproject.org/fedora-meeting-1/2013-06-19/fedora-meeting-1.2013-06-19-20.00.html
20:02:16 * nirik is here.
20:02:23 * masta is here, sry late
20:02:37 <bconoboy> Only action item from last week is setting up aarch64 koji hub vm- Hi Nirk!
20:03:35 <nirik> so, I have the db host mostly setup, going to start on the hub next
20:03:35 <bconoboy> nirik: So, any update?
20:03:47 <bconoboy> cool
20:03:49 <nirik> hopefully I'll have them ready to work on before too long.
20:04:05 <bconoboy> #info aarch64 koji server setup: db host mostly setup. hub is pending
20:04:15 <bconoboy> #action nirik to continue aarch64 koji server setup
20:04:38 <nirik> we will need to then do some config and work out how to talk to builders.
20:04:54 <bconoboy> when do you think you'll need a builder to test with?
20:05:10 <bconoboy> or do we need to do a koji import and branching and such first?
20:05:17 <nirik> not sure. I'm a bit busy also making sure f19 goes out without a hitch...
20:05:28 <nirik> probibly will know more next week
20:05:42 <bconoboy> #info f19 release is taking priority
20:06:19 <bconoboy> anything else?
20:06:32 * nirik doesn't have anything further off hand
20:06:35 <bconoboy> #topic 1) Problem packages
20:07:03 <jonmasters> .fas jonmasters
20:07:03 <zodbot> jonmasters: jcm 'Jon Masters' <jonathan@jonmasters.org>
20:07:08 <bconoboy> Looks like no pbrobinson today- anybody have any updates on problem packages?
20:08:16 <bconoboy> #info No update this week- check next week after F19 is out.
20:08:26 <bconoboy> #topic 2) Kernel Status Update
20:09:09 <bconoboy> Masta just presented #fedora-arm with a panda crashing on boot with f19.  Anybody have other gems? :-)
20:09:16 <masta> omap not working here on MP kernel in rc2
20:10:15 <bconoboy> #info OMAP4 broken on MP kernel with RC2
20:10:15 <jcapik> bconoboy: mine was not crashing
20:10:25 <bconoboy> jcapik: your which?
20:10:31 <jcapik> bconoboy: I experienced just a long delay
20:10:42 <jcapik> bconoboy: my panda A3
20:10:50 <bconoboy> masta: was that a panda es?
20:10:55 <jcapik> bconoboy: nope
20:10:59 <masta> yes, panda_es
20:11:04 * jsmith still can't boot mvebu with the 3.10 kernel :-(
20:11:12 <bconoboy> jcapik: So you're seeing success with rc2? or something earlier?
20:11:19 <jcapik> bconoboy: RC2
20:11:24 <bconoboy> okay, good data point
20:11:32 <bconoboy> Does somebody else have a panda es?
20:11:41 <masta> jcapik: what steps did you follow to prep the uboot partition?
20:11:48 <jcapik> bconoboy: I thought it jammed after reaching a message about failing RTC
20:12:17 <jcapik> bconoboy: but then it continued booting
20:12:20 <dmarlin> jcapik: can you fpaste a boot log for reference?
20:12:34 <jcapik> dmarlin: I'm not in the office
20:12:40 <jcapik> dmarlin: I can do that tomorrow
20:12:53 <bconoboy> We have a panda (non-es) in the farm we can test with too
20:12:54 <dmarlin> jcapik: that would be great.  thanks
20:13:05 <bconoboy> But if the non-es works but the es doesn't I'd like to know that right away
20:13:25 <bconoboy> Let's discuss further when we get to F19 blocker discussion
20:14:16 <bconoboy> jsmith: FYI, I'm expecting Marvell to update uboot to support dtbs in August, so that's when I tentatively think we should focus energy on getting it up and running.
20:14:19 <jcapik> masta: I just mounted the UBOOT and _/ and copied MLO, uBoot.img and uEnv.txt from /usr/share/uboot.panda
20:14:37 <jsmith> bconoboy: OK, that's the best news I've heard all month
20:14:50 <bconoboy> #info May only be Panda-ES that's broken.  Panda-A3 reported successful.
20:15:08 <bconoboy> next?
20:15:36 <bconoboy> #topic 3) Aarch64 - Status Update, problem packages
20:16:00 <bconoboy> Bootstrap is still humming along
20:16:12 <bconoboy> There are 535 packages in the build queue
20:16:24 <jcapik> today I was unable to upload new SRPMs
20:16:32 <bconoboy> oh?
20:16:35 <jcapik> the server asked for password
20:16:45 <bconoboy> did you use the wrong ssh key or user id?
20:17:08 <jcapik> wrong ssh key?
20:17:16 <bconoboy> #info 10522/13595 packages built
20:17:22 <jcapik> the same key like before
20:17:37 <jcapik> I used to upload srpms with script
20:17:47 <bconoboy> eh?
20:18:01 <bconoboy> by upload srpms you mean put them into the queue?
20:18:43 <jcapik> to SCP them to the build directory ....
20:18:59 <msalter> did you ssh-add the id_rsa.upload? after a reboot maybe?
20:19:15 <jcapik> msalter: yes
20:19:26 <bconoboy> I'm confused- you don't use the rebuild script to add source rpms to the queue.  And the build directory is where you put source rpms that have already been built.
20:19:47 <bconoboy> (Well, it's where the build script puts them, anyway)
20:19:55 <jcapik> let's talk about that after the meeting
20:20:00 <bconoboy> okay
20:20:14 <bconoboy> We're just a couple packages away from being able to retire stage 3
20:20:44 <bconoboy> Once that's done we will have something that we can reasonably import into beaker.
20:21:12 <bconoboy> The main outstanding package at this point is openjdk
20:21:34 <bconoboy> #info 535 packages are in the build queue currently
20:22:05 <bconoboy> #info Almost ready to retire stage3, just need libdb, gcc, and llvm rebuilt.  Maybe rpm.
20:22:22 <bconoboy> msalter: Anything to add?
20:22:44 <msalter> libdb is there. just gcc and llvm left I think
20:22:54 <bconoboy> db4 too?
20:22:57 <msalter> yes
20:23:00 <bconoboy> woot
20:23:03 <bconoboy> #undo
20:23:04 <zodbot> Removing item from minutes: <MeetBot.items.Info object at 0xefec510>
20:23:14 <bconoboy> #info Almost ready to retire stage3, just need gcc, and llvm rebuilt.  Maybe rpm.
20:23:21 <bconoboy> msalter: Can we do unpatch rpm once gcc is rebuilt?
20:24:27 <msalter> I think so. There are 3 patches inthe f19 rpm. 1) aarch64 support 2) workaround to file attr 3) workaround to stage3 weirdness with file ownership
20:24:53 <msalter> oh, and workaround to short-circuited rpms
20:25:03 <bconoboy> Do we have any short circuited rpms beyond gcc at this point?
20:25:11 <msalter> no
20:25:16 <bconoboy> great
20:25:30 <bconoboy> is some part of aarch64 support not upstream?
20:25:33 <bconoboy> (in rpm)
20:25:44 <msalter> not in f19 but is in f20/rawhide
20:26:03 <bconoboy> ah, okay
20:26:07 <bconoboy> anything else?
20:26:10 <masta> noticed LLVM had aarch64 updates upstream in new version recently released
20:26:35 <msalter> yes
20:26:40 <bconoboy> I wonder if that new llvm has made it into f20 yet
20:26:46 <masta> llvm.org/releases/3.3/docs/ReleaseNotes.html#aarch64-target
20:27:38 <bconoboy> Looks like 3.3 is already in both f19 and f20
20:27:43 <msalter> yes
20:27:52 <bconoboy> Okay, let's move on
20:28:00 <bconoboy> #topic 4) F19 GA - RC2 testing (VFAD?)
20:28:15 <bconoboy> dgilmore?
20:29:20 <bconoboy> Hmm.
20:29:40 <bconoboy> Okay, ideally we want to ship the ARM release next Tuesday in time with Primary
20:29:59 <bconoboy> To do that we'll need to have something finalized by Fridayish.
20:30:38 <bconoboy> Does anybody know if RC2 is going to be the one for primary?
20:30:51 <jonmasters> dgilmore maybe?
20:30:52 <masta> most likely
20:30:57 <nirik> likely so.
20:31:01 <bconoboy> IE, any blockers that will push out a week?
20:31:06 <nirik> barring last minute blow up.
20:31:13 <jonmasters> has the go no go happened?
20:31:14 <nirik> no blockers currently that I know od
20:31:15 <nirik> of
20:31:21 <nirik> tomorrow
20:31:31 <jonmasters> ok, bconoboy please note we need to check tomorrow
20:31:35 <bconoboy> #topic Primary Go/NoGo decision is Thursday
20:31:38 <bconoboy> #undo
20:31:38 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x12a31410>
20:31:44 <bconoboy> #info Primary Go/NoGo decision is Thursday
20:31:57 <jonmasters> so we're ready to go right?
20:32:11 <bconoboy> Things were looking good in the TCs
20:32:21 <bconoboy> But now Masta is showing an issue on his panda-es
20:32:28 <bconoboy> So we need to track that down.
20:32:32 <bconoboy> And we need to retest everything else.
20:32:33 <nirik> :(
20:32:54 * jsmith is still getting krb5-lib dependency issues on his F19 installation
20:33:04 <bconoboy> jsmith: what's this?
20:33:13 <jonmasters> masta: please summarize your ES problem? Exactly what ES unit do you have?
20:33:23 <jonmasters> (aka we are not blocking on an issue on one Panda ES)
20:33:30 <nirik> jsmith: did you distro-sync or re-enable updates-testing?
20:33:43 <masta> jonmasters: sure let me find my earlier fpaste
20:33:52 <jsmith> nirik: Double-checking now
20:33:52 <masta> jonmasters: it's a kernel panic with a null pointer deref
20:33:55 <bconoboy> #link http://paste.fedoraproject.org/21123/ Panda ES boot issue with RC2
20:33:55 <jsmith> bconoboy: http://www.fpaste.org/21171/
20:34:04 <jonmasters> I've also seen issues on earlier ES boards..looking, wait 10 secs
20:34:28 <bconoboy> masta: What have you successfully used this board for previously?  Any of the TCs?
20:34:42 <jonmasters> checking, 30 secs
20:34:59 * jsmith does a quick "yum distro-sync --skip-broken"
20:35:01 <masta> bconoboy: yes I think some of the earlier TC's, hard to rememberr exactly
20:35:42 <masta> so I'm just going to test all the VFAT images on my panda_es
20:36:09 <masta> hopefully it wa just the kde spin.... will establish more facts as more testing happen
20:36:42 <bconoboy> The principle difference that I'm aware of from the TC's to the RC's is that we're using more Fedora-compliant boot parameters
20:36:59 <bconoboy> bootargs are ro rootwait root=UUID=84a2ff73-b309-4da4-a9ff-db90f1334149 rhgb quiet FONT=latarcyrheb-sun16 KEYMAP=us LANG=en_US.UTF-8 console=ttyO2,115200n8
20:37:15 <bconoboy> previously we weren't passing anything but "ro rootwait root=....  console=..."
20:37:57 <jonmasters> masta: can you try another SD Card please?
20:38:15 <masta> yep
20:38:30 <bconoboy> In any case, we need to do final testing.
20:38:37 <bconoboy> I would like to suggest a vfad to get this done
20:38:39 <masta> that is happenign right now, the minimal sdcard is writing out... on another microsd
20:38:59 <bconoboy> So, either thursday or friday at the latest.  What works for people?
20:39:18 <masta> Friday
20:39:41 <bconoboy> Okay, masta volunteers to test things on Friday :-)
20:39:42 * masta will be testing Friday regardless...
20:39:56 <bconoboy> What time shall we start?  Earlier is probably better.
20:40:03 <jonmasters> masta: systemcrap was trying to fstat a file but I doubt that code has a bug in it. More likely the SD card is bad
20:40:28 <masta> jonmasters: brand new sdcard, opened thsi morning =(
20:40:31 <bconoboy> 10 EDT?
20:40:44 <masta> bconoboy: I'll be online ~ 10 EDT
20:41:01 <jcapik> thursday is better
20:41:03 <jonmasters> masta: please try one you know works
20:41:10 <bconoboy> we could do both
20:41:35 <bconoboy> #information Current ARM release candidate is at http://armpkgs.fedoraproject.org/mash/stage/19-RC2/
20:41:48 <bconoboy> #info Current ARM release candidate is at http://armpkgs.fedoraproject.org/mash/stage/19-RC2/
20:41:49 <bconoboy> (doh)
20:42:11 <bconoboy> Does somebody have a link to the test matrix page?
20:42:48 <masta> https://fedoraproject.org/wiki/Test_Results:Fedora_19_Final_RC2_Base?rd=Test_Results:Current_Base_Test
20:43:13 <masta> https://fedoraproject.org/wiki/Test_Results:Fedora_19_Final_RC2_Desktop?rd=Test_Results:Current_Desktop_Test
20:43:39 <bconoboy> #link Test the base: https://fedoraproject.org/wiki/Test_Results:Fedora_19_Final_RC2_Base?rd=Test_Results:Current_Base_Test
20:43:49 <bconoboy> #link Test the desktop: https://fedoraproject.org/wiki/Test_Results:Fedora_19_Final_RC2_Desktop?rd=Test_Results:Current_Desktop_Test
20:43:57 <masta> and....
20:44:00 <masta> https://fedoraproject.org/wiki/Test_Results:Fedora_19_Final_RC2_Install?rd=Test_Results:Current_Installation_Test
20:44:11 <bconoboy> #link Test anaconda installation: https://fedoraproject.org/wiki/Test_Results:Fedora_19_Final_RC2_Install?rd=Test_Results:Current_Installation_Test
20:44:40 <masta> are folsk without chairs able to use the #link cmd?
20:44:54 <bconoboy> #info Deadline for *successful* test completion is Friday
20:44:56 <bconoboy> #chair masta
20:44:56 <zodbot> Current chairs: agreene ahs3 bconoboy ctyler ddd dgilmore dmarlin j_dulaney jcapik jonmasters masta msalter pbrobinson pwhalen
20:45:02 <bconoboy> no idea :-)
20:45:05 <jonmasters> masta: let me know how the test of another sd card goes
20:45:29 <bconoboy> #info Please test Wednesday and Thursday- update the tables, mention what you're up to in #fedora-arm
20:46:07 <bconoboy> #info VFAD Friday 10AM, but don't wait- test now if at all possible.
20:46:10 <bconoboy> Anything else?
20:46:14 <bconoboy> #undo
20:46:14 <zodbot> Removing item from minutes: <MeetBot.items.Info object at 0x12a31590>
20:46:26 <bconoboy> #info VFAD Friday 10AM US EDT, but don't wait- test now if at all possible.
20:46:53 <bconoboy> Are there any other blockers that we are aware of?
20:47:19 <bconoboy> I'll take silence as a no
20:47:31 <bconoboy> #topic 5) Open Floor
20:47:37 <bconoboy> Anybody?
20:48:13 <jcapik> panda & sound ?
20:48:22 <bconoboy> ?
20:49:00 <jcapik> has anybody succeded with making the sound output working?
20:49:43 <bconoboy> If a board plays a wav file in a lab 1000 miles away, and nobody is there to hear it, does it make a noise?
20:50:17 <dmarlin> bconoboy: +1
20:50:20 * handsome_pirate waves from the late seat
20:50:20 <masta> sounds used to work on panda over hdmi
20:50:53 <bconoboy> handsome_pirate: We're just wrapping up- you have anything for open floor?
20:50:54 * handsome_pirate was geeking out over model railroading and lost track of time
20:50:55 <jcapik> masta: i tried the output jack, but heard just crackles
20:51:14 <handsome_pirate> I need a room mate for Flock
20:51:26 <bconoboy> out of scope:-)
20:51:26 <pwhalen> hey sorry I missed the meeting. I made some pages this morning for recording our RC2 results - https://fedoraproject.org/wiki/Category:Fedora_19_ARM_RC2
20:51:50 <handsome_pirate> bconoboy:  The hope is someone here also needs one
20:51:53 <bconoboy> #link High level RC2 testing result page: https://fedoraproject.org/wiki/Category:Fedora_19_ARM_RC2
20:51:55 <pwhalen> I do not recall sound working on the panda, definitely not recently
20:52:05 <masta> #link https://fedoraproject.org/wiki/Category:Fedora_19_ARM_RC2
20:52:20 <masta> #info page for recording Rc2 results
20:52:29 <masta> thx pwhalen
20:52:40 <pwhalen> I'll try out the rc2 on my ES, it was working with the TC's
20:53:01 <masta> pwhalen: yes please and I hope you have better result then my first test
20:53:19 <bconoboy> #info handsome_pirate looking for roomie at flock (Not johnny depp)- contact if in need. rum optional.
20:53:28 <pwhalen> masta, I have an ES B1, you?
20:53:33 <handsome_pirate> Argh!
20:54:02 <masta> pwhalen: not sure, just and ES
20:54:25 <bconoboy> Shall we take this back to #fedora-arm?
20:54:27 <masta> pwhalen: the sticker says ES rev B1
20:54:31 <pwhalen> bconoboy, sure
20:54:35 <masta> yep
20:54:38 <bconoboy> #endmeeting