16:25:11 <abadger1999> #startmeeting fpc
16:25:11 <zodbot> Meeting started Thu Jul 25 16:25:11 2013 UTC.  The chair is abadger1999. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:25:11 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:25:18 <abadger1999> #topic Roll Call
16:25:32 * RemiFedora is here
16:25:36 * limburgher here
16:25:38 <tibbs|h> Howdy.
16:25:47 <abadger1999> Rathann: You still here?
16:25:59 <tibbs|h> He said he was wandering away.
16:26:10 <abadger1999> yeah...
16:26:17 <tibbs|h> Missed it by that much.
16:26:25 <abadger1999> I'm hoping he just meant until 30 after when limburgher said he'd be back.
16:26:38 <limburgher> I can leave again if you think that'll help.
16:26:45 * abadger1999 pulls up the open tickets to see if there's things to discuss before he comes back.:-P
16:26:50 <tibbs|h> Maybe you're really the same person.
16:27:23 <tibbs|h> We need to prioritize anything that's actually easy.
16:27:24 <limburgher> Not so far as i know.
16:27:32 <tibbs|h> Just to get the ticket count down a bit.
16:28:40 * abadger1999 looks for easy
16:28:53 <tibbs|h> The two things about conflicts, maybe.
16:30:07 <abadger1999> #topic Clarify the spirit of the Conflicts Guidelines  https://fedorahosted.org/fpc/ticket/315
16:30:35 <abadger1999> This is a change to this Guideline: http://fedoraproject.org/wiki/Packaging:Conflicts
16:32:07 <abadger1999> I like this change.
16:32:35 <tibbs|h> I guess I don't really object to the sentiment.it just adds a sentence to the beginning saying that the object is for people to not have to worry about what's already installed.
16:33:09 <tibbs|h> Seemed kind of obvious to me before, but I guess there's a call for more explanation.
16:33:26 <abadger1999> Yeah.
16:33:42 <abadger1999> Let's have everyone who's here vote and then we'll call for additional votes in ticket.
16:33:44 <abadger1999> +1
16:33:45 <tibbs|h> I'll +1 it.
16:34:00 <RemiFedora> +1
16:34:38 <abadger1999> limburgher: You'd make four.
16:34:47 <limburgher> +1
16:36:21 <abadger1999> SmootherFrOgZ: btw, are you here?
16:36:33 <abadger1999> Okay, recorded in ticket that we just need one more vote.
16:36:55 <abadger1999> #topic Allow conflicts when packages are split https://fedorahosted.org/fpc/ticket/316
16:38:17 <RemiFedora> this could make sense, but the new package can also have Requires: original-package > NEVR_BEFORE_SPLIT (in which case, Conflicts is not needed/wanted)
16:38:31 <abadger1999> truthfully I thought this was already allowed.
16:38:44 <abadger1999> but on reading the current guidelines it looks like it isn't.
16:38:46 <abadger1999> RemiFedora: Good point.
16:38:58 <limburgher> What RemiFedora said.  I assumed that if the Requires were done right this wasn't an issue.
16:38:59 * abadger1999 looks at how to edit that in.
16:39:12 <tibbs|h> Right, I also thought this was entirely doable with dependencies.
16:39:34 <tibbs|h> I seem to recall the list discussion went that way as well.
16:45:36 <tibbs|h> So....
16:46:05 <abadger1999> Okay -- updated draft: https://fedoraproject.org/wiki/User:Till/Conflicts_Splitting_Draft
16:46:11 <abadger1999> Does that look good?
16:46:58 <RemiFedora> ok
16:47:00 <tibbs|h> Yeah.
16:47:26 <abadger1999> Alright, let's vote:
16:47:28 <abadger1999> +1
16:47:30 <tibbs|h> +1
16:47:56 <limburgher> +1  Still think it's spurious, but meh.
16:48:01 <RemiFedora> +1
16:49:08 <abadger1999> okay, that's a vote from everyone present.
16:50:30 <abadger1999> anyone have a ticket they'd like to discuss and vote on today?
16:51:37 <RemiFedora> there is the itk one...
16:52:04 <RemiFedora> but seems an awfull one...
16:52:07 <limburgher> I was just thinking that.
16:52:13 <tibbs|h> I thought we kind of shot that down.
16:52:27 <limburgher> Right, so what now, have it blocked?
16:53:03 <RemiFedora> itk 2.2.22 is in the repo (but probably broken as httpd 2.4 is there)
16:54:09 <abadger1999> RemiFedora: So the way I'm seeing it implemented technically,
16:54:26 <RemiFedora> no... it currently present, with the full httpd 2.2 sources + patch + itk
16:54:28 <abadger1999> the httpd-itk package creates a new MPM that it then runs explicitly in the httpd-itk.service file.
16:54:38 <RemiFedora> yes
16:54:42 <abadger1999> So it doesn't depend on the system apache in that manner.
16:54:53 <abadger1999> It does use the apache config from the httpd package.
16:55:10 <abadger1999> So I suppose if there were an incompatible config syntax change, that would break the package.
16:55:13 <RemiFedora> which is incompatible (2.2/2.4)
16:57:26 <abadger1999> Anyhow... yeah --I don't see this going anywhere but asking fesco to block the package.
16:57:58 <RemiFedora> abadger1999, the ticket already comes from fesco...
16:58:17 <abadger1999> We could tlak to hubbittus for awhile longer in the ticket to try to explain why that's the case (I think he's still unclear about that) but I don't see any information which would change that.
16:58:54 <abadger1999> #action toshio will try to explain why we're still convinced that blocking is the right choiuce.  Toshio will either update or open a new ticket for fesco to block the package.
16:59:10 <abadger1999> #undo
16:59:10 <zodbot> Removing item from minutes: <MeetBot.items.Action object at 0x1a6a3f50>
16:59:20 <abadger1999> #topic httpd-itk https://fedorahosted.org/fpc/ticket/310
16:59:26 <abadger1999> #action toshio will try to explain why we're still convinced that blocking is the right choiuce.  Toshio will either update or open a new ticket for fesco to block the package.
17:00:20 <abadger1999> #topic Bundling exception for nodejs-dateformat https://fedorahosted.org/fpc/ticket/319
17:00:26 <abadger1999> This looks like it might be easy-ish
17:00:30 <abadger1999> It looks like a fork to me.
17:01:24 <abadger1999> If others agree that it's a fork, then I think we could vote pretty easily.  If not, then we'll need to discuss.
17:01:50 <tibbs|h> It does seem like a true fork.
17:02:17 <tibbs|h> I'm guessing the modules don't conflict if both are installed.
17:02:37 <tibbs|h> Or are they both imported the same way?  I know nothing about node.js.
17:02:46 <abadger1999> Hmm..
17:03:03 <abadger1999> tchol or jamielinux: ping, are you around by chance?
17:03:48 <abadger1999> I'm pretty sure that node.js imports things differently but I admit to not knowing much about it.
17:03:56 * tchol reads scrollback
17:04:14 <tchol> dunno what's going on with this one in particular.  let me check the ticket real quick
17:04:51 <tchol> okay this is browser js adapted to work with node so it couldn't possibly conflict if both were installed
17:05:39 <abadger1999> Cool.
17:06:03 <tibbs|h> Given the info we have, I'd +1 this.
17:06:06 <abadger1999> +1
17:07:59 <abadger1999> limburgher, RemiFedora: You still around to vote on this one?
17:08:06 <abadger1999> Bundling exception for nodejs-dateformat
17:08:38 <tchol> not overriding the JS internal date format for unrelated is a damn good reason for forking all by itself IMHO ;-)
17:09:01 <abadger1999> Okay then.  I'll record what we have and why and ask for additional votes on ticket.
17:09:17 <RemiFedora> +1
17:09:29 <abadger1999> #topic Problem with lack of quorum -- Proposal for next meeting
17:09:33 <RemiFedora> sorry for late vote
17:10:05 <abadger1999> Okay, so we've been having issues achieving quorum for the past few weeks -- I think this happens every summer as people have vacations, conferences, and other travel plans.
17:10:43 <abadger1999> I'd suggest that we meet every week and people that are present can discuss things that they think are problematic in any particular ticket.
17:10:59 <abadger1999> so that things happen quicker than by replying in the tickets.
17:11:19 <abadger1999> Voting can be done in IRC and finished i nthe ticket.
17:11:29 <tibbs|h> Yes, even if we don't have quorum there is still value in talking about things.
17:12:02 * RemiFedora agree
17:12:21 <abadger1999> Cool.  Unless we miraculously have more people next week (I doubt it -- it's a travel day for people who are going to flock) that'll the plan for next week then.
17:12:31 <tibbs|h> And with this much piling up, we can't afford to waste whatever time we can get.
17:12:56 <limburgher> Sorry got called away, reading back.
17:13:04 <abadger1999> Speaking of flock -- I will be travelling so I might not be present to ru nthe meeting.  I don't know what time spot is travelling so he might not be either.
17:13:06 <nirik> abadger1999: thats one more week out. ;) not next week
17:13:11 <abadger1999> oh
17:13:14 <abadger1999> well then :-)
17:13:21 <abadger1999> never mind that :-)
17:13:37 * abadger1999 pushes more flock stuff to the back burner
17:14:03 <limburgher> Still need a vote from me for nj-dateformat?
17:14:19 <abadger1999> limburgher: Sure -- Then I'll record it in the ticket.
17:14:21 <limburgher> +1
17:14:25 <abadger1999> Excellent.
17:14:29 <abadger1999> #topic Open Floor
17:14:35 <abadger1999> Anyone have anything to add?
17:14:43 <abadger1999> If not, I'll close the meeting in a minute
17:14:55 <limburgher> Nothing here, sorry for being so flaky.
17:15:14 <abadger1999> No problem, you still managed to get your vote in for everything we discussed :-)
17:15:28 <limburgher> Barely.
17:17:13 <abadger1999> #endmeeting