15:29:08 <spot> #startmeeting Fedora Packaging Committee
15:29:08 <zodbot> Meeting started Thu Aug  1 15:29:08 2013 UTC.  The chair is spot. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:29:08 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:29:11 <spot> #meetingname fpc
15:29:11 <zodbot> The meeting name has been set to 'fpc'
15:29:14 <spot> #topic Roll Call
15:29:33 * geppetto is here
15:30:05 <spot> abadger1999, RemiFedora, tibbs|w, Smoother1rOgZ: ping
15:30:20 * RemiFedora here
15:31:02 <tibbs|w> Howdy.
15:31:17 * abadger1999 here
15:31:30 <spot> thats 5.
15:31:37 <abadger1999> Yay, quorum today!
15:31:46 * spot apologizes for being absent for the last few weeks, Flock + OSCON + life
15:32:20 * dwmw2 wonders if he's missed out on doing something that would cause https://fedorahosted.org/fpc/ticket/320 to be on the agenda?
15:32:27 <spot> dwmw2: no, i added it, it will be item #2.
15:32:31 <dwmw2> ta
15:32:44 <spot> #topic Node.js guidelines update - https://fedorahosted.org/fpc/ticket/311
15:32:53 <spot> draft is here: https://fedoraproject.org/wiki/User:Patches/PackagingDrafts/NodeJS
15:33:47 <geppetto> dwmw2: I'm imperfect … feel free to email me, or spot, if I miss something.
15:33:54 <tibbs|w> I can't recall the issues around %nodejs_fixdep now.
15:34:10 <dwmw2> np. I was just assuming it was my fault it didn't turn up last week, and figured I'd turn up to find out what I'd missed.
15:35:07 <tibbs|w> I think the main thing was that we wanted to make sure that if we had to fix dependencies, that the fix went upstream, and that's in the new guideline.
15:36:03 * ignatenkobrain here
15:38:04 <abadger1999> tibbs|w: Yeah, I think there was something about patch being more friendly to upstream but I also remember it not being a strong objection.
15:39:58 <tibbs|w> I have no problem with any of this, really.
15:41:11 <tibbs|w> The multiple version thing is kind of weird, though.  I'm thinking they might need some section on actually naming the different packages.
15:42:04 <abadger1999> For the nodejs_arches => would it be better to recommend defining nodejs_arches at the top of the spec file if we're on Fedora18 or EPEL?
15:42:19 <tibbs|w> Either way, I guess.
15:42:48 <tibbs|w> Though I wonder why EPEL has to differ here.  Red Hat doesn't package the node stuff directly, do they?
15:43:36 <tibbs|w> And F18, for that matter; why not just add the macros somewhere so we don't have to have this pointless difference?
15:43:38 * Smoother1rOgZ here
15:43:51 <abadger1999> Or even %{!?nodejs_arches: %global nodejs_arches  %{ix86} x86_64 %{arm}}
15:44:31 <abadger1999> tibbs|w: yeah -- I wonder if there's something about that needing to be defined in a certain place so that it can be built on the proper builders?
15:45:05 * spot doesn't disagree, but this point seems so minor, i don't know if i would hold up this draft for that cleanup
15:46:40 * spot is +1 on the draft
15:47:47 <geppetto> There are some minor things … like is it ok to add the "%{?nodejs_find_provides_and_requires}" at the top of a non-EPEL6-- specfile.
15:47:54 <geppetto> but, meh, +1
15:48:40 <tibbs|w> Yeah, +1 at this point, but I do think it could be a bit cleaner.
15:49:09 <spot> I see +3 on the draft
15:49:24 <spot> abadger1999, RemiFedora, Smoother1rOgZ ?
15:49:34 * RemiFedora still reading
15:49:35 <abadger1999> The filtering unwanted provides section I think I'd rather just be a pointer to the autoprovreq doc and add a nodejs section there.... As I think about it, I think the caveats to the autoprov system is only documented on that page.
15:49:37 <RemiFedora> but +1
15:49:53 * abadger1999 reading the multiple version portion quickly
15:50:03 * Smoother1rOgZ was reading draft
15:50:11 <Smoother1rOgZ> sound good to me: +1
15:50:57 <spot> abadger1999: we're at +5, would you like to propose any cleanups in a separate ticket?
15:51:46 * spot doesn't mind waiting and doing it now, but we have several more tickets to go through.
15:52:29 <abadger1999> Yeah -- I think there's a few implementation things that should be fixed in multiple versions but I don't have an objection to letting people do it this way for now.
15:52:30 <abadger1999> +1
15:52:47 <spot> #action Draft approved (+1:6, 0:0, -1:0)
15:53:19 <abadger1999> Right now, multiple versions gate on the nodejs-packaging package to update a file; it would be better for them to drop into a dircetory I think.
15:53:33 <spot> #topic BuildRequires: pkgconfig(foo) - https://fedorahosted.org/fpc/ticket/320 - https://fedoraproject.org/wiki/PackagingDrafts/PkgConfigBuildRequires
15:53:45 * dwmw2 wakes up
15:53:59 <limburgher> Crap.  I'm late.  Sorry.
15:54:16 <spot> limburgher: its okay, better late than never.
15:54:20 <ignatenkobrain> Good idea. +1 from me
15:54:34 <geppetto> I'm not that happy about using MUST/MUST NOT language.
15:54:36 <limburgher> spot:  Maybe. :)
15:54:55 <dwmw2> geppetto: Blame Ralf :)
15:54:58 <dwmw2> I can put it back how it was
15:55:03 <abadger1999> So.... In the past, I don't believe we've made anything like this a MUST.
15:55:09 <dwmw2> my original said that packages SHOULD use pkgconfig() where that is actually the dependency
15:55:16 <abadger1999> Maybe the perl requires syntax... I'd have to check.
15:55:28 * spot liked this better when it was a should. While I don't disagree that this is more correct than a -devel Requires, I can hear the collective groaning from every GTK package maintainer who just has BuildRequires: gtk3-devel now
15:56:14 <dwmw2> yeah, let's change it back to SHOULD
15:56:14 <spot> it would be nice if there was a script that would scrape these out of configure
15:56:21 <dwmw2> such scripts do exist.
15:56:30 <dwmw2> autospectacle and stuff like that.
15:56:32 <spot> dwmw2: bonus points if you reference them in the draft. ;)
15:56:42 <abadger1999> "Perl packages use the virtual perl(Foo) naming to indicate a given perl module. Packages should use this methodology, and not require the package name directly. For example, a package requiring the perl module Readonly should not explicitly require perl-Readonly, but rather perl(Readonly), which the perl-Readonly package provides."
15:57:06 <abadger1999> So yeah, there's precedent as a should in one place.
15:57:06 <spot> abadger1999: a should. I'm +1 to this as a should.
15:57:13 <geppetto> yeh
15:57:16 <dwmw2> abadger1999: thanks. I should copy that wording and adjust as appropriate, I think.
15:57:21 <limburgher> Yeah, I see where they're coming from, but both approaches work.  Isn't this a bit like saying packages that don't compile Fortan code MUST NOT BR gcc-gfortran?
15:57:34 <dwmw2> I'm also not keen on the MUST NOT bit that Ralf asked me to add.
15:57:50 <dwmw2> If there's no existing rule against adding gratuitous untrue BuileRequires:, there probably should be one :)
15:57:53 <spot> dwmw2: that line is... odd.
15:57:56 <limburgher> dwm2: I'd feel better about that if I understood the harm.
15:58:19 <dwmw2> should I just revert to my original completely? :)
15:58:30 <geppetto> dwmw2: No, the last paragraph was nice
15:58:51 <dwmw2> hm, cannot open wiki page from here now.
15:59:10 <spot> i'd say, just drop the second sentence, make MUST into should, and its fine.
15:59:31 <limburgher> I can support that.
15:59:35 <geppetto> Yeh, I'm happy to vote on that before dwmw2 gets around to changing it :)
15:59:36 <geppetto> +1
15:59:42 <spot> +1 on that revision
15:59:49 <limburgher> +1
15:59:53 <RemiFedora> +1
15:59:56 <Smoother1rOgZ> +1
16:00:01 <dwmw2> changed
16:00:06 <dwmw2> Proposal
16:00:06 <dwmw2> Fedora packages which use pkg-config to build against a library (e.g. 'foo') on which they depend, SHOULD express their build dependency correctly as pkgconfig(foo).
16:00:09 <tibbs|w> +1
16:00:23 <abadger1999> +1
16:00:43 <spot> #action revised draft approved (+1:7, 0:0, -1:0)
16:01:27 <dwmw2> is it worth revising it further to make it more like the perl wording, just for consistency?
16:01:33 <abadger1999> Just had a thought, rpmbuild only creates the autoProvide for this?  It doesn't create an autorequires?
16:01:43 <spot> #topic Web Assets - https://fedorahosted.org/fpc/ticket/323 - https://fedoraproject.org/wiki/User:Patches/PackagingDrafts/Web_Assets
16:01:46 <dwmw2> I think it does do the autorequires
16:01:47 <geppetto> abadger1999: yeh
16:01:54 <dwmw2> if your .pc file says that it needs others.
16:01:54 <abadger1999> k
16:01:55 <spot> abadger1999: this is for BR, no way to "auto" that.
16:02:20 <abadger1999> ah right.
16:04:14 <abadger1999> I kinda wish tchol was around to give an overview of how JavaScript, Web assets, and nodejs guidelines complement each other.
16:05:25 <geppetto> src="/_sysassets/javascript/jquery/jquery-min.js … holy 50 character paths batman!
16:05:47 <abadger1999> Oh, I see -- web assets are the non-javascript assets but they have similar handling
16:05:57 <spot> i figured we'd do this one at a time
16:06:26 <limburgher> My response to "Not sure if this is a good idea" in the Flash section is "No, you're right, it isn't."
16:06:47 <abadger1999> in web assets "Web applications typically involve code that is executed locally, and thus do not fall under these guidelines."  <= not sure what this line means.
16:06:47 * spot assumes he meant "%{_webassetdir}" in the one place that %{_assetdir} appears.
16:07:32 <limburgher> spot: I imagine.
16:07:39 <tibbs|w> abadger1999: I think he's just saying that something like horde or gallery isnt' covered.
16:08:11 <limburgher> tibbs|w:  You may be right about that.
16:08:34 <RemiFedora> my main concern is about web servers, other than httpd
16:08:35 <tibbs|w> I mean, I assume this isn't attempting to cover anything that might display some web page to others.
16:09:17 <tibbs|w> This whole thing is a huge issue, and I'm glad that someone has attempted to tackle it, but I don't think we'll be able to hash it all out in one or even two meetings.
16:09:23 <RemiFedora> while I think this web guildelines is something usefull, we need to have it working for all web servers, not only httpd
16:09:55 <tibbs|w> I actually disagree with that, but I think that they've done some work towards that goal.
16:10:09 <geppetto> Are they just confused about _sysassets vs. _assets … or am I missing something?
16:10:22 <limburgher> What needs to be done to get the various webservers to recognize _assets?
16:10:32 <spot> just looking at Web_Assets draft, i don't see any real issues with it, aside from being mildly bothered by the Flash binary exception
16:10:35 <limburgher> geppetto: I'm confused as well.
16:10:38 <abadger1999> tibbs|w: I'm not sure.... I mean, the portion that executes locally should fall under different guidelines (php in horde's case).  But if there were a dynamic web UI portion to it, should that fall bunder this guideline?
16:10:51 <geppetto> limburgher: The easiest way would be a symlink in /var/www I guess?
16:11:33 <tibbs|w> abadger1999: I assume the idea is that it shouldn't, but maybe the statement about it could be stronger.
16:11:59 <limburgher> geppetto:  Provided by the webservers?
16:12:01 <tibbs|w> My understanding is that this is for shared assets, not stuff encapsulated into a single application.  But I could just be misunderstanding the whole thing.
16:12:13 <abadger1999> tibbs|w: From the wording, I agree... but my question is why shouldn't it?
16:12:24 <abadger1999> ah
16:12:24 <RemiFedora> yes I understand like tibbs, about "shared" asset
16:12:25 <abadger1999> <nod>
16:12:33 <abadger1999> I agree with the shared vs single application.
16:12:36 <spot> do we want to invite Patches to the meeting in two weeks to discuss this ticket alone?
16:12:41 <spot> (next week being Flock)
16:12:50 <geppetto> limburgher: Ahh, /var/www is provided by "httpd" … thought that was provided by filesystem … oh, well.
16:13:37 <limburgher> geppetto:  Yeah.  So any metapackage requiring it would pull in httpd.
16:13:38 <RemiFedora> (2 weeks being Assomption)
16:14:15 <spot> RemiFedora: i was planning on cancelling the meeting for next week because of Flock
16:14:47 <RemiFedora> nginx use /usr/share/nginx/html/ as docroot IIRC
16:14:57 <abadger1999> tibbs|w: maybe the sentence could be revised to "Web applications typically have web assets that are specific to that application.  Those types of web assets do not fall under these guidelines."
16:15:09 <RemiFedora> Lighttpd use /var/www/lighttpd/ IIRC
16:15:10 <tibbs|w> If that's indeed the intent, I suppose.
16:15:45 <abadger1999> tibbs|w: right.  I don't know if that's the intent; I just don't know what the other wording is intended to convey.
16:16:00 <tibbs|w> So that's one important question to ask.
16:16:28 <spot> anyone opposed to tabling this for two weeks and inviting the author to join us?
16:16:50 <limburgher> no.
16:16:56 <tibbs|w> Not me.
16:17:09 <abadger1999> +1 to table.
16:17:18 <geppetto> No objections.
16:17:27 <RemiFedora> +1 to table (but Aug 15th seems not a good date)
16:17:35 <abadger1999> (jquery-ui is probably not hte best example for web-assets... it appears to be mostly javascript.)
16:18:08 <spot> RemiFedora: why not Aug 15?
16:18:12 <tibbs|w> I had to look up what Assomption was.
16:18:32 <RemiFedora> sorry .... christian hollidays...
16:18:52 <RemiFedora> don't know which country have this as a non working day
16:18:57 * spot forgets that France has more holidays than workdays. :)
16:19:08 <abadger1999> Probably should ask nim-nim or font sig to look over the small change to the font guidelines
16:19:09 <RemiFedora> :)
16:19:09 <tibbs|w> There's always going to be some holiday; the issue is whether we can still manage quorum.
16:19:22 <spot> if we don't have quorum, we'll discuss it then at least.
16:19:29 <spot> and hopefully finish it the next week
16:19:53 <spot> #topic Poor Packaging:CronFiles guidelines - https://fedorahosted.org/fpc/ticket/324
16:20:38 <tibbs|w> We just can't win here.
16:21:22 <spot> Can we resolve the concern with #2 by simply appending "Helper files used by cron job files may also live under /etc/cron.d, but do not need to be marked as %config."
16:21:39 <tibbs|w> Some people want ssimple things like  "what does a cron job look like" actually documented in the guidelines, others complain that once we include the examples, they don't cover their use case.
16:22:21 <geppetto> "Packages with cron job files must be placed" => "Packages with cron job files must place those files"
16:22:26 <geppetto> I think taht solves #1.
16:22:53 <tibbs|w> I thought #1 was already cleaned up.
16:23:14 <spot> Or even: "Helper files used by cron job files should be placed in appropriate system locations (e.g. %{_bindir} or %{_libexecdir}) but do not need to be marked as %config."
16:23:29 <geppetto> ahh abadger1999 already did it … and with similar wording :)
16:24:07 <abadger1999> :-)
16:24:27 <geppetto> spot: +1
16:24:48 <tibbs|w> Honestly I'd s/but/and obviously/.
16:25:10 <spot> how about s/but/and
16:25:17 <spot> obviously sounds condescending. ;)
16:25:25 <tibbs|w> I know.
16:25:48 <tibbs|w> I mean, I originally wondered why we even care of the actual job is a script or an executable or anything else?
16:25:55 <spot> Proposal: add "Helper files used by cron job files should be placed in appropriate system locations (e.g. %{_bindir} or %{_libexecdir}) and do not need to be marked as %config."
16:25:57 <tibbs|w> Why is that even in a guideline at all?
16:26:01 <tibbs|w> +1
16:26:08 <geppetto> +1
16:26:10 <spot> +1
16:26:15 <abadger1999> +1
16:26:18 <Smoother1rOgZ> +1
16:26:20 * RemiFedora have packages to fix...
16:26:21 <RemiFedora> +1
16:26:47 <abadger1999> I think I'd also change this line: "All cron job files installed in any of these directories must be scripts and must be treated as configuration files so that they can easily be modified by the local system administrator." =>
16:27:07 <abadger1999> Both cron job files and crontab definition files installed in any of these directories must be treated as configuration files so that they can easily be modified by the local system administrator.
16:27:23 <spot> +1
16:27:45 <abadger1999> +1
16:27:48 <spot> eliminates confusion, i'm fine with it
16:28:11 <limburgher> +1 as well.
16:28:12 <RemiFedora> +1
16:28:16 <tibbs|w> So, reading this whole guideline again with a critical eye, why on earth does it talk about anything other than the actual cron configuration file that says when to run an executable?  We should just rip out any mention of the executable at all.
16:29:23 <RemiFedora> because file in crond.{hourly,daily..} are scripts (not crontab file)
16:29:25 <geppetto> +1
16:32:01 <spot> i see general approval for the two changes
16:32:31 <spot> +6 for the first, +5 for the second
16:32:35 <Smoother1rOgZ> +1 from me as well
16:32:44 <tibbs|w> +1 for the second, too.  Lost track of what was being proposed.
16:32:55 <spot> #action improved wording (+1:6, 0:0, -1:0)
16:33:11 <spot> lets just do that and we can go at it again if someone else complains
16:33:53 <abadger1999> with that in mind, do we want to tackle the other cron ticket?
16:34:12 <spot> whats the other one?
16:35:19 <abadger1999> I think it was tacked on to the original cron guidelines ticket.
16:35:25 * abadger1999 thinks that might be closed... finds it
16:35:51 <abadger1999> https://fedorahosted.org/fpc/ticket/261#comment:8
16:36:13 <abadger1999> thm has a comment there, in comment8 and then he and I discuss it a bit more through to the end of the ticket.
16:37:18 <spot> I think cron job files (and not helpers) should be marked %config, even in the case thm proposes
16:37:38 <spot> sysadmins should be able to customize those files (even to disable them) without worrying that they'll come back on an update.
16:37:51 <spot> %config(noreplace), rather
16:38:58 <geppetto> yeh, sounds good to me too
16:39:15 <spot> I also don't want to write 400 pages of "but what if i use an ogg file and a microphone to determine if i need to run this cron job" sort of exceptions.
16:40:01 <spot> anyone want to kick this horse a few more times, or shall we move on to bundling fun? :)
16:40:25 * spot is pushing towards hangry (angry hungry)... ;)
16:40:57 <limburgher> spot:  hangry is an awesome word, my wife uses it. :)
16:41:13 <abadger1999> Proposal -- just add this to the ticket:: FPC intends the cron job files in %{_sysconfdir}/cron* continue to be %config(noreplace) if the packager feels strongly about the code portion needing to update they should move the file to a helper location (%{_libexeecdir} for instance) and write a wrapper for the actual cron job file.
16:41:43 <limburgher> abadger1999:  I like it, it's no more ungainly than the reality it describes. +1
16:41:47 <RemiFedora> abadger1999, which is exactly what I plan for my package +1
16:42:15 <abadger1999> +1
16:42:51 <geppetto> +1
16:43:42 <tibbs|w> +1
16:44:07 <abadger1999> that's five.
16:44:16 <spot> +1
16:44:35 <spot> abadger1999: want to do that for me? :)
16:44:44 <abadger1999> spot: yep, I'll do it right now.
16:44:58 <spot> #topic Temporary bundling exception of yajl library - https://fedorahosted.org/fpc/ticket/325
16:45:07 <spot> Have I mentioned lately how much I adore Ruby? :)
16:45:24 <RemiFedora> spot, as much as php ? ;)
16:45:54 <limburgher> Looks like we're waiting for info here.
16:46:22 <spot> ah, good point.
16:46:23 <spot> tabled!
16:46:42 <spot> #topic Bundling exception for python-kapteyn - https://fedorahosted.org/fpc/ticket/326
16:47:41 <geppetto> 326 has also not answered the usual questions
16:47:56 <geppetto> well, not all of them anyway.
16:48:38 <limburgher> Yup.
16:48:48 <limburgher> Who volunteers to ask for that?
16:49:04 <limburgher> And maybe ask why they can't just package cmpfit?
16:49:07 * spot is over-volunteered with flock as is
16:49:10 <limburgher> I'll do it.
16:49:12 <spot> limburgher: its a modified cmpfit
16:49:20 <spot> they changed the mpfit function
16:49:24 <tibbs|w> cmpfit is tiny and pretty much stable/dead
16:49:38 <limburgher> So it's basically a fork/revival.
16:49:55 <abadger1999> limburgher: well... not really -- I don't think they're exporting the code.
16:50:27 <limburgher> abadger1999:  Ok, true.  Other than that.
16:50:36 <spot> #action limburgher will follow up to get questions answered
16:50:51 <spot> #topic Python shebangs should not point to /usr/bin/python - https://fedorahosted.org/fpc/ticket/327
16:51:36 <RemiFedora> this one follow upstream so seems good idea
16:51:39 <abadger1999> hmmm...
16:51:50 <tibbs|w> I'm not sure this is a terribly good idea.
16:51:54 * abadger1999 really quickly checks if bkabrda is doing what he thinks
16:52:16 <limburgher> Seems churny and risky, potentially.
16:52:21 <tibbs|w> Plus, what about all of that python code that pointlessly starts with a shebang line even though it isn't intended to be executed?
16:52:38 <limburgher> Would this handle /usr/bin/env python?
16:52:45 <spot> tibbs|w: then it's no more wrong if it has #!/usr/bin/python2 ?
16:52:57 <abadger1999> yeah.... I like the goal but not the implementation here.
16:52:57 <limburgher> spot: True.
16:53:20 <geppetto> limburgher: using env is already against policy
16:53:20 <tibbs|w> I don't even know.
16:53:27 <spot> i'd rather see this change happen before the files end up in the binary
16:53:33 <limburgher> geppetto:  Oh, right, so it is.
16:53:42 <spot> as opposed to manipulating files in os_install_post
16:53:45 <abadger1999> I'd recommend (1) that we change guidelines to say that shebang lines and scripts must not use /usr/bin/python -- they should use /usr/bin/python2 instead.
16:53:51 <tibbs|w> And reading the painful mailing list discussion, everyone seems to have completely forgotten that we've already been through all of this, and not really all that long ago.
16:53:54 <spot> unless i'm remembering ordering wrong
16:54:03 <abadger1999> (2) that the %{__python} macro be changed in rpm to point to /sur/bin/python2
16:54:05 <spot> ... and i am.
16:54:05 <geppetto> abadger1999: Do you know how soon the plan is to have /usr/bin/python be python3?
16:54:12 <spot> scratch that, nm.
16:54:17 <tibbs|w> Well, OK, maybe perl4->perl5 did happen all that long ago.
16:54:30 <tibbs|w> I guess I'm more ancient than I think.
16:54:32 <limburgher> geppetto:  My understanding was at least f22.
16:54:46 <limburgher> But I've been wrong once or twice before.
16:55:11 * geppetto nods … even f23 is fairly soon though … sooner than I would have expected, I guess.
16:55:16 <spot> this is going to break on any packages which generate python-foo and python3-foo
16:55:19 <abadger1999> geppetto: Not sure -- I think atthe moment we've decided that we'll switch when upstream switches their recommendation in PEP394 http://www.python.org/dev/peps/pep-0394/#recommendation
16:56:02 <abadger1999> geppetto: I think upstream is currently thinking about considering switching that in 2015-- But I don't think that's set in stone.  It's a time frame for them to rediscuss whether to switch the recommendation.
16:56:15 <abadger1999> rather than a date when they will definitely switch
16:56:50 * geppetto nods … I'm tempted to -1 this and say python == python2 until a decent chunk of the OS is using python3 explicitly.
16:57:15 <geppetto> Or at least assuming that should be fine.
16:57:21 <limburgher> geppetto: I think that's rational.
16:58:46 <abadger1999> geppetto: would you be opposed to my proposal too?  The switching of the %{__python} macro should cause most python-* packages to use /usr/bin/python2 shebangs (upstream code seems to rewrite shebangs to be the executable that invoked the build script)
16:59:38 <abadger1999> geppetto: and then someone (I'd think there should be a FESCo Change to implement) would need to go through and clean up the ones that don't use a build system where that rewriting takes place.
17:01:10 <geppetto> abadger1999: I'm not opposed to any python code being explicit in it's desire for python2 … I just think it's fair for packagers to be able to assume python == python2 for a while.
17:01:46 <geppetto> esp. as not assuming that will cause a bunch of busy work that will annoy everyone, IMO.
17:02:19 <geppetto> abadger1999: So changing the __python macro to use python2 seems fine.
17:02:30 <abadger1999> well, if/when the recommendation changes in the PEP, it will have been future-proofing, not busywork.
17:02:45 <geppetto> yeh, I understand.
17:04:03 <spot> abadger1999: want to take this into the ticket?
17:04:07 <spot> we can revisit if he disagrees
17:05:08 <abadger1999> So proposal: FPC would rather  see this change happen before the files end up in the binary rpm as opposed to manipulating files in os_install_post.  We think a way forward would be to switch the %{__python} macro be changed in rpm to point to /sur/bin/python2. FPC is currently split on  changing guidelines to say that shebang lines and scripts must not use /usr/bin/python
17:05:45 <spot> well, os_install_post is before they end up in the binary rpm
17:05:46 <abadger1999> We held off voting to see what you and the rest of the Python SIGs thoughts were on continuing down this alternative.
17:05:48 <spot> so that part was wrong.
17:05:58 <abadger1999> <nod>
17:06:29 <abadger1999> FPC would rather  see this change happen during %build as opposed to manipulating files in os_install_post.  We think a way forward would be to switch the %{__python} macro be changed in rpm to point to /sur/bin/python2. FPC is currently split on  changing guidelines to say that shebang lines and scripts must not use /usr/bin/python
17:06:53 <spot> yeah
17:06:58 <geppetto> yeh, seems good
17:07:26 <abadger1999> Cool.  I'll post that to the ticket.
17:09:15 <spot> okay, we're at 1hr 40 minutes now
17:09:19 <spot> but lets open the floor
17:09:23 <spot> #topic Open Floor
17:10:54 <abadger1999> Nothing here
17:11:16 <spot> okay, late lunch time for me!
17:11:19 <spot> thanks everyone
17:11:21 * Smoother1rOgZ has nothing too
17:11:22 <spot> #endmeeting