15:59:39 <spot> #startmeeting fedora packaging committee
15:59:39 <zodbot> Meeting started Thu Oct 10 15:59:39 2013 UTC.  The chair is spot. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:59:39 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:59:43 <spot> #meetingname fpc
15:59:43 <zodbot> The meeting name has been set to 'fpc'
15:59:47 <spot> #chair spot
15:59:47 <zodbot> Current chairs: spot
16:00:05 <spot> #topic Roll Call
16:00:10 * limburgher here
16:00:12 <abadger1999> tibbs|w: good luck with the resting
16:00:13 * RemiFedora here
16:00:20 * abadger1999 kinda here; kinda sick
16:00:24 <limburgher> :(
16:00:40 <geppetto2> here
16:00:46 <geppetto2> mostly, anyway
16:00:55 <geppetto2> remi can't make it today and next week
16:00:57 <limburgher> Transporter accident?
16:01:03 <geppetto2> and I can't make it next week
16:01:14 <geppetto2> limburgher, more like many disk failures :(
16:01:24 * spot will be away for the next two weeks as well.
16:01:32 <limburgher> geppetto2:   Eek.
16:02:11 <abadger1999> ouch
16:02:14 <spot> i count five people here
16:02:29 <spot> SmootherFrOgZ: ping
16:03:43 <spot> i've been a bit out of touch lately, due to moving and conferences, so please bear with me. :)
16:04:51 * SmootherFrOgZ is sort of here
16:04:58 <spot> #topic Software Collections in Fedora - https://fedorahosted.org/fpc/ticket/339
16:05:24 <spot> I don't know what the status on this one is, to be honest.
16:05:31 <spot> It's marked as "deferred" in the agenda/.
16:05:50 <RemiFedora> still set as DEFERRED in the FPC schedule ;)
16:06:00 <geppetto2> yeh
16:06:04 <spot> what is it waiting on?
16:06:30 <geppetto2> more talking, having some idea what the goals are etc.
16:06:48 <limburgher> General making the waterfowl colinear.
16:06:51 <RemiFedora> I think we should wait for next meeting, a internal meeting is plan to review the guidelines and the remaining question
16:07:15 <spot> RemiFedora: okay then. easy enough.
16:07:52 <spot> #topic Minetest - jthread bundle - https://fedorahosted.org/fpc/ticket/347
16:08:11 <abadger1999> RemiFedora: Note -- there's a lot of changes needed on that.
16:08:48 <abadger1999> so the internal meeting should also talk about what they're willing to change in a "worst case" scenario for them.
16:09:04 <limburgher> So this one is one of my sponsorees working on it on behalf of another of my sponsorees.
16:09:05 <geppetto2> abadger1999, you should be invited to it :)
16:09:16 <limburgher> I also tried to unbundle this myself, and couldn't make it work.
16:09:31 <geppetto2> Yeh, this looks more like a fork than a bundle
16:09:45 <limburgher> Yeah, and they plan to get rid of it altogether when they can.
16:09:46 * abadger1999 ah , sees he was this morning
16:09:46 <RemiFedora> yep, a fork
16:09:48 <geppetto2> I guess we could ask to split it ... but it seems like they want to remove it anyway, so meh
16:09:51 <spot> I think I'm okay with an exception based on this. +1
16:10:00 <geppetto2> +1
16:10:06 <limburgher> Me too. +1
16:10:09 <RemiFedora> +1
16:10:23 <limburgher> My only reservation is that this game is a massive timesuck, but that's not jthread's fault.
16:10:48 <abadger1999> I'd like a timeline but I'd be willing to +1 if we could get that.
16:11:21 <spot> okay, so I think that's a +4 (with a possible future +1 from abadger1999).
16:11:48 <limburgher> So we put the +4 in the ticket, ask for the timeline, and then abadger1999 can +1 in the ticket once we get it?
16:12:06 <spot> limburgher: unless SmootherFrOgZ wants to +1, thats the way we'll have to go.
16:12:17 <abadger1999> limburgher: yeah -- and FPC members not present could also vote _1.
16:12:25 <abadger1999> s/_1/+1/
16:12:37 <limburgher> Is that like a really vehement rejection? :)
16:12:42 <abadger1999> hah :-)
16:13:49 <spot> #action ticket updated with +4 and request for unbundling timeline
16:14:17 <spot> #topic LangPacks Naming Guideline - https://fedorahosted.org/fpc/ticket/348
16:14:43 <spot> https://fedoraproject.org/wiki/PackagingDrafts/LangPack is the draft
16:15:02 <spot> seems pretty logical to me
16:15:10 <limburgher> Me too.
16:15:20 <limburgher> And I just discovered I have a hard stop in 15. :(
16:15:39 <spot> I might reword it a bit though
16:16:38 <spot> "Packages that exist solely to contain additional language translations must be named in the syntax <pkgname>-<langcode>, where langcode is a valid language code from /usr/share/xml/iso-codes/iso_639_3.xml or from /usr/share/i18n/locales."
16:17:04 <limburgher> I like that.
16:17:40 <RemiFedora> it seems unclear to me, example welcome ;)
16:17:52 <RemiFedora> shoudl it be  foo-fr  or foo-fr_FR  ?
16:18:18 <spot> geppetto2: which one does yum-langpacks expect?
16:18:19 <paragan> RemiFedora, foo-fr
16:18:43 <RemiFedora> paragan, yes, I know, but looking in /usr/share/i18n/locales this is not obvious ;)
16:18:59 <geppetto2> spot, paragan is the guy you want to ask questions :)
16:19:34 <abadger1999> paragan: where region matters, would it be foo-pt_BR and foo-pt_PT ?
16:19:45 <paragan> abadger1999, yes
16:19:50 <limburgher> Or would foo-pt include both?
16:20:10 <paragan> that is reason I kept path /usr/share/i18n/locales as a reference
16:20:59 <paragan> limburgher, here we need to check what upstream translations are providing
16:21:15 <limburgher> paragan:  Logical.
16:22:27 <spot> so, the answer seems to be "either two letter or full locales with region specifiers" ?
16:22:37 <spot> is that accurate?
16:22:43 <paragan> I am not sure how to word it
16:22:58 <paragan> the priority is like first two letter
16:23:14 <paragan> for some languages where region matters we need fill locale
16:23:24 <paragan> like zh_CN, zh_TW, pt_BR
16:23:40 <paragan> s/fill/full/
16:23:57 <spot> perhaps we should mandate full locale for everything to avoid confusion?
16:24:17 <abadger1999> spot: the problem would be that in some languages, fr would be fine for all regions.
16:24:26 <spot> otherwise, we have a state machine of "when it matters" that isn't always obvious.
16:24:40 <spot> especially if the packager doesn't speak the languages being subpackaged.
16:24:52 <abadger1999> if you had locale that included region always, then you'd have to duplicate the same translation files there.
16:25:04 <spot> abadger1999: hm.
16:25:21 <abadger1999> paragan: would we be able to depend on upstream's filesystem locations?
16:25:24 <spot> is there a list of the locales where region "matters"
16:25:49 <paragan> abadger1999, filesystem location?
16:26:04 <paragan> spot, pt and zh
16:26:23 <spot> paragan: he means "where the files live on the disk, e.g. /usr/share/foo/bar/pt_BR and /usr/share/foo/bar/fr/"
16:26:28 <limburgher> Ok, have to go AFK, will check back and read if you're still meeting at in 35.
16:26:33 <SmootherFrOgZ> sorry, got distracted at dayjob. +1 for the record.
16:27:33 <abadger1999> paragan: like /usr/share/locale/fr/LC_MESSAGES/foo.mo   <= langcode == fr  ;; /usr/share/locale/pt_BR/LC_MESSAGES/foo.mo  <= langcode == pt_BR
16:27:51 <paragan> abadger1999, right
16:27:57 <abadger1999> paragan: or do some packages have their own filesystem locations and not use the correct langcode?
16:28:04 <abadger1999> (in the filesystem location)
16:28:35 <spot> if pt and zh are the only ones where region matters, lets just call them out as needing to use region and let everything else use the two letter lang code
16:29:02 <paragan> packages use standard filesystem locations like one you specified above
16:29:52 <RemiFedora> T dont think
16:30:29 <geppetto2> ?
16:30:52 <RemiFedora> ex => /usr/share/pear-data/Horde_Perms/locale/bs/LC_MESSAGES/Horde_Perms.mo
16:30:53 <paragan> abadger1999, but here we need guidelines for yum-langpacks plugin that just parses package names in the repo and decides which packages are available for any language
16:30:59 * spot looks in /usr/share/locale and sees lots of other region specific translations
16:32:12 <spot> Perhaps this could be as simple: "The langcode value used in the package name must match the langcode identifier used in the directory path by upstream for the language translation files."
16:32:14 <paragan> so yum-langpacks is not actually looking for say fr if translations are really available/getting installed in /usr/share/locale/fr/LC_MESSAGES/
16:32:45 <paragan> it just looks for packages like aspell-fr or hunspell-fr or hyphen-fr and installs them
16:33:11 <abadger1999> spot: that wording and concept seems right to me.  paragan, do you agree?
16:33:52 <paragan> this one "Packages that exist solely to contain additional language translations must be named in the syntax <pkgname>-<langcode>, where langcode is a valid language code from /usr/share/xml/iso-codes/iso_639_3.xml or from /usr/share/i18n/locales."
16:35:20 <paragan> above looks good
16:36:40 <spot> how about this: https://fedoraproject.org/wiki/PackagingDrafts/LangPack2
16:37:30 <abadger1999> I think having a little of the justifiction might be good.  Maybe something like: "tools such as yum-langpacks depend on the rpm name ending in -<langcode> in order to find requested language packages."
16:37:31 <paragan> looks good
16:37:51 <RemiFedora> spot, clear
16:37:53 <abadger1999> +1 with or without justification addition.
16:38:26 <paragan> if we can add justification that will be more helpful for people who are not aware of yum-langpacks plugin
16:38:36 <spot> okay, i just added some justification wording
16:38:38 <geppetto2> so /usr/share/i18n/locales is supposed to be a directory, right?
16:38:40 <spot> reload https://fedoraproject.org/wiki/PackagingDrafts/LangPack2
16:38:42 <geppetto2> Assuming that +1
16:38:58 <spot> geppetto2: yeah
16:39:00 <SmootherFrOgZ> +1 from me
16:39:03 <spot> i can add a trailing / there
16:39:29 <spot> +1 from me
16:39:31 <spot> i see +4
16:39:32 <geppetto2> additional wording seems great, +1 still :)
16:39:34 <abadger1999> +1
16:39:36 <RemiFedora> +1
16:39:39 * abadger1999 edits grammar
16:39:53 <spot> abadger1999: suehle would be proud of you. ;)
16:40:05 <abadger1999> heh :-)
16:40:26 * spot ninja corrects those "shoulds" to "musts" in the examples
16:40:36 <spot> okay, i see +5 on this
16:41:05 <spot> #action LangPack2 draft approved (+1:5, 0:0, -1:0)
16:41:15 <paragan> thank you all for having this discussion and voting
16:41:34 <spot> paragan: thanks for your help
16:42:13 <spot> #topic Bundling exception for LINPACK && DQRDC2 - https://fedorahosted.org/fpc/ticket/349
16:42:26 <RemiFedora> this one is my fault.
16:43:07 <spot> I think given the circumstances, we should treat LINPACK and DQRDC2 as copylibs
16:43:24 <spot> Unless anyone is really eager to be a new upstream for 30 year old fortran code.
16:43:26 <RemiFedora> besser82 was trying to create a shared library, I think abadger1999 have comment the review
16:43:37 <geppetto2> spot, lol
16:43:51 <RemiFedora> but, this is not possible, because of incompatible license
16:44:33 <RemiFedora> and R already bundled this code, and yes for copylibs (upstream haven't even a build system, only piece of code)
16:44:49 <abadger1999> RemiFedora: do you have that link?  I don't recall what I might have said and why ;-)
16:45:08 <geppetto2> I'm going to +1 and try to forget about this, I think
16:45:41 <spot> +1 to treat these as copylibs
16:45:46 <RemiFedora> +1 for copylibs
16:46:00 <SmootherFrOgZ> +1 as well
16:46:29 <geppetto2> +1
16:47:02 <spot> okay, we're at +4 here.
16:47:21 <abadger1999> RemiFedora: Do you have the link to where I commented?
16:47:27 <RemiFedora> abadger1999, sorry, comment was from raccor
16:47:35 <abadger1999> ah okay :-)
16:47:38 <abadger1999> +1 copylib
16:47:45 <RemiFedora> https://bugzilla.redhat.com/show_bug.cgi?id=1000829
16:48:47 <spot> #action LINPACK && DQRDC2 are copylibs, exception approved (+1:5, 0:0, -1:0)
16:49:39 <RemiFedora> note: the first comment from ralf  was about "quick review" (<1h between submit and approval) which is really a problem
16:49:51 <RemiFedora> s/quick/fast/
16:50:37 <spot> #topic Bundled library exception for codimension-parser - https://fedorahosted.org/fpc/ticket/350
16:50:53 <abadger1999> Ugh :-( "Any proof for this package being BSD-licensed? The license file contained in this package is added by Björn, but I can't find any upstream evidence linpack is actually licensed BSD."
16:51:01 <abadger1999> sorry, that was about linpack.
16:51:17 * abadger1999 context switches to codimension-parser
16:51:56 <spot> looks like a case of a fork to me.
16:53:01 <RemiFedora> yes
16:54:35 * spot has a hard stop in 5 minutes
16:55:06 <spot> but I'm +1 for this exception (as a static lib only for codimension-parser), maintained fork with no real chance of upstream merge.
16:56:42 <geppetto2> +1
16:56:54 <SmootherFrOgZ> +1
16:56:55 <RemiFedora> +1 fork
16:57:20 <spot> we're at +4 on this
16:58:18 <spot> abadger1999, limburgher ?
16:58:29 * abadger1999 is just trying to find out if the fact they're based on antlr-3.2 instead of 3.5 has any bearing.
16:58:47 <spot> abadger1999: i did a quick search for CVE history and there is none i could see
16:58:51 <abadger1999> but I haven't found an antlr changelog online yet.
17:00:18 <abadger1999> Do we know what they're parsing here?
17:00:21 <spot> abadger1999: i'm going to put the +4 in the ticket, and leave it for you (or any other FPC folks) to vote as needed.
17:00:26 <abadger1999> <nod> wfm
17:02:11 <spot> okay, i think we're done for today.
17:02:13 <spot> thanks everyone.
17:02:19 <spot> #endmeeting