21:01:45 <pwhalen> #startmeeting Fedora ARM status meeting
21:01:45 <zodbot> Meeting started Wed Nov  6 21:01:45 2013 UTC.  The chair is pwhalen. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:01:45 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
21:01:45 <pwhalen> #chair pwhalen jonmasters bconoboy ctyler pbrobinson dgilmore dmarlin jdisnard handsome_pirate msalter ahs3 agreene jcapik ddd_
21:01:45 <zodbot> Current chairs: agreene ahs3 bconoboy ctyler ddd_ dgilmore dmarlin handsome_pirate jcapik jdisnard jonmasters msalter pbrobinson pwhalen
21:01:49 <dmarlin> .fas dmarlin
21:01:49 <zodbot> dmarlin: dmarlin 'David A. Marlin' <dmarlin@redhat.com>
21:01:57 <pwhalen> good afternoon all
21:02:00 <pwhalen> .fas pwhalen
21:02:00 <zodbot> pwhalen: pwhalen 'Paul Whalen' <pwhalen@redhat.com>
21:02:00 <masta> howdy
21:02:04 <hrw> hello
21:02:08 <ahs3> greetings and salutations
21:02:08 <hrw> .fas juszkiewicz
21:02:09 <zodbot> hrw: hrw 'Marcin Juszkiewicz' <mjuszkiewicz@redhat.com>
21:02:13 <ahs3> .fas ahs3
21:02:16 <zodbot> ahs3: ahs3 'Al Stone' <ahs3@redhat.com>
21:02:16 <bconoboy> .fas blc@
21:02:19 <zodbot> bconoboy: blc '' <blc@redhat.com>
21:02:49 <hrw> bconoboy: add your name/lastname to fas one day :D
21:03:04 <bconoboy> hrw: it is on the fas site, not really sure why it doesn't come across
21:03:49 * handsome_pirate waves from the crows nest
21:03:57 <pwhalen> #topic 1) Kernel Status Update
21:04:28 <agreene> .fas agreene
21:04:34 <zodbot> agreene: agreene 'Andrew Greene' <andrew.greene@senecacollege.ca> - tag4fedora 'Tim Greene' <tagreene@flowserve.com>
21:05:40 <pbrobinson> well we have a kernel and it mostly works, I'm working on BBBlack 3.12 patch set, what else is outstanding or needs coverage here?
21:06:25 * jwb is partially paying attention
21:06:38 <bconoboy> f20 is going to be 3.11 based right?
21:06:44 <pbrobinson> jwb: I replied on list about the 3.12 thread
21:06:50 <jwb> pbrobinson, i replied back
21:07:11 <pbrobinson> jwb: your too fast! Do some real work would you ;-)
21:07:11 <jwb> bconoboy, unless someone hits me with some serious reasons why we should move to 3.12, yes
21:07:30 <masta> hehe
21:07:35 <jwb> i'm not comfortable with "it works on my laptop".  it works on my laptop too.  that isn't what i'm worried about :)
21:07:40 <hrw> jwb: especially close to release
21:07:57 <masta> when will 3.12 land?
21:08:25 <jwb> last week
21:08:26 <masta> just curious.
21:08:31 <jwb> oh, you mean in f20?
21:08:45 <masta> yep
21:08:49 <pbrobinson> jwb: I don't disagree with you there, we can deal with either, I think on ARM there would be a slightly better experience for ARM for our supported list of devices (wandboard would be better for example, and I believe BBB would be too)
21:09:02 <jwb> "later".  it's being maintained in the rawhide nodebug repo on a separate branch right now
21:09:05 <pbrobinson> masta: check the back log on the #fedora-kernel
21:09:23 <masta> pbrobinson: acknowledge
21:09:59 <bconoboy> So, 3.11 is good to g on what boards?
21:10:11 <bconoboy> (IE, what's the final list for f20?)
21:11:50 <pwhalen> kernel-3.11.6-301.fc20 works on everything (minus panda of course)
21:12:08 <pwhalen> 3.12 looks good, not yet booting on bbb
21:12:53 <pbrobinson> pwhalen: Now 3.12 is no longer a moving target I'm organising a patch set to deal with BBB
21:13:04 <bconoboy> okay, what is everything?
21:13:07 <pwhalen> pbrobinson, awesome
21:13:14 <masta> support for imx6 is looking good so far.
21:13:21 <pwhalen> bconoboy, http://fedoraproject.org/wiki/Architectures/ARM/Quality_Assurance/Kernel_Testing/Fedora_20#kernel-3.11.6-301.fc20
21:13:24 <bconoboy> wandboard? bbb? bbw?
21:13:33 <jwb> what is bbw?
21:13:35 <pbrobinson> masta: define "imx6 support"?
21:13:45 <jwb> oh, white?
21:13:46 <bconoboy> pwhalen: tnx!
21:13:46 <pbrobinson> BeagleBone White (the original one)
21:13:47 <dgilmore> jwb: beaglebone white
21:13:56 <jwb> i thought people disliked that because it was too limited
21:13:58 <bconoboy> #link Latest QE results http://fedoraproject.org/wiki/Architectures/ARM/Quality_Assurance/Kernel_Testing/Fedora_20#kernel-3.11.6-301.fc20
21:14:30 <pbrobinson> jwb: it's much more expensive than the black, it has similar feature set, is better in some cases
21:14:38 <jwb> oh, ok
21:14:45 <bconoboy> #info F20 beta supports versatile xpress, panda board, trimslice, highbank, midway, beagle xm (no network), beaglebone black, wandboard
21:14:51 <pbrobinson> jwb: less ram but has all the JTAG stuff and serial built in
21:15:25 <bconoboy> #info graphics work on vexpress, trimslice
21:15:27 <jwb> ok
21:15:36 * handsome_pirate wonders what needs to be done for usb on BBB
21:16:02 <bconoboy> are imx.6 graphics not upstream yet?
21:16:07 <pwhalen> our supported platforms for f20 - http://fedoraproject.org/wiki/Architectures/ARM/Supported_Platforms
21:16:24 <pbrobinson> handsome_pirate: likely 3.12, I'll be looking at that in the next few days, with storage and network it's something that can come post release without much issue
21:16:30 * handsome_pirate has a wandaboard on order so should be able to test imx.6
21:16:37 <bconoboy> #link http://fedoraproject.org/wiki/Architectures/ARM/Supported_Platforms for more platform limitations
21:17:41 <pbrobinson> bconoboy: no, not currently, the patchset for 3.11 is too huge, for 3.12 it's fairly self contained. The difference between 3.11 and 3.12 for imx6 is quite like and a big bump in terms on enabled features especially one wandboard
21:18:25 <pbrobinson> OK, anything else for kernel needed?
21:18:36 <bconoboy> tnx pbrobinson
21:18:48 <bconoboy> #info Wandboard graphics may arrive in 3.12
21:19:16 <pwhalen> #topic 2a) Aarch64 - Status Update
21:20:10 <bconoboy> I don't think there has been any change here.  Do we have koji as a separate topic?
21:20:25 <pbrobinson> not sure it needs to be
21:20:42 <pwhalen> I think we've slowed down to move to Koji, I set up eight builders, but a build of binutils dgilmore submitted failed to init the buildroot due to perl deps
21:20:55 <bconoboy> we provided a new perl
21:21:05 <bconoboy> and then.... crickets
21:21:17 <pbrobinson> so is the perl problem fixed?
21:21:22 <bconoboy> don't know
21:21:26 <bconoboy> Basically, we need 2 things
21:21:31 <msalter> new perl requires a number of packages to be rebuilt against said new perl
21:21:58 <bconoboy> 1. Somebody with admin privs on arm.koji to handle koji-shadow and import fixed builds to resolve mock init issues
21:21:59 <pbrobinson> so who has that as an action item?
21:22:06 <bconoboy> 2. Somebody to provide fixed builds
21:22:17 <bconoboy> They could be the same person, but I think they should be separate
21:22:28 <pbrobinson> well we need to do build-previous before we do koji-shadow
21:22:56 <bconoboy> Okay, whether it be build-prevoius or koji-shadow or something else, there are chroot init issues.
21:23:05 <dgilmore> i think i need to import the new perl into koji
21:23:19 <bconoboy> dgilmore: I think perl is likely the tip of the iceberg
21:23:42 <dgilmore> bconoboy: possibly
21:23:52 <bconoboy> In any case, this needs sustained attention
21:23:54 <pbrobinson> bconoboy: it'll be the worst bit of the iceberg, the rest can mostly happen automatically
21:23:55 <dgilmore> its going to need some serious hand holding
21:24:20 <pbrobinson> bconoboy: and I've said I'm happy to help and assist who ever is the lead but I don't really wish to be the lead
21:24:34 <bconoboy> We can have somebody on the arm team feed fixed packages, but none of us have the power or know-how to bring them into koji's database.
21:24:41 <pbrobinson> bconoboy: so someone, who's happy to work with me, needs to step up and be the suckker or be assigned :-P
21:25:05 <pbrobinson> bconoboy: so we need someone who's happy to learn and ask lots of questions
21:25:13 <dgilmore> bconoboy: what pbrobinson said
21:25:35 <masta> I can help here
21:25:53 <bconoboy> masta: on the koji-admin side or the package supply side?
21:26:10 <pbrobinson> unfortunately it doesn't happen on it's own, it can be extremely time consuming and even more frustrating and the person needs a level of OCD
21:26:16 <masta> koji admin side mostly, but I'm flexible
21:26:43 <pbrobinson> masta: by admin what do you mean?
21:27:02 <bconoboy> I can be the point person on this side, for now, for feeding you guys fixed packages
21:27:03 <pwhalen> pbrobinson, heh :)
21:27:15 <bconoboy> (unless somebody else wants to:-)
21:27:29 <pbrobinson> bconoboy: I'm not sure you have the full context of this
21:27:49 <bconoboy> ?
21:28:04 <masta> pbrobinson: well.. I means I can help with the koji-admin part bconoboy mentioned... I was recently added to some fas groups that I believe enable me to help.
21:28:07 <pbrobinson> bconoboy: I'm not sure what you mean by "feed fixed packages"
21:28:23 <dgilmore> masta: i need to still give you admin in koji
21:28:26 <dgilmore> thast seperate
21:28:33 <pbrobinson> masta: my point is I don't know what you or bconoboy means by koji-admin
21:28:49 <dgilmore> bconoboy: fixing packages means fixcing in git and building for primary
21:28:59 <pbrobinson> masta: there's build and building of fixed packages....
21:29:07 <pbrobinson> and some more building
21:29:20 * handsome_pirate apologizes for not being attentive
21:29:25 <bconoboy> Fixing in git, none of us are proven packagers
21:29:25 * handsome_pirate has a san exploding
21:29:44 <bconoboy> ... but generating fixed scratch builds is feasible
21:29:52 <dgilmore> bconoboy: well step 1 is fixing in git
21:29:59 <bconoboy> step 1 is fixing
21:30:03 <pbrobinson> bconoboy: I think you'll find that 90% of the packages don't need fixing but I'm happy to push any fixes needed to git and build them on mainline
21:30:06 <dgilmore> bconoboy: so we need a proven packager or two
21:30:19 <dgilmore> bconoboy: but most should be fine
21:30:30 <masta> yeah I'm scared of the packaging side, but I really see no way to avoid looking at and trying to fix them when they stuck...
21:30:31 <pbrobinson> handsome_pirate: well deal with the SAN and don't discuss that here
21:30:56 <bconoboy> dgilmore/pbrobinson: Okay, you guys are the proven packagers in the gang, I'm not particular about who does what, just as long as we make progress.  Open to suggested methods!
21:31:44 <pbrobinson> bconoboy: I think it would be worth while moving the discussion of process to somewhere outside of this meeting and move the meeting forward. Can we take this discussion elsewhere?
21:31:55 <bconoboy> Sure
21:32:04 <dgilmore> pbrobinson: indeed
21:32:17 <pbrobinson> bconoboy: as it's mostly procedural
21:32:26 <bconoboy> y
21:32:33 <pwhalen> do we have an action item to assign here?
21:32:34 <pbrobinson> so what's outstanding for aarch64?
21:33:02 <bconoboy> #action pbrobinson / dgilmore / blc / masta to collude on aarch64 koji planning
21:33:04 <pbrobinson> yes, masta and bconoboy will lead koji with assistance from dgilmore and pbrobinson
21:33:25 <bconoboy> pbrobinson: don't understand the question
21:33:56 <pbrobinson> bconoboy: any outstanding things that need to be discussed in this meeting about aarch64?
21:34:08 <pwhalen> I think we covered it
21:34:22 <bconoboy> agree
21:34:23 <pbrobinson> cool, next item?
21:34:25 <pwhalen> #topic 3) F20 Beta RC4 Testing Summary
21:34:33 <pwhalen> #link Installation: https://fedoraproject.org/wiki/Test_Results:Current_Installation_Test
21:34:38 <pwhalen> #link Base: https://fedoraproject.org/wiki/Test_Results:Current_Base_Test
21:34:43 <pwhalen> #link Desktop: https://fedoraproject.org/wiki/Test_Results:Current_Desktop_Test
21:35:00 <pwhalen> #info Install validation complete
21:35:00 <pwhalen> #info Base validation complete
21:35:00 <pwhalen> #info Need help testing Desktops - Pick your favourite
21:35:49 <pwhalen> I havent come across anything new.. has anyone else had a chance to try out the new images?
21:36:08 <pbrobinson> pwhalen: the little bits I've had time to test all look good
21:36:09 <masta> looking forward to test xfce and mate for the desktop side.
21:36:32 <bconoboy> masta: you volunteering for xfce and mate?
21:36:43 <bconoboy> pwhalen: quick, document it in the minutes :-)
21:36:47 <masta> bconoboy: yea, I try to test the desktop images
21:36:57 <bconoboy> #action masta will test xfce and mate images
21:36:58 <pwhalen> masta, please update the wiki if you do.
21:37:01 <bconoboy> anybody else?
21:38:09 <pwhalen> anything else for RC4?
21:38:13 <masta> pwhalen: yep, will update wiki
21:38:27 <dgilmore> RC5 is underway ;)
21:38:29 <bconoboy> lxde, sugar, cinnamon, also need love
21:38:42 <pbrobinson> pwhalen: is there any specifics that need focused testing at the moment for rc4/rc5?
21:39:15 <pwhalen> really just the desktops/images, install testing is covered, all looking good.
21:39:31 <pwhalen> I try to boot test them all, but they come fast. 24 hours+ to download
21:39:45 <pbrobinson> pwhalen: I would like to thank you for you exceptional effort in the testing too
21:40:03 <pwhalen> pbrobinson, thanks :)
21:40:28 <pwhalen> #topic 4) Open Floor
21:40:32 <masta> yea... pwhalen you are a machine when it comes to the testing ;)
21:40:36 <pwhalen> anything else folks?
21:40:45 <bconoboy> ctyler about?
21:40:47 <handsome_pirate> Note
21:40:48 <pwhalen> masta, ocd, empty matrices
21:40:52 <handsome_pirate> RC5 is coming soon
21:40:54 <bconoboy> curious about pi status
21:41:03 <pwhalen> ctyler is travelling in California this week
21:41:10 <bconoboy> ah, ok
21:41:11 <hrw> bconoboy: pi as r/pi?
21:41:12 <pwhalen> agreene is !
21:41:14 <bconoboy> hrw: y
21:41:20 <hrw> bconoboy: not supported.
21:41:34 <hrw> bconoboy: easiest answer
21:41:49 <pbrobinson> hrw: he's referring to the v6 remix that seneca deals with and hence the question
21:42:03 <pwhalen> agreene, are you able to give us an update?
21:42:04 <pbrobinson> hrw: so your response is out of context
21:42:04 <hrw> ah
21:42:08 <bconoboy> will have to save it for another day
21:42:21 <agreene> we just put out an alpha version of pidora-19
21:42:43 <pbrobinson> agreene: where were the details of that sent to, what's the status on F20?
21:43:38 <agreene> pbrobinson, about 4000 pkgs still need to be built
21:43:43 <bconoboy> agreene: pointer?
21:44:27 <agreene> I am going to send an email out to the mailing list with information for pidora-19-alpha shortly
21:44:47 <masta> thanks agreene
21:44:48 <bconoboy> #action agreene to send email to the list with pidora-19-alpha pinter shortly
21:44:49 <pwhalen> agreene, awesome thanks
21:44:56 <bconoboy> #undo
21:44:56 <zodbot> Removing item from minutes: <MeetBot.items.Action object at 0x40e18610>
21:44:59 <agreene> http://scotland.proximity.on.ca/raspberrypi/test-releases/pidora-19/
21:44:59 <bconoboy> #action agreene to send email to the list with pidora-19-alpha pointer shortly
21:45:41 <masta> cool
21:45:46 <pwhalen> anything else?
21:46:01 * masta does birthday dance
21:46:15 <pbrobinson> masta: are you drunk already?
21:46:25 <masta> pbrobinson: not yet
21:46:31 <pbrobinson> disappointing!
21:46:36 <masta> I know!
21:46:41 <pwhalen> happy birthday masta !!
21:46:50 <bconoboy> #agreed happy birthday masta
21:46:59 <masta> =)
21:47:44 <pwhalen> ok, thanks all! going to wrap it up if no one else has anything
21:47:47 <masta> so on that, I think things are settling down with the Rcs, probably going to start making new chromebook images for f20 .... on the remix side of the house
21:48:14 <hrw> masta: 3.8 kernel for it?
21:48:16 <pbrobinson> masta: you will test yum update this time won't you ;-)
21:48:44 <masta> pbrobinson: yep, lots of changes from the last time... back then I really had no idea what I was doing. sry about that.
21:49:31 <pwhalen> #endmeeting