17:02:17 <number80> #startmeeting Cloud WG weekly meeting
17:02:17 <zodbot> Meeting started Wed Dec  4 17:02:17 2013 UTC.  The chair is number80. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:02:17 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:02:30 <number80> #topic roll call
17:02:45 <number80> .fas hguemar
17:02:45 <zodbot> number80: hguemar 'Haïkel Guémar' <karlthered@gmail.com>
17:02:49 * rbergeron is here
17:02:55 * jzb_ is here
17:03:03 <jzb> sorry
17:03:06 * jzb is here
17:03:51 <mattdm> I'm here but may be vomited on by a small child at any minute.
17:04:10 <rbergeron> mattdm: welcome to my universe of the past two days :)
17:04:30 <number80> mattdm: as long as it doesn't vomit on my irc window, i'm fine ;)
17:04:54 * number80 is enjoying his last days being childless
17:04:57 <jzb> sadly, my life is childless and vomit free
17:05:05 <mattdm> I did ask her to say away from the keyboard
17:05:11 * jzb isn't sure that's actually sad...
17:05:44 <number80> everyone's here ? fedoristas, sick children and fluffy bots ?
17:06:09 <number80> hello frankieonuonga
17:06:13 <mattdm> jzb you can come get vomited on here any time you like
17:06:20 <frankieonuonga> hi number80
17:06:27 <jzb> mattdm: now that's hospitality
17:06:34 <geppetto> mattdm: You are very generous
17:06:48 <number80> samkottler won't be with us tonight but he was kind enough to sent us the agenda of the meeting on the list
17:07:13 <frankieonuonga> oh ok
17:07:17 <number80> #chair rbergeron jzb mattdm frankieonuonga geppetto
17:07:17 <zodbot> Current chairs: frankieonuonga geppetto jzb mattdm number80 rbergeron
17:07:29 <frankieonuonga> welcome mates
17:07:49 <number80> well, if we don't disagree too much, we have a room for quorum + 1 grumpy person :)
17:07:57 <frankieonuonga> :-)
17:08:08 <number80> i suggest that we start ?
17:08:30 <frankieonuonga> yeah
17:08:47 <number80> #topic Release cadence and lifecyle
17:09:16 <rbergeron> oh boy. fun topic :)
17:09:16 <mattdm> so there was a short discussion on the mailing list...
17:09:33 <number80> yup
17:10:12 <mattdm> main focus was on doing refreshed builds and i think there's a general agreement that we should, regularly.
17:10:33 <frankieonuonga> mattdm: how regular ?
17:10:40 * rbergeron nods
17:10:58 <rbergeron> I think weekly seemed to be the consensus of "what seems sane" on the list
17:11:21 <rbergeron> though some other things were mentioned as possible additional triggers
17:11:22 <mattdm> I also think the idea of trigger-based rebuilds is interesting.
17:11:24 <number80> yup, that's what does ubuntu
17:11:25 <rbergeron> security
17:11:49 <number80> mattdm: we could mix both
17:12:08 <mattdm> maybe guaranteed monthly + whatever other triggered updates?
17:12:43 <number80> that seems reasonnable
17:12:43 <rbergeron> mattdm: i do too - esp. for security - i'm not entirely sure that the yum update more than 50MB would be one. (unless it was "if we weren't doing a weekly")
17:13:16 <mattdm> yeah, if we're doing a weekly that trigger is less necessary
17:13:20 <number80> 50MB of update is not a trigger too difficult to enable ;)
17:13:26 <number80> at least, for fedora
17:13:41 <geppetto> It's also not a trigger too difficult to hit with a package or two :)
17:13:52 <frankieonuonga> just a comment. an update every week means people will frequently be visiting the site to download. isnt it easier to just push updates up and advice guys to update
17:13:52 <mattdm> at least, unless bug fix updates start getting batched at a distro level a al spot's proposal
17:13:58 <geppetto> One advantage that ubuntu has is that they have _much_ less updates.
17:14:18 <frankieonuonga> I am thinking in terms of revision...cause we have to think of numbering and all that
17:14:56 <number80> we're still not that good to distinguish security/enhancements updates (contributor-dependent switch)
17:15:08 <jzb> geppetto: why does Ubuntu have fewer updates?
17:15:24 <number80> jzb: less aggressive maintainers
17:15:29 <jzb> if we have a comparable set of packages, won't we average about the same # of updates?
17:15:48 <geppetto> jzb: number80 said it in the most politic way.
17:15:57 <jzb> geppetto: :-)
17:17:46 <mattdm> so, do we want to make any specific decisions on this right now?
17:18:13 <number80> anyone has another option before submitting motion A: weekly and motion B: monthly + trigger-based
17:18:43 <mattdm> (A would also include security-based triggers, right?)
17:18:57 <frankieonuonga> how will we revise this?
17:19:16 <frankieonuonga> in terms of distinguishing the difference
17:19:44 <rbergeron> mattdm: i would say that yes, A should include security-based triggers
17:19:50 <frankieonuonga> I am for it..but most users do not need to be confused...that is why i ask
17:19:51 <rbergeron> mattdm: I guess it partially depends on how much we can automate.
17:20:24 <mattdm> the new automatic nightly builds have me very optimistic about automation possibilities
17:20:40 <number80> so, i'd go for A :)
17:20:43 <rbergeron> I think that weekly is a great goal, but I also fear that we don't have enough automated to produce them and know damn well they will work, whereas monthly can give us a bit of sane testing time and figure out what all actually should be tested
17:20:52 <rbergeron> before we're totally confident that autogenerated things *just work*
17:20:57 <mattdm> right, it's the testing automation that is the problem.
17:20:58 <rbergeron> (the universe i live for. lol)
17:21:06 <frankieonuonga> rbergeron sounds good
17:21:07 <mattdm> +1 to that universe
17:21:28 <rbergeron> and monthly images is something we can think of scheduling in the schedule, and gives us some predictability so people can anticipate when we'll be testing.
17:21:31 <number80> anyone else ?
17:21:44 <frankieonuonga> i will go with b +1
17:21:46 <number80> (let me be the grumpy person for this one ;) )
17:21:47 <mattdm> rbergeron so in that case, would the trigger-based updates get less testing?
17:21:55 <rbergeron> ie: we can schedule those like, if we were doing them ight now, we wouldn't want to be worrying about those in the same weeks as perhaps when we're trying to get a alpha/beta/GA out the door.
17:22:18 <rbergeron> mattdm: i would imaging that a trigger-based update would only pull in the triggering thing? (wihch hopefully isn't a "change the universe" type thing)
17:22:27 <rbergeron> or would we just re-roll the whole thing, all available updates?
17:22:35 <number80> geppetto, jzb your input ?
17:22:49 <mattdm> re-rolling the whole thing is much, much easier.
17:23:03 <geppetto> Unless we have a good way to manage it I think having near 50 imagines available near EOL is probably a bad idea.
17:23:07 <mattdm> plus, you never know if one little change breaks the whole universe
17:23:08 <geppetto> so b +1.
17:23:19 <jzb> number80: I'd go with B+1
17:23:30 <rbergeron> mattdm: yeah
17:24:10 <number80> #agreed cadence release to be monthly + trigger-based updates until we're more confident on automated testing (rbergeron)
17:24:16 <number80> is that ok with you ?
17:24:22 <frankieonuonga> brb guys
17:24:23 <mattdm> yes.
17:24:46 <rbergeron> ack.
17:24:48 <number80> ok, let's switch to another *phun* topic
17:24:51 <mattdm> and we can define triggers as needed. (critical-level security updates, for example.)
17:24:55 * rbergeron doens't know what the triggers are.. but
17:24:59 <rbergeron> yes, what matt said
17:25:06 <number80> #topic Product Branding
17:25:30 <number80> https://fedorahosted.org/cloud/ticket/3
17:25:41 <number80> https://fedorahosted.org/cloud/ticket/3 a ticket has been opened on our trac
17:27:02 <mattdm> okay, so, we're supposed to get back to the design team about this today :)
17:28:36 <number80> Lando Calrissian could have provided us cool artwork :)
17:28:48 <jzb> mattdm: I *think* we agreed on language last meeting?
17:29:22 <mattdm> jzb yeah. plus you and number80 had some good comments on the mailing list before.
17:29:23 <number80> jzb: +1
17:29:41 <mattdm> jzb can you write that up in the ticket and forward it to the design team?
17:29:48 <jzb> mattdm: yeah
17:30:06 <rbergeron> lol
17:30:10 <number80> #agreed jzb will complete the ticket https://fedorahosted.org/cloud/ticket/3 and forward it to the design team
17:30:12 <jzb> rbergeron: ?
17:30:48 * rbergeron was snickering about the lando calrissian comment, that's all
17:30:58 <mattdm> ooh vomit time
17:31:12 <number80> Cloud City is the best
17:31:40 <number80> and there's no vomitting kids only nice stormtroopers
17:31:48 <gholms> mattdm: :/
17:31:59 <number80> anything else to add ?
17:32:08 <number80> about the branding stuff ?
17:32:26 * rbergeron has nothing
17:32:40 <number80> next topic
17:32:47 <number80> #topic PRD
17:33:00 <number80> remember that deadline is december, 15
17:33:24 <number80> https://fedorahosted.org/cloud/ticket/3 it hasn't changed much (or at all) since last meeting
17:33:35 <frankieonuonga> my section will be done by tomorrow night
17:33:42 <number80> great news :)
17:33:49 <jzb> number80: that's the branding ticket :-)
17:33:58 <frankieonuonga> just not put it up
17:34:02 <frankieonuonga> sorry
17:34:08 <number80> jzb: good eyes ;)
17:34:14 <number80> https://fedoraproject.org/wiki/Cloud_PRD
17:34:24 <jzb> number80: not really... :-) and they get worse every year...
17:34:51 <number80> old man !
17:35:18 <number80> btw, i'll have to commit the personas (taken from openstack)
17:35:30 <number80> rbergeron: anything to say ?
17:36:57 <rbergeron> number80: sorry. MANY WINDOWS ON FIRE - I only have to say... help is welcome. pretty please.
17:37:12 <rbergeron> I have been poking here and there but ... yeah.
17:37:22 <rbergeron> frankieonuonga: your section is the personas, yes?
17:37:24 <jzb> rbergeron: I'll try to put in a sustained effort on it tonight or tomorrow.
17:37:36 <frankieonuonga> mine is cloudstack
17:37:47 <number80> i am the darth lord of the personas
17:38:27 <frankieonuonga> personas....i can not recall that well who took that of me..
17:38:27 <frankieonuonga> it is somewhere on the mailing list
17:38:27 <frankieonuonga> but I can take it up if you need me to
17:39:31 * rbergeron nods
17:40:03 <rbergeron> if we don't get much this week we might consider having a mini-hackfest on it for a few hours.
17:40:11 <number80> basically a good kickstart: https://docs.google.com/document/d/16rkiXWxxgzGT47_Wc6hzIPzO2-s2JWAPEKD0gP2mt7E/edit
17:40:11 <rbergeron> nice to have company and stuff while working through it. :)
17:40:27 <frankieonuonga> rbergeron: you need me to take this up ?
17:40:44 <number80> some personnas could be reused or serve as an example for people not used to that
17:40:47 <jzb> rbergeron: I can take Release/Product Overview
17:41:09 <jzb> (inc. Market Oppty, Product Objectives, etc.)
17:42:14 <rbergeron> number80: yeah, i recalled that someone was looking at adding some of that stuff in or ... massaging it so it would fit in. :)
17:42:28 <rbergeron> jzb: that would be dandy.
17:42:44 <rbergeron> basically i think if we can at least get some stuff stubbed in people will feel more confident about filling other parts in or elaborating more.
17:42:53 <number80> #info if PRD is still stuck next week, organize a mini-hackfest to fix that (few hours)
17:43:29 <rbergeron> But if we want to make sure that "what we want to implement" ties back to "what we know people want" and isn't just random shots in the dark - that we're really doing something comprehensive - making sure things like personas or use cases and, market opportunities, overviews, etc. are really good to have.
17:44:00 <rbergeron> otherwise we're just ... kind of going to be adding in whatever sounds awesome, which is great for itch-scratching, but doesn't necessarily get us something pimpin' awesome.
17:44:09 <number80> #agreed frankieonuonga taking lead on cloudstack/ jzb on Release/Product Overview
17:44:25 <rbergeron> and i have this great purple zebra-striped velvet suit i want to wear when i talk about fedora and cloud.
17:44:36 <rbergeron> (okay, not really.)
17:45:19 <frankieonuonga> from that google doc looks like that is only for open stack right ?
17:45:54 <number80> frankieonuonga: yup, but it overlaps or non-strictly includes similar use cases
17:46:02 <rbergeron> frankieonuonga: I think there's a LOT of overlap.
17:46:29 <rbergeron> i am murky about the re-usability of content from a "is it freely available content" perspective
17:46:39 <rbergeron> (unless it's been updated with some sort of license since i last looked)
17:46:54 <number80> rbergeron: nearyd says it was ok, i could ask him again friday
17:47:29 <jzb> rbergeron: what's the source?
17:47:44 <number80> jzb: openstack foundation
17:47:48 <rbergeron> i can harass him about it tomorrow - he may still even be in today - if nothing else it's good inspiration.
17:47:55 <frankieonuonga> ok. Got it .
17:47:56 <frankieonuonga> thanks mates
17:48:11 <number80> rbergeron: right, you're in the same team :)
17:48:12 <rbergeron> jzb: though it was a work in progress for a bit
17:48:31 <number80> up until the summit which has closed few weeks ago
17:48:34 <rbergeron> number80: hahaha. not actually :)
17:48:39 <number80> ok
17:49:41 <number80> so i can't bribe your mgr
17:50:21 <frankieonuonga> oops...we only have 15 min ...we might need to hurry if we have a lot more to cover
17:50:22 <rbergeron> probably not.
17:50:29 <number80> do we continue or move to the next exciting topic ?
17:50:31 <rbergeron> okay, let's move on :)
17:50:57 <number80> #topic Release criteria for post-F20 cloud images
17:50:57 <rbergeron> #action rbergeron to poke mr. neary re: personas
17:51:19 * mattdm is back
17:51:30 <number80> good
17:51:54 <number80> https://fedorahosted.org/cloud/ticket/4 trac ticket opened by mattdm on that matter (+ discussion kickstarted on the list)
17:52:28 <mattdm> this is due to f20 almost being very very broken. :)
17:52:45 * number80 poke gholms there's no eucalyptus in our criteria
17:52:46 <mattdm> I suggest we remove this one from the meeting agenda for now and start accumulating cases in the ticket
17:53:15 <number80> i don't mind so +1
17:53:58 <jzb> +1
17:54:11 <rbergeron> +1
17:54:26 <number80> mattdm: if there are any tickets or urgent testing to do for F20, feel free to send a list on the list
17:54:38 <number80> frankieonuonga: ?
17:55:18 * gholms likes that idea
17:55:35 <frankieonuonga> number80: I will not vote on this one..sorry. I am on the fence
17:55:50 <mattdm> number80 right now, testing the latest candidates (currently TC4) for anything brown-paper-bag-awful is the main thing.
17:55:55 <number80> frankieonuonga: no problem
17:56:25 <number80> mattdm: ok, i'll take some time this w-e for that
17:56:39 <number80> no quorum but postponing should be ok
17:57:05 <number80> #agreed postponing the discussion about release criteria after we clean the F20 mess
17:57:31 <rbergeron> are we postponing or just moving it to the ticket?
17:57:43 <mattdm> not that F20 is actually a _mess_. It's pretty nice really.
17:57:51 <number80> #undo
17:57:51 <zodbot> Removing item from minutes: <MeetBot.items.Agreed object at 0xdb50ad0>
17:57:58 <rbergeron> mattdm: just busy timing :)
17:58:31 <number80> rbergeron: we could continue the thinking on the ticket but polishing F20 is indeed a priority
17:58:50 <number80> (and the PRD too)
17:59:27 <mattdm> yeah we don't _really_ need post-f20 test cases for another four months or so.
17:59:35 <number80> #agreed postponing the discussion about release criteria after F20 release (discussion could continue in the ticket)
17:59:47 <rbergeron> sounds lovely.
17:59:55 <mattdm> +1
18:00:15 <frankieonuonga> is there another ticket guys...we are almost out of time
18:00:38 <number80> frankieonuonga: which one ? our relation with server WG ?
18:01:01 <jzb> I'd move we try to start discussing that on the list.
18:01:07 <number80> ok
18:01:11 <jzb> there's *no way* we can do justice to that right now.
18:01:16 <number80> #topic Relation with server WG
18:01:41 <number80> who agrees with jzb that we move the discussion to the list (no quorum, and very long topic)
18:01:43 <number80> +1
18:01:44 <rbergeron> +1
18:02:25 <frankieonuonga> sorry about that...bad net connection here
18:02:50 <number80> frankieonuonga: we're voting about moving the discussion about our relation with server WG to the list
18:03:23 <geppetto> number80: +1
18:03:24 <frankieonuonga> +1
18:03:28 <number80> quorum
18:04:00 <number80> #agreed move the discussion about the cloud/server WG relation and their overlap to the list
18:04:12 <number80> so i suggest we move to the delightful open floor
18:04:21 <number80> #topic Openfloor
18:04:56 <number80> #info we have nightly qcow nightly builds thanks to Rel-eng koji.fedoraproject.org/koji/tasks?state=all&view=tree&method=appliance&order=-id
18:05:18 <number80> any topic you want to bring on ?
18:05:26 <gholms> \o/
18:08:44 <rbergeron> ...sounds like a no :)
18:08:49 <number80> ok, i'll assume that's the end
18:08:58 <frankieonuonga> thanks for coming guys
18:09:08 <number80> Thank you for your time and see you next week !
18:09:12 <number80> #stopmeeting
18:09:20 <number80> #endmeeting