17:00:56 <samkottler> #startmeeting cloud WG weekly meeting
17:00:56 <zodbot> Meeting started Wed Feb 19 17:00:56 2014 UTC.  The chair is samkottler. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:56 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:01:17 <samkottler> #chair geppetto mattdm rbergeron number80
17:01:17 <zodbot> Current chairs: geppetto mattdm number80 rbergeron samkottler
17:01:27 <jzb> samkottler: here
17:01:31 <samkottler> #chair jzb
17:01:31 <zodbot> Current chairs: geppetto jzb mattdm number80 rbergeron samkottler
17:01:44 <samkottler> who's around?
17:01:50 <number80> not here for long
17:02:06 <number80> (i bought a flat and i'm still moving all my junk)
17:02:20 <samkottler> mattdm: rbergeron: you around?
17:02:31 <jzb> number80: a flat what?
17:02:39 <mattdm> hi!
17:03:18 <number80> jzb: an appartment
17:03:42 <mattdm> i think that was an attempt at humor.
17:03:51 <geppetto> :)
17:03:59 <samkottler> yay, quorum!
17:04:26 <jzb> mattdm: yes. Thanks for recognizing.
17:04:41 <samkottler> #topic start assigning tasks from the PRD
17:04:57 <samkottler> mattdm: didn't you have a document related to this?
17:05:01 <number80> jzb: i wasn't sure, since it was a british word :)
17:05:07 <number80> but it's a good one ;)
17:05:20 <mattdm> samkottler yes, sort of :)
17:05:27 <mattdm> https://fedoraproject.org/wiki/Cloud/Cloud_ToDo
17:05:37 <mattdm> #info gigantic todo list for all things cloud https://fedoraproject.org/wiki/Cloud/Cloud_ToDo
17:05:57 <mattdm> then, there is *specifically* https://fedoraproject.org/wiki/Cloud_Changelist
17:06:06 <mattdm> but that needs work.
17:06:30 <mattdm> thanks to sandro for starting it
17:06:49 <mattdm> there is supposed to be a statement coming from fesco clarifying what fesco is looking for next
17:07:54 * mattdm has apparently overwhelmed the channel
17:08:44 <samkottler> mattdm: do you think we should sit on our hands until fesco speaks?
17:08:45 <number80> i have to go but note that i'm interested in images maintenance
17:08:59 <samkottler> see ya later number80
17:09:00 <mattdm> samkottler no, I think we don't need to sit
17:09:27 <mattdm> the basic part is: what significant changes do we need
17:09:46 <mattdm> and i think the main thing is: production of a number of different images
17:09:49 <samkottler> a huge amount of the stuff on the list seems to be rel-eng related
17:09:54 <mattdm> automatic production of those images so we can test them
17:10:24 <mattdm> and ideally the monthly updates, plus possible non-scheduled security updates
17:10:58 <jzb> mattdm: I'll take lead on the marketing stuff.
17:11:02 <mattdm> basically i think the brainstorming page is good and we just need to start formatting it
17:11:13 * samkottler is willing to take on driving the discussions around what the images should be and what they should each contain
17:11:13 <mattdm> #action jzb to take lead on marketing stuff
17:11:30 <mattdm> +1 sam
17:11:36 <roshi> jzb - I can help with that
17:11:42 <samkottler> #action samkottlerto take on driving the discussions around what the images should be and what they should each contain
17:11:47 <samkottler> #undo
17:11:47 <zodbot> Removing item from minutes: ACTION by samkottler at 17:11:42 : samkottlerto take on driving the discussions around what the images should be and what they should each contain
17:11:55 <samkottler> #action samkottler to take on driving the discussions around what the images should be and what they should each contain
17:12:26 <samkottler> frankie hasn't been around in a while, but he might be interested in working on the koji stuff
17:13:14 <mattdm> I can work on polishing up the changes list
17:13:22 <mattdm> other help doing that welcome
17:13:41 <jzb> question on the branding stuff, though
17:14:03 <jzb> how much of that is coming from Mo's group and how much is from us?
17:14:24 <jzb> what with the questionnaire we filled out and all...
17:14:55 <mattdm> jzb I hope that it works by someone from our group working with design group
17:15:21 <mattdm> possibly/ideally with an overlapping member, but if not, someone willing to act as an overlap
17:15:37 <mattdm> kind of like the fesco liaison
17:15:44 <jzb> k
17:17:23 <samkottler> okay cool so it sounds like most people have stuff they're working on
17:18:01 * mattdm nods
17:19:03 <samkottler> #topic status on different stuff going on around docker
17:19:25 <samkottler> mattdm: anything we should be expecting in the new few weeks?
17:19:42 <samkottler> next few weeks, even
17:19:56 <mattdm> the koji update should happen soon, which should include support for generating docker images
17:20:10 <mattdm> so we can therefore start kicking off the process of making those official
17:20:35 <mattdm> i'll ping koji upstream about it again if that doesn't happen magically by itself in a week or so :)
17:21:03 <mattdm> in related other news, if anyone is interested in packaging up coreos's new 'fleet' thing for fedora, that'd be cool
17:21:48 <geppetto> a distributed init system?
17:22:07 <samkottler> it's pretty interesting
17:22:10 <samkottler> slash terrifying
17:22:19 <geppetto> :)
17:22:24 <jzb> samkottler: if innovation isn't scary, is it really innovation?
17:22:38 <mattdm> it's kind of like condor. but all dockery.
17:22:39 <samkottler> jzb: indeed
17:22:47 <geppetto> it implies it needs etcd
17:22:58 <samkottler> we really need something like that - the coreos folks are doing awesome work
17:23:09 <samkottler> geppetto: yeah, etcd does the consensus bit
17:23:52 <mattdm> we have etcd
17:24:01 <mattdm> at least packaged up. it's not *doing* anything
17:24:31 <samkottler> #info it'd be great if someone wants to take up packaging for https://github.com/coreos/fleet
17:25:17 <mattdm> I think that once we get the basic stuff we are targetting for f21 done (eg the stuff we have planned out so far), figuring out this next level will be really important
17:26:36 <samkottler> yep. the fact that we already have systemd well-integrated and such puts us into a unique position to work with coreos folks, too
17:26:56 * mattdm nods
17:27:21 <samkottler> #topic 'cloud kernel' update
17:27:34 <mattdm> we sent some mail to jwb
17:27:38 <mattdm> needs more figuring out
17:27:43 <mattdm> that's the basic status
17:27:45 <samkottler> we've been thinking about a minimal kernel for a while and are finally kind of working on it
17:28:39 <samkottler> jwb is working on making the kernel spec more modular
17:29:44 <samkottler> zooz isn't here so I don't think we can cover the work that's been happening around GCE in today's meeting
17:29:50 * samkottler will try to make sure zooz is around next week
17:30:40 <samkottler> #topic open floor
17:30:59 <samkottler> anyone got anything?
17:31:32 <mattdm> not anything other than all of the previous :)
17:31:44 <jzb> samkottler: not this week.
17:32:10 <samkottler> cool, well talk to you all next week!
17:32:12 <samkottler> #endmeeting