#fedora-meeting-1: Fedora Packaging Committee

Meeting started by spot at 17:03:44 UTC (full logs).

Meeting summary

  1. Software collections in Fedora (https://fedorahosted.org/fpc/ticket/339) (spot, 17:06:57)
  2. Go Packaging Draft - https://fedorahosted.org/fpc/ticket/382 (spot, 17:13:06)
  3. workarounds for rpm symlink <-> directory issue - https://fedorahosted.org/fpc/ticket/385 (spot, 17:14:18)
    1. https://fedoraproject.org/w/index.php?title=User:Patches/PackagingDrafts/Symlink_Workarounds&diff=370735&oldid=370560 (spot, 17:15:05)

  4. Recommend %autosetup over %setup - https://fedorahosted.org/fpc/ticket/388 (spot, 17:27:47)
    1. http://www.rpm.org/wiki/PackagerDocs/Autosetup has the meat (spot, 17:32:57)
    2. ACTION: spot's mini-draft approved (+1:7, 0:1, -1:0) (spot, 17:43:54)

  5. Exception for bundled libs in icecat - https://fedorahosted.org/fpc/ticket/391 (spot, 17:45:32)
    1. https://fedorahosted.org/fesco/ticket/472#comment:16 (abadger1999, 17:48:08)
    2. https://bugzilla.redhat.com/show_bug.cgi?id=1049889 => no comment (RemiFedora, 18:03:31)
    3. icecat bundling tabled for this week as there's both questions of what we should be doing and fairness wrt firefox. (abadger1999, 18:09:10)

  6. #393 New Packaging Guidelines: Drupal 7 (abadger1999, 18:09:28)
    1. https://fedorahosted.org/fpc/ticket/393 (abadger1999, 18:09:34)
    2. Drupal7 guidelines approved with the virtual provides requirement changed to MUST (+1:6, 0:0, -1:0) (abadger1999, 18:28:49)

  7. #394 Outdated guideline about Requires(foo,bar) syntax (abadger1999, 18:28:51)
    1. https://fedorahosted.org/fpc/ticket/394 (abadger1999, 18:28:59)
    2. Remove the Scriptlets requirements section from the Guidelines and add them to the epel guidelines for EL5 (+1:5, 0:0, -1:0) (abadger1999, 18:31:21)

  8. #395 Mono guidelines include hard-coded library paths (abadger1999, 18:31:53)
    1. https://fedorahosted.org/fpc/ticket/395 (abadger1999, 18:31:58)
    2. Mono path macros approved with the folowing changes: prepend with an underscore and use %{_prefix} (+1:5, 0:0, -1:0) (abadger1999, 18:37:20)

  9. #396 Reserve static UID/GID for OpenStack ironic daemon (abadger1999, 18:37:34)
    1. https://fedorahosted.org/fpc/ticket/396 (abadger1999, 18:37:39)

  10. #397 Please, choose an ID number for a new group called "input" (abadger1999, 18:39:01)
    1. https://fedorahosted.org/fpc/ticket/397 (abadger1999, 18:39:07)

  11. Open floor (abadger1999, 18:50:19)


Meeting ended at 18:52:30 UTC (full logs).

Action items

  1. spot's mini-draft approved (+1:7, 0:1, -1:0)


Action items, by person

  1. spot
    1. spot's mini-draft approved (+1:7, 0:1, -1:0)


People present (lines said)

  1. spot (96)
  2. abadger1999 (92)
  3. geppetto (51)
  4. tibbs|w (32)
  5. RemiFedora (24)
  6. Rathann (22)
  7. limburgher (9)
  8. SmootherFrOgZ (7)
  9. zodbot (6)
  10. willb (5)
  11. tstclair (2)
  12. nirik (2)


Generated by MeetBot 0.1.4.