15:33:43 <dgilmore> #startmeeting
15:33:43 <zodbot> Meeting started Mon Apr  7 15:33:43 2014 UTC.  The chair is dgilmore. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:33:43 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:33:51 <dgilmore> #meetingname releng
15:33:51 <zodbot> The meeting name has been set to 'releng'
15:34:19 <dgilmore> #chair nirik sharkcz dwa masta tyll
15:34:19 <zodbot> Current chairs: dgilmore dwa masta nirik sharkcz tyll
15:34:28 <dgilmore> #topic roll call
15:34:31 * masta is here
15:34:33 * sharkcz is here
15:34:41 * nirik is here
15:35:34 <dgilmore> #topic Tickets: https://fedorahosted.org/rel-eng/report/10
15:35:58 <dgilmore> #topic ticket: https://fedorahosted.org/rel-eng/ticket/5854
15:36:03 <dgilmore> masta: any update?
15:36:20 <masta> regrettably I have no update from last week.
15:37:02 <masta> I actually still have that ticket open in my browser *from* last week, and just haven't knocked it out.
15:37:18 <masta> so I'll just do it =)
15:37:24 <dwa> (ahoyhoy)
15:37:56 <dgilmore> okay cheers
15:38:04 <masta> #action masta to knock out this ticket
15:38:16 <dgilmore> #topic https://fedorahosted.org/rel-eng/ticket/5362
15:38:21 * dgilmore has nothing to update
15:38:29 <dgilmore> #action dgilmore to get it done
15:38:52 <dgilmore> #topic ticket: https://fedorahosted.org/rel-eng/ticket/5870
15:39:03 <dgilmore> nirik: how did your discussions go?
15:39:09 <nirik> so...
15:39:28 <nirik> I talked with mitr, and he's got 0 time to work on sigul and thinks it could be hard to adjust it to automation.
15:39:46 <nirik> I talked to threebean and he said fedmsg triggering signing should be fine if we wanted to.
15:40:06 <nirik> Also, the stacks folks are looking at obs-signd for copr.
15:40:35 <nirik> So... not sure where we go from here. We could also look at just doing obs-signd...
15:40:52 <nirik> but copr and koji have pretty different setups actually.
15:41:17 <tyll> Hi there
15:41:39 <janeznemanic> hi
15:41:53 <nirik> ie, for koji sigul can write out to the koji store... but for copr there's no way to do that, it would need to send the rpm over and get a signed one back
15:41:57 <tyll> Hi janeznemanic
15:42:02 * nirik waves
15:42:31 <nirik> so, I guess we can ponder on it more and try and come up with some brilliant plan. ;)
15:42:47 <dgilmore> nirik: we really should be using koji for stacks and not coprs
15:43:25 <nirik> dgilmore: well, thats something to take up with them I guess. They wanted to make it easy to create a collection of coprs for a 'playground' thing.
15:43:39 <tyll> #note mitr got 0 time to work on sigul and thinks it could be hard to adjust it to automation
15:43:42 <dgilmore> I think we should only have one supported buildsystem for things Fedora officially ships
15:43:55 <tyll> #note stacks folks are looking at obs-signd for copr
15:44:17 <dgilmore> nirik: I will have to take it up with them I guess
15:44:35 <dgilmore> #note all offical fedora builds should be done in koji
15:44:40 <nirik> yeah, the playground stuff I think should be coming as a change... will get discussed more widely then
15:45:06 <dgilmore> #action dgilmore to wirk with the stacks working group to bring them back to building in koji
15:45:34 <dgilmore> nirik: guess it depends on what playground is and if its supported by fedora
15:45:48 <dgilmore> or just somewhere for people to test things out and not really part of Fedora
15:45:49 <nirik> yeah
15:48:23 <dgilmore> anyway lets table for now.
15:48:33 <dgilmore> #topic open floor
15:48:54 <nirik> dgilmore: did you see threebean's mash patches? ;)
15:49:06 <dgilmore> Just wanted to say that I got oz/imagefactory up and running in koji after we updated koji last week
15:49:09 <dgilmore> nirik: I did not
15:49:29 <nirik> https://bugzilla.redhat.com/show_bug.cgi?id=1081622 (I think you already merged this one?)
15:49:46 <nirik> https://bugzilla.redhat.com/show_bug.cgi?id=1082830 (needs more discussion I think)
15:50:04 <nirik> https://bugzilla.redhat.com/show_bug.cgi?id=1082832 (might be ready to go)
15:51:07 <dgilmore> nirik: the last one I really do not like. and the way we do composes we really need to update the multilib policy by doing a build
15:51:48 <nirik> dgilmore: ok, bummer. I was hoping we could avoid builds when changing that, seems like a waste (but I'm probibly missing why
15:51:52 <dgilmore> I am not the biggest fan of keeping old updates in the repo, but I get why it may be needed
15:52:18 <nirik> I think a time limit could be a good compromise.
15:52:22 <nirik> and help people a lot
15:53:25 <dgilmore> we probably need to sit down and work out a list of features we want from releng tools
15:53:41 <nirik> sure. I just thought these were low lying fruit...
15:54:49 <nirik> do you know when you might do a new mash release? (with the drpms patch at least)
15:55:08 <dgilmore> was going to work on appliance-tools and mash updates today
15:56:01 <nirik> cool. If the old updates thing + time looks sane it would be cool to have that too... :)
15:56:01 <sharkcz> dgilmore: then please apply the signing key fix from https://lists.fedoraproject.org/pipermail/buildsys/2014-March/004267.html
15:56:35 <dgilmore> sharkcz: okay, thought it was already, I need to change that list
15:56:45 <dgilmore> just have f20 and f21 keys in rawhide
15:57:12 <sharkcz> dgilmore: you did larger part of the changes I sent some time ago, but skipped the key list in rawhide config
15:57:28 <dgilmore> sharkcz: okay, that needs trimmed
15:57:32 <sharkcz> ok
15:57:34 <dgilmore> i was planning to do so today
15:57:43 <dgilmore> no need to keep ancient keys there
15:57:53 <sharkcz> yep, EFE550F5 is the correct f20 key
15:58:20 <sharkcz> thanks
15:58:22 <dgilmore> anyone else have anything to bring up?
15:58:24 <threebean> another open floor item: locking in pungi -> https://bugzilla.redhat.com/show_bug.cgi?id=1083287
15:58:59 <dgilmore> threebean: ill review the patch
15:59:05 <dgilmore> and try get it some testing
15:59:16 <dgilmore> Id like to start trying to do f21compsoes
15:59:19 <dgilmore> composes
15:59:31 <threebean> cool - thanks :)
15:59:42 <dgilmore> just to see what things will look like
16:00:39 <nirik> threebean: I also filed a few things on releng dash...
16:00:54 <nirik> that just came out of the qa meeting. Want to make it easier for people to get to rawhide.
16:01:48 * dgilmore has rawhide running on 7 machines here
16:02:08 <threebean> nirik: sure.  I'll take a look at the qa meeting notes
16:02:21 <dgilmore> anyone have anything else?
16:02:41 <nirik> threebean: I filed github issues for the 2 they came up with. ;)
16:02:56 <threebean> thanks :)
16:04:11 <dgilmore> will finish the meeting early if there is nothing else
16:05:40 <dgilmore> #endmeeting