18:00:04 <rbergeron> #startmeeting Fedora Board IRC meeting
18:00:05 <zodbot> Meeting started Thu Apr 10 18:00:04 2014 UTC.  The chair is rbergeron. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:05 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:00:14 <rbergeron> wait
18:01:03 * inode0 waits like an obedient puppy
18:01:25 <Sparks> SIT! STAY!  Good boy.
18:01:40 * rbergeron checks UTC clock with the insane feeling of being off
18:01:57 <rbergeron> sorry, i have terrible lag :)
18:02:04 * rbergeron typed and then had to wait forever
18:02:06 <Sparks> rbergeron: Nope, you're right on.
18:03:56 <rbergeron> oh, you're here.
18:03:59 <rbergeron> #topic Who's here
18:04:17 * Sparks 
18:04:19 <mjg59> Hi
18:05:08 <rbergeron> greetings
18:05:21 <Sparks> well, I'm glad we could all be here.
18:05:23 <rbergeron> #info present: sparks inode0 mjg59
18:05:28 <jwb> hi
18:05:42 <rbergeron> #info present: jwb, rbergero
18:05:46 <Sparks> rbergeron: I sent a trademark ticket to spot earlier today.
18:06:01 <rbergeron> #chair sparks inode0 mjg59 jwb
18:06:01 <zodbot> Current chairs: inode0 jwb mjg59 rbergeron sparks
18:06:22 <rbergeron> sparks: ack
18:07:11 <gholms> bacon
18:07:56 * randomuser wanders in
18:08:08 <rbergeron> #chair gholms
18:08:08 <zodbot> Current chairs: gholms inode0 jwb mjg59 rbergeron sparks
18:08:26 <rbergeron> well, that seems to add up
18:08:30 <rbergeron> #topic Agenda
18:09:39 <rbergeron> Agenda for today was lovely ticket #182 - gnome 3.12 pushes google and other commercial, non-foss "apps" at users
18:10:14 <rbergeron> also reference ticket #1273 from fesco - https://fedorahosted.org/fesco/ticket/1273
18:10:40 * Sparks would like to note that he used the term "pushes" in the technical sense and not in the drug-dealer sense.
18:11:00 <inode0> I assumed you did
18:11:11 <Sparks> inode0: Someone made that comment.  :)
18:11:26 <rbergeron> sparks: yeah, i didn't think you meant that either.
18:11:28 <Sparks> rbergeron: randomuser was the original person who brought this issue to light via BZ
18:11:38 <jwb> i'd suggest changing it to "present" then
18:11:41 <rbergeron> sparks: ah, i will link that as well
18:11:58 <rbergeron> #link https://bugzilla.redhat.com/show_bug.cgi?id=1083817
18:12:06 <rbergeron> #topic Ticket #182
18:12:13 <Sparks> jwb: Always a wordsmith.  Wouldn't you like to jin the Docs team?
18:12:22 <gholms> Hehe
18:12:45 * rdieter here late, sorry
18:12:48 <rbergeron> I think we can assume sparks wasn't insinuating anything.
18:12:53 <jwb> not really.  i just suggest it because it avoids negative connotations
18:13:10 <rbergeron> otherwise we might have had ensuing gateway-related jokes about going to the dark side.
18:13:17 <rbergeron> anyway:
18:13:26 <jwb> the internet is a horrible communication medium :)
18:14:10 <gholms> It's sure great for sending people pictures, though.  :P
18:14:46 <rbergeron> So I'll note that there are a number of questions here - some directly related policy and others technical.
18:14:58 <Sparks> gholms: of cats
18:15:03 <jwb> gholms, what an excellent example of a service for this ticket ;)
18:15:30 <gholms> Indeed.
18:16:04 <inode0> shall we start?
18:16:12 <rbergeron> I'm assuming that the ultimate question here is whether or not we feel any of this violates the freedom-portions of fedora's foundations
18:16:29 <rbergeron> inode0: yes, i'm just trying to type :)
18:16:39 <rbergeron> and returning a decision to fesco
18:16:52 <rbergeron> (and more than likely encountering a few questions along the way, to be clear)
18:17:11 <inode0> my answer to that question is no but it is still a bit distasteful to me and will still be problematic
18:17:13 <sgallagh> rbergeron: I think it's also about defining a set of reasonable guidelines to refer to in the future
18:17:18 <rbergeron> does anyone have anything to add/change to the objective here?
18:17:38 <Sparks> .
18:17:40 <rbergeron> sgallagh: i agree
18:17:58 <Sparks> I think the discussion has broken into several different directions that are important to discuss.
18:18:16 <rbergeron> sgallagh: probably one baby step at a time :)
18:18:27 * mattdm is here but mostly writing a Fedora Magazine article, btw
18:18:29 <rbergeron> sparks: as part of leading to decision-making-land?
18:18:56 <rbergeron> sparks: feel free to list.
18:19:03 <sgallagh> rbergeron: Sure, but if the response is limited to "we think the current state is [fine|inappropriate]", I'd like to have a set of published reasons for GNOME to try to align to
18:19:14 <Sparks> Since the whole 'webapp' thing is new to the platform we've not developed any guidance around it.  How does one get on the list (or off)?  Are there privacy concerns?  What gauge do we use to say what's approprate or not.
18:19:33 <mjg59> Sparks: Those mostly sound like things that aren't board decisions
18:19:38 <inode0> this is an impossible rats nest to me
18:19:54 <mjg59> I think there's a well-defined question that we can answer
18:20:06 <mjg59> The answer that we come up with potentially removes the need to care about any other questions
18:20:15 <Sparks> mjg59: No, the Board is ultimately responsible for some of this.  Especially what comes into Fedora.
18:20:34 <jwb> i don't think webapps are new to the platform
18:20:40 <inode0> my bottom line right now is that it is distasteful to my sense of what I want Fedora to be - but it doesn't violate anything and is so nebulous that we won't end up being able to control it
18:20:54 <mjg59> Sparks: I think there's a strong argument that most of the points you raise are either FPC or Fesco issues, and unless they explicitly defer to us I don't see any reason for us to involve ourselves
18:20:56 <Sparks> GNOME has just provided another inclusion method for getting things into Fedora without going through any approval process.
18:21:02 <jwb> i think the inclusion of all of a number of these services in Firefox for a number of years disqualifies it as new
18:21:05 <rdieter> jwb: they're new to being displayed in fedora
18:21:13 <rdieter> jwb: fedora's software management tools, that is
18:21:36 <inode0> the most I hope for is to clearly identify and differentiate webapps from things we install and then leave it to the communities doing the work
18:21:45 <mattdm> this is the "presentation" issue. :)
18:21:48 <jwb> rdieter, in that context sure.  in the broader "is including non-free SaaS in Fedora", no
18:21:52 <mjg59> So, again, I think we should focus on the specific issue of determining whether these things conflict with our project goals
18:21:53 <inode0> if they screw it up too much someone will suggest a replacement :)
18:22:11 <mjg59> If we decide that they do then the rest of the conversation is irrelevant
18:22:14 <rdieter> jwb: sure, but the specific issue at hand is gnome-software
18:22:26 <rbergeron> mjg59: when you ay "these things" do you mean the nebulous concept in general, or a case-by-case evaluation?
18:22:32 <jwb> inode0, i like that take.  cleary identify and differentiate
18:22:49 <jwb> rdieter, rarely does the Board evaluate an issue in a single piece of software ;)
18:23:06 <jwb> rdieter, i don't think being myopic here is going to improve anything
18:23:13 <rdieter> inode0: id go further, insist it be off by default, but that's just me
18:23:14 <mjg59> rbergeron: Well, I think we should try for general guidelines
18:23:34 <mjg59> And then see what happens when we apply them to specific cases
18:23:47 <rdieter> jwb: I don't think solving webapps in any form ... is doable in any reasonable amount of time (much less one meeting)
18:23:48 <mjg59> But the alternative is to argue about specific cases and then try to draw guidelines around those
18:24:20 <sgallagh> rdieter: There's a balance to be struck between philosophical purity and discouraging users.
18:24:31 <Sparks> I'd rather make a blanket statement about this (not specific to GNOME) so we don't have to keep revisiting this.
18:25:02 <jwb> rdieter, maybe not in one meeting, but i do think it's solveable within a short timeframe with persistent discussion
18:25:12 <jwb> i'm hopeful it's solvable today.
18:25:30 <inode0> jwb: speaking of drugs, where did you get them? :)
18:25:31 <rbergeron> so - mjg59's suggestion of guidelines doesn't sound far off from inode0's suggestion of defining/differentiating webapps? overlapping a bit?
18:25:49 <jwb> inode0, hope springs eternal
18:26:18 * rdieter still thinks simply software management tools should not display 3rd party content, by default.  that's my lame duck proposal.
18:27:05 * sgallagh has no vote, but I disagree with rdieter on that point.
18:27:10 <inode0> and I can agree with that but it just pushes the question back one layer
18:27:11 <Sparks> I don't see how webapps like Google Drive meet what we publicly say about our values -> "We provide free alternatives to proprietary code and content to make Fedora completely free and redistributable for everyone."
18:27:13 <jwb> rdieter, from where i sit, that isn't acceptable.  I don't see why we would allow the default web browser to _use_ those services by default, but deny a different application to even present them
18:27:46 <Sparks> rdieter: +1
18:27:50 <sgallagh> Sparks: Making access to apps isn't the same as making the OS itself not free or not redistributable
18:28:44 <sgallagh> Now, I'd be fine with requiring that the default sorting of the display de-prioritized apps with an unknown or non-free license, of course
18:28:45 <Sparks> sgallagh: But it does goes against providing free alternatives to proprietary code.  Right now these webapps are targetting proprietary code and content (in the form of SaaS).
18:28:48 <rbergeron> jwb: is it perhaps a level of trust - most usersthink that firefox is facilitating - vs. perhaps not being able to discern between the desktop and things presented in a software installation tool?
18:28:49 <jwb> Sparks, "we", as in fedora, don't provide free alternatives to them.  perhaps you meant "there exist"?
18:28:54 <inode0> sgallagh: the project's mission goes beyond the distribution, and really strongly emphasizes free software and free content
18:29:03 <Sparks> jwb: Sure they exist.
18:29:17 <randomuser> !
18:29:46 <mjg59> Sparks: Ok. How are you drawing a distinction between Google Drive appearing in Software and Google appearing in Firefox?
18:29:55 <jwb> rbergeron, sure.  which is why i suggested more clearly deliniating them as webapps in the UI
18:30:04 <jwb> rbergeron, but that doesn't prevent their inclusion in the list
18:30:40 <sgallagh> rbergeron: Do users assume that Google provides Netflix if you install the app on an Android phone or tablet?
18:31:01 <sgallagh> maybe that's a bad example, since they do host the file...
18:31:04 <Sparks> mjg59: I don't necessarily like that Google is in Firefox (I don't use that feature).  At least that feature isn't in your face (directly on the desktop) and is provided by another piece of software that isn't Fedora branded.
18:31:05 <rbergeron> not if i have to hunt for it in the google store
18:31:25 <mjg59> Sparks: I'm looking for something that can actually be used as a test
18:31:36 <rbergeron> well, i worded that poorly
18:31:47 <Sparks> mjg59: Bad example since I don't really like Google search in FF.  :)
18:31:58 <mjg59> Sparks: Do you believe that we should forbid its existence?
18:32:17 <jwb> Sparks, i mean this in the best possible way, but this ticket is about what is best for Fedora, not what you like
18:32:24 <jwb> or don't like.
18:32:34 <Sparks> mjg59: I believe I said this on the list a few minutes ago.  I would have no problem with a LibreOffice instance (SaaS) being linked to.
18:32:46 <mjg59> Sparks: That seems unrelated to my question
18:33:07 <Sparks> mjg59: I'm trying to provide a better example.
18:33:12 <gholms> But I do.  The thing that bothers me is being unable to tell whether something is a program on my computer or a web service that runs somewhere else.
18:33:23 <gholms> With a search bar in a browser it's incredibly obvious.
18:33:26 <Sparks> jwb: I'm representing Fedora and their values.
18:33:38 <gholms> With clearly-marked web bookmarks it's obvious.
18:33:51 <Sparks> gholms: +1
18:33:56 <mjg59> Sparks: I'm trying to understand your position. If you feel that we should draft guidelines such that it's forbidden to promote non-free web apps, we either need to figure out how to avoid including Firefox's Google integration or we need to make it clear that we also forbid it
18:34:06 <jwb> Sparks, you're representing a portion of them perhaps.  i'm representing another.  etc etc
18:34:07 <Sparks> rbergeron: I believe randomuser had something to say.
18:34:12 <rbergeron> gholms: i think that's sort of what i'm thinking as well - how can we clearly draw the line -
18:34:18 <sgallagh> gholms: Of course, users of Chrome OS and Chrome Apps are more ambiguous
18:34:18 <rbergeron> oh. randomuser: Sorry! :) go ahead.
18:34:20 <rbergeron> sparks: ty
18:34:22 <jwb> gholms, so again, my suggestion of clearly identifying them as webapps in the UI.
18:34:30 <gholms> I don't care whether a web app is free or not.  People should be able to tell the difference in all cases.
18:34:32 <Sparks> mjg59: Okay
18:34:55 <randomuser> I think the current debate would be most productive within the context of *packaging* guidelines for web apps, and a policy against bundling them so guidelines can actually be applied during review.
18:34:58 <jwb> sgallagh, that example is unhelpful
18:35:03 <jwb> sgallagh, also fairly unrelated.
18:35:24 <sgallagh> Not entirely. As I understand it, that's the model Richard is trying to follow with this
18:35:24 <mjg59> randomuser: Well sure we can pass this back to FPC if we want to
18:35:38 <mjg59> randomuser: And then they'll ask us whether non-free web-apps are permitted
18:36:11 <jwb> sgallagh, we don't control what Chrome OS does, nor do we include Chrome in fedora though.  the aims may be similar, but they don't have to be identical.
18:36:11 <rbergeron> and then "what's a free vs. non-free webapp".
18:36:13 <rdieter> randomuser: <nod> that potentially transforms stuff into not being 3rd-party anymore, and makes me happy
18:36:17 <randomuser> mjg59, what if the non-free web app is a hub for proprietary software?
18:36:20 <Sparks> jwb: So why do you feel that advocating non-free SaaS is okay in Fedora?
18:36:39 <sgallagh> jwb: You misunderstand. I was trying to note that attempting to say "It's always clear that a web app is a web app and users will know the difference" was a flawed assertion
18:36:48 <sgallagh> And I was using Chrome Apps as a representative example
18:37:05 <mjg59> randomuser: That seems to be the kind of thing that we should be discussing now?
18:37:10 <jwb> sgallagh, which is why i'm saying we fix the UI...
18:37:13 <gholms> sgallagh: You have the cause and effect backwards.  We should *make* it obvious.
18:37:47 <mjg59> We appear to be having several different conversations at once
18:37:52 <mjg59> And we still haven't decided what we're attempting to do
18:37:56 <rdieter> gholms: it is also my understanding that hughsie was going to make it so
18:37:58 <jwb> Sparks, imo it's not advocating non-free SaaS
18:38:06 <mjg59> So could everybody please shut up until we've made that decision?
18:38:07 <rbergeron> is the delineation between "what comes from fedora" and "what doesn't" the issue of what is bothering us?
18:38:19 <rdieter> rbergeron: it is for me
18:38:20 <Sparks> jwb: Sure it is.  We're putting it right in users' faces.
18:38:24 <gholms> rbergeron: That's the one that I'm talking about, yes.
18:38:28 <jwb> Sparks, or, more clearly, the UI could be made clearer such that it appears less so
18:39:03 <rbergeron> and *if* that delineation was made clear - then the question of "are we kosher with those third part things being shown, when clearly shown to be third-party" ?
18:39:08 <Sparks> jwb: UI or not, it's *in* Fedora.  We've blocked entry to other software in the past because we didn't want it associated with Fedora.  If we ship it we are endorsing it.
18:39:17 <mjg59> Ok this isn't a productive use of my time
18:39:18 <rbergeron> and some guidelines needed around what being "clear" requires/means?
18:39:28 <mjg59> Could someone ping me when there's a decision making process going on?
18:39:40 <jwb> Sparks, it is very clearly not in fedora.  it's not packaged.  it's not shipped.  if you click it, it opens a browser.
18:40:11 <mattdm> jwb: a browser with no "chrome" -- that is, it doesn't seem like a browser.
18:40:20 <jwb> FIX THE UI
18:40:22 <rbergeron> mjg59: can you suggest a better description of what we're attempting to do?
18:40:24 <Sparks> jwb: We're shipping it.  It's *in* Fedora.  The user didn't have to do anything to add it onto their system.  It's not in a browser, it's on their desktop.
18:40:33 <rdieter> mattdm: <nod>, it opens a window, just like any other "app"
18:40:40 <sgallagh> jwb: To be fair, it's not clear that it opens a browser. It opens a specialized browser with none of the usual trimmings.
18:40:41 <rbergeron> guys: we're sort of in the weeds here and i think we need to zoom out a bit.
18:40:45 <jwb> Sparks, incorrect
18:40:51 <jwb> sgallagh, FIX THE UI
18:40:52 <mjg59> rbergeron: We don't appear to be trying to do anything right now
18:41:02 <sgallagh> Yeah, sorry. IRC hiccuped and I missed mattdm's reply
18:41:14 <jwb> everyone is arguing about appearance, which is a UI issue
18:41:20 * rdieter will be transfering to phone shortly, may drop out for a bit, but should be back
18:41:27 <mjg59> rbergeron: There's an argument about what Fedora's goals are, there's an argument about UI design, there's nothing actionable
18:41:36 <Sparks> rbergeron: Motion: Do we want Fedora to have third-party webapps included?
18:41:57 <jwb> included in what?
18:42:03 <Sparks> included in Fedora
18:42:16 <jwb> sigh
18:42:18 <inode0> We allow access to them already, this is really not in our control.
18:42:23 <jwb> inode0, correct
18:42:37 <Sparks> inode0: Incorrect.  We are now shipping bits that point to non-FOSS webapps
18:42:40 <sgallagh> Sparks: "included in Fedora" is not a useful statement, because by my definition, they aren't included at all.
18:42:41 <Sparks> This is new.
18:42:42 <mjg59> Sparks: Would this motion require us to remove the Google search box from the default Fedora configuration?
18:42:46 <sgallagh> They're advertised, which is different
18:42:47 <inode0> And I would not want to prohibit access to them either
18:43:12 * gholms switches to his phone
18:43:20 <Sparks> inode0: I'm not saying we should drop drive.google.com into a DNS blackhole on Fedora.
18:43:33 <jwb> mjg59, more specifically, all of the search options in firefox
18:43:38 <jwb> because there are several
18:43:52 <Sparks> mjg59: That's not a webapp.
18:43:57 <inode0> we have shipped apps that are front ends to this I find more questionable than google drive
18:43:59 <jwb> Sparks, yes it is
18:44:05 <pjones> Sparks: of course it is
18:44:13 <jwb> Sparks, google search is a damn webapp
18:44:18 <inode0> front ends to web sites
18:44:24 <jwb> inode0, correct
18:44:53 <Sparks> It's not being displayed like the webapps that appeared in GNOME3.12
18:45:00 <jwb> that does not mean it is not a webapp
18:45:09 <jwb> so once again, you're arguing about appearance
18:45:12 <jwb> which is a UI issue
18:45:16 <Sparks> jwb: Okay, I really don't care because I really don't like it either.
18:45:24 <jwb> yes, you've said that
18:45:38 <jwb> and again, your dislike is not an actionable item here
18:45:50 <rbergeron> sparks: so if it was clear that the webapps in gnome 3.12 were third-party, then would it be okay?
18:45:52 <Sparks> jwb: It's  more than a UI issue.  There are links provide by GNOME that point to non-FOSS SaaS that is included *in* Fedora.
18:45:58 <randomuser> the web apps in question are things that have a function and purpose entirely independent from the package that provides it; that sounds like bundling to me
18:46:07 <mjg59> Sparks: Do you intend for your motion to forbid the inclusion of Google in the default Firefox configuration?
18:46:26 <jwb> randomuser, bundling is very clearly defined as including code.  this is not including code.
18:46:27 <randomuser> if these things weren't bundled, existing policy would address many of the questions being raised
18:46:28 <Sparks> rbergeron: No
18:46:34 <sgallagh> Sparks: What non-FOSS SaaS is included in Fedora?
18:46:50 <Sparks> mjg59: The intension isn't specific to Google in FF.
18:46:53 <Sparks> sgallagh: Google Drive
18:46:55 <sgallagh> And by that I mean *shipped from a Fedora repository*
18:47:03 <sgallagh> That is not *IN* Fedora by any reasonable definition
18:47:04 <mjg59> Sparks: Again, that doesn't answer my question
18:47:07 <Sparks> sgallagh: And I mean a *link to that*
18:47:20 <Sparks> mjg59: Do you want it to include the FF feature?
18:47:31 <mjg59> Sparks: I'm asking you what the motion you've presented actually means
18:47:39 <mjg59> Sparks: Because without knowing that, it's difficult to have an opinion on it
18:47:46 <sgallagh> Sparks: I have documentation that points to websites for more information that are not Creative Commons licensed. Is that website "in" Fedora too?
18:47:48 <jwb> i think if you're going to make a motion like that it needs to encompass all of the software in fedora.  otherwise it's a UI issue
18:48:13 <Sparks> mjg59: And I've answered that question.  I'm not thinking about functionality inside FF right now.  Should we talk about that as well?  Sure.
18:48:48 <inode0> No, I'd rather not talk about things we have no control over
18:48:50 <Sparks> Okay, lets include that then.
18:48:54 <mjg59> Sparks: No, you haven't answered that question. The answer is either "yes" or "no".
18:49:25 <mjg59> Sparks: Is it your intention that your motion should forbid the inclusion of the Google search box in the default Firefox configuration?
18:49:46 <sgallagh> Sparks: I feel like you're avoiding the real question here. Are you defining "IN FEDORA" as being "Fedora ever mentions it"?
18:50:14 <Sparks> It is not my intention that my motion should forbid the inclusion of the Google search box.
18:50:26 <gholms> Why are we conflating mixture of hosted and native apps and value judgments of hosted apps, again?
18:50:53 <mjg59> Sparks: Ok. Now, what is your definition of "Web apps" such that the things appearing in the software center are web apps but the Google search box in Firefox isn't?
18:51:30 <jwb> gholms, because firefox includes, by default, usage of hosted apps
18:51:48 <jwb> gholms, and we're trying to clarify whether the motion on the table includes usage of hosted apps
18:51:50 <Sparks> sgallagh: I'm defining "IN FEDORA" as we ship the bits that provide access to x software.  x should not be non-FOSS
18:52:07 <jwb> Sparks, under that defintion, all web browsers would be banned
18:52:11 <mattdm> Sparks define "provide access"
18:52:15 <sgallagh> Sparks: That definition forbids all network-using services
18:52:17 <mattdm> (also tcp)
18:52:35 <gholms> But it doesn't present it alongside native bits, placong it squarely in the second category.
18:52:50 <inode0> please, I'll just vote -1 "I'm defining "IN FEDORA" as we ship the bits that provide access to x software.  x should not be non-FOSS" and let's move on.
18:53:02 <jwb> inode0, agreed.  -1
18:53:14 <gholms> inode0: Yup.
18:53:54 <rbergeron> inode0: thank you
18:54:19 <mattdm> I think Sparks is saying that there is a list of third-party web sites which is being shipped with Fedora, and that the special case is that this list shows up in searches for Fedora software (and thus has the appearance of being promoted by Fedora)
18:54:33 <mattdm> Sparks, is that an accurate phrasing?
18:54:34 <Sparks> mattdm: +1
18:54:56 <mjg59> mattdm: I'm asking how this is different to Firefox defaulting to presenting Google to the user
18:54:56 <inode0> mattdm: and I find that distasteful, but a violation of anything we can reasonably control
18:55:06 <inode0> not a violation
18:55:26 <mattdm> inode0 beacuse it is controlled by Gnome?
18:55:59 <rbergeron> do we have any alternative proposals that anyone would like to make, or something concrete to move forward with
18:56:02 <jwb> Counter Motion: We work with the software-installer developers to clearly delinate non-native applications/webapps
18:56:04 <rdieter> May be worth for anyone with a vote to mention what they *would* support here.  And, if there's no overlap sufficient to consider something passable  , then id suggest its not worth burning meeting time (ie continue onlist)
18:56:05 <inode0> mattdm: no, not at all. It is selective advertising at the present of things I personally think are questionable
18:56:57 <mjg59> jwb: I'd like us to actually figure out why we want that
18:57:10 <inode0> as I said 3 hours ago, I would like to ask that webapps in the software center be clearly identified as such but beyond that I don't think we can control this
18:57:11 <Sparks> jwb: Even if we clearly delinated the third-party apps in the UI I still think it makes it appear that Fedora has sanctioned them.
18:57:15 <sgallagh> jwb: So GNOME Software would show "Fedora Apps" and "Non-Fedora Apps" clearly labeled?
18:57:20 <gholms> jwb: +1.  We should be discussing curation separately anyway.
18:57:28 <jwb> mjg59, because everyone here is bitching about exactly that?  "they look like they're installed", etc
18:57:39 <inode0> I guess we could ask for them to be opt-in, but I'm not sure that is necessary
18:57:59 <mjg59> jwb: It's not my fault that people are talking about a specific case rather than the question that we ought to be answering
18:58:00 <sgallagh> inode0: An opt-out for the purists would probably be sufficient, I'd think
18:58:15 <Sparks> sgallagh: opt-in
18:58:15 <mjg59> jwb: I see no strong argument for the board to be obsessing over UI
18:58:24 <jwb> sgallagh, possibly.  that's an implementation detail
18:58:30 <jwb> mjg59, nor do i, yet here we are.
18:58:32 <rbergeron> mjg59: i think at least so users ubserstand that its not software we include or are responsible for?
18:58:33 * sgallagh nods
18:58:35 <gholms> When I buy a new computer it comes loaded with bookmarks for sites I'm never going to use.  I can delete them and forget about them.
18:58:55 <rbergeron> jesus, fingers.
18:59:02 <mjg59> jwb: So let's not have that conversation
18:59:23 <mattdm> mjg59 Firefox has a strong independent brand and an identity as an individual application. I am not surprised when it uses the same web services it uses on all platforms.
18:59:30 <jwb> mjg59, if you have an alternate conversation that people would like to participate in, i'd gladly join it.  nobody else seems interested?
18:59:57 <mattdm> Gnome as the default Fedora desktop (and as the basis for Fedora Workstation) have a much closer association
19:00:06 <Sparks> Okay, so is including webapps that point to non-FOSS SaaS going against our mission of promoting FOSS solutions and content?
19:00:07 <mjg59> jwb: It appears not, but I'm not going to participate in attempting to micromanage developers
19:00:25 <mattdm> And the software center shows, other than this, only applications from the Fedora repositories
19:00:34 <Sparks> mattdm: I don't think people disassociate Fedora and GNOME.
19:00:35 <mjg59> Sparks: Again, by "webapps" are you including the Google search box in the default Firefox configuration?
19:00:42 <mattdm> and in fact, the previous ruling was specifically that it could not show third party repositories
19:00:47 <Sparks> mjg59: Sure
19:00:49 <jwb> Sparks, you keep using that terminology and i think it's really hurting the discussion.  we aren't including webapps.  at best we have links to them.
19:01:05 <inode0> was that the ruling?
19:01:07 <Sparks> jwb: They were described by the GNOME people as "webapps"
19:01:22 <jwb> Sparks, which they are.  they aren't "included" though
19:01:26 <jwb> linked to perhaps
19:01:26 <Sparks> jwb: I'm using their terminology.
19:01:32 * inode0 thinks the ruling was could not ship 3rd party metadata.
19:01:38 <mjg59> Sparks: Then yes, I think that's in line with our goals. We've included that Google functionality forever, and the world doesn't appear to have ended.
19:01:41 <Sparks> jwb: Okay, that's even better.  Links.
19:01:41 <jwb> inode0, yes
19:01:42 <sgallagh> Sparks: The problem isn't the word "webapp". The problem is "include"
19:02:01 <jwb> mattdm, this isn't showing repos.  it's not including repo metadata
19:02:39 <Sparks> sgallagh: Okay, include is to bring into Fedora by default.  Right now I can point to my system and show links to Google products that are not FOSS.
19:02:43 <mattdm> right, it's showing another kind of metadata -- call it "bookmarks for web sites that will be shown alongside the applications"
19:03:32 <jwb> mattdm, bookmarks/links.  sure.  firefox still has an equivalent, or worse, in providing the search integration.
19:04:25 <Sparks> I wouldn't have nearly the problems I do if there was some sort of setup in the ssettings that allowed the creation of links (so people could add their own manually) and had quick links that they could toggle on and off to include Google and Dropbox and github and...
19:04:38 <mattdm> jwb Yes, it sure does.
19:04:52 <jwb> Sparks, all of that is UI
19:05:16 <Sparks> It would be opt-in, people could make their own, and we could have some sort of wording that says that these are add-ons outside of Fedora's support, etc.
19:05:41 <Sparks> jwb: And I am not providing a UI option as part of my argument since everyone seems to be talking about that.
19:05:49 <mattdm> I'm trying to identify why that gets a different rection. The UI is part of it, and I think from what Sparks is saying that closeness of identification with Fedora is part of it.
19:06:00 <Sparks> jwb: I still don't think we should be providing the links.
19:07:07 <jwb> look, the intention here appears to be to make it easier for a broad variety of users to more easily access services widely used on the internet today.  i don't use the majority of the links provided, but that doesn't mean their inclusion at a fundamental level is majorly objectionable
19:07:13 <inode0> isn't upstream providing the links?
19:07:41 <gholms> mattdm: Ny reaction changes because I go to my app store for native apps and my browser for websites.
19:08:02 <jwb> and i think the existance of similar links in Firefox has shown that Fedora and FOSS adoption is not directly impacted by this
19:08:04 <mattdm> One thing I find funny about this is that other operating systems which include links like this are paid heavily to do so.
19:08:15 <mattdm> (or at least make big cross-corporate deals)
19:08:39 <gholms> mattdm: Links that break that distinction fall under the category of sponsored/pushed content in my mind.
19:08:43 <Sparks> inode0: Yes
19:08:46 <jwb> mattdm, other operating systems have a wider percentage of the market.  also, let's not add another tangent to this given that Fedora _can't_ make monetary deals
19:08:55 <gholms> mattdm: Yeah, just like that.
19:09:17 * gholms has a stop coming up
19:09:27 <pjones> mattdm: in an odd way, so are we - but our distributed-upstream nature makes that less obvious.  But google certainly pays firefox to be their default search engine.
19:10:25 <inode0> Motion: Request upstream to differentiate between webapps and installable applications in the Software Center and move on ...
19:10:42 <jwb> inode0, isn't that the motion i made earlier? :)  anyway, +1
19:10:51 <rdieter> Inode: +1
19:10:58 <gholms> inode0: Yes, please.  We can argue about value judgments separately.
19:11:04 <gholms> (+1)
19:11:06 <Sparks> inode0: If the webapps are opt-in then +1
19:11:09 <rbergeron> guys: we're about to lose people. unless someone has a proposal - or a description of "the question that we're trying to answer" as mjg59 stated earlier
19:11:13 <rbergeron> okay, we have something.
19:11:13 <rbergeron> (lag)
19:11:26 <sgallagh> inode0: Can we differentiate between "Fedora-delivered" and "Non-Fedora-delivered" instead?
19:11:36 <jwb> sgallagh, damnit man.
19:11:45 <gholms> Heh
19:11:45 <mjg59> -1
19:11:47 <Sparks> inode0: If they are to be included in Fedora then they shouldn't be displayed by default.
19:12:10 <rdieter> Sparks: lets consider that separately
19:12:15 <jwb> sgallagh, bikeshed on the request itself.
19:12:16 <mjg59> I don't want to solve a specific case. I want to define why we want that change.
19:12:17 <Sparks> -1
19:12:43 <inode0> mjg59: Please, yes - do you want to rephrase it more abstractly?
19:12:46 <mjg59> So something like:
19:12:50 <jwb> that's 3 +1, 2 -1
19:14:05 * sgallagh really doesn't see what value separating "webapps" from "non-webapps" has, since the former can include FOSS solutions.
19:14:10 <mjg59> Motion: Software not included in the Fedora repositories must be clearly differentiated when presented to the user
19:14:46 <jwb> mjg59, i think that's a valuable abstraction.  +1
19:14:58 <gholms> mjg59: Also +1
19:14:59 <rdieter> +1
19:15:00 <mjg59> +1
19:15:05 <Sparks> mjg59: What does "clearly differentiated" mean?
19:15:06 <rbergeron> mjg59: I think the change would be (at least from what I can get a sense of)  - Either it comes from Fedora, and therefore we support it and it adheres to our principles, or it is .. not.
19:15:16 <sgallagh> mjg59: I think that's pretty much what I was trying to say, so thank you for rephrasing it better.
19:15:16 <gholms> Sparks: The UI makes it obvious
19:15:31 <mattdm> Sparks details, details. FESCo can handle that. :)
19:15:34 <inode0> +1
19:15:46 <gholms> Any other votes?
19:15:47 * rbergeron can +1 that motion.
19:16:01 <mjg59> I think there's a more general question of "Is this the best way to provide this service to users"
19:16:07 <jwb> that's 6 +1
19:16:07 <Sparks> And if it's not from Fedora then it's third-party of which we have rules about?
19:16:28 <gholms> Sparks: Let's decide that next.
19:16:45 <Sparks> *sigh*
19:16:49 <mjg59> And there's a pile of practical issues
19:17:04 <mjg59> But I don't think there's any reason for us to involve ourselves with those questions unless we're asked
19:17:22 <rbergeron> Is that enough to send back to Fesco for them to move forward?
19:17:31 <inode0> randomuser did ask us didn't he?
19:17:47 <Sparks> mjg59: I think this is the second time we've had to discuss third-party FOSS/non-FOSS stuff this year.  I'd prefer if we made a clear decision.
19:17:59 <rdieter> Back to  fesco +1
19:18:24 <jwb> unless i'm mistaken, mjg59's motion passed.
19:18:28 <mjg59> Sparks: I think we just did make a clear decision
19:18:45 <Sparks> mjg59: We didn't answer the question about FOSS/non-FOSS
19:19:14 <randomuser> I'm concerned that leaving the issue here leaves room for more blatantly objectionable practices
19:19:15 <Sparks> mjg59: Which has been the target of discussion from the beginning.
19:19:20 <mattdm> Sparks from the mailing list discussion, it seemed like your concern was more "aligned with promoting FOSS" than "is FOSS"
19:19:22 * gholms has to go now
19:19:39 <Sparks> mattdm: I like to promote FOSS with FOSS
19:20:05 <mjg59> Sparks: You've repeatedly failed to draw a distinction between these webapps and the Google integration in Firefox other than in terms of it being obvious to the user who's providing the service
19:20:26 <mjg59> So we just passed a motion indicating that that had to be obvious to the user
19:20:45 <Sparks> mjg59: I'm speaking specifically about the links that are on the Fedora desktop not the ones that are inside Firefox.
19:20:59 <mjg59> Sparks: I know. And you keep failing to explain how you're making that distinction.
19:21:19 <mattdm> So, the other big strategic question in the FESCo ticket was a distinction between pragmatic approach of making services easily accessible to Fedora users vs. approach where services presented are selected based on FOSS (or FOSS-alignment) or other criteria
19:21:20 <Sparks> mjg59: Because they are on the Fedora desktop and not in another piece of software.
19:21:31 <mjg59> Sparks: Why is that a meaningful distinction?
19:21:44 <Sparks> mjg59: Because people make the distinction.
19:21:52 <mjg59> Sparks: How do people make the distinction?
19:21:56 <jwb> this is now circular
19:22:00 <jwb> mjg59's motion passed
19:22:07 <jwb> if you'd like to continue to discuss it, do it on the lsits
19:22:13 <jwb> lists
19:22:34 <jwb> mattdm, "curation"
19:22:41 <mattdm> jwb indeed
19:22:48 <Sparks> Motion: Any third-party links that come with Fedora must be FOSS-related or links to FOSS SaaS services.
19:22:57 <jwb> Sparks, -1
19:23:26 <rbergeron> guys: I think either way, the motion is useful. if we need to continue past that point or make more decisions, can we take that to the list?
19:24:02 <rbergeron> because i expect we'd still want to separate out "provided by fedora" vs. non-provided by fedora software even if it is only foss-related.
19:24:04 <Sparks> rbergeron: I think it would be good for the community to see where the Board currently stands on FOSS solutions in Fedora.
19:24:35 <jwb> Sparks, personally, i am absolutely for them.  i don't think your motion is helpful to users at all though
19:24:36 <mjg59> Sparks: Would that motion require us to remove the Google search box from the default Firefox configuration?
19:24:53 <Sparks> mjg59: Maybe, you tell me?
19:24:57 <mattdm> Sparks and if you didn't intend that, please clarify
19:25:07 <mattdm> Sparks it very clearly does as worded.
19:25:12 <mjg59> Sparks: Shouldn't you be able to explain your motion?
19:25:15 <Sparks> again, I did not intend for that but I'll include it.
19:25:26 <mjg59> Sparks: In that case, -1
19:25:33 <jwb> mattdm, the motion passed did not set forth criteria along those lines.  curation would be based on in fedora or not.
19:25:34 <Sparks> mjg59: I've answered your question several times.
19:25:45 <inode0> We need to argue for another hour about whether it is FOSS-related
19:25:47 <jwb> mattdm, s/would/could
19:25:52 <rdieter> -1 (as-is)
19:25:56 <inode0> we can't control this
19:26:03 <Sparks> inode0: Sure we can.
19:26:21 <jwb> inode0, agreed.
19:26:26 <inode0> only with people making arbitrary decisions according to their tastes
19:26:59 <Sparks> So it's okay to provide links to Microsoft Office Live to compete with Google Drive and LibreOffice?
19:27:08 <rbergeron> inode0: did you omit a word there :)
19:27:21 <inode0> where?
19:27:24 <jwb> inode0, i would hope we could make suggestions for services to be added to the list, or reasonable arugments for individual servies to be removed.  discussion is always possible.
19:27:29 <rbergeron> (lag, sorry, ugh)
19:27:29 <sgallagh> Sparks: Frankly, yes.
19:27:29 * inode0 omits a lot of words
19:27:39 <rbergeron> inode0: :)
19:27:52 <mattdm> people can make _subjective_ decisions in line with their understanding of Fedora's mission. that's why we have a board.
19:28:10 <Sparks> sgallagh: And thus lies the problem.  GNOME is advertising non-FOSS solutions that compete with our own FOSS solutions.
19:28:21 <jwb> mattdm, who/what are you specifically referring to with that comment?
19:28:24 <mjg59> Sparks: Yes, just like Firefox does.
19:28:36 <mattdm> jwb inode0 says "only with people making arbitrary decisions according to their tastes"
19:28:39 <Sparks> sgallagh: That is against our mission
19:28:40 <inode0> Sparks: sadly I think yes and all I can say is that if whoever wields the decision making power here goes too far then alternatives will arise
19:28:47 <jwb> mattdm, ah.  ok, i already addressed that
19:29:08 <mjg59> Sparks: It's so against our mission that we've been doing it for the entirity of Fedora's existence.
19:29:16 <sgallagh> Motion: Board asserts that the display and linking to non-FOSS web services and applications is not a violation of the "Freedom" foundation
19:29:38 <jwb> Sparks, it would seem reasonable to request they don't display Google Drive when searching for office suites given that Fedora provides LibreOffice.  that's a discussion that could be had with the implementers
19:29:39 <sgallagh> (Not sure if I'm allowed to bring motions, but...)
19:29:49 <mjg59> sgallagh: +1
19:29:51 <Sparks> mjg59: What does FF do that we provide an alternative for?
19:29:52 <inode0> heh, that was the first thing I said rephrased sgallagh
19:30:07 <randomuser> sgallagh, one could say that "display and linking to" ~= "marketing of"
19:30:26 <sgallagh> randomuser: If you have a better phrasing, that's cool
19:30:27 <mjg59> Sparks: There are free software search engines
19:30:37 <Sparks> mjg59: Okay, then why aren't we using those?
19:30:45 <Sparks> mjg59: Let's do it!
19:31:00 <mjg59> Sparks: Because they're not as good as Google
19:31:20 <jwb> are we votign on sgallagh's motion?
19:31:23 <Sparks> mjg59: Then people can add that functionality later?
19:31:38 <rbergeron> jwb: sure.
19:31:58 <jwb> +1 to sgallagh's motion
19:31:58 <mjg59> Sparks: Just to be clear, your assertion is that we've been violating the Freedom foundation in every single Fedora release so far?
19:32:00 <inode0> jwb: I'd rather not without discussion and I really don't want to discuss it today
19:32:17 <inode0> or not without some time to think about it
19:32:22 <Sparks> mjg59: No, that's your assertion.  I'm saying that we could do better.
19:32:23 <jwb> inode0, abstain?
19:32:52 <rdieter> Me too +0
19:32:54 <jwb> i mean... a motion was put forth.  the chair said we're voting
19:32:55 <mjg59> Sparks: I don't see any other way to interpret what you said
19:33:05 <rbergeron> sgallagh: do you mean non-foss web services and applications, or web services and web applications (for clarity)
19:33:07 <jwb> rdieter, it's unclear to me that your vote counts now?
19:33:17 <jwb> rdieter, i value it, but i literally mean it is unclear
19:33:18 <Sparks> mjg59: Do you have some sort of vandeda (I can't spell that) against FF?
19:33:26 <rdieter> Need more time to consider
19:33:42 <rbergeron> oh, jesus.
19:34:06 <sgallagh> rbergeron: I meant it as I said it. I was assuming that the inverse (Linking to FOSS web services) was assumed acceptable from the previous vote
19:34:14 <mjg59> Sparks: A core part of our system has linked to a non-free webapp forever. You appear to be saying that that's unacceptable.
19:34:16 <Sparks> mjg59: I mean, you keep bringing it up and don't seem to accept any answer I give.
19:34:20 <inode0> Sparks: and if we really can do better a better alternative will show up
19:34:29 <mjg59> Sparks: Your answers are evasive or mutually contradictory
19:34:52 <Sparks> mjg59: I've tried to answer your question every way I know how but I apparently keep answering it incorrectly.
19:35:28 <mjg59> Sparks: You believe that Fedora should not include links to non-free web apps. Firefox does so. Is that compatible with our principles?
19:35:32 <Sparks> inode0: Sure.  If there are FOSS solutions out there we should add them to FF and make them default, IMO.
19:35:55 <Sparks> mjg59: I would say no.
19:35:56 <rbergeron> guys: I think we have to take the foss-question to the list. we've lost people. And it's a large question. So let's do that, and send the immediate answer we have to fesco.
19:36:17 <inode0> +1
19:36:23 <randomuser> I'm concerned that leaving the issue here leaves room for more blatantly objectionable practices. giving approval of the situation as-is opens the door to web apps for sites that actually install software on the system, for example
19:36:23 <Sparks> rbergeron: I think that was the core question that started this whole thing.
19:36:24 <inode0> and go back to work :)
19:36:32 * sgallagh wonders when the word "freedom" started to mean "disallowing anything that I don't like"
19:36:45 <mjg59> Sparks: Ok. Given the fact that we have been doing so for the entire history of the project, I think your interpretation of our principles is incorrect.
19:37:06 <jwb> randomuser, that is already possible and has been for a long time.  we even have packaged applications that are not browsers that do exactly that
19:37:19 <Sparks> mjg59: Way to go.  You managed to twist my answer into something you feel discredits me.  Congratulations.
19:37:34 <sgallagh> mjg59: I think that may be overstating things. I think he's probably viewing that as an oversight rather than an intentional interpretation of the rules. (I don't agree with him, but I think I see where the disconnect you two are having comes from)
19:37:43 <randomuser> jwb, what, CPAN, pip, etc? I understand they have their own qualifications for FLOSS
19:37:53 <rbergeron> sparks: and I also feel that we're not making progress at this point.
19:38:27 <Sparks> rbergeron: I don't feel we've made any progress.  We've failed to answer the question that was at hand from the beginning regarding non-FOSS links.
19:38:33 <jwb> randomuser, i'd have to go look up the guideline.  i do not have it handy
19:38:42 <rbergeron> devolving into multiple discussions. so let's take the question with the answer we already have in mind so tha tpeople can clearly describe if they're okay with it under certain circumstances, or not.
19:39:08 <jwb> Sparks, sgallagh's motion specifically addressed that
19:39:28 <Sparks> jwb: Yes but we aren't talking about that any longer.
19:40:09 <rbergeron> jwb: are you willing to be relay with the immediate answer back to fesco
19:40:26 <jwb> rbergeron, sure
19:40:38 <jwb> we should #agreed it here though
19:40:59 <rbergeron> sparks: perhaps we have not made any, but i don't think that we're going to get any further.
19:41:08 <rbergeron> jwb: ah, I thought you tallied earlier with that
19:41:10 <rbergeron> sorry
19:41:13 <rbergeron> or someone did
19:41:29 <Sparks> jwb: You can mark me down as a -1
19:41:41 <jwb> Sparks, will do
19:41:46 <jwb> #agreed Motion: Software not included in the Fedora repositories must be  clearly differentiated when presented to the user
19:41:51 <jwb> #undo
19:41:51 <zodbot> Removing item from minutes: AGREED by jwb at 19:41:46 : Motion: Software not included in the Fedora repositories must be  clearly differentiated when presented to the user
19:42:04 <jwb> #agreed Motion: Software not included in the Fedora repositories must be  clearly differentiated when presented to the user (+1:6 -1:1)
19:42:09 <rbergeron> oh, thanks. /me was scrolling
19:42:47 <rbergeron> #action jwb to relay back to fesco
19:43:06 <rbergeron> guys: thank you for coming.
19:43:32 * rbergeron deeply breathes
19:43:46 <rbergeron> #endmeeting